summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mysql-workbench-5.2.28-python.patch (renamed from mysql-workbench-5.2.22-python.patch)25
-rw-r--r--mysql-workbench.spec11
2 files changed, 34 insertions, 2 deletions
diff --git a/mysql-workbench-5.2.22-python.patch b/mysql-workbench-5.2.28-python.patch
index 9a3bfbc..1e872d2 100644
--- a/mysql-workbench-5.2.22-python.patch
+++ b/mysql-workbench-5.2.28-python.patch
@@ -31,3 +31,28 @@
+diagram = grt.root.wb.doc.physicalModels[0].diagram
+for figure in diagram.figures:
print figure.__grtclassname__, figure.left, figure.top
+--- mysql-workbench-gpl-5.2.28-src/res/scripts/snippets/shell_snippets.py.orig 2010-09-21 17:38:45.243356701 +0200
++++ mysql-workbench-gpl-5.2.28-src/res/scripts/snippets/shell_snippets.py 2010-09-21 17:38:59.850746929 +0200
+@@ -18,14 +18,14 @@
+ for figure in diagram.figures:
+ print figure.__grtclassname__, figure.left, figure.top
+
+- # iterate through all resultset rows
+- resultset = grt.root.wb.sqlEditors[0].activeResultset
+- flag = resultset.goToFirst()
+- while flag:
++# iterate through all resultset rows
++resultset = grt.root.wb.sqlEditors[0].activeResultset
++flag = resultset.goToFirst()
++while flag:
+ print resultset.stringFieldValue(0)
+ flag = resultset.nextRow()
+
+- # replace sql editor contents
+- editor = grt.root.wb.sqlEditors[0].activeQueryBuffer
+- new_text = editor.sql
+- editor.replaceContents(new_text)
++# replace sql editor contents
++editor = grt.root.wb.sqlEditors[0].activeQueryBuffer
++new_text = editor.sql
++editor.replaceContents(new_text)
diff --git a/mysql-workbench.spec b/mysql-workbench.spec
index 7f81a5c..41635be 100644
--- a/mysql-workbench.spec
+++ b/mysql-workbench.spec
@@ -2,6 +2,9 @@
%global tartype gpl
%global cppconnver 1.1.0-0.3.bzr895
+# Temporary workaround for "script_templates" which shouldn't be compiled
+%global _python_bytecompile_errors_terminate_build 0
+
Summary: A MySQL visual database modeling, administration and querying tool
Name: mysql-workbench
Version: 5.2.28
@@ -16,9 +19,9 @@ URL: http://wb.mysql.com
Source: %{name}-%{tartype}-%{version}%{?postver}.tar.gz
# don't build extension, use system one
-# !!! This patch use versioned soname !!!
+# !!! This patch use versioned soname (libmysqlcppconn.so.5) !!!
Patch1: %{name}-5.2.28-cppconn.patch
-Patch2: %{name}-5.2.22-python.patch
+Patch2: %{name}-5.2.28-python.patch
Patch3: %{name}-5.2.27-ctemplate.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -149,6 +152,10 @@ update-desktop-database &> /dev/null || :
%changelog
* Mon Sep 20 2010 Remi Collet <Fedora@famillecollet.com> 5.2.28-1
- update to 5.2.28 Community (OSS) Edition (GPL)
+ http://dev.mysql.com/doc/workbench/en/wb-news-5-2-28.html
+- build against mysql-connector-c++ 1.1.0 (bzr895)
+- improve cppconn patch
+- temporary disable _python_bytecompile_errors_terminate_build
* Sat Sep 18 2010 Remi Collet <Fedora@famillecollet.com> 5.2.27-2
- remove obsoleted configure options