summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mysql-workbench-5.2.24-cppconn.patch85
-rw-r--r--mysql-workbench.spec13
2 files changed, 94 insertions, 4 deletions
diff --git a/mysql-workbench-5.2.24-cppconn.patch b/mysql-workbench-5.2.24-cppconn.patch
new file mode 100644
index 0000000..9d77c33
--- /dev/null
+++ b/mysql-workbench-5.2.24-cppconn.patch
@@ -0,0 +1,85 @@
+diff -up mysql-workbench-ce-5.2.24/configure.in.cppconn mysql-workbench-ce-5.2.24/configure.in
+--- mysql-workbench-ce-5.2.24/configure.in.cppconn 2010-06-19 04:40:20.000000000 +0200
++++ mysql-workbench-ce-5.2.24/configure.in 2010-06-23 20:07:19.190367417 +0200
+@@ -462,8 +462,6 @@ res/mysql.profiles/Makefile
+ res/sqlidedata/Makefile
+ ext/Makefile
+ ext/scintilla/gtk/Makefile
+-ext/cppconn/Makefile
+-ext/cppconn/driver/Makefile
+ backend/Makefile
+ backend/wbpublic/Makefile
+ backend/wbprivate/Makefile
+diff -up mysql-workbench-ce-5.2.24/ext/Makefile.am.cppconn mysql-workbench-ce-5.2.24/ext/Makefile.am
+--- mysql-workbench-ce-5.2.24/ext/Makefile.am.cppconn 2010-06-23 20:08:40.950491999 +0200
++++ mysql-workbench-ce-5.2.24/ext/Makefile.am 2010-06-19 04:40:18.000000000 +0200
+@@ -4,4 +4,4 @@ else
+ ctemplate_dirs=ctemplate
+ endif
+
+-SUBDIRS=scintilla/gtk cppconn $(ctemplate_dirs)
++SUBDIRS=scintilla/gtk $(ctemplate_dirs)
+diff -up mysql-workbench-ce-5.2.24/ext/Makefile.in.cppconn mysql-workbench-ce-5.2.24/ext/Makefile.in
+--- mysql-workbench-ce-5.2.24/ext/Makefile.in.cppconn 2010-06-19 04:40:24.000000000 +0200
++++ mysql-workbench-ce-5.2.24/ext/Makefile.in 2010-06-23 20:09:17.544511184 +0200
+@@ -53,7 +53,7 @@ RECURSIVE_CLEAN_TARGETS = mostlyclean-re
+ distclean-recursive maintainer-clean-recursive
+ ETAGS = etags
+ CTAGS = ctags
+-DIST_SUBDIRS = scintilla/gtk cppconn ctemplate
++DIST_SUBDIRS = scintilla/gtk ctemplate
+ DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+ ACLOCAL = @ACLOCAL@
+ AMTAR = @AMTAR@
+@@ -214,7 +214,7 @@ target_alias = @target_alias@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ @BUILD_CTEMPLATE_FALSE@ctemplate_dirs = ctemplate
+-SUBDIRS = scintilla/gtk cppconn $(ctemplate_dirs)
++SUBDIRS = scintilla/gtk $(ctemplate_dirs)
+ all: all-recursive
+
+ .SUFFIXES:
+diff -up mysql-workbench-ce-5.2.24/library/dbc/src/driver_manager.cpp.cppconn mysql-workbench-ce-5.2.24/library/dbc/src/driver_manager.cpp
+--- mysql-workbench-ce-5.2.24/library/dbc/src/driver_manager.cpp.cppconn 2010-06-19 04:40:15.000000000 +0200
++++ mysql-workbench-ce-5.2.24/library/dbc/src/driver_manager.cpp 2010-06-23 20:07:19.192367230 +0200
+@@ -145,6 +145,8 @@ TunnelConnection *DriverManager::getTunn
+ ConnectionWrapper DriverManager::getConnection(const db_mgmt_ConnectionRef &connectionProperties, ConnectionInitSlot connection_init_slot)
+ {
+ TunnelConnection* tunnel = NULL;
++ gchar *p = NULL;
++ GModule *gmodule = NULL;
+ // 0. determine correct driver filename
+
+ db_mgmt_DriverRef drv = connectionProperties->driver();
+@@ -154,21 +156,21 @@ ConnectionWrapper DriverManager::getConn
+ library = drv->driverLibraryName();
+ else
+ throw SQLException("Invalid connection settings: undefined connection driver");
+-#ifdef _WIN32
+- library.append(".dll");
+-#elif defined(__APPLE__)
+- library.append(".dylib");
+-#else
+- library.append(".so");
+-#endif
++
++ // Patch : use library in standard path
++ p = g_module_build_path (NULL, library.c_str());
+
+ // 1. find driver
+
+- GModule *gmodule= g_module_open((_driver_path + "/" + library).c_str(), G_MODULE_BIND_LOCAL);
++ if (p) {
++ gmodule = g_module_open(std::string(p).append(".4").c_str(), G_MODULE_BIND_LOCAL);
++ g_free(p);
++ }
++
+ if (NULL == gmodule)
+ {
+ fprintf(stderr, "Error: %s", g_module_error());
+- throw SQLException(std::string("Database driver: Failed to open library '").append(_driver_path + "/" + library).append("'. Check settings.").c_str());
++ throw SQLException(std::string("Database driver: Failed to open library '").append(library).append("'. Check settings.").c_str());
+ }
+
+ Driver *(* get_driver_instance)()= NULL;
diff --git a/mysql-workbench.spec b/mysql-workbench.spec
index 00d8aa4..373a5a3 100644
--- a/mysql-workbench.spec
+++ b/mysql-workbench.spec
@@ -1,20 +1,21 @@
#global postver b
+%global tartype ce
%global cppconnver 1.1.0-0.1.bzr819
Summary: A MySQL visual database modeling tool
Name: mysql-workbench
-Version: 5.2.22
+Version: 5.2.24
Release: 1%{?dist}
Group: Applications/Databases
License: GPLv2
URL: http://wb.mysql.com
-Source: %{name}-oss-%{version}%{?postver}.tar.gz
+Source: %{name}-%{tartype}-%{version}%{?postver}.tar.gz
# don't build extension, use system one
# !!! This patch use versioned soname !!!
-Patch1: %{name}-5.2.17-cppconn.patch
+Patch1: %{name}-5.2.24-cppconn.patch
Patch2: %{name}-5.2.16-scintilla.patch
Patch3: %{name}-5.2.22-python.patch
@@ -58,6 +59,7 @@ Requires: mysql gnome-keyring
Requires: mysql-connector-c++ >= %{cppconnver}
# Official upstream build
Conflicts: mysql-workbench-oss
+Conflicts: mysql-workbench-ce
%description
@@ -69,7 +71,7 @@ tools environment for:
%prep
-%setup -q -n %{name}-oss-%{version}%{?postver}
+%setup -q -n %{name}-%{tartype}-%{version}%{?postver}
%patch1 -p1 -b .cppconn
#patch2 -p1 -b .scintilla
@@ -137,6 +139,9 @@ update-desktop-database &> /dev/null || :
%changelog
+* Wed Jun 23 2010 Remi Collet <RPMS@famillecollet.com> 5.2.24-1
+- update to 5.2.24 RC3 Community Edition (CE)
+
* Fri Jun 04 2010 Remi Collet <RPMS@famillecollet.com> 5.2.22-1
- update to 5.2.22 RC Community (OSS) Edition
- build against mysql-connector-c++ 1.1.0 (bzr819)