summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mysql-workbench-5.2.16-scintilla.patch221
-rw-r--r--mysql-workbench-5.2.17-cppconn.patch73
-rw-r--r--mysql-workbench.spec216
3 files changed, 510 insertions, 0 deletions
diff --git a/mysql-workbench-5.2.16-scintilla.patch b/mysql-workbench-5.2.16-scintilla.patch
new file mode 100644
index 0000000..5eb41fe
--- /dev/null
+++ b/mysql-workbench-5.2.16-scintilla.patch
@@ -0,0 +1,221 @@
+diff -up mysql-workbench-oss-5.2.16/configure.in.orig mysql-workbench-oss-5.2.16/configure.in
+--- mysql-workbench-oss-5.2.16/configure.in.orig 2010-02-17 18:07:16.000000000 +0100
++++ mysql-workbench-oss-5.2.16/configure.in 2010-02-17 18:07:28.000000000 +0100
+@@ -412,7 +412,6 @@ res/wbdata/Makefile
+ res/mysql.profiles/Makefile
+ res/sqlidedata/Makefile
+ ext/Makefile
+-ext/scintilla/gtk/Makefile
+ backend/Makefile
+ backend/wbpublic/Makefile
+ backend/wbprivate/Makefile
+diff -up mysql-workbench-oss-5.2.16/ext/Makefile.am.orig mysql-workbench-oss-5.2.16/ext/Makefile.am
+--- mysql-workbench-oss-5.2.16/ext/Makefile.am.orig 2010-02-17 18:03:58.000000000 +0100
++++ mysql-workbench-oss-5.2.16/ext/Makefile.am 2010-02-17 18:05:16.000000000 +0100
+@@ -1 +1 @@
+-SUBDIRS=ctemplate scintilla/gtk
++SUBDIRS=ctemplate
+diff -up mysql-workbench-oss-5.2.16/ext/Makefile.in.orig mysql-workbench-oss-5.2.16/ext/Makefile.in
+--- mysql-workbench-oss-5.2.16/ext/Makefile.in.orig 2010-02-17 18:04:03.000000000 +0100
++++ mysql-workbench-oss-5.2.16/ext/Makefile.in 2010-02-17 18:05:14.000000000 +0100
+@@ -213,7 +213,7 @@ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-SUBDIRS = ctemplate scintilla/gtk
++SUBDIRS = ctemplate
+ all: all-recursive
+
+ .SUFFIXES:
+diff -up mysql-workbench-oss-5.2.16/frontend/linux/linux_utilities/Makefile.am.orig mysql-workbench-oss-5.2.16/frontend/linux/linux_utilities/Makefile.am
+--- mysql-workbench-oss-5.2.16/frontend/linux/linux_utilities/Makefile.am.orig 2010-02-17 18:39:59.000000000 +0100
++++ mysql-workbench-oss-5.2.16/frontend/linux/linux_utilities/Makefile.am 2010-02-17 18:40:40.000000000 +0100
+@@ -4,14 +4,14 @@ AM_CXXFLAGS=-rdynamic
+ pkglib_LTLIBRARIES=liblinux_utilities.la
+
+ liblinux_utilities_la_LIBADD=$(top_srcdir)/frontend/linux/sqlide/libsqlide.la\
+- $(top_srcdir)/ext/scintilla/gtk/libwbscintilla.la
++ -lscintilla
+
+ INCLUDES=@GLIB_CFLAGS@ @SIGC_CFLAGS@ @GRT_CFLAGS@ @CAIRO_CFLAGS@ @GNOME_CFLAGS@\
+ -I$(top_srcdir)/library/grt/src -I$(top_srcdir)/library/base/src \
+ -I$(top_srcdir)/backend/wbpublic -I$(top_srcdir)/generated -I$(top_srcdir)/library/canvas/src\
+ -I$(top_srcdir)/frontend/linux/workbench\
+ -I$(top_srcdir)/frontend/linux/sqlide\
+- -I$(top_srcdir)/ext/scintilla/include\
++ -I/usr/include/scintilla\
+ -I$(top_srcdir)/ext\
+ -I$(top_srcdir)/library/forms\
+ -I$(top_srcdir)/library/forms/gtk\
+diff -up mysql-workbench-oss-5.2.16/frontend/linux/linux_utilities/Makefile.in.orig mysql-workbench-oss-5.2.16/frontend/linux/linux_utilities/Makefile.in
+--- mysql-workbench-oss-5.2.16/frontend/linux/linux_utilities/Makefile.in.orig 2010-02-17 18:40:09.000000000 +0100
++++ mysql-workbench-oss-5.2.16/frontend/linux/linux_utilities/Makefile.in 2010-02-17 18:41:09.000000000 +0100
+@@ -51,8 +51,7 @@ am__installdirs = "$(DESTDIR)$(pkglibdir
+ pkglibLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(pkglib_LTLIBRARIES)
+ liblinux_utilities_la_DEPENDENCIES = \
+- $(top_srcdir)/frontend/linux/sqlide/libsqlide.la \
+- $(top_srcdir)/ext/scintilla/gtk/libwbscintilla.la
++ $(top_srcdir)/frontend/linux/sqlide/libsqlide.la
+ am_liblinux_utilities_la_OBJECTS = custom_renderers.lo \
+ listmodel_wrapper.lo treemodel_wrapper.lo \
+ plugin_editor_base.lo image_cache.lo gtk_helpers.lo \
+@@ -237,14 +236,14 @@ top_srcdir = @top_srcdir@
+ AM_CXXFLAGS = -rdynamic
+ pkglib_LTLIBRARIES = liblinux_utilities.la
+ liblinux_utilities_la_LIBADD = $(top_srcdir)/frontend/linux/sqlide/libsqlide.la\
+- $(top_srcdir)/ext/scintilla/gtk/libwbscintilla.la
++ -lscintilla
+
+ INCLUDES = @GLIB_CFLAGS@ @SIGC_CFLAGS@ @GRT_CFLAGS@ @CAIRO_CFLAGS@ @GNOME_CFLAGS@\
+ -I$(top_srcdir)/library/grt/src -I$(top_srcdir)/library/base/src \
+ -I$(top_srcdir)/backend/wbpublic -I$(top_srcdir)/generated -I$(top_srcdir)/library/canvas/src\
+ -I$(top_srcdir)/frontend/linux/workbench\
+ -I$(top_srcdir)/frontend/linux/sqlide\
+- -I$(top_srcdir)/ext/scintilla/include\
++ -I/usr/include/scintilla\
+ -I$(top_srcdir)/ext\
+ -I$(top_srcdir)/library/forms\
+ -I$(top_srcdir)/library/forms/gtk\
+diff -up mysql-workbench-oss-5.2.16/frontend/linux/sqlide/Makefile.am.orig mysql-workbench-oss-5.2.16/frontend/linux/sqlide/Makefile.am
+--- mysql-workbench-oss-5.2.16/frontend/linux/sqlide/Makefile.am.orig 2010-02-17 18:36:21.000000000 +0100
++++ mysql-workbench-oss-5.2.16/frontend/linux/sqlide/Makefile.am 2010-02-17 18:38:36.000000000 +0100
+@@ -5,7 +5,7 @@ res/query_sidebar.glade
+
+ pkglib_LTLIBRARIES=libsqlide.la
+
+-libsqlide_la_LIBADD=$(top_srcdir)/ext/scintilla/gtk/libwbscintilla.la
++libsqlide_la_LIBADD=-lscintilla
+
+ INCLUDES=\
+ -I$(top_srcdir)/frontend/linux\
+@@ -19,7 +19,7 @@ INCLUDES=\
+ -I$(top_srcdir)/library/dbc/src\
+ -I$(top_srcdir)/ext/cppconn\
+ -I$(top_srcdir)/library/vsqlite++/include\
+--I$(top_srcdir)/ext/scintilla/include\
++-I/usr/include/scintilla\
+ @GRT_CFLAGS@ @CAIRO_CFLAGS@ @GNOME_CFLAGS@ @GLIB_CFLAGS@ @SIGC_CFLAGS@
+
+ libsqlide_la_SOURCES=\
+diff -up mysql-workbench-oss-5.2.16/frontend/linux/sqlide/Makefile.in.orig mysql-workbench-oss-5.2.16/frontend/linux/sqlide/Makefile.in
+--- mysql-workbench-oss-5.2.16/frontend/linux/sqlide/Makefile.in.orig 2010-02-17 18:36:33.000000000 +0100
++++ mysql-workbench-oss-5.2.16/frontend/linux/sqlide/Makefile.in 2010-02-17 18:37:34.000000000 +0100
+@@ -51,8 +51,7 @@ am__strip_dir = `echo $$p | sed -e 's|^.
+ am__installdirs = "$(DESTDIR)$(pkglibdir)" "$(DESTDIR)$(pkgdatadir)"
+ pkglibLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(pkglib_LTLIBRARIES)
+-libsqlide_la_DEPENDENCIES = \
+- $(top_srcdir)/ext/scintilla/gtk/libwbscintilla.la
++libsqlide_la_DEPENDENCIES =
+ am_libsqlide_la_OBJECTS = sql_editor_fe.lo errors_list.lo \
+ grid_view_model.lo grid_view.lo recordset_view.lo \
+ sqlide_form.lo sql_snippets_view.lo query_sidebar.lo \
+@@ -241,7 +240,7 @@ res/db_sql_editor_view.glade\
+ res/query_sidebar.glade
+
+ pkglib_LTLIBRARIES = libsqlide.la
+-libsqlide_la_LIBADD = $(top_srcdir)/ext/scintilla/gtk/libwbscintilla.la
++libsqlide_la_LIBADD = -lscintilla
+ INCLUDES = \
+ -I$(top_srcdir)/frontend/linux\
+ -I$(top_srcdir)/backend/wbpublic\
+@@ -254,7 +253,7 @@ INCLUDES = \
+ -I$(top_srcdir)/library/dbc/src\
+ -I$(top_srcdir)/ext/cppconn\
+ -I$(top_srcdir)/library/vsqlite++/include\
+--I$(top_srcdir)/ext/scintilla/include\
++-I/usr/include/scintilla\
+ @GRT_CFLAGS@ @CAIRO_CFLAGS@ @GNOME_CFLAGS@ @GLIB_CFLAGS@ @SIGC_CFLAGS@
+
+ libsqlide_la_SOURCES = \
+diff -up mysql-workbench-oss-5.2.16/modules/wb.model/Makefile.am.orig mysql-workbench-oss-5.2.16/modules/wb.model/Makefile.am
+--- mysql-workbench-oss-5.2.16/modules/wb.model/Makefile.am.orig 2010-02-17 18:08:14.000000000 +0100
++++ mysql-workbench-oss-5.2.16/modules/wb.model/Makefile.am 2010-02-17 18:34:14.000000000 +0100
+@@ -65,8 +65,7 @@ INCLUDES=-I$(top_srcdir)/generated\
+ -I$(top_srcdir)/library/sql-parser/source/linux\
+ -I$(top_srcdir)/ext/silvercity/src\
+ -I$(top_srcdir)/library/tinyxml\
+- -I$(top_srcdir)/ext/scintilla/include\
+- -I$(top_srcdir)/ext/scintilla/src\
++ -I/usr/include/scintilla\
+ -I$(top_srcdir)/ext\
+ -I$(top_srcdir)/modules/db.mysql.sqlide/src\
+ -I$(top_srcdir)/ext/ctemplate/ctemplate-src/src\
+@@ -74,7 +73,7 @@ INCLUDES=-I$(top_srcdir)/generated\
+
+
+ wb_model_grt_la_LDFLAGS=-module
+-#wb_model_grt_la_LIBADD=$(top_srcdir)/ext/ctemplate
++wb_model_grt_la_LIBADD=-lscintilla
+
+ wb_model_grt_la_SOURCES=src/graph_renderer.cpp \
+ src/reporting.cpp \
+diff -up mysql-workbench-oss-5.2.16/modules/wb.model/Makefile.in.orig mysql-workbench-oss-5.2.16/modules/wb.model/Makefile.in
+--- mysql-workbench-oss-5.2.16/modules/wb.model/Makefile.in.orig 2010-02-17 18:08:19.000000000 +0100
++++ mysql-workbench-oss-5.2.16/modules/wb.model/Makefile.in 2010-02-17 18:35:08.000000000 +0100
+@@ -306,15 +306,14 @@ INCLUDES = -I$(top_srcdir)/generated\
+ -I$(top_srcdir)/library/sql-parser/source/linux\
+ -I$(top_srcdir)/ext/silvercity/src\
+ -I$(top_srcdir)/library/tinyxml\
+- -I$(top_srcdir)/ext/scintilla/include\
+- -I$(top_srcdir)/ext/scintilla/src\
++ -I/usr/include/scintilla\
+ -I$(top_srcdir)/ext\
+ -I$(top_srcdir)/modules/db.mysql.sqlide/src\
+ -I$(top_srcdir)/ext/ctemplate/ctemplate-src/src\
+ @MYSQL_INCLUDE@ @GRT_CFLAGS@ @GLIB_CFLAGS@ @SIGC_CFLAGS@
+
+ wb_model_grt_la_LDFLAGS = -module
+-#wb_model_grt_la_LIBADD=$(top_srcdir)/ext/ctemplate
++wb_model_grt_la_LIBADD=-lscintilla
+ wb_model_grt_la_SOURCES = src/graph_renderer.cpp \
+ src/reporting.cpp \
+ src/wb_model.cpp \
+diff -up mysql-workbench-oss-5.2.16/plugins/db.mysql.editors/linux/Makefile.am.orig mysql-workbench-oss-5.2.16/plugins/db.mysql.editors/linux/Makefile.am
+--- mysql-workbench-oss-5.2.16/plugins/db.mysql.editors/linux/Makefile.am.orig 2010-02-17 18:41:58.000000000 +0100
++++ mysql-workbench-oss-5.2.16/plugins/db.mysql.editors/linux/Makefile.am 2010-02-17 18:43:10.000000000 +0100
+@@ -28,13 +28,13 @@ INCLUDES=-I$(top_srcdir)/generated -I$(t
+ -I$(top_srcdir)/frontend/linux/workbench\
+ -I$(top_srcdir)/frontend/linux/linux_utilities\
+ -I$(top_srcdir)/frontend/linux/sqlide\
+- -I$(top_srcdir)/ext/scintilla/include\
++ -I/usr/include/scintilla\
+ @GRT_CFLAGS@ @GLIB_CFLAGS@ @GNOME_CFLAGS@ @SIGC_CFLAGS@
+
+
+ db_mysql_editors_wbp_la_LDFLAGS=-module
+ db_mysql_editors_wbp_la_LIBADD=$(top_srcdir)/frontend/linux/linux_utilities/liblinux_utilities.la\
+- $(top_srcdir)/ext/scintilla/gtk/libwbscintilla.la
++ -lscintilla
+
+ db_mysql_editors_wbp_la_SOURCES=\
+ ../backend/mysql_relationship_editor.cpp\
+diff -up mysql-workbench-oss-5.2.16/plugins/db.mysql.editors/linux/Makefile.in.orig mysql-workbench-oss-5.2.16/plugins/db.mysql.editors/linux/Makefile.in
+--- mysql-workbench-oss-5.2.16/plugins/db.mysql.editors/linux/Makefile.in.orig 2010-02-17 18:42:08.000000000 +0100
++++ mysql-workbench-oss-5.2.16/plugins/db.mysql.editors/linux/Makefile.in 2010-02-17 18:42:42.000000000 +0100
+@@ -51,8 +51,7 @@ am__installdirs = "$(DESTDIR)$(pkglibdir
+ "$(DESTDIR)$(plugindatadir)"
+ pkglibLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(pkglib_LTLIBRARIES)
+-db_mysql_editors_wbp_la_DEPENDENCIES = $(top_srcdir)/frontend/linux/linux_utilities/liblinux_utilities.la \
+- $(top_srcdir)/ext/scintilla/gtk/libwbscintilla.la
++db_mysql_editors_wbp_la_DEPENDENCIES = $(top_srcdir)/frontend/linux/linux_utilities/liblinux_utilities.la
+ am_db_mysql_editors_wbp_la_OBJECTS = mysql_relationship_editor.lo \
+ mysql_routine_editor.lo mysql_routinegroup_editor.lo \
+ mysql_schema_editor.lo mysql_table_editor.lo \
+@@ -276,12 +275,12 @@ INCLUDES = -I$(top_srcdir)/generated -I$
+ -I$(top_srcdir)/frontend/linux/workbench\
+ -I$(top_srcdir)/frontend/linux/linux_utilities\
+ -I$(top_srcdir)/frontend/linux/sqlide\
+- -I$(top_srcdir)/ext/scintilla/include\
++ -I/usr/include/scintilla\
+ @GRT_CFLAGS@ @GLIB_CFLAGS@ @GNOME_CFLAGS@ @SIGC_CFLAGS@
+
+ db_mysql_editors_wbp_la_LDFLAGS = -module
+ db_mysql_editors_wbp_la_LIBADD = $(top_srcdir)/frontend/linux/linux_utilities/liblinux_utilities.la\
+- $(top_srcdir)/ext/scintilla/gtk/libwbscintilla.la
++ -lscintilla
+
+ db_mysql_editors_wbp_la_SOURCES = \
+ ../backend/mysql_relationship_editor.cpp\
diff --git a/mysql-workbench-5.2.17-cppconn.patch b/mysql-workbench-5.2.17-cppconn.patch
new file mode 100644
index 0000000..511fc11
--- /dev/null
+++ b/mysql-workbench-5.2.17-cppconn.patch
@@ -0,0 +1,73 @@
+diff -up mysql-workbench-oss-5.2.17/configure.in.cppconn mysql-workbench-oss-5.2.17/configure.in
+--- mysql-workbench-oss-5.2.17/configure.in.cppconn 2010-04-02 03:26:27.000000000 +0200
++++ mysql-workbench-oss-5.2.17/configure.in 2010-04-03 15:37:43.000000000 +0200
+@@ -459,8 +459,6 @@ res/mysql.profiles/Makefile
+ res/sqlidedata/Makefile
+ ext/Makefile
+ ext/scintilla/gtk/Makefile
+-ext/cppconn/Makefile
+-ext/cppconn/driver/Makefile
+ backend/Makefile
+ backend/wbpublic/Makefile
+ backend/wbprivate/Makefile
+diff -up mysql-workbench-oss-5.2.17/ext/Makefile.am.cppconn mysql-workbench-oss-5.2.17/ext/Makefile.am
+--- mysql-workbench-oss-5.2.17/ext/Makefile.am.cppconn 2010-04-02 03:26:17.000000000 +0200
++++ mysql-workbench-oss-5.2.17/ext/Makefile.am 2010-04-03 15:37:43.000000000 +0200
+@@ -1 +1 @@
+-SUBDIRS=ctemplate scintilla/gtk cppconn
++SUBDIRS=ctemplate scintilla/gtk
+diff -up mysql-workbench-oss-5.2.17/ext/Makefile.in.cppconn mysql-workbench-oss-5.2.17/ext/Makefile.in
+--- mysql-workbench-oss-5.2.17/ext/Makefile.in.cppconn 2010-04-02 03:26:32.000000000 +0200
++++ mysql-workbench-oss-5.2.17/ext/Makefile.in 2010-04-03 15:37:43.000000000 +0200
+@@ -213,7 +213,7 @@ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-SUBDIRS = ctemplate scintilla/gtk cppconn
++SUBDIRS = ctemplate scintilla/gtk
+ all: all-recursive
+
+ .SUFFIXES:
+diff -up mysql-workbench-oss-5.2.17/library/dbc/src/driver_manager.cpp.cppconn mysql-workbench-oss-5.2.17/library/dbc/src/driver_manager.cpp
+--- mysql-workbench-oss-5.2.17/library/dbc/src/driver_manager.cpp.cppconn 2010-04-03 15:38:46.000000000 +0200
++++ mysql-workbench-oss-5.2.17/library/dbc/src/driver_manager.cpp 2010-04-03 15:40:59.000000000 +0200
+@@ -139,6 +139,8 @@ TunnelConnection *DriverManager::getTunn
+ ConnectionWrapper DriverManager::getConnection(const db_mgmt_ConnectionRef &connectionProperties, ConnectionInitSlot connection_init_slot)
+ {
+ TunnelConnection* tunnel = NULL;
++ gchar *p = NULL;
++ GModule *gmodule = NULL;
+ // 0. determine correct driver filename
+
+ db_mgmt_DriverRef drv = connectionProperties->driver();
+@@ -148,21 +150,21 @@ ConnectionWrapper DriverManager::getConn
+ library = drv->driverLibraryName();
+ else
+ throw SQLException("Invalid connection settings: undefined connection driver");
+-#ifdef _WIN32
+- library.append(".dll");
+-#elif defined(__APPLE__)
+- library.append(".dylib");
+-#else
+- library.append(".so");
+-#endif
++
++ // Patch : use library in standard path
++ p = g_module_build_path (NULL, library.c_str());
+
+ // 1. find driver
+
+- GModule *gmodule= g_module_open((_driver_path + "/" + library).c_str(), G_MODULE_BIND_LOCAL);
++ if (p) {
++ gmodule = g_module_open(std::string(p).append(".4").c_str(), G_MODULE_BIND_LOCAL);
++ g_free(p);
++ }
++
+ if (NULL == gmodule)
+ {
+ fprintf(stderr, "Error: %s", g_module_error());
+- throw SQLException(std::string("Database driver: Failed to open library '").append(_driver_path + "/" + library).append("'. Check settings.").c_str());
++ throw SQLException(std::string("Database driver: Failed to open library '").append(library).append("'. Check settings.").c_str());
+ }
+
+ Driver *(* get_driver_instance)()= NULL;
diff --git a/mysql-workbench.spec b/mysql-workbench.spec
new file mode 100644
index 0000000..281ab1f
--- /dev/null
+++ b/mysql-workbench.spec
@@ -0,0 +1,216 @@
+#global postver b
+
+%global cppconnver 1.1.0
+
+Summary: A MySQL visual database modeling tool
+Name: mysql-workbench
+Version: 5.2.20
+Release: 1%{?dist}
+Group: Applications/Databases
+License: GPLv2
+
+URL: http://wb.mysql.com
+Source: %{name}-oss-%{version}%{?postver}.tar.gz
+
+# don't build extension, use system one
+# !!! This patch use versioned soname !!!
+Patch1: %{name}-5.2.17-cppconn.patch
+Patch2: %{name}-5.2.16-scintilla.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: pcre-devel >= 3.9
+BuildRequires: libglade2-devel >= 2.0.0
+BuildRequires: lua-devel >= 5.1
+%if %{fedora} >= 12
+BuildRequires: ctemplate-devel
+%endif
+BuildRequires: libgnome-devel >= 2
+BuildRequires: automake autoconf libtool
+BuildRequires: lua-devel
+BuildRequires: libzip-devel libxml2-devel
+BuildRequires: libglade2-devel
+BuildRequires: readline-devel
+BuildRequires: python-devel >= 2.4
+BuildRequires: gnome-keyring-devel
+BuildRequires: boost-devel
+BuildRequires: libsigc++20-devel
+BuildRequires: curl-devel
+BuildRequires: openssl-devel
+BuildRequires: mysql-devel >= 5.1
+%if %{fedora} >= 12
+BuildRequires: libuuid-devel
+%endif
+BuildRequires: uuid-devel
+BuildRequires: gtkmm24-devel
+BuildRequires: mesa-libGL-devel
+BuildRequires: sqlite-devel
+
+
+BuildRequires: mysql-connector-c++-devel >= %{cppconnver}
+BuildRequires: desktop-file-utils
+Requires(post): desktop-file-utils
+Requires(postun): desktop-file-utils
+
+Requires: python-paramiko pexpect
+# requires mysql client pkg (for mysqldump and mysql cmdline client)
+Requires: mysql gnome-keyring
+Requires: mysql-connector-c++ >= %{cppconnver}
+# Official upstream build
+Conflicts: mysql-workbench-oss
+
+
+%description
+MySQL Workbench provides DBAs and developers an integrated
+tools environment for:
+* Database Design & Modeling
+* SQL Development (replacing MySQL Query Browser)
+* Database Administration (replacing MySQL Administrator)
+
+
+%prep
+%setup -q -n %{name}-oss-%{version}%{?postver}
+
+%patch1 -p1 -b .cppconn
+#patch2 -p1 -b .scintilla
+
+# we use System provided libraries
+rm -rf ext/boost
+rm -rf ext/curl
+rm -rf ext/libsigc++
+rm -rf ext/yassl
+rm -rf ext/cppconn
+#rm -rf ext/scintilla
+
+
+
+%build
+NOCONFIGURE=yes ./autogen.sh
+%configure \
+%if %{fedora} >= 12
+ --with-system-ctemplate \
+%endif
+ --disable-debug
+
+make %{?_smp_mflags}
+
+
+%install
+rm -rf %{buildroot}
+make install DESTDIR=%{buildroot}
+
+# clean dev files
+echo Cleanup dev file
+find %{buildroot}%{_libdir}/mysql-workbench -name \*.a -exec rm {} \; -print
+find %{buildroot}%{_libdir}/mysql-workbench -name \*.la -exec rm {} \; -print
+#find %{buildroot}%{_libdir}/mysql-workbench -type f -name \*.so.\* -exec chmod +x {} \;
+
+desktop-file-install --vendor="" \
+ --dir=%{buildroot}%{_datadir}/applications/ \
+ MySQLWorkbench.desktop
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+update-desktop-database &> /dev/null || :
+
+
+%postun
+update-desktop-database &> /dev/null || :
+
+
+%files
+%defattr(-, root, root, -)
+%doc COPYING samples ChangeLog
+%attr(0755,root,root) %{_bindir}/mysql-workbench
+%attr(0755,root,root) %{_bindir}/mysql-workbench-bin
+##%attr(0755,root,root) %{_bindir}/grtshell
+%dir %{_libdir}/mysql-workbench
+%{_libdir}/mysql-workbench/*
+%{_datadir}/applications/*.desktop
+%dir %{_datadir}/mysql-workbench
+%{_datadir}/mysql-workbench/*
+
+
+%changelog
+* Wed Apr 28 2010 Remi Collet <RPMS@famillecollet.com> 5.2.20-1.###.remi
+- update to 5.2.20 beta 10 Community (OSS) Edition
+
+* Sat Apr 17 2010 Remi Collet <RPMS@famillecollet.com> 5.2.19-1.###.remi
+- update to 5.2.19 beta 9 Community (OSS) Edition
+
+* Thu Apr 15 2010 Remi Collet <RPMS@famillecollet.com> 5.2.18-1.###.remi
+- update to 5.2.18 beta 8 Community (OSS) Edition
+
+* Sat Apr 03 2010 Remi Collet <RPMS@famillecollet.com> 5.2.17-1.###.remi
+- update to 5.2.17 beta Community (OSS) Edition
+- build against mysql-connector-c++ 1.1.0 (bzr818)
+
+* Wed Feb 17 2010 Remi Collet <RPMS@famillecollet.com> 5.2.16-1.###.remi
+- update to 5.2.16 beta Community (OSS) Edition
+
+* Thu Feb 04 2010 Remi Collet <RPMS@famillecollet.com> 5.2.15-2.###.remi
+- update to 5.2.15b beta Community (OSS) Edition
+
+* Sat Jan 30 2010 Remi Collet <RPMS@famillecollet.com> 5.2.15-1.###.remi
+- update to 5.2.15 beta Community (OSS) Edition
+
+* Fri Jan 22 2010 Remi Collet <RPMS@famillecollet.com> 5.2.14-1.###.remi
+- update to 5.2.14 beta Community (OSS) Edition
+
+* Sun Jan 10 2010 Remi Collet <RPMS@famillecollet.com> 5.2.11-1.###.remi
+- update to 5.2.11 beta Community (OSS) Edition
+
+* Sat Sep 05 2009 Remi Collet <RPMS@famillecollet.com> 5.1.18-1.###.remi
+- update to 5.1.18 GA Community (OSS) Edition
+
+* Sun Aug 16 2009 Remi Collet <RPMS@famillecollet.com> 5.1.17-1.###.remi
+- update to 5.1.17 GA Community (OSS) Edition
+
+* Wed Jul 01 2009 Remi Collet <RPMS@famillecollet.com> 5.1.16-1.###.remi
+- update to 5.1.16 GA Community (OSS) Edition
+
+* Sun Jun 28 2009 Remi Collet <RPMS@famillecollet.com> 5.1.15-3.###.remi
+- switch to system mysql-connector-c++ librairy
+
+* Sat Jun 27 2009 Remi Collet <RPMS@famillecollet.com> 5.1.15-2.###.remi
+- switch to system librairies (boost, libsigc++, curl, openssl)
+
+* Sat Jun 27 2009 Remi Collet <RPMS@famillecollet.com> 5.1.15-1.###.remi
+- update to 5.1.15 RC3 Community (OSS) Edition
+
+* Fri Jun 19 2009 Remi Collet <RPMS@famillecollet.com> 5.1.14-1.###.remi
+- update to 5.1.14 RC2 Community (OSS) Edition
+
+* Fri Jun 12 2009 Remi Collet <RPMS@famillecollet.com> 5.1.13-1.###.remi
+- update to 5.1.13 RC1 Community (OSS) Edition
+
+* Fri May 01 2009 Remi Collet <RPMS@famillecollet.com> 5.1.12-2.fc11.remi
+- F11 build
+- add BR mesa-libGL-devel
+- add gcc44 patch
+
+* Tue Apr 28 2009 Remi Collet <RPMS@famillecollet.com> 5.1.12-1.###.remi
+- update to 5.1.12 Beta Community (OSS) Edition
+- add a patch for ppc build
+
+* Fri Apr 10 2009 Remi Collet <RPMS@famillecollet.com> 5.1.10-1.###.remi
+- update to 5.1.10 beta
+
+* Sat Mar 21 2009 Remi Collet <RPMS@famillecollet.com> 5.1.9-1.###.remi
+- update to 5.1.9 beta
+
+* Sun Jan 13 2009 Remi Collet <RPMS@famillecollet.com> 5.1.7-1.###.remi
+- update to 5.1.7 alpha
+
+* Sat Dec 13 2008 Remi Collet <RPMS@famillecollet.com> 5.1.5-1.###.remi
+- update to 5.1.5 alpha
+
+* Wed Dec 03 2008 Remi Collet <RPMS@famillecollet.com> 5.1.4-1.fc10.remi.1
+- remove dev files
+
+* Tue Dec 02 2008 Remi Collet <RPMS@famillecollet.com> 5.1.4-1.fc10.remi
+- F10 build
+