summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-04-16 09:38:48 +0200
committerRemi Collet <fedora@famillecollet.com>2012-04-16 09:38:48 +0200
commitf7203b3496ea9af906403112f558ba8aed119ba8 (patch)
tree074150136bc151d05a585932632d671c7dbce9cd
parentef684a6dac45a38c0c45d55041f3ec0c374b48cd (diff)
MySQL Workbench 5.2.39
-rw-r--r--mysql-workbench-5.2.34-man.patch12
-rw-r--r--mysql-workbench-gpl-5.2.39.spec145
-rw-r--r--mysql-workbench.spec68
3 files changed, 151 insertions, 74 deletions
diff --git a/mysql-workbench-5.2.34-man.patch b/mysql-workbench-5.2.34-man.patch
deleted file mode 100644
index 9a12a74..0000000
--- a/mysql-workbench-5.2.34-man.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up mysql-workbench-gpl-5.2.34-src/ext/mysql-utilities/setup.py.orig mysql-workbench-gpl-5.2.34-src/ext/mysql-utilities/setup.py
---- mysql-workbench-gpl-5.2.34-src/ext/mysql-utilities/setup.py.orig 2011-05-28 08:32:01.667811328 +0200
-+++ mysql-workbench-gpl-5.2.34-src/ext/mysql-utilities/setup.py 2011-05-28 08:32:30.464887518 +0200
-@@ -110,7 +110,7 @@ class install_man(distutils.core.Command
- self.set_undefined_options('build_sphinx',
- ('build_dir', 'build_dir'),
- )
-- self.target_dir = os.path.join(self.install_base, 'man')
-+ self.target_dir = os.path.join(self.install_base, 'share/man')
- self.source_dir = os.path.join(self.build_dir, 'man')
-
- def run(self):
diff --git a/mysql-workbench-gpl-5.2.39.spec b/mysql-workbench-gpl-5.2.39.spec
new file mode 100644
index 0000000..9e82cee
--- /dev/null
+++ b/mysql-workbench-gpl-5.2.39.spec
@@ -0,0 +1,145 @@
+%if !%{defined version}
+%define version 5.2.39
+%endif
+%define release 1
+%define edition gpl
+%define have_python26 1
+%include %{_rpmconfigdir}/macros.python
+
+Summary: A MySQL visual database modeling, administration and querying tool.
+Name: mysql-workbench-%{edition}
+Version: %{version}
+Release: %{release}%{targos}
+Group: Applications/Databases
+Vendor: Oracle Corporation
+License: GPL
+URL: http://wb.mysql.com
+Source: %{name}-%{version}-src.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-root
+BuildRequires: pcre-devel >= 3.9
+BuildRequires: lua-devel >= 5.1
+BuildRequires: automake autoconf libtool
+BuildRequires: libzip-devel libxml2-devel
+BuildRequires: python-devel >= 2.5
+BuildRequires: gnome-keyring-devel
+BuildRequires: boost-devel
+
+%if %_vendor == suse
+BuildRequires: libmysqlclient-devel, libctemplate-devel
+BuildRequires: Mesa
+%else
+%if %targos == fc15
+BuildRequires: ctemplate-devel
+%endif
+BuildRequires: mysql-devel >= 5.1
+BuildRequires: gtkmm24-devel
+BuildRequires: mesa-libGL-devel
+BuildRequires: sqlite-devel
+%endif
+
+%if %_vendor == suse
+Requires: python-paramiko python-pexpect
+%else
+Requires: python-paramiko pexpect
+%endif
+%if %{defined fc13}
+Requires: python-sqlite2
+%endif
+# requires mysql client pkg (for mysqldump and mysql cmdline client)
+Requires: mysql gnome-keyring
+
+# our old package name
+Obsoletes: mysql-workbench-oss
+Conflicts: mysql-workbench-oss
+Conflicts: mysql-workbench-com-se
+
+%description
+MySQL Workbench is a modeling tool that allows you to design
+and generate MySQL databases graphically. It also has administration
+and query development modules where you can manage MySQL server instances
+and execute SQL queries.
+
+%prep
+%setup -q -n %{name}-%{version}-src
+
+%build
+
+NOCONFIGURE=yes ./autogen.sh
+%if %{have_python26}
+%if %targos == el6
+%configure --disable-debug --enable-mysql-utilities --disable-dependency-tracking --with-bundled-ctemplate
+%else
+%configure --disable-debug --enable-mysql-utilities --disable-dependency-tracking
+%endif
+%else
+%configure --disable-debug --disable-dependency-tracking
+%endif
+make
+
+%install
+make install DESTDIR=%{buildroot}
+rm -fr %{buildroot}/usr/share/doc/mysql-workbench
+%if %{have_python26}
+make -C ext install-utils DESTDIR=%{buildroot}
+make -C ext install-connector DESTDIR=%{buildroot}
+%endif
+
+find %{buildroot}%{_libdir}/mysql-workbench -name \*.a -exec rm {} \; -print
+find %{buildroot}%{_libdir}/mysql-workbench -name \*.la -exec rm {} \; -print
+
+%if %{defined centos}
+for l in libpixman-1.so.0 libcairo.so.2 libatkmm-1.6.so.1 libcairomm-1.0.so.1 libgdkmm-2.4.so.1 libglibmm-2.4.so.1 libgtkmm-2.4.so.1 libpangomm-1.4.so.1 libzip.so.1 libsigc-2.0.so.0; do
+cp %{_libdir}/$l %{buildroot}/%{_libdir}/mysql-workbench
+/usr/sbin/prelink -u %{buildroot}/%{_libdir}/mysql-workbench/$l || true
+done
+%endif
+
+%post
+touch --no-create %{_datadir}/icons/hicolor || :
+if [ -x %{_bindir}/gtk-update-icon-cache ]; then
+ %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
+fi
+
+if [ -x %{_bindir}/update-desktop-database ]; then
+ %{_bindir}/update-desktop-database
+fi
+
+if [ -x %{_bindir}/update-mime-database ]; then
+ %{_bindir}/update-mime-database %{_datadir}/mime
+fi
+
+%postun
+touch --no-create %{_datadir}/icons/hicolor || :
+if [ -x %{_bindir}/gtk-update-icon-cache ]; then
+ %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
+fi
+
+if [ -x %{_bindir}/update-desktop-database ]; then
+ %{_bindir}/update-desktop-database
+fi
+
+if [ -x %{_bindir}/update-mime-database ]; then
+ %{_bindir}/update-mime-database %{_datadir}/mime
+fi
+
+
+%clean
+rm -rf %{buildroot}
+rm -rf %{_builddir}/%{name}-%{version}-src
+
+%files
+%defattr(0644, root, root, 0755)
+%doc COPYING README
+%attr(0755,root,root) %{_bindir}/mysql*
+%dir %{_libdir}/mysql-workbench
+%{_libdir}/mysql-workbench/*
+%{_datadir}/icons/hicolor/*/mimetypes/*
+%{_datadir}/icons/hicolor/*/apps/*
+%{_datadir}/mime-info/*
+%{_datadir}/mime/packages/*
+%{_datadir}/applications/*.desktop
+%dir %{_datadir}/mysql-workbench
+%{_datadir}/mysql-workbench/*
+
+%changelog
+
diff --git a/mysql-workbench.spec b/mysql-workbench.spec
index bfbc69e..8ea2450 100644
--- a/mysql-workbench.spec
+++ b/mysql-workbench.spec
@@ -1,6 +1,6 @@
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
-%global mw_version 5.2.38
+%global mw_version 5.2.39
%global mw_release 1
%global tarversion gpl-%{mw_version}-src
%global srcversion gpl-%{mw_version}-src
@@ -29,8 +29,6 @@ Source: http://gd.tuwien.ac.at/db/mysql/Downloads/MySQLGUITools/%{name}-%{tar
Patch1: %{name}-5.2.28-cppconn.patch
Patch2: %{name}-5.2.32-ctemplate.patch
Patch3: %{name}-5.2.36-tinyxml.patch
-# redirect man page to /usr/share
-Patch5: %{name}-5.2.34-man.patch
# http://bugs.mysql.com/63705 - Only <glib.h> can be included directly
Patch6: %{name}-5.2.36-glib.patch
# http://bugs.mysql.com/63777 - service startup/shutdown command
@@ -108,27 +106,6 @@ an integrated tools environment for:
* Database Administration (replacing MySQL Administrator)
-%package -n mysql-utilities
-
-Summary: Scripts for managing and administering MySQL servers
-# Not yet published (else will be package separatly)
-# see ext/mysql-utilities/CHANGES.txt
-Version: 1.0.3
-Release: 0.%{mw_version}%{?dist}.%{mw_release}
-
-BuildArch: noarch
-BuildRequires: python-devel >= 2.4
-%if 0%{?fedora} >= 14
-BuildRequires: python-sphinx >= 1.0
-%endif
-
-Requires: mysql-connector-python
-
-%description -n mysql-utilities
-MySQL Utilities contain a collection of scripts useful for managing
-and administering MySQL servers.
-
-
%prep
%setup -q -n %{name}-%{srcversion}
@@ -147,7 +124,6 @@ rm -rf ext/ctemplate
rm -rf library/tinyxml
%endif
-%patch5 -p1 -b .man
%patch6 -p1 -b .glib
%patch7 -p1 -b .profiles
%patch8 -p1 -b .automake
@@ -179,22 +155,11 @@ export CXXFLAGS="$RPM_OPT_FLAGS -fpermissive"
make %{?_smp_mflags}
-%if 0%{?fedora} >= 14
-pushd ext/mysql-utilities
-%{__python} setup.py build_man
-popd
-%endif
-
%install
rm -rf %{buildroot}
make install DESTDIR=%{buildroot}
-pushd ext/mysql-utilities
-install --directory %{buildroot}%{_mandir}/man1
-%{__python} setup.py install --skip-profile --root %{buildroot}
-popd
-
# clean dev files
echo Cleanup dev file
find %{buildroot}%{_libdir}/%{name} -name \*.a -exec rm {} \; -print
@@ -244,33 +209,12 @@ fi
%exclude %{_datadir}/doc/%{name}
-%files -n mysql-utilities
-%defattr(-, root, root, -)
-%doc ext/mysql-utilities/*.txt
-%{_bindir}/mysqldbcompare
-%{_bindir}/mysqldbcopy
-%{_bindir}/mysqldbexport
-%{_bindir}/mysqldbimport
-%{_bindir}/mysqldiff
-%{_bindir}/mysqldiskusage
-%{_bindir}/mysqlindexcheck
-%{_bindir}/mysqlmetagrep
-%{_bindir}/mysqlprocgrep
-%{_bindir}/mysqlreplicate
-%{_bindir}/mysqlrplcheck
-%{_bindir}/mysqlserverclone
-%{_bindir}/mysqlserverinfo
-%{_bindir}/mysqluserclone
-%{python_sitelib}/mysql/utilities
-%{python_sitelib}/mysql_utilities*
-%if 0%{?fedora} >= 14
-%{_mandir}/man1/*
-%endif
-# empty file already provided by mysql-connector-python
-%exclude %{python_sitelib}/mysql/__init*
-
-
%changelog
+* Sun Apr 15 2012 Remi Collet <remi@fedoraproject.org> 5.2.39-1
+- update to 5.2.39 Community (OSS) Edition (GPL)
+ http://dev.mysql.com/doc/workbench/en/wb-news-5-2-39.html
+- remove mysql-utilities sub-package (available separately)
+
* Fri Feb 24 2012 Remi Collet <remi@fedoraproject.org> 5.2.38-1
- update to 5.2.38 Community (OSS) Edition (GPL)
http://dev.mysql.com/doc/workbench/en/wb-news-5-2-38.html