summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2010-08-07 08:44:58 +0200
committerRemi Collet <fedora@famillecollet.com>2010-08-07 08:44:58 +0200
commit1ab04de429fe808bdb32b09645c15989d1a031b8 (patch)
tree886deb7020e91885ebb2bfa7ffea5372fbf0a710
parent2e5b67700dfe741768d35bb4a71395dec63f10a4 (diff)
MySQL Workbench 5.2.26
-rw-r--r--mysql-workbench-5.2.17-cppconn.patch73
-rw-r--r--mysql-workbench-5.2.26-cppconn.patch (renamed from mysql-workbench-5.2.24-cppconn.patch)26
-rw-r--r--mysql-workbench-gpl-5.2.26-1fc12.spec97
-rw-r--r--mysql-workbench.spec11
4 files changed, 117 insertions, 90 deletions
diff --git a/mysql-workbench-5.2.17-cppconn.patch b/mysql-workbench-5.2.17-cppconn.patch
deleted file mode 100644
index 511fc11..0000000
--- a/mysql-workbench-5.2.17-cppconn.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-diff -up mysql-workbench-oss-5.2.17/configure.in.cppconn mysql-workbench-oss-5.2.17/configure.in
---- mysql-workbench-oss-5.2.17/configure.in.cppconn 2010-04-02 03:26:27.000000000 +0200
-+++ mysql-workbench-oss-5.2.17/configure.in 2010-04-03 15:37:43.000000000 +0200
-@@ -459,8 +459,6 @@ res/mysql.profiles/Makefile
- res/sqlidedata/Makefile
- ext/Makefile
- ext/scintilla/gtk/Makefile
--ext/cppconn/Makefile
--ext/cppconn/driver/Makefile
- backend/Makefile
- backend/wbpublic/Makefile
- backend/wbprivate/Makefile
-diff -up mysql-workbench-oss-5.2.17/ext/Makefile.am.cppconn mysql-workbench-oss-5.2.17/ext/Makefile.am
---- mysql-workbench-oss-5.2.17/ext/Makefile.am.cppconn 2010-04-02 03:26:17.000000000 +0200
-+++ mysql-workbench-oss-5.2.17/ext/Makefile.am 2010-04-03 15:37:43.000000000 +0200
-@@ -1 +1 @@
--SUBDIRS=ctemplate scintilla/gtk cppconn
-+SUBDIRS=ctemplate scintilla/gtk
-diff -up mysql-workbench-oss-5.2.17/ext/Makefile.in.cppconn mysql-workbench-oss-5.2.17/ext/Makefile.in
---- mysql-workbench-oss-5.2.17/ext/Makefile.in.cppconn 2010-04-02 03:26:32.000000000 +0200
-+++ mysql-workbench-oss-5.2.17/ext/Makefile.in 2010-04-03 15:37:43.000000000 +0200
-@@ -213,7 +213,7 @@ sysconfdir = @sysconfdir@
- target_alias = @target_alias@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
--SUBDIRS = ctemplate scintilla/gtk cppconn
-+SUBDIRS = ctemplate scintilla/gtk
- all: all-recursive
-
- .SUFFIXES:
-diff -up mysql-workbench-oss-5.2.17/library/dbc/src/driver_manager.cpp.cppconn mysql-workbench-oss-5.2.17/library/dbc/src/driver_manager.cpp
---- mysql-workbench-oss-5.2.17/library/dbc/src/driver_manager.cpp.cppconn 2010-04-03 15:38:46.000000000 +0200
-+++ mysql-workbench-oss-5.2.17/library/dbc/src/driver_manager.cpp 2010-04-03 15:40:59.000000000 +0200
-@@ -139,6 +139,8 @@ TunnelConnection *DriverManager::getTunn
- ConnectionWrapper DriverManager::getConnection(const db_mgmt_ConnectionRef &connectionProperties, ConnectionInitSlot connection_init_slot)
- {
- TunnelConnection* tunnel = NULL;
-+ gchar *p = NULL;
-+ GModule *gmodule = NULL;
- // 0. determine correct driver filename
-
- db_mgmt_DriverRef drv = connectionProperties->driver();
-@@ -148,21 +150,21 @@ ConnectionWrapper DriverManager::getConn
- library = drv->driverLibraryName();
- else
- throw SQLException("Invalid connection settings: undefined connection driver");
--#ifdef _WIN32
-- library.append(".dll");
--#elif defined(__APPLE__)
-- library.append(".dylib");
--#else
-- library.append(".so");
--#endif
-+
-+ // Patch : use library in standard path
-+ p = g_module_build_path (NULL, library.c_str());
-
- // 1. find driver
-
-- GModule *gmodule= g_module_open((_driver_path + "/" + library).c_str(), G_MODULE_BIND_LOCAL);
-+ if (p) {
-+ gmodule = g_module_open(std::string(p).append(".4").c_str(), G_MODULE_BIND_LOCAL);
-+ g_free(p);
-+ }
-+
- if (NULL == gmodule)
- {
- fprintf(stderr, "Error: %s", g_module_error());
-- throw SQLException(std::string("Database driver: Failed to open library '").append(_driver_path + "/" + library).append("'. Check settings.").c_str());
-+ throw SQLException(std::string("Database driver: Failed to open library '").append(library).append("'. Check settings.").c_str());
- }
-
- Driver *(* get_driver_instance)()= NULL;
diff --git a/mysql-workbench-5.2.24-cppconn.patch b/mysql-workbench-5.2.26-cppconn.patch
index 9d77c33..b941d03 100644
--- a/mysql-workbench-5.2.24-cppconn.patch
+++ b/mysql-workbench-5.2.26-cppconn.patch
@@ -1,6 +1,6 @@
-diff -up mysql-workbench-ce-5.2.24/configure.in.cppconn mysql-workbench-ce-5.2.24/configure.in
---- mysql-workbench-ce-5.2.24/configure.in.cppconn 2010-06-19 04:40:20.000000000 +0200
-+++ mysql-workbench-ce-5.2.24/configure.in 2010-06-23 20:07:19.190367417 +0200
+diff -up mysql-workbench-gpl-5.2.26/configure.in.cppconn mysql-workbench-gpl-5.2.26/configure.in
+--- mysql-workbench-gpl-5.2.26/configure.in.cppconn 2010-08-05 15:33:27.000000000 +0200
++++ mysql-workbench-gpl-5.2.26/configure.in 2010-08-07 08:11:56.906643649 +0200
@@ -462,8 +462,6 @@ res/mysql.profiles/Makefile
res/sqlidedata/Makefile
ext/Makefile
@@ -10,18 +10,18 @@ diff -up mysql-workbench-ce-5.2.24/configure.in.cppconn mysql-workbench-ce-5.2.2
backend/Makefile
backend/wbpublic/Makefile
backend/wbprivate/Makefile
-diff -up mysql-workbench-ce-5.2.24/ext/Makefile.am.cppconn mysql-workbench-ce-5.2.24/ext/Makefile.am
---- mysql-workbench-ce-5.2.24/ext/Makefile.am.cppconn 2010-06-23 20:08:40.950491999 +0200
-+++ mysql-workbench-ce-5.2.24/ext/Makefile.am 2010-06-19 04:40:18.000000000 +0200
+diff -up mysql-workbench-gpl-5.2.26/ext/Makefile.am.cppconn mysql-workbench-gpl-5.2.26/ext/Makefile.am
+--- mysql-workbench-gpl-5.2.26/ext/Makefile.am.cppconn 2010-08-05 15:33:23.000000000 +0200
++++ mysql-workbench-gpl-5.2.26/ext/Makefile.am 2010-08-07 08:11:56.907643461 +0200
@@ -4,4 +4,4 @@ else
ctemplate_dirs=ctemplate
endif
-SUBDIRS=scintilla/gtk cppconn $(ctemplate_dirs)
+SUBDIRS=scintilla/gtk $(ctemplate_dirs)
-diff -up mysql-workbench-ce-5.2.24/ext/Makefile.in.cppconn mysql-workbench-ce-5.2.24/ext/Makefile.in
---- mysql-workbench-ce-5.2.24/ext/Makefile.in.cppconn 2010-06-19 04:40:24.000000000 +0200
-+++ mysql-workbench-ce-5.2.24/ext/Makefile.in 2010-06-23 20:09:17.544511184 +0200
+diff -up mysql-workbench-gpl-5.2.26/ext/Makefile.in.cppconn mysql-workbench-gpl-5.2.26/ext/Makefile.in
+--- mysql-workbench-gpl-5.2.26/ext/Makefile.in.cppconn 2010-08-05 15:33:32.000000000 +0200
++++ mysql-workbench-gpl-5.2.26/ext/Makefile.in 2010-08-07 08:11:56.907643461 +0200
@@ -53,7 +53,7 @@ RECURSIVE_CLEAN_TARGETS = mostlyclean-re
distclean-recursive maintainer-clean-recursive
ETAGS = etags
@@ -40,9 +40,9 @@ diff -up mysql-workbench-ce-5.2.24/ext/Makefile.in.cppconn mysql-workbench-ce-5.
all: all-recursive
.SUFFIXES:
-diff -up mysql-workbench-ce-5.2.24/library/dbc/src/driver_manager.cpp.cppconn mysql-workbench-ce-5.2.24/library/dbc/src/driver_manager.cpp
---- mysql-workbench-ce-5.2.24/library/dbc/src/driver_manager.cpp.cppconn 2010-06-19 04:40:15.000000000 +0200
-+++ mysql-workbench-ce-5.2.24/library/dbc/src/driver_manager.cpp 2010-06-23 20:07:19.192367230 +0200
+diff -up mysql-workbench-gpl-5.2.26/library/dbc/src/driver_manager.cpp.cppconn mysql-workbench-gpl-5.2.26/library/dbc/src/driver_manager.cpp
+--- mysql-workbench-gpl-5.2.26/library/dbc/src/driver_manager.cpp.cppconn 2010-08-05 15:33:19.000000000 +0200
++++ mysql-workbench-gpl-5.2.26/library/dbc/src/driver_manager.cpp 2010-08-07 08:11:56.907643461 +0200
@@ -145,6 +145,8 @@ TunnelConnection *DriverManager::getTunn
ConnectionWrapper DriverManager::getConnection(const db_mgmt_ConnectionRef &connectionProperties, ConnectionInitSlot connection_init_slot)
{
@@ -71,7 +71,7 @@ diff -up mysql-workbench-ce-5.2.24/library/dbc/src/driver_manager.cpp.cppconn my
- GModule *gmodule= g_module_open((_driver_path + "/" + library).c_str(), G_MODULE_BIND_LOCAL);
+ if (p) {
-+ gmodule = g_module_open(std::string(p).append(".4").c_str(), G_MODULE_BIND_LOCAL);
++ gmodule = g_module_open(std::string(p).append(".5").c_str(), G_MODULE_BIND_LOCAL);
+ g_free(p);
+ }
+
diff --git a/mysql-workbench-gpl-5.2.26-1fc12.spec b/mysql-workbench-gpl-5.2.26-1fc12.spec
new file mode 100644
index 0000000..d4db759
--- /dev/null
+++ b/mysql-workbench-gpl-5.2.26-1fc12.spec
@@ -0,0 +1,97 @@
+%if !%{defined version}
+%define version 5.2.26
+%endif
+%define release 1
+%define edition gpl
+
+Summary: A MySQL visual database modeling, administration and querying tool.
+Name: mysql-workbench-%{edition}
+Version: %{version}
+Release: %{release}%{targos}
+Group: Applications/Databases
+Vendor: Oracle Corporation
+License: GPL
+URL: http://wb.mysql.com
+Source: %{name}-%{version}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-root
+BuildRequires: pcre-devel >= 3.9
+BuildRequires: libglade2-devel >= 2.0.0
+BuildRequires: lua-devel >= 5.1
+BuildRequires: libgnome-devel >= 2
+BuildRequires: automake autoconf libtool
+BuildRequires: lua-devel
+BuildRequires: libzip-devel libxml2-devel
+BuildRequires: libglade2-devel
+BuildRequires: readline-devel
+BuildRequires: python-devel >= 2.4
+BuildRequires: gnome-keyring-devel
+BuildRequires: boost-devel
+
+%if %{defined suse}
+BuildRequires: libmysqlclient-devel
+BuildRequires: Mesa
+%else
+BuildRequires: mysql-devel >= 5.1
+%if !%{defined centos}
+BuildRequires: uuid-devel
+%endif
+BuildRequires: gtkmm24-devel
+BuildRequires: mesa-libGL-devel
+%endif
+
+%if %{defined suse}
+Requires: python-paramiko python-pexpect
+%else
+Requires: python-paramiko pexpect
+%endif
+%if %{defined fc12}
+Requires: python-sqlite2
+%endif
+# requires mysql client pkg (for mysqldump and mysql cmdline client)
+Requires: mysql gnome-keyring
+
+# our old package name
+Obsoletes: mysql-workbench-oss
+Conflicts: mysql-workbench-oss
+
+%description
+MySQL Workbench is a modeling tool that allows you to design
+and generate MySQL databases graphically. It also has administration
+and query development modules where you can manage MySQL server instances
+and execute SQL queries.
+
+%prep
+%setup -q -n %{name}-%{version}
+
+%build
+
+NOCONFIGURE=yes ./autogen.sh
+%configure --disable-debug --enable-python-modules
+make
+
+%install
+make install DESTDIR=%{buildroot}
+%if %{defined centos}
+for l in libpixman-1.so.0 libcairo.so.2 libatkmm-1.6.so.1 libcairomm-1.0.so.1 libgdkmm-2.4.so.1 libglibmm-2.4.so.1 libgtkmm-2.4.so.1 libpangomm-1.4.so.1 libzip.so.1 libsigc-2.0.so.0; do
+cp %{_libdir}/$l %{buildroot}/%{_libdir}/mysql-workbench
+/usr/sbin/prelink -u %{buildroot}/%{_libdir}/mysql-workbench/$l || true
+done
+%endif
+
+%clean
+rm -rf %{buildroot}
+rm -rf %{_builddir}/%{name}-%{version}
+
+%files
+%defattr(0644, root, root, 0755)
+%doc COPYING
+%attr(0755,root,root) %{_bindir}/mysql-workbench
+%attr(0755,root,root) %{_bindir}/mysql-workbench-bin
+%dir %{_libdir}/mysql-workbench
+%{_libdir}/mysql-workbench/*
+%{_datadir}/applications/*.desktop
+%dir %{_datadir}/mysql-workbench
+%{_datadir}/mysql-workbench/*
+
+%changelog
+
diff --git a/mysql-workbench.spec b/mysql-workbench.spec
index 682f5e1..390271f 100644
--- a/mysql-workbench.spec
+++ b/mysql-workbench.spec
@@ -1,11 +1,11 @@
#global postver b
%global tartype gpl
-%global cppconnver 1.1.0-0.1.bzr819
+%global cppconnver 1.1.0-0.1.bzr888
-Summary: A MySQL visual database modeling tool
+Summary: A MySQL visual database modeling, administration and querying tool.
Name: mysql-workbench
-Version: 5.2.25
+Version: 5.2.26
Release: 1%{?dist}
Group: Applications/Databases
License: GPLv2
@@ -15,7 +15,7 @@ Source: %{name}-%{tartype}-%{version}%{?postver}.tar.gz
# don't build extension, use system one
# !!! This patch use versioned soname !!!
-Patch1: %{name}-5.2.24-cppconn.patch
+Patch1: %{name}-5.2.26-cppconn.patch
Patch2: %{name}-5.2.16-scintilla.patch
Patch3: %{name}-5.2.22-python.patch
@@ -139,6 +139,9 @@ update-desktop-database &> /dev/null || :
%changelog
+* Sat Aug 07 2010 Remi Collet <RPMS@famillecollet.com> 5.2.26-1
+- update to 5.2.26 Community Edition (GPL)
+
* Thu Jul 01 2010 Remi Collet <RPMS@famillecollet.com> 5.2.25-1
- update to 5.2.25 Community Edition (GPL)