summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2011-03-20 10:57:04 +0100
committerRemi Collet <fedora@famillecollet.com>2011-03-20 10:57:04 +0100
commitd960b25276d927d6e3163d0e808f91b8dbd1eeee (patch)
treea7cd85a900bbdf0b01fef5d5714d675af0bf238e
parent628b9084cdf861b98d6eca7136cdadcae36efe19 (diff)
mysql-connector-python3
-rw-r--r--mysql-connector-python.spec27
1 files changed, 25 insertions, 2 deletions
diff --git a/mysql-connector-python.spec b/mysql-connector-python.spec
index e280a5f..a5d9d4a 100644
--- a/mysql-connector-python.spec
+++ b/mysql-connector-python.spec
@@ -3,7 +3,7 @@
Name: mysql-connector-python
Version: 0.3.2
Release: 2%{?dist}
-Summary: MySQL Connector/Python
+Summary: MySQL Connector for Python 2
Group: Development/Languages
License: GPLv2 with exceptions
@@ -13,6 +13,7 @@ Source0: http://launchpad.net/myconnpy/0.3/%{version}/+download/%{name}-%
BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: python-devel
+BuildRequires: python3-devel
# for unittest
BuildRequires: mysql-server
@@ -22,11 +23,20 @@ MySQL Connector/Python is implementing the MySQL Client/Server protocol
completely in Python. No MySQL libraries are needed, and no compilation
is necessary to run this Python DB API v2.0 compliant driver.
+%package -n mysql-connector-python3
+
+Summary: MySQL Connector for Python 3
+
+%description -n mysql-connector-python3
+MySQL Connector/Python is implementing the MySQL Client/Server protocol
+completely in Python. No MySQL libraries are needed, and no compilation
+is necessary to run this Python DB API v2.0 compliant driver.
+
%prep
%setup -q -n %{name}-%{version}-devel
-%{__chmod} -x python2/examples/*py
+%{__chmod} -x python?/examples/*py
%build
@@ -35,6 +45,11 @@ is necessary to run this Python DB API v2.0 compliant driver.
%install
%{__rm} -rf $RPM_BUILD_ROOT
+# Python 3 build
+%{__python3} setup.py install --root $RPM_BUILD_ROOT
+
+%{__rm} -rf build
+# Python 2 build (end with this for tests)
%{__python} setup.py install --root $RPM_BUILD_ROOT
@@ -53,10 +68,18 @@ is necessary to run this Python DB API v2.0 compliant driver.
%{python_sitelib}/*
+%files -n mysql-connector-python3
+%defattr(-,root,root,-)
+%doc ChangeLog COPYING EXCEPTIONS-CLIENT README
+%doc python3/examples
+%{python3_sitelib}/*
+
+
%changelog
* Sun Mar 20 2011 Remi Collet <Fedora@famillecollet.com> 0.3.2-2
- run unittest during %%check
- fix License
+- add python3 sub package
* Wed Mar 09 2011 Remi Collet <Fedora@famillecollet.com> 0.3.2-1
- first RPM