summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-04-15 17:07:30 +0200
committerRemi Collet <fedora@famillecollet.com>2012-04-15 17:07:30 +0200
commit12f15e9163494fd293d466dfd9f4b371b6e0ded9 (patch)
tree9e0bea1b8e0d29e7ce831364166f08f892d45c9e
mydumper-0.2.3: new package
-rw-r--r--Makefile4
-rw-r--r--mydumper.spec73
2 files changed, 77 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1e65467
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../common/Makefile
+
diff --git a/mydumper.spec b/mydumper.spec
new file mode 100644
index 0000000..d0d9a5a
--- /dev/null
+++ b/mydumper.spec
@@ -0,0 +1,73 @@
+%if 0%{?fedora} >= 14 || 0%{?rhel} >= 6
+%global with_doc 1
+%else
+%global with_doc 0
+%endif
+
+Name: mydumper
+Version: 0.2.3
+Release: 1%{?dist}
+Summary: A high-performance MySQL backup tool
+
+Group: Applications/Databases
+License: GPLv3+
+URL: http://www.mydumper.org/
+Source0: http://launchpad.net/mydumper/0.2/%{version}/+download/%{name}-%{version}.tar.gz
+
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: glib2-devel mysql-devel zlib-devel pcre-devel
+BuildRequires: cmake
+%if %{with_doc}
+BuildRequires: python-sphinx
+%endif
+
+%description
+Mydumper (aka. MySQL Data Dumper) is a high-performance multi-threaded backup
+(and restore) toolset for MySQL and Drizzle.
+
+The main developers originally worked as Support Engineers at MySQL
+(one has moved to Facebook and another to SkySQL) and this is how they would
+envisage mysqldump based on years of user feedback.
+
+%if %{with_doc}
+Documentation: /usr/share/doc/mydumper/html/index.html
+%endif
+
+
+%prep
+%setup -q
+
+
+%build
+cmake -DCMAKE_INSTALL_PREFIX="%{_prefix}" .
+make %{?_smp_mflags} VERBOSE=1
+
+
+%install
+rm -rf %{buildroot}
+
+make install DESTDIR=%{buildroot}
+
+rm -f %{buildroot}%{_datadir}/doc/%{name}/html/.buildinfo
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{_bindir}/mydumper
+%{_bindir}/myloader
+%if %{with_doc}
+%{_mandir}/man1/mydumper.*
+%{_mandir}/man1/myloader.*
+%doc %{_datadir}/doc/%{name}
+%endif
+
+
+%changelog
+* Sun Apr 15 2012 Remi Collet <remi@fedoraproject.org> - 0.2.3-1
+- initial package
+