summaryrefslogtreecommitdiffstats
path: root/rhbz-304121.patch
diff options
context:
space:
mode:
Diffstat (limited to 'rhbz-304121.patch')
-rw-r--r--rhbz-304121.patch13
1 files changed, 6 insertions, 7 deletions
diff --git a/rhbz-304121.patch b/rhbz-304121.patch
index 941aca2..d8d8ac3 100644
--- a/rhbz-304121.patch
+++ b/rhbz-304121.patch
@@ -1,13 +1,12 @@
-diff -up firefox-18.0/mozilla-release/media/webrtc/trunk/Makefile.old firefox-18.0/mozilla-release/media/webrtc/trunk/Makefile
-diff -up firefox-18.0/mozilla-release/media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py.old firefox-18.0/mozilla-release/media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py
---- firefox-18.0/mozilla-release/media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py.old 2013-01-05 00:44:41.000000000 +0100
-+++ firefox-18.0/mozilla-release/media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py 2013-01-10 14:48:58.418321640 +0100
-@@ -376,7 +376,7 @@ class MakefileGenerator(object):
+diff -up xulrunner-20.0/mozilla-release/media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py.rhbz-304121 xulrunner-20.0/mozilla-release/media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py
+--- xulrunner-20.0/mozilla-release/media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py.rhbz-304121 2013-03-26 23:17:58.000000000 +0100
++++ xulrunner-20.0/mozilla-release/media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py 2013-04-01 11:11:56.938411785 +0200
+@@ -377,7 +377,7 @@ class MakefileGenerator(object):
WriteMakefile(output_file, data, build_file, depth, top,
# we set srcdir up one directory, since the subdir
# doesn't actually exist in the source directory
- swapslashes(os.path.join(top, self.relative_srcdir, os.path.split(rel_path)[0])),
+ swapslashes(os.path.normpath(os.path.join(top, self.relative_srcdir, os.path.split(rel_path)[0]))),
- self.relative_srcdir)
+ self.relative_srcdir,
+ self.common_mk_path)
return True
-