summaryrefslogtreecommitdiffstats
path: root/mozilla-851850.patch
diff options
context:
space:
mode:
Diffstat (limited to 'mozilla-851850.patch')
-rw-r--r--mozilla-851850.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/mozilla-851850.patch b/mozilla-851850.patch
new file mode 100644
index 0000000..04260b9
--- /dev/null
+++ b/mozilla-851850.patch
@@ -0,0 +1,31 @@
+
+# HG changeset patch
+# User Steve Singer <steve@ssinger.info>
+# Date 1363699875 14400
+# Node ID fe010206e5add13f4202113dcd74f54acb1e5b37
+# Parent 90c5dd3a2d1533ce2646a53c6ec84773e6f42d43
+Bug 851850 - Link in altivec on ppc64. r=jmuizelaar
+
+diff --git a/gfx/qcms/Makefile.in b/gfx/qcms/Makefile.in
+--- a/gfx/qcms/Makefile.in
++++ b/gfx/qcms/Makefile.in
+@@ -48,17 +48,17 @@ else
+ endif
+ else
+ SSE1_FLAGS=
+ SSE2_FLAGS=
+ endif
+ endif
+ endif
+ else
+-ifeq (ppc,$(CPU_ARCH))
++ifeq (ppc,$(findstring ppc,$(CPU_ARCH)))
+ ifdef GNU_CC
+ CSRCS += transform-altivec.c
+ ALTIVEC_FLAGS=-maltivec
+ endif
+ endif
+ endif
+
+ FORCE_STATIC_LIB = 1
+