summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mozilla-706724.patch12
-rw-r--r--mozilla-722127.patch74
-rw-r--r--mozilla-file.patch26
-rw-r--r--xulrunner-10.0-gcc47.patch25
-rw-r--r--xulrunner-9.0-secondary-build-fix.patch11
5 files changed, 148 insertions, 0 deletions
diff --git a/mozilla-706724.patch b/mozilla-706724.patch
new file mode 100644
index 0000000..b0792ed
--- /dev/null
+++ b/mozilla-706724.patch
@@ -0,0 +1,12 @@
+diff -up mozilla-beta/ipc/chromium/src/base/file_util.cc.old mozilla-beta/ipc/chromium/src/base/file_util.cc
+--- mozilla-beta/ipc/chromium/src/base/file_util.cc.old 2012-01-25 13:48:11.000000000 +0100
++++ mozilla-beta/ipc/chromium/src/base/file_util.cc 2012-01-25 13:52:25.096659244 +0100
+@@ -8,7 +8,7 @@
+ #include <io.h>
+ #endif
+ #include <stdio.h>
+-#if defined(ANDROID)
++#if defined(ANDROID) || defined(OS_POSIX)
+ #include <unistd.h>
+ #endif
+
diff --git a/mozilla-722127.patch b/mozilla-722127.patch
new file mode 100644
index 0000000..63a9e0a
--- /dev/null
+++ b/mozilla-722127.patch
@@ -0,0 +1,74 @@
+# HG changeset patch
+# Parent 0a6f3638cdaba9d3b5ef2eef73a42b2a167dc52a
+# User ojab <ojab@ojab.ru>
+Bug 722127 - Build --with-system-libvpx is broken for libvpx-1.0.0
+
+diff -up xulrunner-10.0/mozilla-beta/configure.in.vpx1.0.0 xulrunner-10.0/mozilla-beta/configure.in
+--- xulrunner-10.0/mozilla-beta/configure.in.vpx1.0.0 2012-01-24 02:59:49.000000000 -0500
++++ xulrunner-10.0/mozilla-beta/configure.in 2012-01-30 13:11:22.303053551 -0500
+@@ -5616,20 +5616,20 @@ if test -n "$MOZ_WEBM"; then
+ [MOZ_NATIVE_LIBVPX_DEC_TEST=1],
+ ([--with-system-libvpx requested but symbol vpx_codec_dec_init_ver not found]))
+ if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
+- AC_MSG_CHECKING([for libvpx version >= v0.9.7])
+- dnl We need at least v0.9.7 to fix several crash bugs (for which we
+- dnl had local patches prior to v0.9.7).
++ AC_MSG_CHECKING([for libvpx version >= v1.0.0])
++ dnl We need at least v1.0.0 to fix several crash bugs (for which we
++ dnl had local patches prior to v1.0.0).
+ dnl
+ dnl This is a terrible test for the library version, but we don't
+ dnl have a good one. There is no version number in a public header,
+ dnl and testing the headers still doesn't guarantee we link against
+ dnl the right version. While we could call vpx_codec_version() at
+ dnl run-time, that would break cross-compiling. There are no
+- dnl additional exported symbols between the v0.9.7 release and the
+- dnl v0.9.6 one to check for.
++ dnl additional exported decoder symbols between the v1.0.0 release
++ dnl and the v0.9.7 one to check for.
+ AC_TRY_COMPILE([
+ #include <vpx/vpx_decoder.h>
+- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
++ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
+ #error "test failed."
+ #endif
+ ],
+@@ -5639,7 +5639,7 @@ if test -n "$MOZ_WEBM"; then
+ MOZ_LIBVPX_INCLUDES="-I${LIBVPX_DIR}/include"
+ MOZ_LIBVPX_LIBS="-L${LIBVPX_DIR}/lib -lvpx"],
+ [AC_MSG_RESULT([no])
+- AC_MSG_ERROR([--with-system-libvpx requested but it is not v0.9.7 or later])])
++ AC_MSG_ERROR([--with-system-libvpx requested but it is not v1.0.0 or later])])
+ fi
+ CFLAGS=$_SAVE_CFLAGS
+ LDFLAGS=$_SAVE_LDFLAGS
+diff -up xulrunner-10.0/mozilla-beta/configure.vpx1.0.0 xulrunner-10.0/mozilla-beta/configure
+--- xulrunner-10.0/mozilla-beta/configure.vpx1.0.0 2012-01-30 13:11:47.805847514 -0500
++++ xulrunner-10.0/mozilla-beta/configure 2012-01-30 13:14:07.818716354 -0500
+@@ -17727,14 +17727,14 @@ else
+ fi
+
+ if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
+- echo $ac_n "checking for libvpx version >= v0.9.7""... $ac_c" 1>&6
+-echo "configure:17732: checking for libvpx version >= v0.9.7" >&5
++ echo $ac_n "checking for libvpx version >= v1.0.0""... $ac_c" 1>&6
++echo "configure:17732: checking for libvpx version >= v1.0.0" >&5
+ cat > conftest.$ac_ext <<EOF
+ #line 17734 "configure"
+ #include "confdefs.h"
+
+ #include <vpx/vpx_decoder.h>
+- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
++ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
+ #error "test failed."
+ #endif
+
+@@ -17753,7 +17753,7 @@ else
+ cat conftest.$ac_ext >&5
+ rm -rf conftest*
+ echo "$ac_t""no" 1>&6
+- { echo "configure: error: --with-system-libvpx requested but it is not v0.9.7 or later" 1>&2; exit 1; }
++ { echo "configure: error: --with-system-libvpx requested but it is not v1.0.0 or later" 1>&2; exit 1; }
+ fi
+ rm -f conftest*
+ fi
diff --git a/mozilla-file.patch b/mozilla-file.patch
new file mode 100644
index 0000000..14b0182
--- /dev/null
+++ b/mozilla-file.patch
@@ -0,0 +1,26 @@
+diff -up mozilla-beta/ipc/chromium/src/base/file_util_linux.cc.file mozilla-beta/ipc/chromium/src/base/file_util_linux.cc
+--- mozilla-beta/ipc/chromium/src/base/file_util_linux.cc.file 2012-01-24 09:00:00.000000000 +0100
++++ mozilla-beta/ipc/chromium/src/base/file_util_linux.cc 2012-01-25 15:30:43.707796295 +0100
+@@ -5,6 +5,9 @@
+ #include "base/file_util.h"
+
+ #include <fcntl.h>
++#if defined(ANDROID) || defined(OS_POSIX)
++#include <unistd.h>
++#endif
+
+ #include <string>
+ #include <vector>
+diff -up mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc.file mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc
+--- mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc.file 2012-01-24 09:00:00.000000000 +0100
++++ mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc 2012-01-25 15:13:11.947771212 +0100
+@@ -6,6 +6,9 @@
+
+ #include <errno.h>
+ #include <fcntl.h>
++#if defined(ANDROID) || defined(OS_POSIX)
++#include <unistd.h>
++#endif
+
+ #include "eintr_wrapper.h"
+ #include "base/logging.h"
diff --git a/xulrunner-10.0-gcc47.patch b/xulrunner-10.0-gcc47.patch
new file mode 100644
index 0000000..91a948a
--- /dev/null
+++ b/xulrunner-10.0-gcc47.patch
@@ -0,0 +1,25 @@
+diff -up mozilla-beta/ipc/chromium/src/base/time_posix.cc.gcc47 mozilla-beta/ipc/chromium/src/base/time_posix.cc
+--- mozilla-beta/ipc/chromium/src/base/time_posix.cc.gcc47 2012-01-24 03:00:00.000000000 -0500
++++ mozilla-beta/ipc/chromium/src/base/time_posix.cc 2012-01-30 14:12:49.198472212 -0500
+@@ -14,6 +14,8 @@
+ #include <time.h>
+ #endif
+
++#include <unistd.h>
++
+ #include <limits>
+
+ #include "base/basictypes.h"
+diff -up mozilla-beta/toolkit/crashreporter/client/Makefile.in.gcc47 mozilla-beta/toolkit/crashreporter/client/Makefile.in
+--- mozilla-beta/toolkit/crashreporter/client/Makefile.in.gcc47 2012-01-30 14:41:14.475441039 -0500
++++ mozilla-beta/toolkit/crashreporter/client/Makefile.in 2012-01-30 14:43:03.587646656 -0500
+@@ -69,6 +69,9 @@ CPPSRCS = \
+ $(STDCXX_COMPAT) \
+ $(NULL)
+
++# Needed for moz_free
++LIBS += -L$(LIBXUL_DIST)/lib -lmozalloc
++
+ ifeq ($(OS_ARCH),WINNT)
+ CPPSRCS += crashreporter_win.cpp
+ LIBS += \
diff --git a/xulrunner-9.0-secondary-build-fix.patch b/xulrunner-9.0-secondary-build-fix.patch
new file mode 100644
index 0000000..fc1c1db
--- /dev/null
+++ b/xulrunner-9.0-secondary-build-fix.patch
@@ -0,0 +1,11 @@
+diff -up xulrunner-9.0.1/mozilla-release/js/src/jscompartment.cpp.orig xulrunner-9.0.1/mozilla-release/js/src/jscompartment.cpp
+--- xulrunner-9.0.1/mozilla-release/js/src/jscompartment.cpp.orig 2012-01-04 11:06:39.000000000 +0100
++++ xulrunner-9.0.1/mozilla-release/js/src/jscompartment.cpp 2012-01-04 11:06:43.000000000 +0100
+@@ -50,7 +50,6 @@
+ #include "jswatchpoint.h"
+ #include "jswrapper.h"
+ #include "assembler/wtf/Platform.h"
+-#include "assembler/jit/ExecutableAllocator.h"
+ #include "yarr/BumpPointerAllocator.h"
+ #include "methodjit/MethodJIT.h"
+ #include "methodjit/PolyIC.h"