summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mozilla-239254.patch483
-rw-r--r--mozilla-791626.patch46
-rw-r--r--rhbz-304121.patch12
-rw-r--r--rhbz-928353.patch108
-rw-r--r--xulrunner.spec25
5 files changed, 53 insertions, 621 deletions
diff --git a/mozilla-239254.patch b/mozilla-239254.patch
deleted file mode 100644
index 9ce3838..0000000
--- a/mozilla-239254.patch
+++ /dev/null
@@ -1,483 +0,0 @@
-# HG changeset patch
-# Parent cb34bd8957ec517c72d506f7c439e3af1950e38d
-# User Martin Stransky <stransky@redhat.com>
-Bug 239254 - [Linux] Support disk cache on a local path, r=michal.novotny
-
-diff --git a/netwerk/cache/nsCacheService.cpp b/netwerk/cache/nsCacheService.cpp
---- a/netwerk/cache/nsCacheService.cpp
-+++ b/netwerk/cache/nsCacheService.cpp
-@@ -712,27 +712,18 @@ nsCacheProfilePrefObserver::ReadPrefs(ns
- nsCOMPtr<nsIFile> profDir;
- NS_GetSpecialDirectory(NS_APP_USER_PROFILE_50_DIR,
- getter_AddRefs(profDir));
- NS_GetSpecialDirectory(NS_APP_USER_PROFILE_LOCAL_50_DIR,
- getter_AddRefs(directory));
- if (!directory)
- directory = profDir;
- else if (profDir) {
-- bool same;
-- if (NS_SUCCEEDED(profDir->Equals(directory, &same)) && !same) {
-- // We no longer store the cache directory in the main
-- // profile directory, so we should cleanup the old one.
-- rv = profDir->AppendNative(NS_LITERAL_CSTRING("Cache"));
-- if (NS_SUCCEEDED(rv)) {
-- bool exists;
-- if (NS_SUCCEEDED(profDir->Exists(&exists)) && exists)
-- nsDeleteDir::DeleteDir(profDir, false);
-- }
-- }
-+ nsCacheService::MoveOrRemoveDiskCache(profDir, directory,
-+ "Cache");
- }
- }
- // use file cache in build tree only if asked, to avoid cache dir litter
- if (!directory && PR_GetEnv("NECKO_DEV_ENABLE_DISK_CACHE")) {
- rv = NS_GetSpecialDirectory(NS_XPCOM_CURRENT_PROCESS_DIR,
- getter_AddRefs(directory));
- }
- if (directory)
-@@ -788,16 +779,20 @@ nsCacheProfilePrefObserver::ReadPrefs(ns
- // try to get the profile directory (there may not be a profile yet)
- nsCOMPtr<nsIFile> profDir;
- NS_GetSpecialDirectory(NS_APP_USER_PROFILE_50_DIR,
- getter_AddRefs(profDir));
- NS_GetSpecialDirectory(NS_APP_USER_PROFILE_LOCAL_50_DIR,
- getter_AddRefs(directory));
- if (!directory)
- directory = profDir;
-+ else if (profDir) {
-+ nsCacheService::MoveOrRemoveDiskCache(profDir, directory,
-+ "OfflineCache");
-+ }
- }
- #if DEBUG
- if (!directory) {
- // use current process directory during development
- rv = NS_GetSpecialDirectory(NS_XPCOM_CURRENT_PROCESS_DIR,
- getter_AddRefs(directory));
- }
- #endif
-@@ -3012,16 +3007,67 @@ nsCacheService::SetDiskSmartSize_Locked(
- DispatchToCacheIOThread(event);
- } else {
- return NS_ERROR_FAILURE;
- }
-
- return NS_OK;
- }
-
-+void
-+nsCacheService::MoveOrRemoveDiskCache(nsIFile *aOldCacheDir,
-+ nsIFile *aNewCacheDir,
-+ const char *aCacheSubdir)
-+{
-+ bool same;
-+ if (NS_FAILED(aOldCacheDir->Equals(aNewCacheDir, &same)) || same)
-+ return;
-+
-+ nsCOMPtr<nsIFile> aOldCacheSubdir;
-+ aOldCacheDir->Clone(getter_AddRefs(aOldCacheSubdir));
-+
-+ nsresult rv = aOldCacheSubdir->AppendNative(
-+ nsDependentCString(aCacheSubdir));
-+ if (NS_FAILED(rv))
-+ return;
-+
-+ bool exists;
-+ if (NS_FAILED(aOldCacheSubdir->Exists(&exists)) || !exists)
-+ return;
-+
-+ nsCOMPtr<nsIFile> aNewCacheSubdir;
-+ aNewCacheDir->Clone(getter_AddRefs(aNewCacheSubdir));
-+
-+ rv = aNewCacheSubdir->AppendNative(nsDependentCString(aCacheSubdir));
-+ if (NS_FAILED(rv))
-+ return;
-+
-+ nsAutoCString newPath;
-+ rv = aNewCacheSubdir->GetNativePath(newPath);
-+ if (NS_FAILED(rv))
-+ return;
-+
-+ if (NS_SUCCEEDED(aNewCacheSubdir->Exists(&exists)) && !exists) {
-+ // New cache directory does not exist, try to move the old one here
-+ // rename needs an empty target directory
-+ rv = aNewCacheSubdir->Create(nsIFile::DIRECTORY_TYPE, 0777);
-+ if (NS_SUCCEEDED(rv)) {
-+ nsAutoCString oldPath;
-+ rv = aOldCacheSubdir->GetNativePath(oldPath);
-+ if (NS_FAILED(rv))
-+ return;
-+ if(rename(oldPath.get(), newPath.get()) == 0)
-+ return;
-+ }
-+ }
-+
-+ // Delay delete by 1 minute to avoid IO thrash on startup.
-+ nsDeleteDir::DeleteDir(aOldCacheSubdir, false, 60000);
-+}
-+
- static bool
- IsEntryPrivate(nsCacheEntry* entry)
- {
- return entry->IsPrivate();
- }
-
- void
- nsCacheService::LeavePrivateBrowsing()
-diff --git a/netwerk/cache/nsCacheService.h b/netwerk/cache/nsCacheService.h
---- a/netwerk/cache/nsCacheService.h
-+++ b/netwerk/cache/nsCacheService.h
-@@ -194,16 +194,20 @@ public:
-
- static void SetMemoryCache();
-
- static void SetCacheCompressionLevel(int32_t level);
-
- // Starts smart cache size computation if disk device is available
- static nsresult SetDiskSmartSize();
-
-+ static void MoveOrRemoveDiskCache(nsIFile *aOldCacheDir,
-+ nsIFile *aNewCacheDir,
-+ const char *aCacheSubdir);
-+
- nsresult Init();
- void Shutdown();
-
- static bool IsInitialized()
- {
- if (!gService) {
- return false;
- }
-diff --git a/startupcache/StartupCache.cpp b/startupcache/StartupCache.cpp
---- a/startupcache/StartupCache.cpp
-+++ b/startupcache/StartupCache.cpp
-@@ -168,16 +168,30 @@ StartupCache::Init()
- nsCOMPtr<nsIFile> file;
- rv = NS_GetSpecialDirectory("ProfLDS",
- getter_AddRefs(file));
- if (NS_FAILED(rv)) {
- // return silently, this will fail in mochitests's xpcshell process.
- return rv;
- }
-
-+ nsCOMPtr<nsIFile> profDir;
-+ NS_GetSpecialDirectory("ProfDS", getter_AddRefs(profDir));
-+ if (profDir) {
-+ bool same;
-+ if (NS_SUCCEEDED(profDir->Equals(file, &same)) && !same) {
-+ // We no longer store the startup cache in the main profile
-+ // directory, so we should cleanup the old one.
-+ if (NS_SUCCEEDED(
-+ profDir->AppendNative(NS_LITERAL_CSTRING("startupCache")))) {
-+ profDir->Remove(true);
-+ }
-+ }
-+ }
-+
- rv = file->AppendNative(NS_LITERAL_CSTRING("startupCache"));
- NS_ENSURE_SUCCESS(rv, rv);
-
- // Try to create the directory if it's not there yet
- rv = file->Create(nsIFile::DIRECTORY_TYPE, 0777);
- if (NS_FAILED(rv) && rv != NS_ERROR_FILE_ALREADY_EXISTS)
- return rv;
-
-diff --git a/toolkit/xre/nsXREDirProvider.cpp b/toolkit/xre/nsXREDirProvider.cpp
---- a/toolkit/xre/nsXREDirProvider.cpp
-+++ b/toolkit/xre/nsXREDirProvider.cpp
-@@ -1170,18 +1170,32 @@ nsXREDirProvider::GetUserDataDirectoryHo
- #elif defined(MOZ_WIDGET_GONK)
- rv = NS_NewNativeLocalFile(NS_LITERAL_CSTRING("/data/b2g"), true,
- getter_AddRefs(localDir));
- #elif defined(XP_UNIX)
- const char* homeDir = getenv("HOME");
- if (!homeDir || !*homeDir)
- return NS_ERROR_FAILURE;
-
-- rv = NS_NewNativeLocalFile(nsDependentCString(homeDir), true,
-- getter_AddRefs(localDir));
-+ if (aLocal) {
-+ // If $XDG_CACHE_HOME is defined use it, otherwise use $HOME/.cache.
-+ const char* cacheHome = getenv("XDG_CACHE_HOME");
-+ if (cacheHome && *cacheHome) {
-+ rv = NS_NewNativeLocalFile(nsDependentCString(cacheHome), true,
-+ getter_AddRefs(localDir));
-+ } else {
-+ rv = NS_NewNativeLocalFile(nsDependentCString(homeDir), true,
-+ getter_AddRefs(localDir));
-+ if (NS_SUCCEEDED(rv))
-+ rv = localDir->AppendNative(NS_LITERAL_CSTRING(".cache"));
-+ }
-+ } else {
-+ rv = NS_NewNativeLocalFile(nsDependentCString(homeDir), true,
-+ getter_AddRefs(localDir));
-+ }
- #else
- #error "Don't know how to get product dir on your platform"
- #endif
-
- NS_IF_ADDREF(*aFile = localDir);
- return rv;
- }
-
-@@ -1256,17 +1270,17 @@ nsXREDirProvider::GetUserDataDirectory(n
- const nsACString* aProfileName,
- const nsACString* aAppName,
- const nsACString* aVendorName)
- {
- nsCOMPtr<nsIFile> localDir;
- nsresult rv = GetUserDataDirectoryHome(getter_AddRefs(localDir), aLocal);
- NS_ENSURE_SUCCESS(rv, rv);
-
-- rv = AppendProfilePath(localDir, aProfileName, aAppName, aVendorName);
-+ rv = AppendProfilePath(localDir, aProfileName, aAppName, aVendorName, aLocal);
- NS_ENSURE_SUCCESS(rv, rv);
-
- #ifdef DEBUG_jungshik
- nsAutoCString cwd;
- localDir->GetNativePath(cwd);
- printf("nsXREDirProvider::GetUserDataDirectory: %s\n", cwd.get());
- #endif
- rv = EnsureDirectoryExists(localDir);
-@@ -1377,17 +1391,18 @@ nsXREDirProvider::AppendSysUserExtension
- return NS_OK;
- }
-
-
- nsresult
- nsXREDirProvider::AppendProfilePath(nsIFile* aFile,
- const nsACString* aProfileName,
- const nsACString* aAppName,
-- const nsACString* aVendorName)
-+ const nsACString* aVendorName,
-+ bool aLocal)
- {
- NS_ASSERTION(aFile, "Null pointer!");
-
- if (!gAppData) {
- return NS_ERROR_FAILURE;
- }
-
- nsAutoCString profile;
-@@ -1439,28 +1454,31 @@ nsXREDirProvider::AppendProfilePath(nsIF
- // The parent of this directory is set in GetUserDataDirectoryHome
- // XXX: handle gAppData->profile properly
- // XXXsmaug ...and the rest of the profile creation!
- MOZ_ASSERT(!aAppName,
- "Profile creation for external applications is not implemented!");
- rv = aFile->AppendNative(nsDependentCString("mozilla"));
- NS_ENSURE_SUCCESS(rv, rv);
- #elif defined(XP_UNIX)
-- // Make it hidden (i.e. using the ".")
-- nsAutoCString folder(".");
-+ nsAutoCString folder;
-+ // Make it hidden (by starting with "."), except when local (the
-+ // profile is already under ~/.cache or XDG_CACHE_HOME).
-+ if (!aLocal)
-+ folder.Assign('.');
-
- if (!profile.IsEmpty()) {
- // Skip any leading path characters
- const char* profileStart = profile.get();
- while (*profileStart == '/' || *profileStart == '\\')
- profileStart++;
-
- // On the off chance that someone wanted their folder to be hidden don't
- // let it become ".."
-- if (*profileStart == '.')
-+ if (*profileStart == '.' && !aLocal)
- profileStart++;
-
- folder.Append(profileStart);
- ToLowerCase(folder);
-
- rv = AppendProfileString(aFile, folder.BeginReading());
- }
- else {
-diff --git a/toolkit/xre/nsXREDirProvider.h b/toolkit/xre/nsXREDirProvider.h
---- a/toolkit/xre/nsXREDirProvider.h
-+++ b/toolkit/xre/nsXREDirProvider.h
-@@ -109,17 +109,18 @@ protected:
- static nsresult EnsureDirectoryExists(nsIFile* aDirectory);
- void EnsureProfileFileExists(nsIFile* aFile);
-
- // Determine the profile path within the UAppData directory. This is different
- // on every major platform.
- static nsresult AppendProfilePath(nsIFile* aFile,
- const nsACString* aProfileName,
- const nsACString* aAppName,
-- const nsACString* aVendorName);
-+ const nsACString* aVendorName,
-+ bool aLocal);
-
- static nsresult AppendSysUserExtensionPath(nsIFile* aFile);
-
- // Internal helper that splits a path into components using the '/' and '\\'
- // delimiters.
- static inline nsresult AppendProfileString(nsIFile* aFile, const char* aPath);
-
- // Calculate and register extension and theme bundle directories.
-# HG changeset patch
-# User Tim Taubert <ttaubert@mozilla.com>
-# Date 1360362227 -3600
-# Node ID 873170d2679ac23114f22543cee3214a940abef3
-Bug 239254 - [Linux] Migrate existing thumbnails to their new local path
-
-diff --git a/browser/components/thumbnails/PageThumbs.jsm b/browser/components/thumbnails/PageThumbs.jsm
---- a/browser/components/thumbnails/PageThumbs.jsm
-+++ b/browser/components/thumbnails/PageThumbs.jsm
-@@ -7,17 +7,17 @@
- this.EXPORTED_SYMBOLS = ["PageThumbs", "PageThumbsStorage"];
-
- const Cu = Components.utils;
- const Cc = Components.classes;
- const Ci = Components.interfaces;
-
- const HTML_NAMESPACE = "http://www.w3.org/1999/xhtml";
- const PREF_STORAGE_VERSION = "browser.pagethumbnails.storage_version";
--const LATEST_STORAGE_VERSION = 2;
-+const LATEST_STORAGE_VERSION = 3;
-
- const EXPIRATION_MIN_CHUNK_SIZE = 50;
- const EXPIRATION_INTERVAL_SECS = 3600;
-
- /**
- * Name of the directory in the profile that contains the thumbnails.
- */
- const THUMBNAIL_DIRECTORY = "thumbnails";
-@@ -359,47 +359,51 @@ let PageThumbsStorageMigrator = {
-
- set currentVersion(aVersion) {
- Services.prefs.setIntPref(PREF_STORAGE_VERSION, aVersion);
- },
-
- migrate: function Migrator_migrate() {
- let version = this.currentVersion;
-
-- if (version < 1) {
-- this.removeThumbnailsFromRoamingProfile();
-- }
-- if (version < 2) {
-- this.renameThumbnailsFolder();
-+ // Storage version 1 never made it to beta.
-+ // At the time of writing only Windows had (ProfD != ProfLD) and we
-+ // needed to move thumbnails from the roaming profile to the locale
-+ // one so that they're not needlessly included in backups and/or
-+ // written via SMB.
-+
-+ // Storage version 2 also never made it to beta.
-+ // The thumbnail folder structure has been changed and old thumbnails
-+ // were not migrated. Instead, we just renamed the current folder to
-+ // "<name>-old" and will remove it later.
-+
-+ if (version < 3) {
-+ this.migrateToVersion3();
- }
-
- this.currentVersion = LATEST_STORAGE_VERSION;
- },
-
-- removeThumbnailsFromRoamingProfile:
-- function Migrator_removeThumbnailsFromRoamingProfile() {
-- let local = FileUtils.getDir("ProfLD", [THUMBNAIL_DIRECTORY]);
-+ /**
-+ * Bug 239254 added support for having the disk cache and thumbnail
-+ * directories on a local path (i.e. ~/.cache/) under Linux. We'll first
-+ * try to move the old thumbnails to their new location. If that's not
-+ * possible (because ProfD might be on a different file system than
-+ * ProfLD) we'll just discard them.
-+ */
-+ migrateToVersion3: function Migrator_migrateToVersion3() {
-+ let local = FileUtils.getDir("ProfLD", [THUMBNAIL_DIRECTORY], true);
- let roaming = FileUtils.getDir("ProfD", [THUMBNAIL_DIRECTORY]);
-
-- if (!roaming.equals(local) && roaming.exists()) {
-- roaming.followLinks = false;
-- try {
-- roaming.remove(true);
-- } catch (e) {
-- // The directory might not exist or we're not permitted to remove it.
-- }
-- }
-- },
--
-- renameThumbnailsFolder: function Migrator_renameThumbnailsFolder() {
-- let dir = FileUtils.getDir("ProfLD", [THUMBNAIL_DIRECTORY]);
-- try {
-- dir.moveTo(null, dir.leafName + "-old");
-- } catch (e) {
-- // The directory might not exist or we're not permitted to rename it.
-+ if (!roaming.equals(local)) {
-+ PageThumbsWorker.postMessage({
-+ type: "moveOrDeleteAllThumbnails",
-+ from: roaming.path,
-+ to: local.path
-+ });
- }
- }
- };
-
- let PageThumbsExpiration = {
- _filters: [],
-
- init: function Expiration_init() {
-diff --git a/browser/components/thumbnails/PageThumbsWorker.js b/browser/components/thumbnails/PageThumbsWorker.js
---- a/browser/components/thumbnails/PageThumbsWorker.js
-+++ b/browser/components/thumbnails/PageThumbsWorker.js
-@@ -20,16 +20,19 @@ let PageThumbsWorker = {
-
- switch (msg.type) {
- case "removeFile":
- data.result = this.removeFile(msg);
- break;
- case "expireFilesInDirectory":
- data.result = this.expireFilesInDirectory(msg);
- break;
-+ case "moveOrDeleteAllThumbnails":
-+ data.result = this.moveOrDeleteAllThumbnails(msg);
-+ break;
- default:
- data.result = false;
- data.detail = "message not understood";
- break;
- }
-
- self.postMessage(data);
- },
-@@ -62,12 +65,35 @@ let PageThumbsWorker = {
- getFileEntriesInDirectory:
- function Worker_getFileEntriesInDirectory(aPath, aSkipFiles) {
- let skip = new Set(aSkipFiles);
- let iter = new OS.File.DirectoryIterator(aPath);
-
- return [entry
- for (entry in iter)
- if (!entry.isDir && !entry.isSymLink && !skip.has(entry.name))];
-+ },
-+
-+ moveOrDeleteAllThumbnails:
-+ function Worker_moveOrDeleteAllThumbnails(msg) {
-+ if (!OS.File.exists(msg.from))
-+ return true;
-+
-+ let iter = new OS.File.DirectoryIterator(msg.from);
-+ for (let entry in iter) {
-+ if (!entry.isDir && !entry.isSymLink) {
-+ let from = OS.Path.join(msg.from, entry.name);
-+ let to = OS.Path.join(msg.to, entry.name);
-+
-+ try {
-+ OS.File.move(from, to, {noOverwrite: true, noCopy: true});
-+ } catch (e) {
-+ OS.File.remove(from);
-+ }
-+ }
-+ }
-+
-+ OS.File.removeEmptyDir(msg.from);
-+ return true;
- }
- };
-
- self.onmessage = PageThumbsWorker.handleMessage.bind(PageThumbsWorker);
diff --git a/mozilla-791626.patch b/mozilla-791626.patch
deleted file mode 100644
index c2e77ab..0000000
--- a/mozilla-791626.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-# HG changeset patch
-# Parent 3523e7f7a89d7933c5f1dc8f5f22559b48ec44c4
-diff --git a/netwerk/base/src/nsIOService.cpp b/netwerk/base/src/nsIOService.cpp
---- a/netwerk/base/src/nsIOService.cpp
-+++ b/netwerk/base/src/nsIOService.cpp
-@@ -818,17 +818,18 @@ nsIOService::PrefsChanged(nsIPrefBranch
- if (NS_SUCCEEDED(rv)) {
- if (mSocketTransportService)
- mSocketTransportService->SetAutodialEnabled(enableAutodial);
- }
- }
-
- if (!pref || strcmp(pref, MANAGE_OFFLINE_STATUS_PREF) == 0) {
- bool manage;
-- if (NS_SUCCEEDED(prefs->GetBoolPref(MANAGE_OFFLINE_STATUS_PREF,
-+ if (mNetworkLinkServiceInitialized &&
-+ NS_SUCCEEDED(prefs->GetBoolPref(MANAGE_OFFLINE_STATUS_PREF,
- &manage)))
- SetManageOfflineStatus(manage);
- }
-
- if (!pref || strcmp(pref, NECKO_BUFFER_CACHE_COUNT_PREF) == 0) {
- int32_t count;
- if (NS_SUCCEEDED(prefs->GetIntPref(NECKO_BUFFER_CACHE_COUNT_PREF,
- &count)))
-@@ -928,16 +929,20 @@ nsIOService::Observe(nsISupports *subjec
- }
- else if (!strcmp(topic, kProfileDoChange)) {
- if (data && NS_LITERAL_STRING("startup").Equals(data)) {
- // Lazy initialization of network link service (see bug 620472)
- InitializeNetworkLinkService();
- // Set up the initilization flag regardless the actuall result.
- // If we fail here, we will fail always on.
- mNetworkLinkServiceInitialized = true;
-+ // And now reflect the preference setting
-+ nsCOMPtr<nsIPrefBranch> prefBranch;
-+ GetPrefBranch(getter_AddRefs(prefBranch));
-+ PrefsChanged(prefBranch, MANAGE_OFFLINE_STATUS_PREF);
- }
- }
- else if (!strcmp(topic, NS_XPCOM_SHUTDOWN_OBSERVER_ID)) {
- // Remember we passed XPCOM shutdown notification to prevent any
- // changes of the offline status from now. We must not allow going
- // online after this point.
- mShutdown = true;
-
diff --git a/rhbz-304121.patch b/rhbz-304121.patch
deleted file mode 100644
index d8d8ac3..0000000
--- a/rhbz-304121.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up xulrunner-20.0/mozilla-release/media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py.rhbz-304121 xulrunner-20.0/mozilla-release/media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py
---- xulrunner-20.0/mozilla-release/media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py.rhbz-304121 2013-03-26 23:17:58.000000000 +0100
-+++ xulrunner-20.0/mozilla-release/media/webrtc/trunk/tools/gyp/pylib/gyp/generator/mozmake.py 2013-04-01 11:11:56.938411785 +0200
-@@ -377,7 +377,7 @@ class MakefileGenerator(object):
- WriteMakefile(output_file, data, build_file, depth, top,
- # we set srcdir up one directory, since the subdir
- # doesn't actually exist in the source directory
-- swapslashes(os.path.join(top, self.relative_srcdir, os.path.split(rel_path)[0])),
-+ swapslashes(os.path.normpath(os.path.join(top, self.relative_srcdir, os.path.split(rel_path)[0]))),
- self.relative_srcdir,
- self.common_mk_path)
- return True
diff --git a/rhbz-928353.patch b/rhbz-928353.patch
index 14a5ba1..00d8e67 100644
--- a/rhbz-928353.patch
+++ b/rhbz-928353.patch
@@ -1,86 +1,62 @@
-diff -r -U2 xulrunner-20.0/mozilla-release/config/Makefile.in xulrunner-20.0.new/mozilla-release/config/Makefile.in
---- xulrunner-20.0/mozilla-release/config/Makefile.in 2013-03-26 18:17:37.000000000 -0400
-+++ xulrunner-20.0.new/mozilla-release/config/Makefile.in 2013-03-30 01:50:11.109526990 -0400
-@@ -38,5 +38,5 @@
+diff -up xulrunner-21.0/mozilla-release/config/Makefile.in.old xulrunner-21.0/mozilla-release/config/Makefile.in
+--- xulrunner-21.0/mozilla-release/config/Makefile.in.old 2013-05-11 21:19:23.000000000 +0200
++++ xulrunner-21.0/mozilla-release/config/Makefile.in 2013-05-13 08:53:03.351969145 +0200
+@@ -37,7 +37,7 @@ override NSBUILDROOT :=
+ endif
ifdef GNU_CC
-MODULE_OPTIMIZE_FLAGS = -O3
+MODULE_OPTIMIZE_FLAGS = -Os
endif
-diff -r -U2 xulrunner-20.0/mozilla-release/configure.in xulrunner-20.0.new/mozilla-release/configure.in
---- xulrunner-20.0/mozilla-release/configure.in 2013-03-26 18:17:37.000000000 -0400
-+++ xulrunner-20.0.new/mozilla-release/configure.in 2013-03-30 01:50:03.474547207 -0400
-@@ -1848,5 +1848,5 @@
- HOST_CFLAGS="$HOST_CFLAGS -DXP_UNIX -DXP_MACOSX -DNO_X11"
- HOST_NSPR_MDCPUCFG='\"md/_darwin.cfg\"'
-- HOST_OPTIMIZE_FLAGS="${HOST_OPTIMIZE_FLAGS=-O3}"
-+ HOST_OPTIMIZE_FLAGS="${HOST_OPTIMIZE_FLAGS=-Os}"
- ;;
-
-@@ -1854,5 +1854,5 @@
+ include $(topsrcdir)/config/config.mk
+diff -up xulrunner-21.0/mozilla-release/configure.in.old xulrunner-21.0/mozilla-release/configure.in
+--- xulrunner-21.0/mozilla-release/configure.in.old 2013-05-11 21:19:23.000000000 +0200
++++ xulrunner-21.0/mozilla-release/configure.in 2013-05-13 09:02:12.931823544 +0200
+@@ -1791,7 +1791,7 @@ case "$host" in
+ *-linux*|*-kfreebsd*-gnu|*-gnu*)
HOST_CFLAGS="$HOST_CFLAGS -DXP_UNIX"
HOST_NSPR_MDCPUCFG='\"md/_linux.cfg\"'
- HOST_OPTIMIZE_FLAGS="${HOST_OPTIMIZE_FLAGS=-O3}"
+ HOST_OPTIMIZE_FLAGS="${HOST_OPTIMIZE_FLAGS=-Os}"
;;
-@@ -1961,5 +1961,5 @@
- MKSHLIB='$(CXX) $(CXXFLAGS) $(DSO_PIC_CFLAGS) $(DSO_LDOPTS) -o $@'
- MKCSHLIB='$(CC) $(CFLAGS) $(DSO_PIC_CFLAGS) $(DSO_LDOPTS) -o $@'
-- MOZ_OPTIMIZE_FLAGS="-O3"
-+ MOZ_OPTIMIZE_FLAGS="-Os"
- _PEDANTIC=
- # Statically disable jemalloc on 10.5 and 32-bit 10.6. See bug 702250.
-@@ -2106,5 +2106,5 @@
+ *os2*)
+@@ -2041,7 +2041,7 @@ ia64*-hpux*)
+ # -Os is broken on gcc 4.5.x we need to tweak it to get good results.
MOZ_OPTIMIZE_SIZE_TWEAK="-finline-limit=50"
esac
- MOZ_PGO_OPTIMIZE_FLAGS="-O3"
+ MOZ_PGO_OPTIMIZE_FLAGS="-Os"
MOZ_OPTIMIZE_FLAGS="-Os -freorder-blocks $MOZ_OPTIMIZE_SIZE_TWEAK"
MOZ_DEBUG_FLAGS="-g"
-diff -r -U2 xulrunner-20.0/mozilla-release/js/src/config/Makefile.in xulrunner-20.0.new/mozilla-release/js/src/config/Makefile.in
---- xulrunner-20.0/mozilla-release/js/src/config/Makefile.in 2013-03-26 18:17:46.000000000 -0400
-+++ xulrunner-20.0.new/mozilla-release/js/src/config/Makefile.in 2013-03-30 01:51:03.443862662 -0400
-@@ -27,5 +27,5 @@
+ fi
+diff -up xulrunner-21.0/mozilla-release/js/src/config/Makefile.in.old xulrunner-21.0/mozilla-release/js/src/config/Makefile.in
+--- xulrunner-21.0/mozilla-release/js/src/config/Makefile.in.old 2013-05-11 21:19:32.000000000 +0200
++++ xulrunner-21.0/mozilla-release/js/src/config/Makefile.in 2013-05-13 08:53:03.353969129 +0200
+@@ -26,7 +26,7 @@ override NSBUILDROOT :=
+ endif
ifdef GNU_CC
-MODULE_OPTIMIZE_FLAGS = -O3
+MODULE_OPTIMIZE_FLAGS = -Os
endif
-diff -r -U2 xulrunner-20.0/mozilla-release/js/src/configure.in xulrunner-20.0.new/mozilla-release/js/src/configure.in
---- xulrunner-20.0/mozilla-release/js/src/configure.in 2013-03-26 18:17:46.000000000 -0400
-+++ xulrunner-20.0.new/mozilla-release/js/src/configure.in 2013-03-30 01:50:46.254052920 -0400
-@@ -1443,5 +1443,5 @@
- HOST_CFLAGS="$HOST_CFLAGS -DXP_UNIX -DXP_MACOSX -DNO_X11"
- HOST_NSPR_MDCPUCFG='\"md/_darwin.cfg\"'
-- HOST_OPTIMIZE_FLAGS="${HOST_OPTIMIZE_FLAGS=-O3}"
-+ HOST_OPTIMIZE_FLAGS="${HOST_OPTIMIZE_FLAGS=-Os}"
- ;;
-
-@@ -1449,5 +1449,5 @@
+ include $(topsrcdir)/config/config.mk
+diff -up xulrunner-21.0/mozilla-release/js/src/configure.in.old xulrunner-21.0/mozilla-release/js/src/configure.in
+--- xulrunner-21.0/mozilla-release/js/src/configure.in.old 2013-05-11 21:19:32.000000000 +0200
++++ xulrunner-21.0/mozilla-release/js/src/configure.in 2013-05-13 09:00:24.431225716 +0200
+@@ -1391,7 +1391,7 @@ case "$host" in
+ *-linux*|*-kfreebsd*-gnu|*-gnu*)
HOST_CFLAGS="$HOST_CFLAGS -DXP_UNIX"
HOST_NSPR_MDCPUCFG='\"md/_linux.cfg\"'
- HOST_OPTIMIZE_FLAGS="${HOST_OPTIMIZE_FLAGS=-O3}"
+ HOST_OPTIMIZE_FLAGS="${HOST_OPTIMIZE_FLAGS=-Os}"
;;
-@@ -1554,5 +1554,5 @@
- MKSHLIB='$(CXX) $(CXXFLAGS) $(DSO_PIC_CFLAGS) $(DSO_LDOPTS) -o $@'
- MKCSHLIB='$(CC) $(CFLAGS) $(DSO_PIC_CFLAGS) $(DSO_LDOPTS) -o $@'
-- MOZ_OPTIMIZE_FLAGS="-O3 -fno-stack-protector"
-+ MOZ_OPTIMIZE_FLAGS="-Os -fno-stack-protector"
- _PEDANTIC=
- CFLAGS="$CFLAGS -fno-common"
-@@ -1648,5 +1648,5 @@
-
- MOZ_GFX_OPTIMIZE_MOBILE=1
-- MOZ_OPTIMIZE_FLAGS="-O3 -freorder-blocks -fno-reorder-functions"
-+ MOZ_OPTIMIZE_FLAGS="-Os -freorder-blocks -fno-reorder-functions"
- # The Maemo builders don't know about this flag
- MOZ_ARM_VFP_FLAGS="-mfpu=vfp"
-@@ -1668,6 +1668,6 @@
+ *os2*)
+@@ -1596,8 +1596,8 @@ ia64*-hpux*)
+ # -Os is broken on gcc 4.5.x we need to tweak it to get good results.
MOZ_OPTIMIZE_SIZE_TWEAK="-finline-limit=50"
esac
- MOZ_PGO_OPTIMIZE_FLAGS="-O3"
@@ -89,26 +65,18 @@ diff -r -U2 xulrunner-20.0/mozilla-release/js/src/configure.in xulrunner-20.0.ne
+ MOZ_OPTIMIZE_FLAGS="-Os -freorder-blocks $MOZ_OPTIMIZE_SIZE_TWEAK"
MOZ_DEBUG_FLAGS="-g"
fi
-diff -r -U2 xulrunner-20.0/mozilla-release/memory/jemalloc/src/configure xulrunner-20.0.new/mozilla-release/memory/jemalloc/src/configure
---- xulrunner-20.0/mozilla-release/memory/jemalloc/src/configure 2013-03-26 18:17:58.000000000 -0400
-+++ xulrunner-20.0.new/mozilla-release/memory/jemalloc/src/configure 2013-03-30 01:51:38.533133311 -0400
-@@ -5279,7 +5279,7 @@
- TCFLAGS="${CFLAGS}"
- if test "x${CFLAGS}" = "x" ; then
-- CFLAGS="-O3"
-+ CFLAGS="-Os"
- else
-- CFLAGS="${CFLAGS} -O3"
-+ CFLAGS="${CFLAGS} -Os"
- fi
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-diff -r -U2 xulrunner-20.0/mozilla-release/memory/jemalloc/src/configure.ac xulrunner-20.0.new/mozilla-release/memory/jemalloc/src/configure.ac
---- xulrunner-20.0/mozilla-release/memory/jemalloc/src/configure.ac 2013-03-26 18:17:58.000000000 -0400
-+++ xulrunner-20.0.new/mozilla-release/memory/jemalloc/src/configure.ac 2013-03-30 01:51:15.753872639 -0400
-@@ -574,5 +574,5 @@
+
+diff -up xulrunner-21.0/mozilla-release/media/webrtc/trunk/Makefile.old xulrunner-21.0/mozilla-release/media/webrtc/trunk/Makefile
+diff -up xulrunner-21.0/mozilla-release/memory/jemalloc/src/configure.ac.old xulrunner-21.0/mozilla-release/memory/jemalloc/src/configure.ac
+--- xulrunner-21.0/mozilla-release/memory/jemalloc/src/configure.ac.old 2013-05-11 21:19:46.000000000 +0200
++++ xulrunner-21.0/mozilla-release/memory/jemalloc/src/configure.ac 2013-05-13 08:53:03.355969113 +0200
+@@ -573,7 +573,7 @@ if test "x$enable_debug" = "x0" -a "x$no
+ echo "$EXTRA_CFLAGS" | grep "\-O" >/dev/null || optimize="yes"
if test "x${optimize}" = "xyes" ; then
if test "x$GCC" = "xyes" ; then
- JE_CFLAGS_APPEND([-O3])
+ JE_CFLAGS_APPEND([-Os])
JE_CFLAGS_APPEND([-funroll-loops])
elif test "x$je_cv_msvc" = "xyes" ; then
+ JE_CFLAGS_APPEND([-O2])
+diff -up xulrunner-21.0/mozilla-release/memory/jemalloc/src/configure.old xulrunner-21.0/mozilla-release/memory/jemalloc/src/configure
diff --git a/xulrunner.spec b/xulrunner.spec
index a2ea5cd..4e7cd72 100644
--- a/xulrunner.spec
+++ b/xulrunner.spec
@@ -1,5 +1,5 @@
# Use system nspr/nss?
-%if 0%{?fedora} < 17
+%if 0%{?fedora} < 18
%define system_nss 0
%else
%define system_nss 1
@@ -41,7 +41,7 @@
%if %{?system_nss}
# grep 'min_ns.*=[0-9]' configure
-%global nspr_version 4.9.4
+%global nspr_version 4.9.6
%global nspr_build_version %(pkg-config --silence-errors --modversion nspr 2>/dev/null || echo 65536)
%global nss_version 3.14.3
%global nss_build_version %(pkg-config --silence-errors --modversion nss 2>/dev/null || echo 65536)
@@ -92,7 +92,7 @@
Summary: XUL Runtime for Gecko Applications
Name: %{shortname}-last
-Version: 20.0.1
+Version: 21.0
Release: 1%{?pre_tag}%{?dist}
URL: http://developer.mozilla.org/En/XULRunner
License: MPLv1.1 or GPLv2+ or LGPLv2+
@@ -110,7 +110,6 @@ Patch14: xulrunner-2.0-chromium-types.patch
Patch17: xulrunner-15.0-gcc47.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=814879#c3
Patch18: xulrunner-16.0-jemalloc-ppc.patch
-Patch19: rhbz-304121.patch
# Fedora specific patches
Patch20: mozilla-193-pkgconfig.patch
@@ -118,8 +117,6 @@ Patch21: rhbz-911314.patch
Patch22: rhbz-928353.patch
# Upstream patches
-Patch101: mozilla-791626.patch
-Patch102: mozilla-239254.patch
Patch104: mozilla-844883.patch
# ---------------------------------------------------
@@ -268,7 +265,6 @@ cd %{tarballdir}
%patch14 -p2 -b .chromium-types
%patch17 -p2 -b .gcc47
%patch18 -p2 -b .jemalloc-ppc
-%patch19 -p2 -b .rhbz-304121
%patch20 -p2 -b .pk
%ifarch ppc ppc64
@@ -282,9 +278,6 @@ cd %{tarballdir}
%endif
%endif
-%patch101 -p1 -b .791626
-%patch102 -p1 -b .239254
-
%{__rm} -f .mozconfig
%{__cat} %{SOURCE10} \
%if ! %{system_vpx}
@@ -587,6 +580,18 @@ fi
#---------------------------------------------------------------------
%changelog
+* Tue May 14 2013 Remi Collet <RPMS@FamilleCollet.com> - 21.0-1
+- Update to 21.0, sync with rawhide
+
+* Mon May 13 2013 Martin Stransky <stransky@redhat.com> - 21.0-3
+- New upstream tarball (build 4)
+
+* Mon May 13 2013 Martin Stransky <stransky@redhat.com> - 21.0-2
+- Updated requested NSS/NSPR versions
+
+* Sun May 12 2013 Martin Stransky <stransky@redhat.com> - 21.0-1
+- Update to latest upstream (21.0)
+
* Mon Apr 15 2013 Remi Collet <RPMS@FamilleCollet.com> - 20.0.1-1
- Update to 20.0.1, sync with rawhide