summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-08-28 13:41:27 +0200
committerRemi Collet <fedora@famillecollet.com>2012-08-28 13:41:27 +0200
commit6f0113bdef18bdc597a7c79a89e8ab9b6a11a146 (patch)
tree4ab84cbacdb9a8441261e833ed4d62c26b9390ab
parentae594094606ae28490c52bde58690c795d17d08e (diff)
Xulrunner / Firefox 15.0
-rw-r--r--crashreporter-remove-static.patch11
-rw-r--r--mozilla-691898.patch288
-rw-r--r--mozilla-709732-gfx-icc-profile-fix.patch21
-rw-r--r--mozilla-750620.patch33
-rw-r--r--xulrunner-10.0-gcc47.patch13
-rw-r--r--xulrunner-15.0-gcc47.patch13
-rw-r--r--xulrunner.spec42
7 files changed, 59 insertions, 362 deletions
diff --git a/crashreporter-remove-static.patch b/crashreporter-remove-static.patch
deleted file mode 100644
index b94d165..0000000
--- a/crashreporter-remove-static.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -up comm-1.9.2/mozilla/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in.static comm-1.9.2/mozilla/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in
---- mozilla/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in.static 2010-06-23 19:47:11.000000000 +0200
-+++ mozilla/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in 2010-07-12 15:51:41.000000000 +0200
-@@ -64,6 +64,6 @@ FORCE_USE_PIC = 1
-
- #XXX: bug 554854 causes us to be unable to run binaries on the build slaves
- # due to them having an older libstdc++
--HOST_LDFLAGS += -static
-+#HOST_LDFLAGS += -static
-
- include $(topsrcdir)/config/rules.mk
diff --git a/mozilla-691898.patch b/mozilla-691898.patch
deleted file mode 100644
index d138d84..0000000
--- a/mozilla-691898.patch
+++ /dev/null
@@ -1,288 +0,0 @@
-diff -up xulrunner-14.0.1/mozilla-release/js/src/assembler/jit/ExecutableAllocator.h.691898 xulrunner-14.0.1/mozilla-release/js/src/assembler/jit/ExecutableAllocator.h
---- xulrunner-14.0.1/mozilla-release/js/src/assembler/jit/ExecutableAllocator.h.691898 2012-07-13 23:42:56.000000000 +0200
-+++ xulrunner-14.0.1/mozilla-release/js/src/assembler/jit/ExecutableAllocator.h 2012-07-16 13:46:03.512655482 +0200
-@@ -468,8 +468,6 @@ public:
- {
- sync_instruction_memory((caddr_t)code, size);
- }
--#else
-- #error "The cacheFlush support is missing on this platform."
- #endif
-
- private:
-diff -up xulrunner-14.0.1/mozilla-release/js/src/Makefile.in.691898 xulrunner-14.0.1/mozilla-release/js/src/Makefile.in
---- xulrunner-14.0.1/mozilla-release/js/src/Makefile.in.691898 2012-07-13 23:42:56.000000000 +0200
-+++ xulrunner-14.0.1/mozilla-release/js/src/Makefile.in 2012-07-16 13:48:34.039399155 +0200
-@@ -320,20 +320,22 @@ endif
-
- endif
-
--# For architectures without YARR JIT, PCRE is faster than the YARR
--# interpreter (bug 684559).
--
- ifeq (,$(filter arm% sparc %86 x86_64 mips%,$(TARGET_CPU)))
-
--VPATH += $(srcdir)/yarr/pcre \
-- $(NULL)
-+VPATH += $(srcdir)/assembler \
-+ $(srcdir)/assembler/wtf \
-+ $(srcdir)/assembler/jit \
-+ $(srcdir)/yarr \
-
--CPPSRCS += \
-- pcre_compile.cpp \
-- pcre_exec.cpp \
-- pcre_tables.cpp \
-- pcre_xclass.cpp \
-- pcre_ucp_searchfuncs.cpp \
-+CPPSRCS += ExecutableAllocator.cpp \
-+ ExecutableAllocatorPosix.cpp \
-+ OSAllocatorOS2.cpp \
-+ OSAllocatorPosix.cpp \
-+ OSAllocatorWin.cpp \
-+ PageBlock.cpp \
-+ YarrInterpreter.cpp \
-+ YarrPattern.cpp \
-+ YarrSyntaxChecker.cpp \
- $(NULL)
- else
-
-@@ -903,4 +905,3 @@ endif
- #
- # END kludges for the Nitro assembler
- ###############################################
--
-diff -up xulrunner-14.0.1/mozilla-release/js/src/vm/RegExpObject.cpp.691898 xulrunner-14.0.1/mozilla-release/js/src/vm/RegExpObject.cpp
---- xulrunner-14.0.1/mozilla-release/js/src/vm/RegExpObject.cpp.691898 2012-07-13 23:42:59.000000000 +0200
-+++ xulrunner-14.0.1/mozilla-release/js/src/vm/RegExpObject.cpp 2012-07-16 13:46:03.897657354 +0200
-@@ -168,7 +168,6 @@ MatchPairs::checkAgainst(size_t inputLen
-
- /* detail::RegExpCode */
-
--#if ENABLE_YARR_JIT
- void
- RegExpCode::reportYarrError(JSContext *cx, TokenStream *ts, ErrorCode error)
- {
-@@ -200,46 +199,9 @@ RegExpCode::reportYarrError(JSContext *c
- }
- }
-
--#else /* !ENABLE_YARR_JIT */
--
--void
--RegExpCode::reportPCREError(JSContext *cx, int error)
--{
--#define REPORT(msg_) \
-- JS_ReportErrorFlagsAndNumberUC(cx, JSREPORT_ERROR, js_GetErrorMessage, NULL, msg_); \
-- return
-- switch (error) {
-- case -2: REPORT(JSMSG_REGEXP_TOO_COMPLEX);
-- case 0: JS_NOT_REACHED("Precondition violation: an error must have occurred.");
-- case 1: REPORT(JSMSG_TRAILING_SLASH);
-- case 2: REPORT(JSMSG_TRAILING_SLASH);
-- case 3: REPORT(JSMSG_REGEXP_TOO_COMPLEX);
-- case 4: REPORT(JSMSG_BAD_QUANTIFIER);
-- case 5: REPORT(JSMSG_BAD_QUANTIFIER);
-- case 6: REPORT(JSMSG_BAD_CLASS_RANGE);
-- case 7: REPORT(JSMSG_REGEXP_TOO_COMPLEX);
-- case 8: REPORT(JSMSG_BAD_CLASS_RANGE);
-- case 9: REPORT(JSMSG_BAD_QUANTIFIER);
-- case 10: REPORT(JSMSG_UNMATCHED_RIGHT_PAREN);
-- case 11: REPORT(JSMSG_REGEXP_TOO_COMPLEX);
-- case 12: REPORT(JSMSG_UNMATCHED_RIGHT_PAREN);
-- case 13: REPORT(JSMSG_REGEXP_TOO_COMPLEX);
-- case 14: REPORT(JSMSG_MISSING_PAREN);
-- case 15: REPORT(JSMSG_BAD_BACKREF);
-- case 16: REPORT(JSMSG_REGEXP_TOO_COMPLEX);
-- case 17: REPORT(JSMSG_REGEXP_TOO_COMPLEX);
-- default:
-- JS_NOT_REACHED("Precondition violation: unknown PCRE error code.");
-- }
--#undef REPORT
--}
--
--#endif /* ENABLE_YARR_JIT */
--
- bool
- RegExpCode::compile(JSContext *cx, JSLinearString &pattern, unsigned *parenCount, RegExpFlag flags)
- {
--#if ENABLE_YARR_JIT
- /* Parse the pattern. */
- ErrorCode yarrError;
- YarrPattern yarrPattern(pattern, bool(flags & IgnoreCaseFlag), bool(flags & MultilineFlag),
-@@ -256,7 +218,7 @@ RegExpCode::compile(JSContext *cx, JSLin
- * case we have to bytecode compile it.
- */
-
--#ifdef JS_METHODJIT
-+#if ENABLE_YARR_JIT && defined(JS_METHODJIT)
- if (isJITRuntimeEnabled(cx) && !yarrPattern.m_containsBackreferences) {
- JSC::ExecutableAllocator *execAlloc = cx->runtime->getExecutableAllocator(cx);
- if (!execAlloc) {
-@@ -277,21 +239,11 @@ RegExpCode::compile(JSContext *cx, JSLin
- return false;
- }
-
-+#if ENABLE_YARR_JIT
- codeBlock.setFallBack(true);
-+#endif
- byteCode = byteCompile(yarrPattern, bumpAlloc).get();
- return true;
--#else /* !defined(ENABLE_YARR_JIT) */
-- int error = 0;
-- compiled = jsRegExpCompile(pattern.chars(), pattern.length(),
-- ignoreCase() ? JSRegExpIgnoreCase : JSRegExpDoNotIgnoreCase,
-- multiline() ? JSRegExpMultiline : JSRegExpSingleLine,
-- parenCount, &error);
-- if (error) {
-- reportPCREError(cx, error);
-- return false;
-- }
-- return true;
--#endif
- }
-
- RegExpRunStatus
-@@ -306,19 +258,12 @@ RegExpCode::execute(JSContext *cx, const
- else
- result = JSC::Yarr::execute(codeBlock, chars, start, length, output);
- #else
-- result = jsRegExpExecute(cx, compiled, chars, length, start, output, outputCount);
-+ result = JSC::Yarr::interpret(byteCode, chars, start, length, output);
- #endif
-
- if (result == -1)
- return RegExpRunStatus_Success_NotFound;
-
--#if !ENABLE_YARR_JIT
-- if (result < 0) {
-- reportPCREError(cx, result);
-- return RegExpRunStatus_Error;
-- }
--#endif
--
- JS_ASSERT(result >= 0);
- return RegExpRunStatus_Success;
- }
-diff -up xulrunner-14.0.1/mozilla-release/js/src/vm/RegExpObject.h.691898 xulrunner-14.0.1/mozilla-release/js/src/vm/RegExpObject.h
---- xulrunner-14.0.1/mozilla-release/js/src/vm/RegExpObject.h.691898 2012-07-13 23:42:59.000000000 +0200
-+++ xulrunner-14.0.1/mozilla-release/js/src/vm/RegExpObject.h 2012-07-16 13:46:03.897657354 +0200
-@@ -52,10 +52,8 @@
- #include "yarr/Yarr.h"
- #if ENABLE_YARR_JIT
- #include "yarr/YarrJIT.h"
--#include "yarr/YarrSyntaxChecker.h"
--#else
--#include "yarr/pcre/pcre.h"
- #endif
-+#include "yarr/YarrSyntaxChecker.h"
-
- /*
- * JavaScript Regular Expressions
-@@ -113,68 +111,51 @@ namespace detail {
-
- class RegExpCode
- {
--#if ENABLE_YARR_JIT
- typedef JSC::Yarr::BytecodePattern BytecodePattern;
- typedef JSC::Yarr::ErrorCode ErrorCode;
-+ typedef JSC::Yarr::YarrPattern YarrPattern;
-+#if ENABLE_YARR_JIT
- typedef JSC::Yarr::JSGlobalData JSGlobalData;
- typedef JSC::Yarr::YarrCodeBlock YarrCodeBlock;
-- typedef JSC::Yarr::YarrPattern YarrPattern;
-
- /* Note: Native code is valid only if |codeBlock.isFallBack() == false|. */
- YarrCodeBlock codeBlock;
-- BytecodePattern *byteCode;
--#else
-- JSRegExp *compiled;
- #endif
-+ BytecodePattern *byteCode;
-
- public:
- RegExpCode()
- :
- #if ENABLE_YARR_JIT
- codeBlock(),
-- byteCode(NULL)
--#else
-- compiled(NULL)
- #endif
-+ byteCode(NULL)
- { }
-
- ~RegExpCode() {
- #if ENABLE_YARR_JIT
- codeBlock.release();
-+#endif
- if (byteCode)
- Foreground::delete_<BytecodePattern>(byteCode);
--#else
-- if (compiled)
-- jsRegExpFree(compiled);
--#endif
- }
-
- static bool checkSyntax(JSContext *cx, TokenStream *tokenStream, JSLinearString *source) {
--#if ENABLE_YARR_JIT
- ErrorCode error = JSC::Yarr::checkSyntax(*source);
- if (error == JSC::Yarr::NoError)
- return true;
-
- reportYarrError(cx, tokenStream, error);
- return false;
--#else
--# error "Syntax checking not implemented for !ENABLE_YARR_JIT"
--#endif
- }
-
- #if ENABLE_YARR_JIT
- static inline bool isJITRuntimeEnabled(JSContext *cx);
-- static void reportYarrError(JSContext *cx, TokenStream *ts, JSC::Yarr::ErrorCode error);
--#else
-- static void reportPCREError(JSContext *cx, int error);
- #endif
-+ static void reportYarrError(JSContext *cx, TokenStream *ts, JSC::Yarr::ErrorCode error);
-
- static size_t getOutputSize(size_t pairCount) {
--#if ENABLE_YARR_JIT
- return pairCount * 2;
--#else
-- return pairCount * 3; /* Should be x2, but PCRE has... needs. */
--#endif
- }
-
- bool compile(JSContext *cx, JSLinearString &pattern, unsigned *parenCount, RegExpFlag flags);
-diff -up xulrunner-14.0.1/mozilla-release/js/src/vm/RegExpObject-inl.h.691898 xulrunner-14.0.1/mozilla-release/js/src/vm/RegExpObject-inl.h
---- xulrunner-14.0.1/mozilla-release/js/src/vm/RegExpObject-inl.h.691898 2012-07-13 23:42:59.000000000 +0200
-+++ xulrunner-14.0.1/mozilla-release/js/src/vm/RegExpObject-inl.h 2012-07-16 13:46:03.898657360 +0200
-@@ -137,6 +137,7 @@ RegExpObject::setSticky(bool enabled)
- setSlot(STICKY_FLAG_SLOT, BooleanValue(enabled));
- }
-
-+#if ENABLE_YARR_JIT
- /* This function should be deleted once bad Android platforms phase out. See bug 604774. */
- inline bool
- detail::RegExpCode::isJITRuntimeEnabled(JSContext *cx)
-@@ -147,6 +148,7 @@ detail::RegExpCode::isJITRuntimeEnabled(
- return true;
- #endif
- }
-+#endif
-
- inline bool
- RegExpToShared(JSContext *cx, JSObject &obj, RegExpGuard *g)
-diff -up xulrunner-14.0.1/mozilla-release/js/src/yarr/wtfbridge.h.691898 xulrunner-14.0.1/mozilla-release/js/src/yarr/wtfbridge.h
---- xulrunner-14.0.1/mozilla-release/js/src/yarr/wtfbridge.h.691898 2012-07-13 23:42:59.000000000 +0200
-+++ xulrunner-14.0.1/mozilla-release/js/src/yarr/wtfbridge.h 2012-07-16 13:46:03.898657360 +0200
-@@ -49,9 +49,7 @@
- #include "jsprvtd.h"
- #include "vm/String.h"
- #include "assembler/wtf/Platform.h"
--#if ENABLE_YARR_JIT
- #include "assembler/jit/ExecutableAllocator.h"
--#endif
-
- namespace JSC { namespace Yarr {
-
diff --git a/mozilla-709732-gfx-icc-profile-fix.patch b/mozilla-709732-gfx-icc-profile-fix.patch
new file mode 100644
index 0000000..7e268d0
--- /dev/null
+++ b/mozilla-709732-gfx-icc-profile-fix.patch
@@ -0,0 +1,21 @@
+diff -r dd29535bac5f gfx/thebes/gfxPlatformGtk.cpp
+--- a/gfx/thebes/gfxPlatformGtk.cpp Sat May 05 20:22:53 2012 -0700
++++ b/gfx/thebes/gfxPlatformGtk.cpp Wed May 09 11:42:21 2012 +0200
+@@ -538,16 +538,10 @@
+ if (iccAtom) {
+ // read once to get size, once for the data
+ if (Success == XGetWindowProperty(dpy, root, iccAtom,
+- 0, 0 /* length */,
++ 0, INT_MAX /* length */,
+ False, AnyPropertyType,
+ &retAtom, &retFormat, &retLength,
+ &retAfter, &retProperty)) {
+- XGetWindowProperty(dpy, root, iccAtom,
+- 0, retLength,
+- False, AnyPropertyType,
+- &retAtom, &retFormat, &retLength,
+- &retAfter, &retProperty);
+-
+ qcms_profile* profile = NULL;
+
+ if (retLength > 0)
diff --git a/mozilla-750620.patch b/mozilla-750620.patch
deleted file mode 100644
index c8c6d10..0000000
--- a/mozilla-750620.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-# HG changeset patch
-# User Mike Hommey <mh+mozilla@glandium.org>
-# Date 1337607752 -7200
-# Node ID 93093285af6065c441a806e97ca8f79225a158c6
-# Parent 87c452c6444eecd226a30458e735d0cfaad714fd
-Bug 750620 - Declare double conversion correctness for more architectures
-
-diff --git a/mfbt/double-conversion/utils.h b/mfbt/double-conversion/utils.h
---- a/mfbt/double-conversion/utils.h
-+++ b/mfbt/double-conversion/utils.h
-@@ -48,17 +48,21 @@
- // An easy way to test if the floating-point operations are correct is to
- // evaluate: 89255.0/1e22. If the floating-point stack is 64 bits wide then
- // the result is equal to 89255e-22.
- // The best way to test this, is to create a division-function and to compare
- // the output of the division with the expected result. (Inlining must be
- // disabled.)
- // On Linux,x86 89255e-22 != Div_double(89255.0/1e22)
- #if defined(_M_X64) || defined(__x86_64__) || \
-- defined(__ARMEL__) || \
-+ defined(__ARMEL__) || defined(__avr32__) || \
-+ defined(__hppa__) || defined(__ia64__) || \
-+ defined(__mips__) || defined(__powerpc__) || \
-+ defined(__sparc__) || defined(__s390__) || \
-+ defined(__SH4__) || defined(__alpha__) || \
- defined(_MIPS_ARCH_MIPS32R2)
- #define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1
- #elif defined(_M_IX86) || defined(__i386__)
- #if defined(_WIN32)
- // Windows uses a 64bit wide floating point stack.
- #define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1
- #else
- #undef DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS
diff --git a/xulrunner-10.0-gcc47.patch b/xulrunner-10.0-gcc47.patch
deleted file mode 100644
index 093357b..0000000
--- a/xulrunner-10.0-gcc47.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -up mozilla-beta/toolkit/crashreporter/client/Makefile.in.gcc47 mozilla-beta/toolkit/crashreporter/client/Makefile.in
---- mozilla-beta/toolkit/crashreporter/client/Makefile.in.gcc47 2012-01-30 14:41:14.475441039 -0500
-+++ mozilla-beta/toolkit/crashreporter/client/Makefile.in 2012-01-30 14:43:03.587646656 -0500
-@@ -69,6 +69,9 @@ CPPSRCS = \
- $(STDCXX_COMPAT) \
- $(NULL)
-
-+# Needed for moz_free
-+LIBS += -L$(LIBXUL_DIST)/lib -lmozalloc
-+
- ifeq ($(OS_ARCH),WINNT)
- CPPSRCS += crashreporter_win.cpp
- LIBS += \
diff --git a/xulrunner-15.0-gcc47.patch b/xulrunner-15.0-gcc47.patch
new file mode 100644
index 0000000..0d44796
--- /dev/null
+++ b/xulrunner-15.0-gcc47.patch
@@ -0,0 +1,13 @@
+diff -up xulrunner-15.0/mozilla-beta/toolkit/crashreporter/client/Makefile.in.gcc47 xulrunner-15.0/mozilla-beta/toolkit/crashreporter/client/Makefile.in
+--- xulrunner-15.0/mozilla-beta/toolkit/crashreporter/client/Makefile.in.gcc47 2012-08-15 07:48:31.000000000 +0200
++++ xulrunner-15.0/mozilla-beta/toolkit/crashreporter/client/Makefile.in 2012-08-20 15:05:41.782947739 +0200
+@@ -34,6 +34,9 @@ CPPSRCS = \
+ crashreporter.cpp \
+ $(NULL)
+
++# Needed for moz_free
++LIBS += -L$(LIBXUL_DIST)/lib -lmozalloc
++
+ ifeq ($(OS_ARCH),WINNT)
+ CPPSRCS += crashreporter_win.cpp
+ LIBS += \
diff --git a/xulrunner.spec b/xulrunner.spec
index a97da27..d7f10ea 100644
--- a/xulrunner.spec
+++ b/xulrunner.spec
@@ -1,16 +1,20 @@
# Use system nspr/nss?
-%if 0%{?fedora} < 15
+%if 0%{?fedora} < 15 && 0%{?rhel} < 6
%define system_nss 0
-%define system_vpx 0
%else
%define system_nss 1
+%endif
+
+%if 0%{?fedora} < 15
+%define system_vpx 0
+%else
%define system_vpx 1
%endif
# Use system sqlite?
%if 0%{?fedora} <= 17
%define system_sqlite 0
-%else
+%else7
%define system_sqlite 1
%endif
@@ -44,7 +48,7 @@
# alpha_version should be set to the alpha number if using an alpha, 0 otherwise
# beta_version should be set to the beta number if using a beta, 0 otherwise
# rc_version should be set to the RC number if using an RC, 0 otherwise
-%global gecko_dir_ver 14
+%global gecko_dir_ver 15
%global alpha_version 0
%global beta_version 0
%global rc_version 0
@@ -77,7 +81,7 @@
Summary: XUL Runtime for Gecko Applications
Name: %{shortname}%{gecko_dir_ver}
-Version: 14.0.1
+Version: 15.0
Release: 1%{?dist}
URL: http://developer.mozilla.org/En/XULRunner
License: MPLv1.1 or GPLv2+ or LGPLv2+
@@ -94,19 +98,17 @@ Source21: %{shortname}.sh.in
Patch0: xulrunner-version.patch
Patch1: mozilla-build.patch
Patch14: xulrunner-2.0-chromium-types.patch
-Patch17: xulrunner-10.0-gcc47.patch
+Patch17: xulrunner-15.0-gcc47.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=814879#c3
Patch18: xulrunner-12.0-jemalloc-ppc.patch
# Fedora specific patches
Patch20: mozilla-193-pkgconfig.patch
-Patch24: crashreporter-remove-static.patch
# Upstream patches
-Patch47: mozilla-691898.patch
Patch49: mozilla-746112.patch
-Patch50: mozilla-750620.patch
+Patch51: mozilla-709732-gfx-icc-profile-fix.patch
# ---------------------------------------------------
@@ -153,10 +155,10 @@ Requires: nss >= %{nss_version}
%endif
Provides: gecko-libs = %{gecko_verrel}
Provides: gecko-libs%{?_isa} = %{gecko_verrel}
-Obsoletes: xulrunner10
Obsoletes: xulrunner11
Obsoletes: xulrunner12
Obsoletes: xulrunner13
+Obsoletes: xulrunner14
%if %{?system_sqlite}
BuildRequires: sqlite-devel >= %{sqlite_version}
@@ -176,10 +178,10 @@ Group: Development/Libraries
Obsoletes: mozilla-devel < 1.9
Obsoletes: firefox-devel < 2.1
Obsoletes: xulrunner-devel-unstable
-Obsoletes: xulrunner10-devel
Obsoletes: xulrunner11-devel
Obsoletes: xulrunner12-devel
Obsoletes: xulrunner13-devel
+Obsoletes: xulrunner14-devel
Provides: gecko-devel = %{gecko_verrel}
Provides: gecko-devel%{?_isa} = %{gecko_verrel}
Provides: gecko-devel-unstable = %{gecko_verrel}
@@ -248,7 +250,7 @@ debug %{name}, you want to install %{name}-debuginfo instead.
#---------------------------------------------------------------------
%prep
-echo TARGET = %{name}-%{version}-%{release}%{?dist} GECKO = %{gecko_verrel}
+echo TARGET = %{name}-%{version}-%{release} GECKO = %{gecko_verrel}
%setup -q -c
cd %{tarballdir}
@@ -258,17 +260,15 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{gecko_dir_ver}/' %{P:%%PATCH0} \
%patch1 -p1 -b .build
%patch14 -p1 -b .chromium-types
-%patch17 -p1 -b .gcc47
+%patch17 -p2 -b .gcc47
%patch18 -p2 -b .jemalloc-ppc
%patch20 -p2 -b .pk
-%patch24 -p1 -b .static
-%patch47 -p2 -b .691898
%ifarch ppc ppc64
%patch49 -p2 -b .746112
%endif
-%patch50 -p1 -b .750620
+%patch51 -p1 -b .709732
%{__rm} -f .mozconfig
%{__cat} %{SOURCE10} \
@@ -526,7 +526,6 @@ fi
%{mozappdir}/mozilla-xremote-client
%{mozappdir}/run-mozilla.sh
%{mozappdir}/xulrunner
-%{mozappdir}/xulrunner-bin
%{mozappdir}/xulrunner-stub
%{mozappdir}/platform.ini
%{mozappdir}/dependentlibs.list
@@ -555,6 +554,15 @@ fi
#---------------------------------------------------------------------
%changelog
+* Tue Aug 28 2012 Remi Collet <RPMS@FamilleCollet.com> - 15.0-1
+- Sync with rawhide, update to 15.0
+
+* Wed Aug 22 2012 Martin Stransky <stransky@redhat.com> - 15.0-2
+- Update to 15.0
+
+* Thu Aug 9 2012 Jan Horak <jhorak@redhat.com> - 14.0.1-6
+- Added fix for mozbz#709732
+
* Wed Jul 25 2012 Dan HorĂ¡k <dan[at]danny.cz> - 14.0.1-5
- Added fix for secondary arches - mozbz#750620