summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-11-18 09:38:27 +0100
committerRemi Collet <fedora@famillecollet.com>2012-11-18 09:38:27 +0100
commit53c46516b2d6504c1fb66614874389ea5b880858 (patch)
tree81476eba79c01b4dda3c748abb48217498fdc0da
parent62c994864309c3db6024437364469d6945918329 (diff)
Xulrunner / Firefox 17.0 Beta 6
-rw-r--r--mozilla-709732-gfx-icc-profile-fix.patch21
-rw-r--r--mozilla-746112.patch121
-rw-r--r--mozilla-build.patch17
-rw-r--r--xulrunner.spec51
4 files changed, 68 insertions, 142 deletions
diff --git a/mozilla-709732-gfx-icc-profile-fix.patch b/mozilla-709732-gfx-icc-profile-fix.patch
deleted file mode 100644
index 7e268d0..0000000
--- a/mozilla-709732-gfx-icc-profile-fix.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -r dd29535bac5f gfx/thebes/gfxPlatformGtk.cpp
---- a/gfx/thebes/gfxPlatformGtk.cpp Sat May 05 20:22:53 2012 -0700
-+++ b/gfx/thebes/gfxPlatformGtk.cpp Wed May 09 11:42:21 2012 +0200
-@@ -538,16 +538,10 @@
- if (iccAtom) {
- // read once to get size, once for the data
- if (Success == XGetWindowProperty(dpy, root, iccAtom,
-- 0, 0 /* length */,
-+ 0, INT_MAX /* length */,
- False, AnyPropertyType,
- &retAtom, &retFormat, &retLength,
- &retAfter, &retProperty)) {
-- XGetWindowProperty(dpy, root, iccAtom,
-- 0, retLength,
-- False, AnyPropertyType,
-- &retAtom, &retFormat, &retLength,
-- &retAfter, &retProperty);
--
- qcms_profile* profile = NULL;
-
- if (retLength > 0)
diff --git a/mozilla-746112.patch b/mozilla-746112.patch
index 0370f3c..765f993 100644
--- a/mozilla-746112.patch
+++ b/mozilla-746112.patch
@@ -1,86 +1,35 @@
-diff -up mozilla-release/js/src/gc/Heap.h.746112 mozilla-release/js/src/gc/Heap.h
---- mozilla-release/js/src/gc/Heap.h.746112 2012-10-24 16:32:52.000000000 +0200
-+++ mozilla-release/js/src/gc/Heap.h 2012-10-31 12:44:02.400733198 +0100
-@@ -103,26 +103,31 @@ struct Cell
- };
-
- /*
-- * Page size is 4096 by default, except for SPARC, where it is 8192.
-+ * Page size must be static to support our arena pointer optimizations, so we
-+ * are forced to support each platform with non-4096 pages as a special case.
-+ * Note: The freelist supports a maximum arena shift of 15.
- * Note: Do not use JS_CPU_SPARC here, this header is used outside JS.
- * Bug 692267: Move page size definition to gc/Memory.h and include it
- * directly once jsgc.h is no longer an installed header.
- */
- #if defined(SOLARIS) && (defined(__sparc) || defined(__sparcv9))
- const size_t PageShift = 13;
-+const size_t ArenaShift = PageShift;
-+#elif defined(__powerpc__)
-+const size_t PageShift = 16;
-+const size_t ArenaShift = 12;
- #else
- const size_t PageShift = 12;
-+const size_t ArenaShift = PageShift;
- #endif
- const size_t PageSize = size_t(1) << PageShift;
-+const size_t ArenaSize = size_t(1) << ArenaShift;
-+const size_t ArenaMask = ArenaSize - 1;
-
- const size_t ChunkShift = 20;
- const size_t ChunkSize = size_t(1) << ChunkShift;
- const size_t ChunkMask = ChunkSize - 1;
-
--const size_t ArenaShift = PageShift;
--const size_t ArenaSize = PageSize;
--const size_t ArenaMask = ArenaSize - 1;
--
- /*
- * This is the maximum number of arenas we allow in the FreeCommitted state
- * before we trigger a GC_SHRINK to release free arenas to the OS.
-diff -up mozilla-release/js/src/jsgc.cpp.746112 mozilla-release/js/src/jsgc.cpp
---- mozilla-release/js/src/jsgc.cpp.746112 2012-10-24 16:32:54.000000000 +0200
-+++ mozilla-release/js/src/jsgc.cpp 2012-10-31 12:42:50.681735540 +0100
-@@ -194,6 +194,13 @@ const uint32_t Arena::FirstThingOffsets[
-
- #undef OFFSET
-
-+/* Unused memory decommiting requires the arena size match the page size. */
-+static bool
-+DecommitEnabled()
-+{
-+ return PageSize == ArenaSize;
-+}
-+
- #ifdef DEBUG
- void
- ArenaHeader::checkSynchronizedWithFreeList() const
-@@ -677,7 +684,8 @@ Chunk::fetchNextDecommittedArena()
- decommittedArenas.unset(offset);
-
- Arena *arena = &arenas[offset];
-- MarkPagesInUse(arena, ArenaSize);
-+ if (DecommitEnabled())
-+ MarkPagesInUse(arena, ArenaSize);
- arena->aheader.setAsNotAllocated();
-
- return &arena->aheader;
-@@ -2634,7 +2642,7 @@ DecommitArenasFromAvailableList(JSRuntim
- chunk->removeFromAvailableList();
-
- size_t arenaIndex = Chunk::arenaIndex(aheader->arenaAddress());
-- bool ok;
-+ bool ok = true;
- {
- /*
- * If the main thread waits for the decommit to finish, skip
-@@ -2644,7 +2652,8 @@ DecommitArenasFromAvailableList(JSRuntim
- Maybe<AutoUnlockGC> maybeUnlock;
- if (!rt->isHeapBusy())
- maybeUnlock.construct(rt);
-- ok = MarkPagesUnused(aheader->getArena(), ArenaSize);
-+ if (DecommitEnabled())
-+ ok = MarkPagesUnused(aheader->getArena(), ArenaSize);
- }
-
- if (ok) {
+Index: xulrunner-10.0.1/mozilla-release/js/src/yarr/YarrInterpreter.h
+===================================================================
+--- xulrunner-10.0.1.orig/mozilla-release/js/src/yarr/YarrInterpreter.h
++++ xulrunner-10.0.1/mozilla-release/js/src/yarr/YarrInterpreter.h
+@@ -167,7 +167,7 @@ struct ByteTerm {
+ inputPosition = inputPos;
+ }
+
+- ByteTerm(Type type, unsigned subpatternId, ByteDisjunction* parenthesesInfo, bool capture, int inputPos)
++ ByteTerm(Type type, unsigned subpatternId, ByteDisjunction* parenthesesInfo, bool capture, int inputPos) __attribute__((noinline))
+ : type(type)
+ , m_capture(capture)
+ , m_invert(false)
+@@ -188,7 +188,7 @@ struct ByteTerm {
+ atom.quantityCount = 1;
+ }
+
+- ByteTerm(Type type, unsigned subpatternId, bool capture, bool invert, int inputPos)
++ ByteTerm(Type type, unsigned subpatternId, bool capture, bool invert, int inputPos) __attribute__((noinline))
+ : type(type)
+ , m_capture(capture)
+ , m_invert(invert)
+Index: xulrunner-10.0.1/mozilla-release/js/src/yarr/YarrPattern.h
+===================================================================
+--- xulrunner-10.0.1.orig/mozilla-release/js/src/yarr/YarrPattern.h
++++ xulrunner-10.0.1/mozilla-release/js/src/yarr/YarrPattern.h
+@@ -171,7 +171,7 @@ struct PatternTerm {
+ quantityCount = 1;
+ }
+
+- PatternTerm(Type type, unsigned subpatternId, PatternDisjunction* disjunction, bool capture = false, bool invert = false)
++ PatternTerm(Type type, unsigned subpatternId, PatternDisjunction* disjunction, bool capture = false, bool invert = false) __attribute__((noinline))
+ : type(type)
+ , m_capture(capture)
+ , m_invert(invert)
diff --git a/mozilla-build.patch b/mozilla-build.patch
index be1ba4b..9468e02 100644
--- a/mozilla-build.patch
+++ b/mozilla-build.patch
@@ -1,7 +1,7 @@
-diff -up mozilla-beta/security/manager/Makefile.in.build mozilla-beta/security/manager/Makefile.in
---- mozilla-beta/security/manager/Makefile.in.build 2012-03-09 01:39:56.000000000 +0100
-+++ mozilla-beta/security/manager/Makefile.in 2012-03-09 13:56:28.612328083 +0100
-@@ -174,7 +174,6 @@ DEFAULT_GMAKE_FLAGS += NSPR_INCLUDE_DIR=
+diff -up mozilla-aurora-7676a9a06403/security/build/Makefile.in.build mozilla-aurora-7676a9a06403/security/build/Makefile.in
+--- mozilla-aurora-7676a9a06403/security/build/Makefile.in.build 2012-09-13 14:18:35.000000000 +0200
++++ mozilla-aurora-7676a9a06403/security/build/Makefile.in 2012-09-18 10:58:45.560063613 +0200
+@@ -139,7 +139,6 @@ DEFAULT_GMAKE_FLAGS += NSPR_INCLUDE_DIR=
DEFAULT_GMAKE_FLAGS += NSPR_LIB_DIR=$(NSPR_LIB_DIR)
DEFAULT_GMAKE_FLAGS += MOZILLA_CLIENT=1
DEFAULT_GMAKE_FLAGS += NO_MDUPDATE=1
@@ -9,10 +9,11 @@ diff -up mozilla-beta/security/manager/Makefile.in.build mozilla-beta/security/m
DEFAULT_GMAKE_FLAGS += NSINSTALL="$(NSINSTALL)"
ifndef MOZ_NATIVE_SQLITE
DEFAULT_GMAKE_FLAGS += SQLITE_LIB_NAME=mozsqlite3
-diff -up mozilla-beta/security/manager/ssl/src/Makefile.in.build mozilla-beta/security/manager/ssl/src/Makefile.in
---- mozilla-beta/security/manager/ssl/src/Makefile.in.build 2012-03-09 01:39:56.000000000 +0100
-+++ mozilla-beta/security/manager/ssl/src/Makefile.in 2012-03-09 13:57:37.055657208 +0100
-@@ -116,7 +116,6 @@ CSRCS += md4.c
+diff -up mozilla-aurora-7676a9a06403/security/manager/Makefile.in.build mozilla-aurora-7676a9a06403/security/manager/Makefile.in
+diff -up mozilla-aurora-7676a9a06403/security/manager/ssl/src/Makefile.in.build mozilla-aurora-7676a9a06403/security/manager/ssl/src/Makefile.in
+--- mozilla-aurora-7676a9a06403/security/manager/ssl/src/Makefile.in.build 2012-09-13 14:18:35.000000000 +0200
++++ mozilla-aurora-7676a9a06403/security/manager/ssl/src/Makefile.in 2012-09-18 10:54:16.310505794 +0200
+@@ -84,7 +84,6 @@ CSRCS += md4.c
EXTRA_DEPS = $(NSS_DEP_LIBS)
DEFINES += \
diff --git a/xulrunner.spec b/xulrunner.spec
index 5ab07fd..c711099 100644
--- a/xulrunner.spec
+++ b/xulrunner.spec
@@ -31,7 +31,6 @@
%global freetype_version 2.1.9
%global libnotify_version 0.7.0
%global libvpx_version 1.0.0
-%global lcms_version 1.18
%if %{?system_nss}
%global nspr_version 4.9.2
@@ -52,7 +51,7 @@
# rc_version should be set to the RC number if using an RC, 0 otherwise
%global gecko_dir_ver %{version}
%global alpha_version 0
-%global beta_version 0
+%global beta_version 6
%global rc_version 0
%global mozappdir %{_libdir}/%{name}
@@ -83,8 +82,8 @@
Summary: XUL Runtime for Gecko Applications
Name: %{shortname}-last
-Version: 16.0.2
-Release: 1%{?dist}
+Version: 17.0
+Release: 0.2%{?pre_tag}%{?dist}
URL: http://developer.mozilla.org/En/XULRunner
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
@@ -97,8 +96,8 @@ Source12: %{shortname}-redhat-default-prefs.js
Source21: %{shortname}.sh.in
# build patches
-Patch1: mozilla-build.patch
-Patch2: xulrunner-install-dir.patch
+Patch1: xulrunner-install-dir.patch
+Patch2: mozilla-build.patch
Patch14: xulrunner-2.0-chromium-types.patch
Patch17: xulrunner-15.0-gcc47.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=814879#c3
@@ -109,7 +108,6 @@ Patch20: mozilla-193-pkgconfig.patch
# Upstream patches
Patch49: mozilla-746112.patch
-Patch51: mozilla-709732-gfx-icc-profile-fix.patch
# ---------------------------------------------------
@@ -139,11 +137,6 @@ BuildRequires: alsa-lib-devel
BuildRequires: libnotify-devel
BuildRequires: mesa-libGL-devel
BuildRequires: curl-devel
-BuildRequires: lcms-devel >= %{lcms_version}
-BuildRequires: yasm
-%ifarch %{ix86} x86_64
-BuildRequires: wireless-tools-devel
-%endif
%if %{system_vpx}
BuildRequires: libvpx-devel >= %{libvpx_version}
%endif
@@ -219,11 +212,6 @@ Requires: mesa-libGL-devel
%if %{system_vpx}
Requires: libvpx-devel >= %{libvpx_version}
%endif
-Requires: lcms-devel
-Requires: yasm
-%ifarch %{ix86} x86_64
-Requires: wireless-tools-devel
-%endif
%description devel
This package contains the libraries amd header files that are needed
@@ -255,22 +243,18 @@ echo TARGET = %{name}-%{version}-%{release} GECKO = %{gecko_verrel}
%setup -q -c
cd %{tarballdir}
-%patch1 -p1 -b .build
-%patch2 -p1
+%patch1 -p1
+%patch2 -p1 -b .build
%patch14 -p1 -b .chromium-types
%patch17 -p2 -b .gcc47
%patch18 -p2 -b .jemalloc-ppc
%patch20 -p2 -b .pk
-%patch49 -p1 -b .746112
-%patch51 -p1 -b .709732
+%patch49 -p2 -b .746112
%{__rm} -f .mozconfig
%{__cat} %{SOURCE10} \
-%ifarch %{ix86} x86_64
- | grep -v disable-necko-wifi \
-%endif
%if ! %{system_vpx}
| grep -v with-system-libvpx \
%endif
@@ -280,8 +264,6 @@ cd %{tarballdir}
%{__cat} %{SOURCE11} >> .mozconfig
%endif
-echo "ac_add_options --enable-system-lcms" >> .mozconfig
-
%if %{?system_nss}
echo "ac_add_options --with-system-nspr" >> .mozconfig
echo "ac_add_options --with-system-nss" >> .mozconfig
@@ -364,7 +346,7 @@ cd %{tarballdir}
# Disable C++ exceptions since Mozilla code is not exception-safe
#
MOZ_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS -fpermissive" | \
- %{__sed} -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g')
+ %{__sed} -e 's/-Wall//')
%if %{?debug_build}
MOZ_OPT_FLAGS=$(echo "$MOZ_OPT_FLAGS" | %{__sed} -e 's/-O2//')
%endif
@@ -545,6 +527,9 @@ fi
%{mozappdir}/crashreporter.ini
%{mozappdir}/Throbber-small.gif
%endif
+%exclude %{mozappdir}/components/.mkdir.done
+%exclude %{mozappdir}/defaults/pref/.mkdir.done
+%exclude %{mozappdir}/modules/.mkdir.done
%files devel
%defattr(-,root,root,-)
@@ -558,6 +543,18 @@ fi
#---------------------------------------------------------------------
%changelog
+* Sun Nov 18 2012 Remi Collet <RPMS@FamilleCollet.com> - 17.0-0.2.b6
+- Update to 17.0 Beta 6, sync with rawhide
+
+* Wed Nov 14 2012 Martin Stransky <stransky@redhat.com> - 17.0-0.2b6
+- Update to 17.0 Beta 6
+
+* Tue Nov 13 2012 Martin Stransky <stransky@redhat.com> - 17.0-0.1b5
+- Update to 17.0 Beta 5
+
+* Tue Nov 6 2012 Martin Stransky <stransky@redhat.com> - 16.0.2-2
+- Added fix for rhbz#872752
+
* Thu Nov 1 2012 Remi Collet <RPMS@FamilleCollet.com> - 16.0.2-1
- sync patch with rawhide
- rename to xulrunner-last