summaryrefslogtreecommitdiffstats
path: root/xulrunner-10.0-gcc47.patch
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-01-31 17:52:58 +0100
committerRemi Collet <fedora@famillecollet.com>2012-01-31 17:52:58 +0100
commit1f2fd2b0629db5399fb609e8cc5eda981d367144 (patch)
treebc5a7df884a16012858291531715e5f11adc3b33 /xulrunner-10.0-gcc47.patch
parent3be039f60b8238b18a674953c8270e8d62e8eefa (diff)
thunderbird 10, missing patches
Diffstat (limited to 'xulrunner-10.0-gcc47.patch')
-rw-r--r--xulrunner-10.0-gcc47.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/xulrunner-10.0-gcc47.patch b/xulrunner-10.0-gcc47.patch
new file mode 100644
index 0000000..91a948a
--- /dev/null
+++ b/xulrunner-10.0-gcc47.patch
@@ -0,0 +1,25 @@
+diff -up mozilla-beta/ipc/chromium/src/base/time_posix.cc.gcc47 mozilla-beta/ipc/chromium/src/base/time_posix.cc
+--- mozilla-beta/ipc/chromium/src/base/time_posix.cc.gcc47 2012-01-24 03:00:00.000000000 -0500
++++ mozilla-beta/ipc/chromium/src/base/time_posix.cc 2012-01-30 14:12:49.198472212 -0500
+@@ -14,6 +14,8 @@
+ #include <time.h>
+ #endif
+
++#include <unistd.h>
++
+ #include <limits>
+
+ #include "base/basictypes.h"
+diff -up mozilla-beta/toolkit/crashreporter/client/Makefile.in.gcc47 mozilla-beta/toolkit/crashreporter/client/Makefile.in
+--- mozilla-beta/toolkit/crashreporter/client/Makefile.in.gcc47 2012-01-30 14:41:14.475441039 -0500
++++ mozilla-beta/toolkit/crashreporter/client/Makefile.in 2012-01-30 14:43:03.587646656 -0500
+@@ -69,6 +69,9 @@ CPPSRCS = \
+ $(STDCXX_COMPAT) \
+ $(NULL)
+
++# Needed for moz_free
++LIBS += -L$(LIBXUL_DIST)/lib -lmozalloc
++
+ ifeq ($(OS_ARCH),WINNT)
+ CPPSRCS += crashreporter_win.cpp
+ LIBS += \