summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2010-09-21 17:43:12 +0200
committerRemi Collet <fedora@famillecollet.com>2010-09-21 17:43:12 +0200
commitfca26e4a9c1fccc83d7d87e7d60b7dddd5c80412 (patch)
treeb4e3398333daf5af6c2cd49e43aa9f4fcaff36db
parent741df0ae02a1d6b6d817ec3790e7817c344dda4b (diff)
thunderbird, sync with rawhide, f-14 build
-rw-r--r--mozilla-libjpeg-turbo.patch54
-rw-r--r--mozilla-missing-cflags.patch9
-rw-r--r--thunderbird-mozconfig-debuginfo5
-rw-r--r--thunderbird-path.patch239
-rw-r--r--thunderbird.spec18
5 files changed, 317 insertions, 8 deletions
diff --git a/mozilla-libjpeg-turbo.patch b/mozilla-libjpeg-turbo.patch
new file mode 100644
index 0000000..43783de
--- /dev/null
+++ b/mozilla-libjpeg-turbo.patch
@@ -0,0 +1,54 @@
+diff -up xulrunner-1.9.2.7/mozilla-1.9.2/modules/libpr0n/decoders/jpeg/nsJPEGDecoder.cpp.old xulrunner-1.9.2.7/mozilla-1.9.2/modules/libpr0n/decoders/jpeg/nsJPEGDecoder.cpp
+--- xulrunner-1.9.2.7/mozilla/modules/libpr0n/decoders/jpeg/nsJPEGDecoder.cpp.old 2010-07-13 21:10:28.000000000 +0200
++++ xulrunner-1.9.2.7/mozilla/modules/libpr0n/decoders/jpeg/nsJPEGDecoder.cpp 2010-07-22 12:33:21.000000000 +0200
+@@ -57,19 +57,6 @@
+
+ extern "C" {
+ #include "iccjpeg.h"
+-
+-/* Colorspace conversion (copied from jpegint.h) */
+-struct jpeg_color_deconverter {
+- JMETHOD(void, start_pass, (j_decompress_ptr cinfo));
+- JMETHOD(void, color_convert, (j_decompress_ptr cinfo,
+- JSAMPIMAGE input_buf, JDIMENSION input_row,
+- JSAMPARRAY output_buf, int num_rows));
+-};
+-
+-METHODDEF(void)
+-ycc_rgb_convert_argb (j_decompress_ptr cinfo,
+- JSAMPIMAGE input_buf, JDIMENSION input_row,
+- JSAMPARRAY output_buf, int num_rows);
+ }
+
+ NS_IMPL_ISUPPORTS1(nsJPEGDecoder, imgIDecoder)
+@@ -514,14 +501,6 @@ nsresult nsJPEGDecoder::ProcessData(cons
+ return NS_OK; /* I/O suspension */
+ }
+
+- /* Force to use our YCbCr to Packed RGB converter when possible */
+- if (!mTransform && (gfxPlatform::GetCMSMode() == eCMSMode_Off) &&
+- mInfo.jpeg_color_space == JCS_YCbCr && mInfo.out_color_space == JCS_RGB) {
+- /* Special case for the most common case: transform from YCbCr direct into packed ARGB */
+- mInfo.out_color_components = 4; /* Packed ARGB pixels are always 4 bytes...*/
+- mInfo.cconvert->color_convert = ycc_rgb_convert_argb;
+- }
+-
+ /* If this is a progressive JPEG ... */
+ mState = mInfo.buffered_image ? JPEG_DECOMPRESS_PROGRESSIVE : JPEG_DECOMPRESS_SEQUENTIAL;
+ }
+@@ -678,15 +657,6 @@ nsJPEGDecoder::OutputScanlines(PRBool* s
+ PRUint32 *imageRow = ((PRUint32*)mImageData) +
+ (mInfo.output_scanline * mInfo.output_width);
+
+- if (mInfo.cconvert->color_convert == ycc_rgb_convert_argb) {
+- /* Special case: scanline will be directly converted into packed ARGB */
+- if (jpeg_read_scanlines(&mInfo, (JSAMPARRAY)&imageRow, 1) != 1) {
+- *suspend = PR_TRUE; /* suspend */
+- break;
+- }
+- continue; /* all done for this row! */
+- }
+-
+ JSAMPROW sampleRow = (JSAMPROW)imageRow;
+ if (mInfo.output_components == 3) {
+ /* Put the pixels at end of row to enable in-place expansion */
diff --git a/mozilla-missing-cflags.patch b/mozilla-missing-cflags.patch
new file mode 100644
index 0000000..fcef959
--- /dev/null
+++ b/mozilla-missing-cflags.patch
@@ -0,0 +1,9 @@
+diff -up comm-1.9.2/mozilla/toolkit/system/gnome/Makefile.in.mozcflags comm-1.9.2/mozilla/toolkit/system/gnome/Makefile.in
+--- comm-1.9.2/mozilla/toolkit/system/gnome/Makefile.in.mozcflags 2010-07-26 12:52:38.000000000 +0200
++++ comm-1.9.2/mozilla/toolkit/system/gnome/Makefile.in 2010-07-26 12:39:34.000000000 +0200
+@@ -93,4 +93,5 @@ CXXFLAGS += \
+ $(MOZ_GNOMEVFS_CFLAGS) \
+ $(GLIB_CFLAGS) \
+ $(MOZ_LIBNOTIFY_CFLAGS) \
++ $(MOZ_GTK2_CFLAGS) \
+ $(NULL)
diff --git a/thunderbird-mozconfig-debuginfo b/thunderbird-mozconfig-debuginfo
index 65ec915..a0ef07a 100644
--- a/thunderbird-mozconfig-debuginfo
+++ b/thunderbird-mozconfig-debuginfo
@@ -1,6 +1,5 @@
# For mozilla's debuginfo:
-export CFLAGS="-gdwarf-2"
-export CXXFLAGS="-gdwarf-2"
+export CFLAGS="-gstabs+"
+export CXXFLAGS="-gstabs+"
export MOZ_DEBUG_SYMBOLS=1
-ac_add_options --enable-debug-symbols="-gdwarf-2"
ac_add_options --enable-crashreporter
diff --git a/thunderbird-path.patch b/thunderbird-path.patch
new file mode 100644
index 0000000..75d5705
--- /dev/null
+++ b/thunderbird-path.patch
@@ -0,0 +1,239 @@
+--- mozilla/toolkit/xre/nsAppRunner.h.old 2007-09-25 18:01:56.000000000 +0200
++++ mozilla/toolkit/xre/nsAppRunner.h 2007-09-25 18:02:23.000000000 +0200
+@@ -48,7 +48,8 @@
+ #elif defined(CCHMAXPATH)
+ #define MAXPATHLEN CCHMAXPATH
+ #else
+-#define MAXPATHLEN 1024
++#include <limits.h>
++#define MAXPATHLEN PATH_MAX
+ #endif
+ #endif
+
+diff -up mozilla/toolkit/mozapps/update/src/updater/updater.cpp.old mozilla/toolkit/mozapps/update/src/updater/updater.cpp
+--- mozilla/toolkit/mozapps/update/src/updater/updater.cpp.old 2007-09-25 18:00:26.000000000 +0200
++++ mozilla/toolkit/mozapps/update/src/updater/updater.cpp 2007-09-25 18:00:53.000000000 +0200
+@@ -107,7 +107,8 @@ void LaunchChild(int argc, char **argv);
+ # elif defined(CCHMAXPATH)
+ # define MAXPATHLEN CCHMAXPATH
+ # else
+-# define MAXPATHLEN 1024
++# include <limits.h>
++# define MAXPATHLEN PATH_MAX
+ # endif
+ #endif
+
+diff -up mozilla/mailnews/import/comm4x/src/nsComm4xProfile.cpp.old mozilla/mailnews/import/comm4x/src/nsComm4xProfile.cpp
+--- mozilla/mailnews/import/comm4x/src/nsComm4xProfile.cpp.old 2007-09-25 17:58:43.000000000 +0200
++++ mozilla/mailnews/import/comm4x/src/nsComm4xProfile.cpp 2007-09-25 17:59:22.000000000 +0200
+@@ -70,7 +70,8 @@
+ #elif defined(CCHMAXPATH)
+ #define MAXPATHLEN CCHMAXPATH
+ #else
+-#define MAXPATHLEN 1024
++#include <limits.h>
++#define MAXPATHLEN PATH_MAX
+ #endif
+ #endif
+
+diff -up mozilla/xpcom/io/SpecialSystemDirectory.cpp.old mozilla/xpcom/io/SpecialSystemDirectory.cpp
+--- mozilla/xpcom/io/SpecialSystemDirectory.cpp.old 2007-09-25 18:04:25.000000000 +0200
++++ mozilla/xpcom/io/SpecialSystemDirectory.cpp 2007-09-25 18:04:48.000000000 +0200
+@@ -109,7 +109,8 @@
+ #elif defined(CCHMAXPATH)
+ #define MAXPATHLEN CCHMAXPATH
+ #else
+-#define MAXPATHLEN 1024
++#include <limits.h>
++#define MAXPATHLEN PATH_MAX
+ #endif
+ #endif
+
+diff -up mozilla/xpcom/obsolete/nsFileSpecUnix.cpp.old mozilla/xpcom/obsolete/nsFileSpecUnix.cpp
+--- mozilla/xpcom/obsolete/nsFileSpecUnix.cpp.old 2006-11-28 01:18:37.000000000 +0100
++++ mozilla/xpcom/obsolete/nsFileSpecUnix.cpp 2007-09-25 18:05:49.000000000 +0200
+@@ -79,7 +79,8 @@
+ #endif
+
+ #ifndef MAXPATHLEN
+-#define MAXPATHLEN 1024 /* Guessing this is okay. Works for SCO. */
++#include <limits.h>
++#define MAXPATHLEN PATH_MAX /* Guessing this is okay. Works for SCO. */
+ #endif
+
+ #if defined(__QNX__)
+diff -up mozilla/xpcom/build/nsXPCOMPrivate.h.old mozilla/xpcom/build/nsXPCOMPrivate.h
+--- mozilla/xpcom/build/nsXPCOMPrivate.h.old 2007-09-25 18:02:58.000000000 +0200
++++ mozilla/xpcom/build/nsXPCOMPrivate.h 2007-09-25 18:03:15.000000000 +0200
+@@ -252,7 +252,8 @@ NS_GetFrozenFunctions(XPCOMFunctions *en
+ #elif defined(CCHMAXPATH)
+ #define MAXPATHLEN CCHMAXPATH
+ #else
+-#define MAXPATHLEN 1024
++#include <limits.h>
++#define MAXPATHLEN PATH_MAX
+ #endif
+ #endif
+
+diff -up mozilla/dbm/include/mcom_db.h.old mozilla/dbm/include/mcom_db.h
+--- mozilla/dbm/include/mcom_db.h.old 2007-09-25 17:57:09.000000000 +0200
++++ mozilla/dbm/include/mcom_db.h 2007-09-25 17:57:49.000000000 +0200
+@@ -214,7 +214,8 @@
+ #endif /* __DBINTERFACE_PRIVATE */
+
+ #ifdef SCO
+-#define MAXPATHLEN 1024
++#include <limits.h>
++#define MAXPATHLEN PATH_MAX
+ #endif
+
+ #include <fcntl.h>
+diff -up mozilla/mail/components/migration/src/nsProfileMigrator.cpp.old mozilla/mail/components/migration/src/nsProfileMigrator.cpp
+--- mozilla/mail/components/migration/src/nsProfileMigrator.cpp.old 2007-09-25 17:55:11.000000000 +0200
++++ mozilla/mail/components/migration/src/nsProfileMigrator.cpp 2007-09-25 18:07:56.000000000 +0200
+@@ -73,7 +73,8 @@
+ #elif defined(CCHMAXPATH)
+ #define MAXPATHLEN CCHMAXPATH
+ #else
+-#define MAXPATHLEN 1024
++#include <limits.h>
++#define MAXPATHLEN PATH_MAX
+ #endif
+ #endif
+
+diff -up mozilla/nsprpub/config/nsinstall.c.old mozilla/nsprpub/config/nsinstall.c
+diff -up mozilla/js/src/jsfile.c.old mozilla/js/src/jsfile.c
+--- mozilla/js/src/jsfile.c.old 2006-07-26 20:55:08.000000000 +0200
++++ mozilla/js/src/jsfile.c 2007-09-25 18:22:52.000000000 +0200
+@@ -105,7 +105,8 @@
+ #define utfstring "binary"
+ #define unicodestring "unicode"
+
+-#define MAX_PATH_LENGTH 1024
++#include <limits.h>
++#define MAX_PATH_LENGTH PATH_MAX
+ #define MODE_SIZE 256
+ #define NUMBER_SIZE 32
+ #define MAX_LINE_LENGTH 256
+diff -up mozilla/webshell/tests/viewer/nsViewerApp.cpp.old mozilla/webshell/tests/viewer/nsViewerApp.cpp
+--- mozilla/webshell/tests/viewer/nsViewerApp.cpp.old 2007-09-25 18:34:51.000000000 +0200
++++ mozilla/webshell/tests/viewer/nsViewerApp.cpp 2007-09-25 18:35:33.000000000 +0200
+@@ -692,7 +692,8 @@ nsViewerApp::OpenWindow(PRUint32 aNewChr
+
+ #if !defined(XP_WIN) && !defined(XP_OS2)
+ #ifndef XP_MAC
+-#define _MAX_PATH 512
++#include <limits.h>
++#define _MAX_PATH PATH_MAX
+ #endif
+ #endif
+
+diff -up mozilla/xpcom/typelib/xpidl/xpidl_java.c.old mozilla/xpcom/typelib/xpidl/xpidl_java.c
+--- mozilla/xpcom/typelib/xpidl/xpidl_java.c.old 2007-09-25 18:38:52.000000000 +0200
++++ mozilla/xpcom/typelib/xpidl/xpidl_java.c 2007-09-25 18:39:17.000000000 +0200
+@@ -44,6 +44,7 @@
+ #include "xpidl.h"
+ #include <ctype.h>
+ #include <glib.h>
++#include <limits.h>
+
+ #ifdef XP_WIN
+ #include <windef.h>
+diff -up mozilla/widget/src/xremoteclient/XRemoteClient.cpp.old mozilla/widget/src/xremoteclient/XRemoteClient.cpp
+--- mozilla/widget/src/xremoteclient/XRemoteClient.cpp.old 2007-09-25 18:14:08.000000000 +0200
++++ mozilla/widget/src/xremoteclient/XRemoteClient.cpp 2007-09-25 18:36:55.000000000 +0200
+@@ -76,7 +76,8 @@
+ #endif
+
+ #ifndef MAX_PATH
+-#define MAX_PATH 1024
++#include <limits.h>
++#define MAX_PATH PATH_MAX
+ #endif
+
+ #define ARRAY_LENGTH(array_) (sizeof(array_)/sizeof(array_[0]))
+diff -up mozilla/modules/libreg/src/reg.c.old mozilla/modules/libreg/src/reg.c
+--- mozilla/modules/libreg/src/reg.c.old 2007-09-25 18:25:02.000000000 +0200
++++ mozilla/modules/libreg/src/reg.c 2007-09-25 18:27:46.000000000 +0200
+@@ -96,7 +96,8 @@
+ #define MAX_PATH PATH_MAX
+ #elif defined(XP_UNIX)
+ #ifndef MAX_PATH
+-#define MAX_PATH 1024
++#include <limits.h>
++#define MAX_PATH PATH_MAX
+ #endif
+ #elif defined(XP_OS2)
+ #ifndef MAX_PATH
+diff -up mozilla/directory/c-sdk/config/pathsub.h.old mozilla/directory/c-sdk/config/pathsub.h
+--- mozilla/directory/c-sdk/config/pathsub.h.old 2006-02-03 15:41:18.000000000 +0100
++++ mozilla/directory/c-sdk/config/pathsub.h 2007-09-25 18:48:58.000000000 +0200
+@@ -50,7 +50,7 @@
+ #endif
+
+ #ifndef PATH_MAX
+-#define PATH_MAX 1024
++#error "PATH_MAX is not defined!"
+ #endif
+
+ /*
+diff -up mozilla/config/pathsub.h.old mozilla/config/pathsub.h
+--- mozilla/config/pathsub.h.old 2004-04-18 16:17:25.000000000 +0200
++++ mozilla/config/pathsub.h 2007-09-25 18:48:13.000000000 +0200
+@@ -46,7 +46,7 @@
+ #include <sys/types.h>
+
+ #ifndef PATH_MAX
+-#define PATH_MAX 1024
++#error "PATH_MAX is not defined!"
+ #endif
+
+ /*
+diff -up mozilla/modules/libjar/nsZipArchive.cpp.old mozilla/modules/libjar/nsZipArchive.cpp
+--- mozilla/modules/libjar/nsZipArchive.cpp.old 2006-09-13 20:32:37.000000000 +0200
++++ mozilla/modules/libjar/nsZipArchive.cpp 2007-09-25 18:51:00.000000000 +0200
+@@ -121,7 +121,7 @@ char * strdup(const char *src)
+ # define S_IFLNK 0120000
+ # endif
+ # ifndef PATH_MAX
+-# define PATH_MAX 1024
++# include <limits.h>
+ # endif
+ #endif /* XP_UNIX */
+
+diff -up mozilla/nsprpub/config/pathsub.h.old mozilla/nsprpub/config/pathsub.h
+--- mozilla/nsprpub/config/pathsub.h.old 2004-04-25 17:00:34.000000000 +0200
++++ mozilla/nsprpub/config/pathsub.h 2007-09-25 18:57:51.000000000 +0200
+@@ -50,7 +50,7 @@
+ #endif
+
+ #ifndef PATH_MAX
+-#define PATH_MAX 1024
++#error "PATH_MAX is not defined!"
+ #endif
+
+ /*
+diff -up mozilla/gfx/src/gtk/nsPrintdGTK.h.old mozilla/gfx/src/gtk/nsPrintdGTK.h
+--- mozilla/gfx/src/gtk/nsPrintdGTK.h.old 2004-04-17 23:52:29.000000000 +0200
++++ mozilla/gfx/src/gtk/nsPrintdGTK.h 2007-09-25 18:56:48.000000000 +0200
+@@ -63,7 +63,7 @@ PR_BEGIN_EXTERN_C
+ #ifdef _POSIX_PATH_MAX
+ #define PATH_MAX _POSIX_PATH_MAX
+ #else
+-#define PATH_MAX 256
++#error "PATH_MAX is not defined!"
+ #endif
+ #endif
+
+diff -up mozilla/security/coreconf/nsinstall/pathsub.h.old mozilla/security/coreconf/nsinstall/pathsub.h
+--- mozilla/security/coreconf/nsinstall/pathsub.h.old 2004-04-25 17:02:18.000000000 +0200
++++ mozilla/security/coreconf/nsinstall/pathsub.h 2007-09-25 19:00:35.000000000 +0200
+@@ -49,7 +49,7 @@
+ #endif
+
+ #ifndef PATH_MAX
+-#define PATH_MAX 1024
++#error "PATH_MAX is not defined!"
+ #endif
+
+ /*
diff --git a/thunderbird.spec b/thunderbird.spec
index 0b36c49..81ed783 100644
--- a/thunderbird.spec
+++ b/thunderbird.spec
@@ -69,7 +69,10 @@ Patch2: thunderbird-shared-error.patch
# Fixes gcc complain that nsFrame::delete is protected
Patch4: xulrunner-1.9.2.1-build.patch
# Fix missing includes for crash reporter, remove in 3.1 final
-Patch6: remove-static.patch
+
+Patch6: mozilla-libjpeg-turbo.patch
+Patch7: mozilla-missing-cflags.patch
+Patch8: mozilla-build-s390.patch
%if %{official_branding}
# Required by Mozilla Corporation
@@ -80,8 +83,7 @@ Patch6: remove-static.patch
%endif
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-%if 0%{?fedora} >= 13
-## NSPR 4.8.6 is on updates-testing (f12)
+%if 0%{?fedora} >= 12
BuildRequires: nspr-devel >= %{nspr_version}
%endif
%if 0%{?fedora} >= 11
@@ -125,7 +127,7 @@ BuildRequires: GConf2-devel
%if 0%{?fedora} >= 9
Requires: mozilla-filesystem
%endif
-%if 0%{?fedora} >= 13
+%if 0%{?fedora} >= 12
Requires: nspr >= %{nspr_version}
%endif
%if 0%{?fedora} >= 11
@@ -167,7 +169,11 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
%patch1 -p0 -b .jemalloc
%patch2 -p1 -b .shared-error
%patch4 -p1 -b .protected
-%patch6 -p1 -b .static
+%patch6 -p1 -b .turbo
+%patch7 -p1 -b .mozcflags
+%ifarch s390
+%patch8 -p0 -b .s390
+%endif
%if %{official_branding}
@@ -183,6 +189,8 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
cat %{SOURCE10} \
%if %{fedora} < 15
| grep -v system-sqlite \
+%endif
+%if %{fedora} < 12
| grep -v system-nspr \
%endif
%if %{fedora} < 11