summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-10-09 19:07:15 +0200
committerRemi Collet <fedora@famillecollet.com>2012-10-09 19:07:15 +0200
commit854a1fc76e7a9d86f75b623ad264089297d0d332 (patch)
treed02e74642cb882acdc5fe5e3cd8a7cc8821c4205
parent0b14e6f168d68f1cfec0ba157e723f66a0620a34 (diff)
Thunderbird 16
-rw-r--r--rhbz-855923.patch19
-rw-r--r--thunderbird-install-dir.patch49
-rw-r--r--thunderbird-mozconfig2
-rw-r--r--thunderbird.spec74
-rw-r--r--xulrunner-16.0-jemalloc-ppc.patch (renamed from xulrunner-852698.patch)8
5 files changed, 98 insertions, 54 deletions
diff --git a/rhbz-855923.patch b/rhbz-855923.patch
new file mode 100644
index 0000000..c6282b0
--- /dev/null
+++ b/rhbz-855923.patch
@@ -0,0 +1,19 @@
+Index: comm-release/mozilla/js/src/gc/Memory.cpp
+===================================================================
+--- comm-release.orig/mozilla/js/src/gc/Memory.cpp
++++ comm-release/mozilla/js/src/gc/Memory.cpp
+@@ -348,9 +348,14 @@ UnmapPages(void *p, size_t size)
+ bool
+ MarkPagesUnused(void *p, size_t size)
+ {
++// A workaround for Bug 746112 - endless loop on ppc64
++#if !(defined(__powerpc__))
+ JS_ASSERT(uintptr_t(p) % PageSize == 0);
+ int result = madvise(p, size, MADV_DONTNEED);
+ return result != -1;
++#else
++ return true;
++#endif
+ }
+
+ bool
diff --git a/thunderbird-install-dir.patch b/thunderbird-install-dir.patch
index 931e7ad..96342b9 100644
--- a/thunderbird-install-dir.patch
+++ b/thunderbird-install-dir.patch
@@ -1,7 +1,7 @@
-diff -up thunderbird-7.0/comm-beta/config/autoconf.mk.in.old thunderbird-7.0/comm-beta/config/autoconf.mk.in
---- thunderbird-7.0/comm-beta/config/autoconf.mk.in.old 2011-09-05 12:24:29.000000000 +0200
-+++ thunderbird-7.0/comm-beta/config/autoconf.mk.in 2011-09-12 12:21:09.304918326 +0200
-@@ -65,7 +65,7 @@ datadir = @datadir@
+diff -up thunderbird-16.0/comm-release/config/autoconf.mk.in.dir thunderbird-16.0/comm-release/config/autoconf.mk.in
+--- thunderbird-16.0/comm-release/config/autoconf.mk.in.dir 2012-10-05 23:20:26.000000000 +0200
++++ thunderbird-16.0/comm-release/config/autoconf.mk.in 2012-10-09 12:57:24.290767832 +0200
+@@ -36,7 +36,7 @@ datadir = @datadir@
mandir = @mandir@
idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
@@ -10,27 +10,28 @@ diff -up thunderbird-7.0/comm-beta/config/autoconf.mk.in.old thunderbird-7.0/com
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
MOZDEPTH = $(DEPTH)/mozilla
-diff -up thunderbird-7.0/comm-beta/mozilla/config/autoconf.mk.in.old thunderbird-7.0/comm-beta/mozilla/config/autoconf.mk.in
---- thunderbird-7.0/comm-beta/mozilla/config/autoconf.mk.in.old 2011-09-05 12:38:22.000000000 +0200
-+++ thunderbird-7.0/comm-beta/mozilla/config/autoconf.mk.in 2011-09-12 12:21:24.192991555 +0200
-@@ -68,7 +68,7 @@ datadir = @datadir@
- mandir = @mandir@
- idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+diff -up thunderbird-16.0/comm-release/mozilla/config/autoconf.mk.in.dir thunderbird-16.0/comm-release/mozilla/config/autoconf.mk.in
+diff -up thunderbird-16.0/comm-release/mozilla/config/baseconfig.mk.dir thunderbird-16.0/comm-release/mozilla/config/baseconfig.mk
+--- thunderbird-16.0/comm-release/mozilla/config/baseconfig.mk.dir 2012-10-05 23:27:15.000000000 +0200
++++ thunderbird-16.0/comm-release/mozilla/config/baseconfig.mk 2012-10-09 13:01:32.269317094 +0200
+@@ -2,7 +2,7 @@ INCLUDED_AUTOCONF_MK = 1
--installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-+installdir = $(libdir)/$(MOZ_APP_NAME)
- sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
+ includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+ idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
++installdir = $(libdir)/$(MOZ_APP_NAME)
+ sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
+ DIST = $(DEPTH)/dist
- DIST = $(DEPTH)/dist
-diff -up thunderbird-7.0/comm-beta/mozilla/js/src/config/autoconf.mk.in.old thunderbird-7.0/comm-beta/mozilla/js/src/config/autoconf.mk.in
---- thunderbird-7.0/comm-beta/mozilla/js/src/config/autoconf.mk.in.old 2011-09-05 12:38:30.000000000 +0200
-+++ thunderbird-7.0/comm-beta/mozilla/js/src/config/autoconf.mk.in 2011-09-12 12:21:37.409056596 +0200
-@@ -61,7 +61,7 @@ libdir = @libdir@
- datadir = @datadir@
- mandir = @mandir@
+diff -up thunderbird-16.0/comm-release/mozilla/js/src/config/autoconf.mk.in.dir thunderbird-16.0/comm-release/mozilla/js/src/config/autoconf.mk.in
+diff -up thunderbird-16.0/comm-release/mozilla/js/src/config/baseconfig.mk.dir thunderbird-16.0/comm-release/mozilla/js/src/config/baseconfig.mk
+--- thunderbird-16.0/comm-release/mozilla/js/src/config/baseconfig.mk.dir 2012-10-05 23:27:30.000000000 +0200
++++ thunderbird-16.0/comm-release/mozilla/js/src/config/baseconfig.mk 2012-10-09 13:02:00.885495014 +0200
+@@ -1,6 +1,6 @@
+ INCLUDED_AUTOCONF_MK = 1
--installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-+installdir = $(libdir)/$(MOZ_APP_NAME)
- sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
+-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
++installdir = $(libdir)/$(MOZ_APP_NAME)
+ sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
- TOP_DIST = @TOP_DIST@
+ ifneq (,$(filter /%,$(TOP_DIST)))
diff --git a/thunderbird-mozconfig b/thunderbird-mozconfig
index 88c79fd..ab3b28c 100644
--- a/thunderbird-mozconfig
+++ b/thunderbird-mozconfig
@@ -7,8 +7,6 @@ mk_add_options AUTOCONF=autoconf-2.13
ac_add_options --prefix="$PREFIX"
ac_add_options --libdir="$LIBDIR"
-ac_add_options --with-system-nspr
-ac_add_options --with-system-nss
ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
ac_add_options --with-system-libvpx
diff --git a/thunderbird.spec b/thunderbird.spec
index ce38396..d92beba 100644
--- a/thunderbird.spec
+++ b/thunderbird.spec
@@ -1,3 +1,10 @@
+# Use system nspr/nss?
+%if 0%{?fedora} < 15 && 0%{?rhel} < 6
+%define system_nss 0
+%else
+%define system_nss 1
+%endif
+
# Build as a debug package?
%define debug_build 0
@@ -7,13 +14,6 @@
%else
%define system_sqlite 1
%endif
-%if 0%{?fedora} < 15 && 0%{?rhel} < 6
-%define system_nspr 0
-%define system_nss 0
-%else
-%define system_nspr 1
-%define system_nss 1
-%endif
%if 0%{?fedora} < 15
%define system_cairo 0
%define system_vpx 0
@@ -24,12 +24,16 @@
%define build_langpacks 1
+%if %{?system_nss}
%define nspr_version 4.9
%define nss_version 3.13.3
+%endif
%define cairo_version 1.10.0
%define freetype_version 2.1.9
%define lcms_version 1.19
+%if %{?system_sqlite}
%define sqlite_version 3.7.10
+%endif
%define libnotify_version 0.4
%global libvpx_version 1.0.0
%define _default_patch_fuzz 2
@@ -52,14 +56,14 @@
Summary: Mozilla Thunderbird mail/newsgroup client
Name: thunderbird
-Version: 15.0.1
+Version: 16.0
Release: 1%{?dist}
URL: http://www.mozilla.org/projects/thunderbird/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
Source0: ftp://ftp.mozilla.org/pub/thunderbird/releases/%{version}%{?pre_version}/source/thunderbird-%{version}%{?pre_version}.source.tar.bz2
%if %{build_langpacks}
-Source1: thunderbird-langpacks-%{version}-20120911.tar.xz
+Source1: thunderbird-langpacks-%{version}-20121009.tar.xz
%endif
Source10: thunderbird-mozconfig
Source11: thunderbird-mozconfig-branded
@@ -80,7 +84,8 @@ Patch104: xulrunner-10.0-gcc47.patch
Patch200: thunderbird-8.0-enable-addons.patch
# PPC fixes
-Patch300: xulrunner-852698.patch
+Patch300: xulrunner-16.0-jemalloc-ppc.patch
+Patch301: rhbz-855923.patch
%if %{official_branding}
# Required by Mozilla Corporation
@@ -90,11 +95,9 @@ Patch300: xulrunner-852698.patch
%endif
-%if %{system_nspr}
+%if %{?system_nss}
+BuildRequires: nss-static >= %{nss_version}
BuildRequires: nspr-devel >= %{nspr_version}
-%endif
-%if %{system_nss}
-BuildRequires: nss-static
BuildRequires: nss-devel >= %{nss_version}
%endif
%if %{system_cairo}
@@ -135,10 +138,8 @@ BuildRequires: libvpx-devel >= %{libvpx_version}
%endif
Requires: mozilla-filesystem
-%if %{system_nspr}
+%if %{?system_nss}
Requires: nspr >= %{nspr_version}
-%endif
-%if %{system_nss}
Requires: nss >= %{nss_version}
%endif
%if %{?system_sqlite}
@@ -197,6 +198,7 @@ cd ..
%patch200 -p1 -b .addons
%patch300 -p1 -b .852698
+%patch301 -p1 -b .855923
%if %{official_branding}
# Required by Mozilla Corporation
@@ -209,12 +211,6 @@ cd ..
%{__rm} -f .mozconfig
#{__cp} %{SOURCE10} .mozconfig
cat %{SOURCE10} \
-%if ! %{system_nss}
- | grep -v system-nss \
-%endif
-%if ! %{system_nspr}
- | grep -v system-nspr \
-%endif
%if ! %{system_cairo}
| grep -v enable-system-cairo \
%endif
@@ -234,6 +230,14 @@ echo "ac_add_options --disable-libjpeg-turbo" >> .mozconfig
%{__cat} %{SOURCE13} >> .mozconfig
%endif
+%if %{?system_nss}
+echo "ac_add_options --with-system-nspr" >> .mozconfig
+echo "ac_add_options --with-system-nss" >> .mozconfig
+%else
+echo "ac_add_options --without-system-nspr" >> .mozconfig
+echo "ac_add_options --without-system-nss" >> .mozconfig
+%endif
+
# s390(x) fails to start with jemalloc enabled
%ifarch s390 s390x
echo "ac_add_options --disable-jemalloc" >> .mozconfig
@@ -274,8 +278,16 @@ MOZ_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS -fpermissive" | \
%if %{?debug_build}
MOZ_OPT_FLAGS=$(echo "$MOZ_OPT_FLAGS" | %{__sed} -e 's/-O2//')
%endif
+%ifarch s390
+MOZ_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS" | %{__sed} -e 's/-g/-g1')
+%endif
+%ifarch s390 %{arm} ppc
+MOZ_LINK_FLAGS="-Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
+%endif
+
export CFLAGS=$MOZ_OPT_FLAGS
export CXXFLAGS=$MOZ_OPT_FLAGS
+export LDFLAGS=$MOZ_LINK_FLAGS
export PREFIX='%{_prefix}'
export LIBDIR='%{_libdir}'
@@ -393,7 +405,6 @@ touch $RPM_BUILD_ROOT%{mozappdir}/components/xpti.dat
install -m 644 mail/extensions/newsblog/rss.rdf $RPM_BUILD_ROOT%{mozappdir}/isp/
rm -rf $RPM_BUILD_ROOT%{mozappdir}/isp/en-US
-rm -rf $RPM_BUILD_ROOT%{mozappdir}/*.chk
#===============================================================================
@@ -472,6 +483,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{mozappdir}/crashreporter.ini
%{mozappdir}/Throbber-small.gif
%endif
+%if !%{?system_nss}
+%{mozappdir}/*.chk
+%endif
%exclude %{_datadir}/idl/%{name}-%{version}
%exclude %{_includedir}/%{name}-%{version}
%{mozappdir}/chrome.manifest
@@ -482,6 +496,18 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#===============================================================================
%changelog
+* Tue Oct 9 2012 Remi Collet <RPMS@FamilleCollet.com> - 16.0-1
+- Sync with rawhide, update to 16.0
+
+* Tue Oct 9 2012 Jan Horak <jhorak@redhat.com> - 16.0-1
+- Update to 16.0
+
+* Tue Sep 18 2012 Dan HorĂ¡k <dan[at]danny.cz> - 15.0.1-3
+- Added fix for rhbz#855923 - TB freezes on Fedora 18 for PPC64
+
+* Fri Sep 14 2012 Martin Stransky <stransky@redhat.com> - 15.0.1-2
+- Added build flags for second arches
+
* Wed Sep 12 2012 Remi Collet <RPMS@FamilleCollet.com> - 15.0.1-1
- update to 15.0.1
diff --git a/xulrunner-852698.patch b/xulrunner-16.0-jemalloc-ppc.patch
index 34aa147..e4fca79 100644
--- a/xulrunner-852698.patch
+++ b/xulrunner-16.0-jemalloc-ppc.patch
@@ -1,8 +1,8 @@
-Index: comm-release/mozilla/memory/jemalloc/jemalloc.c
+Index: xulrunner-11.0/mozilla-release/memory/jemalloc/jemalloc.c
===================================================================
---- comm-release.orig/mozilla/memory/jemalloc/jemalloc.c
-+++ comm-release/mozilla/memory/jemalloc/jemalloc.c
-@@ -1091,7 +1091,9 @@ static unsigned ncpus;
+--- a/mozilla/memory/mozjemalloc/jemalloc.c
++++ b/mozilla/memory/mozjemalloc/jemalloc.c
+@@ -1089,7 +1089,9 @@ static unsigned ncpus;
* controlling the malloc behavior are defined as compile-time constants
* for best performance and cannot be altered at runtime.
*/