summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2011-09-27 19:47:45 +0200
committerRemi Collet <fedora@famillecollet.com>2011-09-27 19:47:45 +0200
commit6697d15cbc42d3585045780c141d4740dbcc3671 (patch)
tree693e3ecfa3fc753aeefa5376370fa92d800a38d2
parent5acd9d23e91d3305d13a4444b24bcfbf1ac94217 (diff)
Thunderbird 7
-rw-r--r--thunderbird-install-dir.patch36
-rw-r--r--thunderbird-version.patch12
-rw-r--r--thunderbird.sh.in10
-rw-r--r--thunderbird.spec51
4 files changed, 58 insertions, 51 deletions
diff --git a/thunderbird-install-dir.patch b/thunderbird-install-dir.patch
new file mode 100644
index 0000000..931e7ad
--- /dev/null
+++ b/thunderbird-install-dir.patch
@@ -0,0 +1,36 @@
+diff -up thunderbird-7.0/comm-beta/config/autoconf.mk.in.old thunderbird-7.0/comm-beta/config/autoconf.mk.in
+--- thunderbird-7.0/comm-beta/config/autoconf.mk.in.old 2011-09-05 12:24:29.000000000 +0200
++++ thunderbird-7.0/comm-beta/config/autoconf.mk.in 2011-09-12 12:21:09.304918326 +0200
+@@ -65,7 +65,7 @@ datadir = @datadir@
+ mandir = @mandir@
+ idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+
+-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
++installdir = $(libdir)/$(MOZ_APP_NAME)
+ sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
+
+ MOZDEPTH = $(DEPTH)/mozilla
+diff -up thunderbird-7.0/comm-beta/mozilla/config/autoconf.mk.in.old thunderbird-7.0/comm-beta/mozilla/config/autoconf.mk.in
+--- thunderbird-7.0/comm-beta/mozilla/config/autoconf.mk.in.old 2011-09-05 12:38:22.000000000 +0200
++++ thunderbird-7.0/comm-beta/mozilla/config/autoconf.mk.in 2011-09-12 12:21:24.192991555 +0200
+@@ -68,7 +68,7 @@ datadir = @datadir@
+ mandir = @mandir@
+ idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+
+-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
++installdir = $(libdir)/$(MOZ_APP_NAME)
+ sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
+
+ DIST = $(DEPTH)/dist
+diff -up thunderbird-7.0/comm-beta/mozilla/js/src/config/autoconf.mk.in.old thunderbird-7.0/comm-beta/mozilla/js/src/config/autoconf.mk.in
+--- thunderbird-7.0/comm-beta/mozilla/js/src/config/autoconf.mk.in.old 2011-09-05 12:38:30.000000000 +0200
++++ thunderbird-7.0/comm-beta/mozilla/js/src/config/autoconf.mk.in 2011-09-12 12:21:37.409056596 +0200
+@@ -61,7 +61,7 @@ libdir = @libdir@
+ datadir = @datadir@
+ mandir = @mandir@
+
+-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
++installdir = $(libdir)/$(MOZ_APP_NAME)
+ sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
+
+ TOP_DIST = @TOP_DIST@
diff --git a/thunderbird-version.patch b/thunderbird-version.patch
deleted file mode 100644
index fa3096f..0000000
--- a/thunderbird-version.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up comm-1.9.2/mail/installer/Makefile.in.version comm-1.9.2/mail/installer/Makefile.in
---- comm-1.9.2/mail/installer/Makefile.in.version 2010-05-21 11:42:45.000000000 -0700
-+++ comm-1.9.2/mail/installer/Makefile.in 2010-05-25 15:16:18.446197181 -0700
-@@ -44,6 +44,8 @@ include $(DEPTH)/config/autoconf.mk
-
- include $(topsrcdir)/config/rules.mk
-
-+MOZ_APP_VERSION="__RPM_VERSION_INTERNAL__"
-+
- MOZ_PKG_REMOVALS = $(srcdir)/removed-files.in
-
- MOZ_PKG_MANIFEST_P = $(srcdir)/package-manifest.in
diff --git a/thunderbird.sh.in b/thunderbird.sh.in
index c787869..dfa0247 100644
--- a/thunderbird.sh.in
+++ b/thunderbird.sh.in
@@ -19,18 +19,18 @@ case $MOZ_ARCH in
;;
esac
-if [ ! -x $MOZ_LIB_DIR/thunderbird-TBIRD_VERSION/thunderbird ]; then
- if [ ! -x $SECONDARY_LIB_DIR/thunderbird-TBIRD_VERSION/thunderbird ]; then
- echo "Error: $MOZ_LIB_DIR/thunderbird-TBIRD_VERSION/thunderbird not found"
+if [ ! -x $MOZ_LIB_DIR/thunderbird/thunderbird ]; then
+ if [ ! -x $SECONDARY_LIB_DIR/thunderbird/thunderbird ]; then
+ echo "Error: $MOZ_LIB_DIR/thunderbird/thunderbird not found"
if [ -d $SECONDARY_LIB_DIR ]; then
- echo " $SECONDARY_LIB_DIR/thunderbird-TBIRD_VERSION/thunderbird not found"
+ echo " $SECONDARY_LIB_DIR/thunderbird/thunderbird not found"
fi
exit 1
fi
MOZ_LIB_DIR="$SECONDARY_LIB_DIR"
fi
-MOZ_DIST_BIN="$MOZ_LIB_DIR/thunderbird-TBIRD_VERSION"
+MOZ_DIST_BIN="$MOZ_LIB_DIR/thunderbird"
MOZ_PROGRAM="$MOZ_DIST_BIN/thunderbird"
MOZ_LANGPACKS_DIR="$MOZ_DIST_BIN/langpacks"
MOZ_EXTENSIONS_PROFILE_DIR="$HOME/.mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}"
diff --git a/thunderbird.spec b/thunderbird.spec
index fc3167a..cc3b6aa 100644
--- a/thunderbird.spec
+++ b/thunderbird.spec
@@ -13,19 +13,17 @@
#
# IMPORTANT: If there is no top level directory, this should be
# set to the cwd, ie: '.'
-#%define tarballdir .
%define tarballdir comm-release
%define official_branding 1
# don't enable crash reporter for remi repo
%define enable_mozilla_crashreporter 0
-%define version_internal 6
-%define mozappdir %{_libdir}/%{name}-%{version_internal}
+%define mozappdir %{_libdir}/%{name}
Summary: Mozilla Thunderbird mail/newsgroup client
Name: thunderbird
-Version: 6.0.2
+Version: 7.0
Release: 1%{?dist}
URL: http://www.mozilla.org/projects/thunderbird/
License: MPLv1.1 or GPLv2+ or LGPLv2+
@@ -37,7 +35,7 @@ Group: Applications/Internet
%endif
Source0: %{tarball}
%if %{build_langpacks}
-Source1: thunderbird-langpacks-%{version}-20110906.tar.bz2
+Source1: thunderbird-langpacks-%{version}-20110927.tar.bz2
%endif
Source10: thunderbird-mozconfig
@@ -49,7 +47,7 @@ Source21: thunderbird.sh.in
Source100: find-external-requires
# Mozilla (XULRunner) patches
-Patch0: thunderbird-version.patch
+Patch0: thunderbird-install-dir.patch
Patch7: crashreporter-remove-static.patch
Patch8: xulrunner-6.0-secondary-ipc.patch
@@ -113,8 +111,6 @@ Requires: nss >= %{nss_version}
Requires: sqlite >= %{sqlite_version}
%endif
-Obsoletes: thunderbird3
-
AutoProv: 0
%define _use_internal_dependency_generator 0
%define __find_requires %{SOURCE100}
@@ -153,10 +149,7 @@ sed -e "s/^Name=.*/Name=Thunderbird %{version} %{?relcan}/" \
cd %{tarballdir}
-sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
- > version.patch
-%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
-
+%patch0 -p2 -b .dir
# Mozilla (XULRunner) patches
cd mozilla
%patch7 -p2 -b .static
@@ -167,7 +160,7 @@ cd ..
# Required by Mozilla Corporation
%else
-# Not yet approved by Mozillla Corporation
+# Not yet approved by Mozilla Corporation
%endif
@@ -212,9 +205,6 @@ EOF
%build
cd %{tarballdir}
-INTERNAL_GECKO=%{version_internal}
-MOZ_APP_DIR=%{mozappdir}
-
# -fpermissive is needed to build with gcc 4.6+ which has become stricter
#
# Mozilla builds with -Wall with exception of a few warnings which show up
@@ -252,11 +242,6 @@ make buildsymbols
%{__rm} -rf $RPM_BUILD_ROOT
cd %{tarballdir}
-INTERNAL_GECKO=%{version_internal}
-
-INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
-MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
-
DESTDIR=$RPM_BUILD_ROOT make install
# install icons
@@ -274,9 +259,7 @@ desktop-file-install --vendor mozilla \
# set up the thunderbird start script
rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
-%{__cat} %{SOURCE21} | %{__sed} -e 's,TBIRD_VERSION,%{version_internal},g' > \
- $RPM_BUILD_ROOT%{_bindir}/thunderbird
-%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
+install -m 755 %{SOURCE21} $RPM_BUILD_ROOT%{_bindir}/thunderbird
# set up our default preferences
%{__cat} %{SOURCE12} | %{__sed} -e 's,Fedora,Remi,g' \
@@ -305,14 +288,7 @@ for langpack in `ls thunderbird-langpacks/*.xpi`; do
language=`basename $langpack .xpi`
extensionID=langpack-$language@thunderbird.mozilla.org
-# extensiondir=$RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-$language@thunderbird.mozilla.org
-# %{__mkdir_p} $extensiondir
-# unzip -q $langpack -d $extensiondir
-# find $extensiondir -type f | xargs chmod 644
-
language=`echo $language | sed -e 's/-/_/g'`
-# extensiondir=`echo $extensiondir | sed -e "s,^$RPM_BUILD_ROOT,,"`
-# echo "%%lang($language) $extensiondir" >> %{name}.lang
%{__install} -m 644 ${langpack} $RPM_BUILD_ROOT%{mozappdir}/langpacks/${extensionID}.xpi
echo "%%lang($language) %{mozappdir}/langpacks/${extensionID}.xpi" >> %{name}.lang
done
@@ -436,14 +412,21 @@ fi
%{mozappdir}/crashreporter.ini
%{mozappdir}/Throbber-small.gif
%endif
-%exclude %{_datadir}/idl/%{name}-%{version_internal}
-%exclude %{_includedir}/%{name}-%{version_internal}
-%exclude %{_libdir}/%{name}-devel-%{version_internal}
+%exclude %{_datadir}/idl/%{name}-%{version}
+%exclude %{_includedir}/%{name}-%{version}
+%exclude %{_libdir}/%{name}-devel-%{version}
%{mozappdir}/chrome.manifest
+%{mozappdir}/hyphenation
#===============================================================================
%changelog
+* Tue Sep 27 2011 Remi Collet <rpms@famillecollet.com> 7.0-1
+- Thunderbird 7.0
+
+* Tue Sep 27 2011 Jan Horak <jhorak@redhat.com> - 7.0-1
+- Update to 7.0
+
* Tue Sep 06 2011 Remi Collet <rpms@famillecollet.com> 6.0.2-1
- Thunderbird 6.0.2