summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-08-06 18:28:44 +0200
committerRemi Collet <fedora@famillecollet.com>2012-08-06 18:28:44 +0200
commit621ecb9357c1f2a6ffc323aa852068ba225c7097 (patch)
tree6c9cba2b8342d6f878fa8e228b52da421bda4396
parent26c5ef963969d7eac4afc7a3e5d96467f9a20d8f (diff)
thunderbird: sync with rawhide (no build)
-rw-r--r--thunderbird.desktop1
-rw-r--r--thunderbird.sh.in32
-rw-r--r--thunderbird.spec4
3 files changed, 35 insertions, 2 deletions
diff --git a/thunderbird.desktop b/thunderbird.desktop
index 47aee02..f1c62f3 100644
--- a/thunderbird.desktop
+++ b/thunderbird.desktop
@@ -8,7 +8,6 @@ TryExec=thunderbird
Icon=thunderbird
Terminal=false
Type=Application
-StartupWMClass=Thunderbird-bin
MimeType=message/rfc822;x-scheme-handler/mailto;
StartupNotify=true
Categories=Network;Email;
diff --git a/thunderbird.sh.in b/thunderbird.sh.in
index 1ee2261..8c92010 100644
--- a/thunderbird.sh.in
+++ b/thunderbird.sh.in
@@ -34,6 +34,7 @@ MOZ_DIST_BIN="$MOZ_LIB_DIR/thunderbird"
MOZ_PROGRAM="$MOZ_DIST_BIN/thunderbird"
MOZ_LANGPACKS_DIR="$MOZ_DIST_BIN/langpacks"
MOZ_EXTENSIONS_PROFILE_DIR="$HOME/.mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}"
+MOZ_LAUNCHER="$MOZ_DIST_BIN/run-mozilla.sh"
##
## Set MOZ_ENABLE_PANGO is no longer used because Pango is enabled by default
@@ -117,4 +118,33 @@ if [ $MOZILLA_DOWN -ne 0 ]; then
create_langpack_link $SHORTMOZLOCALE || create_langpack_link $MOZLOCALE || true
fi
-exec $MOZ_PROGRAM "$@"
+# Prepare command line arguments
+script_args=""
+pass_arg_count=0
+while [ $# -gt $pass_arg_count ]
+do
+ case "$1" in
+ -g | --debug)
+ script_args="$script_args -g"
+ debugging=1
+ shift
+ ;;
+ -d | --debugger)
+ if [ $# -gt 1 ]; then
+ script_args="$script_args -d $2"
+ shift 2
+ else
+ shift
+ fi
+ ;;
+ *)
+ # Move the unrecognized argument to the end of the list.
+ arg="$1"
+ shift
+ set -- "$@" "$arg"
+ pass_arg_count=`expr $pass_arg_count + 1`
+ ;;
+ esac
+done
+
+exec $MOZ_LAUNCHER $script_args $MOZ_PROGRAM "$@"
diff --git a/thunderbird.spec b/thunderbird.spec
index d405f59..7c5b9c8 100644
--- a/thunderbird.spec
+++ b/thunderbird.spec
@@ -478,6 +478,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#===============================================================================
%changelog
+* Wed Aug 1 2012 Martin Stransky <stransky@redhat.com> - 14.0-3
+- removed StartupWMClass (rhbz#844863)
+- Fixed -g parameter
+
* Sat Jul 21 2012 Remi Collet <RPMS@FamilleCollet.com> - 14.0-1
- Sync with rawhide, update to 14.0