summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2010-05-31 19:15:19 +0200
committerRemi Collet <fedora@famillecollet.com>2010-05-31 19:15:19 +0200
commit12a9b079ddbb46e5a9d66749a7062aab41beef51 (patch)
tree4ebb5da41472322e83d9774bd48c547e575c7fe6
parentc5886e4c1519a2105b4ddd1882664c5dc47f6cc0 (diff)
update to thunderbird 3.1rc1
-rw-r--r--thunderbird-mozconfig1
-rw-r--r--thunderbird-path.patch239
-rw-r--r--thunderbird-shared-error.patch5
-rw-r--r--thunderbird-version.patch15
-rw-r--r--thunderbird.desktop5
-rw-r--r--thunderbird.pngbin0 -> 21835 bytes
-rw-r--r--thunderbird.sh.in72
-rw-r--r--thunderbird.spec76
-rw-r--r--xulrunner-1.9.2.1-build.patch12
9 files changed, 383 insertions, 42 deletions
diff --git a/thunderbird-mozconfig b/thunderbird-mozconfig
index 3df47c0..c7334ff 100644
--- a/thunderbird-mozconfig
+++ b/thunderbird-mozconfig
@@ -27,6 +27,7 @@ ac_add_options --enable-svg
ac_add_options --enable-canvas
ac_add_options --enable-system-hunspell
ac_add_options --disable-crashreporter
+ac_add_options --disable-necko-wifi
export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
diff --git a/thunderbird-path.patch b/thunderbird-path.patch
new file mode 100644
index 0000000..75d5705
--- /dev/null
+++ b/thunderbird-path.patch
@@ -0,0 +1,239 @@
+--- mozilla/toolkit/xre/nsAppRunner.h.old 2007-09-25 18:01:56.000000000 +0200
++++ mozilla/toolkit/xre/nsAppRunner.h 2007-09-25 18:02:23.000000000 +0200
+@@ -48,7 +48,8 @@
+ #elif defined(CCHMAXPATH)
+ #define MAXPATHLEN CCHMAXPATH
+ #else
+-#define MAXPATHLEN 1024
++#include <limits.h>
++#define MAXPATHLEN PATH_MAX
+ #endif
+ #endif
+
+diff -up mozilla/toolkit/mozapps/update/src/updater/updater.cpp.old mozilla/toolkit/mozapps/update/src/updater/updater.cpp
+--- mozilla/toolkit/mozapps/update/src/updater/updater.cpp.old 2007-09-25 18:00:26.000000000 +0200
++++ mozilla/toolkit/mozapps/update/src/updater/updater.cpp 2007-09-25 18:00:53.000000000 +0200
+@@ -107,7 +107,8 @@ void LaunchChild(int argc, char **argv);
+ # elif defined(CCHMAXPATH)
+ # define MAXPATHLEN CCHMAXPATH
+ # else
+-# define MAXPATHLEN 1024
++# include <limits.h>
++# define MAXPATHLEN PATH_MAX
+ # endif
+ #endif
+
+diff -up mozilla/mailnews/import/comm4x/src/nsComm4xProfile.cpp.old mozilla/mailnews/import/comm4x/src/nsComm4xProfile.cpp
+--- mozilla/mailnews/import/comm4x/src/nsComm4xProfile.cpp.old 2007-09-25 17:58:43.000000000 +0200
++++ mozilla/mailnews/import/comm4x/src/nsComm4xProfile.cpp 2007-09-25 17:59:22.000000000 +0200
+@@ -70,7 +70,8 @@
+ #elif defined(CCHMAXPATH)
+ #define MAXPATHLEN CCHMAXPATH
+ #else
+-#define MAXPATHLEN 1024
++#include <limits.h>
++#define MAXPATHLEN PATH_MAX
+ #endif
+ #endif
+
+diff -up mozilla/xpcom/io/SpecialSystemDirectory.cpp.old mozilla/xpcom/io/SpecialSystemDirectory.cpp
+--- mozilla/xpcom/io/SpecialSystemDirectory.cpp.old 2007-09-25 18:04:25.000000000 +0200
++++ mozilla/xpcom/io/SpecialSystemDirectory.cpp 2007-09-25 18:04:48.000000000 +0200
+@@ -109,7 +109,8 @@
+ #elif defined(CCHMAXPATH)
+ #define MAXPATHLEN CCHMAXPATH
+ #else
+-#define MAXPATHLEN 1024
++#include <limits.h>
++#define MAXPATHLEN PATH_MAX
+ #endif
+ #endif
+
+diff -up mozilla/xpcom/obsolete/nsFileSpecUnix.cpp.old mozilla/xpcom/obsolete/nsFileSpecUnix.cpp
+--- mozilla/xpcom/obsolete/nsFileSpecUnix.cpp.old 2006-11-28 01:18:37.000000000 +0100
++++ mozilla/xpcom/obsolete/nsFileSpecUnix.cpp 2007-09-25 18:05:49.000000000 +0200
+@@ -79,7 +79,8 @@
+ #endif
+
+ #ifndef MAXPATHLEN
+-#define MAXPATHLEN 1024 /* Guessing this is okay. Works for SCO. */
++#include <limits.h>
++#define MAXPATHLEN PATH_MAX /* Guessing this is okay. Works for SCO. */
+ #endif
+
+ #if defined(__QNX__)
+diff -up mozilla/xpcom/build/nsXPCOMPrivate.h.old mozilla/xpcom/build/nsXPCOMPrivate.h
+--- mozilla/xpcom/build/nsXPCOMPrivate.h.old 2007-09-25 18:02:58.000000000 +0200
++++ mozilla/xpcom/build/nsXPCOMPrivate.h 2007-09-25 18:03:15.000000000 +0200
+@@ -252,7 +252,8 @@ NS_GetFrozenFunctions(XPCOMFunctions *en
+ #elif defined(CCHMAXPATH)
+ #define MAXPATHLEN CCHMAXPATH
+ #else
+-#define MAXPATHLEN 1024
++#include <limits.h>
++#define MAXPATHLEN PATH_MAX
+ #endif
+ #endif
+
+diff -up mozilla/dbm/include/mcom_db.h.old mozilla/dbm/include/mcom_db.h
+--- mozilla/dbm/include/mcom_db.h.old 2007-09-25 17:57:09.000000000 +0200
++++ mozilla/dbm/include/mcom_db.h 2007-09-25 17:57:49.000000000 +0200
+@@ -214,7 +214,8 @@
+ #endif /* __DBINTERFACE_PRIVATE */
+
+ #ifdef SCO
+-#define MAXPATHLEN 1024
++#include <limits.h>
++#define MAXPATHLEN PATH_MAX
+ #endif
+
+ #include <fcntl.h>
+diff -up mozilla/mail/components/migration/src/nsProfileMigrator.cpp.old mozilla/mail/components/migration/src/nsProfileMigrator.cpp
+--- mozilla/mail/components/migration/src/nsProfileMigrator.cpp.old 2007-09-25 17:55:11.000000000 +0200
++++ mozilla/mail/components/migration/src/nsProfileMigrator.cpp 2007-09-25 18:07:56.000000000 +0200
+@@ -73,7 +73,8 @@
+ #elif defined(CCHMAXPATH)
+ #define MAXPATHLEN CCHMAXPATH
+ #else
+-#define MAXPATHLEN 1024
++#include <limits.h>
++#define MAXPATHLEN PATH_MAX
+ #endif
+ #endif
+
+diff -up mozilla/nsprpub/config/nsinstall.c.old mozilla/nsprpub/config/nsinstall.c
+diff -up mozilla/js/src/jsfile.c.old mozilla/js/src/jsfile.c
+--- mozilla/js/src/jsfile.c.old 2006-07-26 20:55:08.000000000 +0200
++++ mozilla/js/src/jsfile.c 2007-09-25 18:22:52.000000000 +0200
+@@ -105,7 +105,8 @@
+ #define utfstring "binary"
+ #define unicodestring "unicode"
+
+-#define MAX_PATH_LENGTH 1024
++#include <limits.h>
++#define MAX_PATH_LENGTH PATH_MAX
+ #define MODE_SIZE 256
+ #define NUMBER_SIZE 32
+ #define MAX_LINE_LENGTH 256
+diff -up mozilla/webshell/tests/viewer/nsViewerApp.cpp.old mozilla/webshell/tests/viewer/nsViewerApp.cpp
+--- mozilla/webshell/tests/viewer/nsViewerApp.cpp.old 2007-09-25 18:34:51.000000000 +0200
++++ mozilla/webshell/tests/viewer/nsViewerApp.cpp 2007-09-25 18:35:33.000000000 +0200
+@@ -692,7 +692,8 @@ nsViewerApp::OpenWindow(PRUint32 aNewChr
+
+ #if !defined(XP_WIN) && !defined(XP_OS2)
+ #ifndef XP_MAC
+-#define _MAX_PATH 512
++#include <limits.h>
++#define _MAX_PATH PATH_MAX
+ #endif
+ #endif
+
+diff -up mozilla/xpcom/typelib/xpidl/xpidl_java.c.old mozilla/xpcom/typelib/xpidl/xpidl_java.c
+--- mozilla/xpcom/typelib/xpidl/xpidl_java.c.old 2007-09-25 18:38:52.000000000 +0200
++++ mozilla/xpcom/typelib/xpidl/xpidl_java.c 2007-09-25 18:39:17.000000000 +0200
+@@ -44,6 +44,7 @@
+ #include "xpidl.h"
+ #include <ctype.h>
+ #include <glib.h>
++#include <limits.h>
+
+ #ifdef XP_WIN
+ #include <windef.h>
+diff -up mozilla/widget/src/xremoteclient/XRemoteClient.cpp.old mozilla/widget/src/xremoteclient/XRemoteClient.cpp
+--- mozilla/widget/src/xremoteclient/XRemoteClient.cpp.old 2007-09-25 18:14:08.000000000 +0200
++++ mozilla/widget/src/xremoteclient/XRemoteClient.cpp 2007-09-25 18:36:55.000000000 +0200
+@@ -76,7 +76,8 @@
+ #endif
+
+ #ifndef MAX_PATH
+-#define MAX_PATH 1024
++#include <limits.h>
++#define MAX_PATH PATH_MAX
+ #endif
+
+ #define ARRAY_LENGTH(array_) (sizeof(array_)/sizeof(array_[0]))
+diff -up mozilla/modules/libreg/src/reg.c.old mozilla/modules/libreg/src/reg.c
+--- mozilla/modules/libreg/src/reg.c.old 2007-09-25 18:25:02.000000000 +0200
++++ mozilla/modules/libreg/src/reg.c 2007-09-25 18:27:46.000000000 +0200
+@@ -96,7 +96,8 @@
+ #define MAX_PATH PATH_MAX
+ #elif defined(XP_UNIX)
+ #ifndef MAX_PATH
+-#define MAX_PATH 1024
++#include <limits.h>
++#define MAX_PATH PATH_MAX
+ #endif
+ #elif defined(XP_OS2)
+ #ifndef MAX_PATH
+diff -up mozilla/directory/c-sdk/config/pathsub.h.old mozilla/directory/c-sdk/config/pathsub.h
+--- mozilla/directory/c-sdk/config/pathsub.h.old 2006-02-03 15:41:18.000000000 +0100
++++ mozilla/directory/c-sdk/config/pathsub.h 2007-09-25 18:48:58.000000000 +0200
+@@ -50,7 +50,7 @@
+ #endif
+
+ #ifndef PATH_MAX
+-#define PATH_MAX 1024
++#error "PATH_MAX is not defined!"
+ #endif
+
+ /*
+diff -up mozilla/config/pathsub.h.old mozilla/config/pathsub.h
+--- mozilla/config/pathsub.h.old 2004-04-18 16:17:25.000000000 +0200
++++ mozilla/config/pathsub.h 2007-09-25 18:48:13.000000000 +0200
+@@ -46,7 +46,7 @@
+ #include <sys/types.h>
+
+ #ifndef PATH_MAX
+-#define PATH_MAX 1024
++#error "PATH_MAX is not defined!"
+ #endif
+
+ /*
+diff -up mozilla/modules/libjar/nsZipArchive.cpp.old mozilla/modules/libjar/nsZipArchive.cpp
+--- mozilla/modules/libjar/nsZipArchive.cpp.old 2006-09-13 20:32:37.000000000 +0200
++++ mozilla/modules/libjar/nsZipArchive.cpp 2007-09-25 18:51:00.000000000 +0200
+@@ -121,7 +121,7 @@ char * strdup(const char *src)
+ # define S_IFLNK 0120000
+ # endif
+ # ifndef PATH_MAX
+-# define PATH_MAX 1024
++# include <limits.h>
+ # endif
+ #endif /* XP_UNIX */
+
+diff -up mozilla/nsprpub/config/pathsub.h.old mozilla/nsprpub/config/pathsub.h
+--- mozilla/nsprpub/config/pathsub.h.old 2004-04-25 17:00:34.000000000 +0200
++++ mozilla/nsprpub/config/pathsub.h 2007-09-25 18:57:51.000000000 +0200
+@@ -50,7 +50,7 @@
+ #endif
+
+ #ifndef PATH_MAX
+-#define PATH_MAX 1024
++#error "PATH_MAX is not defined!"
+ #endif
+
+ /*
+diff -up mozilla/gfx/src/gtk/nsPrintdGTK.h.old mozilla/gfx/src/gtk/nsPrintdGTK.h
+--- mozilla/gfx/src/gtk/nsPrintdGTK.h.old 2004-04-17 23:52:29.000000000 +0200
++++ mozilla/gfx/src/gtk/nsPrintdGTK.h 2007-09-25 18:56:48.000000000 +0200
+@@ -63,7 +63,7 @@ PR_BEGIN_EXTERN_C
+ #ifdef _POSIX_PATH_MAX
+ #define PATH_MAX _POSIX_PATH_MAX
+ #else
+-#define PATH_MAX 256
++#error "PATH_MAX is not defined!"
+ #endif
+ #endif
+
+diff -up mozilla/security/coreconf/nsinstall/pathsub.h.old mozilla/security/coreconf/nsinstall/pathsub.h
+--- mozilla/security/coreconf/nsinstall/pathsub.h.old 2004-04-25 17:02:18.000000000 +0200
++++ mozilla/security/coreconf/nsinstall/pathsub.h 2007-09-25 19:00:35.000000000 +0200
+@@ -49,7 +49,7 @@
+ #endif
+
+ #ifndef PATH_MAX
+-#define PATH_MAX 1024
++#error "PATH_MAX is not defined!"
+ #endif
+
+ /*
diff --git a/thunderbird-shared-error.patch b/thunderbird-shared-error.patch
index ae41bbc..2869fd8 100644
--- a/thunderbird-shared-error.patch
+++ b/thunderbird-shared-error.patch
@@ -11,5 +11,6 @@ diff -up comm-central/mail/installer/Makefile.in.shared-error comm-central/mail/
endif
+endif
- # On mozilla-central, packager.mk uses core_abspath to redefine DIST
- # As the comm-central config.mk doesn't set it, do it ourselves instead
+ include $(MOZILLA_SRCDIR)/toolkit/mozapps/installer/packager.mk
+
+
diff --git a/thunderbird-version.patch b/thunderbird-version.patch
index 07979cb..fa3096f 100644
--- a/thunderbird-version.patch
+++ b/thunderbird-version.patch
@@ -1,11 +1,12 @@
---- comm-1.9.1/mail/installer/Makefile.in.old 2010-01-20 14:27:43.000000000 +0100
-+++ comm-1.9.1/mail/installer/Makefile.in 2010-01-20 14:29:21.000000000 +0100
-@@ -42,6 +42,8 @@ VPATH = @srcdir@
+diff -up comm-1.9.2/mail/installer/Makefile.in.version comm-1.9.2/mail/installer/Makefile.in
+--- comm-1.9.2/mail/installer/Makefile.in.version 2010-05-21 11:42:45.000000000 -0700
++++ comm-1.9.2/mail/installer/Makefile.in 2010-05-25 15:16:18.446197181 -0700
+@@ -44,6 +44,8 @@ include $(DEPTH)/config/autoconf.mk
- include $(DEPTH)/config/autoconf.mk
+ include $(topsrcdir)/config/rules.mk
+MOZ_APP_VERSION="__RPM_VERSION_INTERNAL__"
+
- NO_PKG_FILES = \
- thunderbird-bin.elf \
- thunderbird-config \
+ MOZ_PKG_REMOVALS = $(srcdir)/removed-files.in
+
+ MOZ_PKG_MANIFEST_P = $(srcdir)/package-manifest.in
diff --git a/thunderbird.desktop b/thunderbird.desktop
index 2cf3ab5..159c15f 100644
--- a/thunderbird.desktop
+++ b/thunderbird.desktop
@@ -1,7 +1,6 @@
[Desktop Entry]
Version=1.0
-Encoding=UTF-8
-Name=Thunderbird Email
+Name=Thunderbird
GenericName=Email
Comment=Send and Receive Email
Exec=thunderbird
@@ -10,4 +9,4 @@ Terminal=false
Type=Application
StartupWMClass=Thunderbird-bin
MimeType=message/rfc822;
-StartupNotify=true
+StartupNotify=true \ No newline at end of file
diff --git a/thunderbird.png b/thunderbird.png
new file mode 100644
index 0000000..d1f9827
--- /dev/null
+++ b/thunderbird.png
Binary files differ
diff --git a/thunderbird.sh.in b/thunderbird.sh.in
index 9012fa3..0630fd3 100644
--- a/thunderbird.sh.in
+++ b/thunderbird.sh.in
@@ -9,7 +9,7 @@
##
MOZ_ARCH=$(uname -m)
case $MOZ_ARCH in
- x86_64 | ia64 | s390 )
+ x86_64 | s390x | sparc64 )
MOZ_LIB_DIR="/usr/lib64"
SECONDARY_LIB_DIR="/usr/lib"
;;
@@ -32,6 +32,8 @@ fi
MOZ_DIST_BIN="$MOZ_LIB_DIR/thunderbird-TBIRD_VERSION"
MOZ_PROGRAM="$MOZ_DIST_BIN/thunderbird"
+MOZ_LANGPACKS_DIR="$MOZ_DIST_BIN/langpacks"
+MOZ_EXTENSIONS_PROFILE_DIR="$HOME/.mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}"
##
## Set MOZ_ENABLE_PANGO is no longer used because Pango is enabled by default
@@ -51,4 +53,72 @@ export MOZ_APP_LAUNCHER="/usr/bin/thunderbird"
GNOME_DISABLE_CRASH_DIALOG=1
export GNOME_DISABLE_CRASH_DIALOG
+##
+## To disable the use of Firefox localization, set MOZ_DISABLE_LANGPACKS=1
+## in your environment before launching Firefox.
+##
+#
+# MOZ_DISABLE_LANGPACKS=1
+# export MOZ_DISABLE_LANGPACKS
+#
+
+##
+## Automatically installed langpacks are tracked by .fedora-langpack-install
+## config file.
+##
+FEDORA_LANGPACK_CONFIG="$MOZ_EXTENSIONS_PROFILE_DIR/.fedora-langpack-install"
+
+# MOZ_DISABLE_LANGPACKS disables language packs completelly
+MOZILLA_DOWN=0
+if ! [ $MOZ_DISABLE_LANGPACKS ] || [ $MOZ_DISABLE_LANGPACKS -eq 0 ]; then
+ if [ -x $MOZ_DIST_BIN/mozilla-xremote-client ]; then
+ # Is thunderbird running?
+ $MOZ_DIST_BIN/mozilla-xremote-client -a thunderbird 'ping()' > /dev/null 2>&1
+ MOZILLA_DOWN=$?
+ fi
+fi
+
+# Modify language pack configuration only when thunderbird is not running
+# and language packs are not disabled
+if [ $MOZILLA_DOWN -ne 0 ]; then
+
+ # Clear already installed langpacks
+ mkdir -p $MOZ_EXTENSIONS_PROFILE_DIR
+ if [ -f $FEDORA_LANGPACK_CONFIG ]; then
+ rm `cat $FEDORA_LANGPACK_CONFIG` > /dev/null 2>&1
+ rm $FEDORA_LANGPACK_CONFIG > /dev/null 2>&1
+ fi
+
+ # Get locale from system
+ CURRENT_LOCALE=$LC_ALL
+ CURRENT_LOCALE=${CURRENT_LOCALE:-$LC_MESSAGES}
+ CURRENT_LOCALE=${CURRENT_LOCALE:-$LANG}
+
+ # Try without a local variant first, then with a local variant
+ # So that pt-BR doesn't try to use pt for example
+ SHORTMOZLOCALE=`echo $CURRENT_LOCALE | sed "s|_\([^.]*\).*||g"`
+ MOZLOCALE=`echo $CURRENT_LOCALE | sed "s|_\([^.]*\).*|-\1|g"`
+
+ # Try to link global langpacks to an extension directory
+ if [ -f $MOZ_LANGPACKS_DIR/langpack-${SHORTMOZLOCALE}@thunderbird.mozilla.org/chrome/$SHORTMOZLOCALE.jar ]; then
+ if [ -d $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@thunderbird.mozilla.org ]; then
+ rmdir "$MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@thunderbird.mozilla.org" > /dev/null 2>&1
+ fi
+ if ! [ -e $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@thunderbird.mozilla.org ]; then
+ ln -s $MOZ_LANGPACKS_DIR/langpack-${SHORTMOZLOCALE}@thunderbird.mozilla.org \
+ $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@thunderbird.mozilla.org
+ echo "$MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@thunderbird.mozilla.org" > $FEDORA_LANGPACK_CONFIG
+ fi
+ elif [ -f $MOZ_LANGPACKS_DIR/langpack-${MOZLOCALE}@thunderbird.mozilla.org/chrome/$MOZLOCALE.jar ]; then
+ if [ -d $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@thunderbird.mozilla.org ]; then
+ rmdir "$MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@thunderbird.mozilla.org" > /dev/null 2>&1
+ fi
+ if ! [ -e $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@thunderbird.mozilla.org ]; then
+ ln -s $MOZ_LANGPACKS_DIR/langpack-${MOZLOCALE}@thunderbird.mozilla.org \
+ $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@thunderbird.mozilla.org
+ echo "$MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@thunderbird.mozilla.org" > $FEDORA_LANGPACK_CONFIG
+ fi
+ fi
+fi
+
exec $MOZ_PROGRAM "$@"
diff --git a/thunderbird.spec b/thunderbird.spec
index 65e5aa9..9dc9642 100644
--- a/thunderbird.spec
+++ b/thunderbird.spec
@@ -3,6 +3,7 @@
%define cairo_version 1.8.8
%define freetype_version 2.1.9
%define sqlite_version 3.6.14
+%define libnotify_version 0.4
%define build_langpacks 1
%define moz_objdir objdir-tb
%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
@@ -13,31 +14,33 @@
# IMPORTANT: If there is no top level directory, this should be
# set to the cwd, ie: '.'
#%define tarballdir .
-%define tarballdir comm-1.9.1
+%define tarballdir comm-1.9.2
%define official_branding 1
%define include_debuginfo 0
-%define version_internal 3.0
+%define version_internal 3.1
%define mozappdir %{_libdir}/%{name}-%{version_internal}
+%define mycomment RC1
Summary: Mozilla Thunderbird mail/newsgroup client
Name: thunderbird
-Version: 3.0.4
-Release: 1%{?dist}
+Version: 3.1
+Release: 0.1.rc1%{?dist}
URL: http://www.mozilla.org/projects/thunderbird/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
%if %{official_branding}
-%define tarball thunderbird-%{version}.source.tar.bz2
+#%define tarball thunderbird-%{version}.source.tar.bz2
+%define tarball thunderbird-3.1rc1.source.tar.bz2
%else
-%define tarball thunderbird-3.0b2-source.tar.bz2
+%define tarball thunderbird-3.1rc1.source.tar.bz2
%endif
Source0: %{tarball}
#NoSource: 0
%if %{build_langpacks}
# Language package archive is build by RH
-Source1: thunderbird-langpacks-%{version}-20100330.tar.bz2
+Source1: thunderbird-langpacks-3.1rc1-20100531.tar.bz2
%endif
# Config file for compilation
Source10: thunderbird-mozconfig
@@ -62,9 +65,8 @@ Patch0: thunderbird-version.patch
Patch1: mozilla-jemalloc.patch
# Fix for installation fail when building with dynamic linked libraries
Patch2: thunderbird-shared-error.patch
-
-
-Patch9: thunderbird-3.0-ppc64.patch
+# Fixes gcc complain that nsFrame::delete is protected
+Patch4: xulrunner-1.9.2.1-build.patch
%if %{official_branding}
# Required by Mozilla Corporation
@@ -82,6 +84,9 @@ BuildRequires: nss-devel >= %{nss_version}
%if %{fedora} >= 11
BuildRequires: cairo-devel >= %{cairo_version}
%endif
+%if %{fedora} >= 10
+BuildRequires: libnotify-devel >= %{libnotify_version}
+%endif
BuildRequires: libpng-devel
BuildRequires: libjpeg-devel
BuildRequires: zip
@@ -143,9 +148,7 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
%patch1 -p0 -b .jemalloc
%patch2 -p1 -b .shared-error
-
-
-%patch9 -p0 -b .ppc64
+%patch4 -p1 -b .protected
%if %{official_branding}
@@ -172,6 +175,20 @@ cat %{SOURCE10} \
%endif
| tee .mozconfig
+cat <<EOF | tee -a .mozconfig
+%if %{fedora} >= 10
+ac_add_options --enable-libnotify
+%else
+ac_add_options --disable-libnotify
+%endif
+%if %{fedora} >= 9
+ac_add_options --enable-system-lcms
+%endif
+%if %{fedora} >= 12
+ac_add_options --enable-system-sqlite
+%endif
+EOF
+
%if %{official_branding}
%{__cat} %{SOURCE11} >> .mozconfig
%endif
@@ -179,7 +196,7 @@ cat %{SOURCE10} \
%{__cat} %{SOURCE13} >> .mozconfig
%endif
-sed -e "s/^Name=.*/Name=Thunderbird %{version}/" \
+sed -e "s/^Name=.*/Name=Thunderbird %{version} %{?mycomment}/" \
-e "s/thunderbird/%{name}/" \
%{SOURCE20} | tee %{name}.desktop
@@ -290,19 +307,11 @@ install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
%{__rm} -f %{name}.lang # Delete for --short-circuit option
touch %{name}.lang
%if %{build_langpacks}
-%if 0%{?fedora} >= 13
%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/langpacks
-%else
-%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/extensions
-%endif
%{__tar} xjf %{SOURCE1}
for langpack in `ls thunderbird-langpacks/*.xpi`; do
language=`basename $langpack .xpi`
-%if 0%{?fedora} >= 13
extensiondir=$RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-$language@thunderbird.mozilla.org
-%else
- extensiondir=$RPM_BUILD_ROOT%{mozappdir}/extensions/langpack-$language@thunderbird.mozilla.org
-%endif
%{__mkdir_p} $extensiondir
unzip $langpack -d $extensiondir
find $extensiondir -type f | xargs chmod 644
@@ -328,7 +337,6 @@ done
%{__rm} -rf thunderbird-langpacks
%endif # build_langpacks
-
# Copy over the LICENSE
cd mozilla
install -c -m 644 LICENSE $RPM_BUILD_ROOT%{mozappdir}
@@ -345,6 +353,7 @@ ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{mozappdir}/dictionaries
touch $RPM_BUILD_ROOT%{mozappdir}/components/compreg.dat
touch $RPM_BUILD_ROOT%{mozappdir}/components/xpti.dat
+
# Add debuginfo for crash-stats.mozilla.com
%if %{include_debuginfo}
cp mozilla/dist/thunderbird-%{version}.en-US.linux-%{_target_cpu}-crashreporter-symbols.zip $RPM_BUILD_ROOT/%{_libdir}/debug%{mozappdir}
@@ -363,6 +372,7 @@ cp %{moz_objdir}/mozilla/dist/thunderbird-%{version}.en-US.linux-i686.crashrepor
install -m 644 mail/extensions/newsblog/rss.rdf $RPM_BUILD_ROOT%{mozappdir}/isp/
rm -rf $RPM_BUILD_ROOT%{mozappdir}/isp/en-US
+rm -rf $RPM_BUILD_ROOT%{mozappdir}/*.chk
#===============================================================================
@@ -414,6 +424,7 @@ fi
%dir %{mozappdir}/components
%ghost %{mozappdir}/components/compreg.dat
%ghost %{mozappdir}/components/xpti.dat
+%{mozappdir}/components/components.list
%{mozappdir}/components/*.so
%{mozappdir}/components/*.xpt
%attr(644,root,root) %{mozappdir}/components/*.js
@@ -421,9 +432,7 @@ fi
%{mozappdir}/dictionaries
%dir %{mozappdir}/extensions
%{mozappdir}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
-%if 0%{?fedora} >= 13
%dir %{mozappdir}/langpacks
-%endif
%{mozappdir}/greprefs
%{mozappdir}/icons
%{mozappdir}/isp
@@ -446,7 +455,6 @@ fi
%{mozappdir}/platform.ini
%{mozappdir}/updater.ini
%{mozappdir}/application.ini
-%exclude %{mozappdir}/dependentlibs.list
%exclude %{mozappdir}/removed-files
%{mozappdir}/update.locale
%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
@@ -460,13 +468,23 @@ fi
%{mozappdir}/crashreporter.ini
%{mozappdir}/Throbber-small.gif
%endif
-%if %{fedora} <= 10
-%exclude %{mozappdir}/*.chk
-%endif
#===============================================================================
%changelog
+* Mon May 31 2010 Remi Collet <rpms@famillecollet.com> 3.1-0.1.rc1
+- update to 3.1rc1
+- sync with rawhide and backport to old fedora
+
+* Tue May 25 2010 Christopher Aillon <caillon@redhat.com> 3.1-0.1.rc1
+- Thunderbird 3.1 RC1
+
+* Fri Apr 30 2010 Jan Horak <jhorak@redhat.com> - 3.0.4-3
+- Fix for mozbz#550455
+
+* Tue Apr 13 2010 Martin Stransky <stransky@redhat.com> - 3.0.4-2
+- Fixed langpacks (#580444)
+
* Tue Mar 30 2010 Remi Collet <rpms@famillecollet.com> 3.0.4-1.fc#.remi
- update to 3.0.4
- sync with F12 and backport to old fedora
diff --git a/xulrunner-1.9.2.1-build.patch b/xulrunner-1.9.2.1-build.patch
new file mode 100644
index 0000000..4d9ee43
--- /dev/null
+++ b/xulrunner-1.9.2.1-build.patch
@@ -0,0 +1,12 @@
+diff -up xulrunner-1.9.2.1/mozilla-1.9.2/layout/generic/nsFrame.h.old xulrunner-1.9.2.1/mozilla-1.9.2/layout/generic/nsFrame.h
+--- xulrunner-1.9.2.1/mozilla/layout/generic/nsFrame.h.old 2009-11-11 15:34:51.000000000 +0100
++++ xulrunner-1.9.2.1/mozilla/layout/generic/nsFrame.h 2009-11-11 15:33:09.000000000 +0100
+@@ -157,7 +157,7 @@ private:
+ // Left undefined; nsFrame objects are never allocated from the heap.
+ void* operator new(size_t sz) CPP_THROW_NEW;
+
+-protected:
++public:
+ // Overridden to prevent the global delete from being called, since
+ // the memory came out of an arena instead of the heap.
+ //