summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-02-09 18:50:27 +0100
committerRemi Collet <fedora@famillecollet.com>2012-02-09 18:50:27 +0100
commit0eb3b805f01ba07fa8a7c23102f29690ddd1d0ac (patch)
treec95447d41408bf85c63b4f46ea91916b24f78769
parent5b7965c3795e005ff9562fa434465006a4f43580 (diff)
Thunderbird 10.0.1
-rw-r--r--thunderbird.spec13
-rw-r--r--xulrunner-10.0-gcc47.patch38
2 files changed, 49 insertions, 2 deletions
diff --git a/thunderbird.spec b/thunderbird.spec
index 88c6dff..e27dd5c 100644
--- a/thunderbird.spec
+++ b/thunderbird.spec
@@ -29,7 +29,7 @@
Summary: Mozilla Thunderbird mail/newsgroup client
Name: thunderbird
-Version: 10.0
+Version: 10.0.1
Release: 1%{?dist}
URL: http://www.mozilla.org/projects/thunderbird/
License: MPLv1.1 or GPLv2+ or LGPLv2+
@@ -41,7 +41,7 @@ Group: Applications/Internet
%endif
Source0: %{tarball}
%if %{build_langpacks}
-Source1: thunderbird-langpacks-%{version}-20120131.tar.bz2
+Source1: thunderbird-langpacks-%{version}-20120209.tar.bz2
%endif
Source10: thunderbird-mozconfig
@@ -445,6 +445,15 @@ fi
#===============================================================================
%changelog
+* Thu Feb 09 2012 Remi Collet <RPMS@FamilleCollet.com> - 10.0.1-1
+- update to 10.0.1, sync with rawhide
+
+* Thu Feb 9 2012 Jan Horak <jhorak@redhat.com> - 10.0.1-1
+- Update to 10.0.1
+
+* Mon Feb 6 2012 Martin Stransky <stransky@redhat.com> - 10.0-2
+- gcc 4.7 build fixes
+
* Tue Jan 31 2012 Remi Collet <rpms@famillecollet.com> 10.0-1
- Thunderbird 10.0, sync with rawhide
diff --git a/xulrunner-10.0-gcc47.patch b/xulrunner-10.0-gcc47.patch
index 91a948a..7efbfba 100644
--- a/xulrunner-10.0-gcc47.patch
+++ b/xulrunner-10.0-gcc47.patch
@@ -23,3 +23,41 @@ diff -up mozilla-beta/toolkit/crashreporter/client/Makefile.in.gcc47 mozilla-bet
ifeq ($(OS_ARCH),WINNT)
CPPSRCS += crashreporter_win.cpp
LIBS += \
+diff -up mozilla-beta/ipc/chromium/src/base/file_util_linux.cc.file mozilla-beta/ipc/chromium/src/base/file_util_linux.cc
+--- mozilla-beta/ipc/chromium/src/base/file_util_linux.cc.file 2012-01-24 09:00:00.000000000 +0100
++++ mozilla-beta/ipc/chromium/src/base/file_util_linux.cc 2012-01-25 15:30:43.707796295 +0100
+@@ -5,6 +5,9 @@
+ #include "base/file_util.h"
+
+ #include <fcntl.h>
++#if defined(ANDROID) || defined(OS_POSIX)
++#include <unistd.h>
++#endif
+
+ #include <string>
+ #include <vector>
+diff -up mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc.file mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc
+--- mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc.file 2012-01-24 09:00:00.000000000 +0100
++++ mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc 2012-01-25 15:13:11.947771212 +0100
+@@ -6,6 +6,9 @@
+
+ #include <errno.h>
+ #include <fcntl.h>
++#if defined(ANDROID) || defined(OS_POSIX)
++#include <unistd.h>
++#endif
+
+ #include "eintr_wrapper.h"
+ #include "base/logging.h"
+diff -up mozilla-beta/ipc/chromium/src/base/file_util.cc.old mozilla-beta/ipc/chromium/src/base/file_util.cc
+--- mozilla-beta/ipc/chromium/src/base/file_util.cc.old 2012-01-25 13:48:11.000000000 +0100
++++ mozilla-beta/ipc/chromium/src/base/file_util.cc 2012-01-25 13:52:25.096659244 +0100
+@@ -8,7 +8,7 @@
+ #include <io.h>
+ #endif
+ #include <stdio.h>
+-#if defined(ANDROID)
++#if defined(ANDROID) || defined(OS_POSIX)
+ #include <unistd.h>
+ #endif
+