summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2011-11-12 17:38:26 +0100
committerRemi Collet <fedora@famillecollet.com>2011-11-12 17:38:26 +0100
commitb7f7bfa66831b3339e8ad58674b0356ee737e589 (patch)
tree276421c8c25be695029ea172c1d0d913617fd347
parentd17609f7ea513a65d57e5eb266bfdad2b0ebffbb (diff)
Lightning 1.0rc2 for Thunderbird 8.0
-rwxr-xr-xmklangsource.sh2
-rw-r--r--mozilla-670719.patch53
-rw-r--r--thunderbird-lightning.spec45
3 files changed, 80 insertions, 20 deletions
diff --git a/mklangsource.sh b/mklangsource.sh
index 964937e..437add2 100755
--- a/mklangsource.sh
+++ b/mklangsource.sh
@@ -1,7 +1,7 @@
#!/bin/bash
# This checks out and builds the language sources. The lightning source needs
# to already be unpacked
-locales=$PWD/thunderbird-lightning-1.0/comm-release/calendar/locales/shipped-locales
+locales=$PWD/thunderbird-lightning-1.0/comm-beta/calendar/locales/shipped-locales
if [ ! -f $locale ]
then
echo "ERROR: missing $locales, try fedpkg prep first"
diff --git a/mozilla-670719.patch b/mozilla-670719.patch
new file mode 100644
index 0000000..afae907
--- /dev/null
+++ b/mozilla-670719.patch
@@ -0,0 +1,53 @@
+# HG changeset patch
+# User Mike Hommey <mh+mozilla@glandium.org>
+# Date 1313846520 -7200
+# Node ID fdc3b63938f5a76d99c1e2bb12fd448465debc94
+# Parent 07a5a618ebe3f67b23100ceb1b51e92bb79be0cd
+Bug 670719 - Only add -DENABLE_JIT=1 to CXXFLAGS if any of trace/method/yarr jit is enabled.
+
+diff --git a/js/src/Makefile.in b/js/src/Makefile.in
+--- a/js/src/Makefile.in
++++ b/js/src/Makefile.in
+@@ -433,16 +433,19 @@ CPPSRCS += \
+ YarrPattern.cpp \
+ YarrSyntaxChecker.cpp \
+ $(NULL)
+ else
+
+ ###############################################
+ # BEGIN include sources for the Nitro assembler
+ #
++
++ENABLE_YARR_JIT = 1
++
+ VPATH += $(srcdir)/assembler \
+ $(srcdir)/assembler/wtf \
+ $(srcdir)/assembler/jit \
+ $(srcdir)/assembler/assembler \
+ $(srcdir)/methodjit \
+ $(srcdir)/yarr \
+ $(NONE)
+
+@@ -1070,17 +1073,21 @@ endif
+
+ ###############################################
+ # BEGIN kludges for the Nitro assembler
+ #
+
+ # Needed to "configure" it correctly. Unfortunately these
+ # flags wind up being applied to all code in js/src, not just
+ # the code in js/src/assembler.
+-CXXFLAGS += -DUSE_SYSTEM_MALLOC=1 -DENABLE_ASSEMBLER=1 -DENABLE_JIT=1
++CXXFLAGS += -DUSE_SYSTEM_MALLOC=1 -DENABLE_ASSEMBLER=1
++
++ifneq (,$(ENABLE_YARR_JIT)$(ENABLE_TRACEJIT)$(ENABLE_METHODJIT))
++CXXFLAGS += -DENABLE_JIT=1
++endif
+
+ INCLUDES += -I$(srcdir)/assembler -I$(srcdir)/yarr
+
+ ifdef ENABLE_METHODJIT
+ # Build a standalone test program that exercises the assembler
+ # sources a bit.
+ TESTMAIN_OBJS = \
+ Assertions.$(OBJ_SUFFIX) \
diff --git a/thunderbird-lightning.spec b/thunderbird-lightning.spec
index 09b7e61..d130aa0 100644
--- a/thunderbird-lightning.spec
+++ b/thunderbird-lightning.spec
@@ -7,12 +7,12 @@
%global sqlite_version 3.6.22
%global libnotify_version 0.4
# Update these two as a pair
-%global thunderbird_version 7.0
-%global thunderbird_next_version 8.0
-%global lightprever b7
+%global thunderbird_version 8.0
+%global thunderbird_next_version 9.0
+%global lightprever rc2
# Compatible versions are listed in:
-# comm-release/calendar/lightning/install.rdf.rej
-# comm-release/calendar/providers/gdata/install.rdf.rej
+# comm-beta/calendar/lightning/install.rdf
+# comm-beta/calendar/providers/gdata/install.rdf
%global moz_objdir objdir-tb
%global lightning_extname %{_libdir}/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}/{e2fda1a4-762b-4020-b5ad-a41df1933103}
%global gdata_extname %{_libdir}/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}/{a62ef8ec-5fdc-40c2-873c-223b8a6925cc}
@@ -23,19 +23,19 @@
# IMPORTANT: If there is no top level directory, this should be
# set to the cwd, ie: '.'
#define tarballdir .
-%global tarballdir comm-release
+%global tarballdir comm-beta
%global mozappdir %{_libdir}/%{name}
Name: thunderbird-lightning
Summary: The calendar extension to Thunderbird
Version: 1.0
-Release: 0.50.%{lightprever}%{?dist}
+Release: 0.52.%{lightprever}%{?dist}
URL: http://www.mozilla.org/projects/calendar/lightning/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Productivity
#Someday lightning will produce a release we can use
-Source0: http://releases.mozilla.org/pub/mozilla.org/calendar/lightning/releases/1.0b7/source/lightning-1.0b7.source.tar.bz2
+Source0: http://releases.mozilla.org/pub/mozilla.org/calendar/lightning/releases/1.0rc2/source/lightning-1.0rc2.source.tar.bz2
#Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{thunderbird_version}/source/thunderbird-%{thunderbird_version}.source.tar.bz2
# This script will generate the language source below
Source1: mklangsource.sh
@@ -50,7 +50,9 @@ Source100: find-external-requires
# Mozilla (XULRunner) patches
Patch0: thunderbird-install-dir.patch
-Patch8: xulrunner-6.0-secondary-ipc.patch
+# Fix build on secondary arches (patches copied from xulrunner)
+Patch2: xulrunner-6.0-secondary-ipc.patch
+Patch3: mozilla-670719.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -96,9 +98,6 @@ BuildRequires: yasm
BuildRequires: mesa-libGL-devel
BuildRequires: GConf2-devel
BuildRequires: lcms-devel >= %{lcms_version}
-%ifarch %{ix86} x86_64
-BuildRequires: wireless-tools-devel
-%endif
Requires: thunderbird >= %{thunderbird_version}
Obsoletes: thunderbird-lightning-wcap <= 0.8
@@ -134,7 +133,8 @@ fi
%patch0 -p2 -b .dir
# Mozilla (XULRunner) patches
cd mozilla
-%patch8 -p2 -b .secondary-ipc
+%patch2 -p2 -b .secondary-ipc
+%patch3 -p1 -b .moz670719
cd ..
%{__rm} -f .mozconfig
@@ -150,16 +150,13 @@ cat %{SOURCE10} \
%if 0%{?fedora} < 15 && 0%{?rhel} <= 6
| grep -v enable-system-cairo \
%endif
-%ifarch %{ix86} x86_64
- | grep -v disable-necko-wifi \
-%endif
| tee .mozconfig
cat <<EOF | tee -a .mozconfig
-ac_add_options --enable-libnotify
-ac_add_options --enable-system-lcms
+#ac_add_options --enable-libnotify
+#ac_add_options --enable-system-lcms
%if 0%{?fedora} >= 15
-ac_add_options --enable-system-sqlite
+#ac_add_options --enable-system-sqlite
%endif
%if 0%{?fedora} < 14 && 0%{?rhel} <= 6
ac_add_options --disable-libjpeg-turbo
@@ -252,6 +249,16 @@ find $RPM_BUILD_ROOT -name \*.so | xargs chmod 0755
#===============================================================================
%changelog
+* Sat Nov 12 2011 Remi Collet <rpms@famillecollet.com> 1.0-0.52.rc2
+- Use lightning 1.0rc2 source for TB 8, sync with rawhide
+
+* Wed Nov 9 2011 Jan Horak <jhorak@redhat.com> - 1.0-0.52.r2
+- Use lightning 1.0rc2 source for TB 8
+- Update l10n source
+
+* Wed Oct 12 2011 Dan HorĂ¡k <dan[at]danny.cz> - 1.0-0.51.b7
+- sync secondary arches support with xulrunner/thunderbird
+
* Wed Oct 12 2011 Georgi Georgiev <chutzimir@gmail.com> - 1.0-0.50.b7
- Make it work on RHEL