summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-04-28 16:35:45 +0200
committerRemi Collet <fedora@famillecollet.com>2012-04-28 16:35:45 +0200
commit6a917eba17aeeb5bc59d377c717745639f4ce33c (patch)
tree955fb77b5cf82f576568b28ef0c00fea3f28e917
parent8afce1a071732901add1629f2bd88eb51af3c61c (diff)
Enigmail 1.4.1 for Thunderbird 12.0
-rw-r--r--mozilla-722127.patch74
-rw-r--r--mozilla-724615.patch24
-rw-r--r--mozilla-733867-x.patch90
-rw-r--r--mozilla-file.patch26
-rw-r--r--thunderbird-enigmail.spec41
-rw-r--r--thunderbird-mozconfig3
-rw-r--r--xulrunner-10.0-gcc47.patch38
7 files changed, 116 insertions, 180 deletions
diff --git a/mozilla-722127.patch b/mozilla-722127.patch
deleted file mode 100644
index f86fcae..0000000
--- a/mozilla-722127.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-diff -up xulrunner-11.0/mozilla-beta/configure.in.vpx1.0.0 xulrunner-11.0/mozilla-beta/configure.in
---- xulrunner-11.0/mozilla-beta/configure.in.vpx1.0.0 2012-03-09 01:39:31.000000000 +0100
-+++ xulrunner-11.0/mozilla-beta/configure.in 2012-03-09 15:03:51.246031329 +0100
-@@ -5710,20 +5710,20 @@ if test -n "$MOZ_WEBM"; then
- [MOZ_NATIVE_LIBVPX_DEC_TEST=1],
- ([--with-system-libvpx requested but symbol vpx_codec_dec_init_ver not found]))
- if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
-- AC_MSG_CHECKING([for libvpx version >= v0.9.7])
-- dnl We need at least v0.9.7 to fix several crash bugs (for which we
-- dnl had local patches prior to v0.9.7).
-+ AC_MSG_CHECKING([for libvpx version >= v1.0.0])
-+ dnl We need at least v1.0.0 to fix several crash bugs (for which we
-+ dnl had local patches prior to v1.0.0).
- dnl
- dnl This is a terrible test for the library version, but we don't
- dnl have a good one. There is no version number in a public header,
- dnl and testing the headers still doesn't guarantee we link against
- dnl the right version. While we could call vpx_codec_version() at
- dnl run-time, that would break cross-compiling. There are no
-- dnl additional exported symbols between the v0.9.7 release and the
-- dnl v0.9.6 one to check for.
-+ dnl additional exported decoder symbols between the v1.0.0 release
-+ dnl and the v0.9.7 one to check for.
- AC_TRY_COMPILE([
- #include <vpx/vpx_decoder.h>
-- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
-+ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
- #error "test failed."
- #endif
- ],
-@@ -5734,7 +5734,7 @@ if test -n "$MOZ_WEBM"; then
- MOZ_LIBVPX_INCLUDES="-I${LIBVPX_DIR}/include"
- MOZ_LIBVPX_LIBS="-L${LIBVPX_DIR}/lib -lvpx"],
- [AC_MSG_RESULT([no])
-- AC_MSG_ERROR([--with-system-libvpx requested but it is not v0.9.7 or later])])
-+ AC_MSG_ERROR([--with-system-libvpx requested but it is not v1.0.0 or later])])
- fi
- CFLAGS=$_SAVE_CFLAGS
- LDFLAGS=$_SAVE_LDFLAGS
-diff -up xulrunner-11.0/mozilla-beta/configure.vpx1.0.0 xulrunner-11.0/mozilla-beta/configure
---- xulrunner-11.0/mozilla-beta/configure.vpx1.0.0 2012-03-09 01:58:50.000000000 +0100
-+++ xulrunner-11.0/mozilla-beta/configure 2012-03-09 15:15:42.537585632 +0100
-@@ -17761,14 +17761,14 @@ else
- fi
-
- if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
-- echo $ac_n "checking for libvpx version >= v0.9.7""... $ac_c" 1>&6
--echo "configure:17766: checking for libvpx version >= v0.9.7" >&5
-+ echo $ac_n "checking for libvpx version >= v1.0.0""... $ac_c" 1>&6
-+echo "configure:17766: checking for libvpx version >= v1.0.0" >&5
- cat > conftest.$ac_ext <<EOF
- #line 17768 "configure"
- #include "confdefs.h"
-
- #include <vpx/vpx_decoder.h>
-- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
-+ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
- #error "test failed."
- #endif
-
-@@ -17791,7 +17791,7 @@ else
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- echo "$ac_t""no" 1>&6
-- { echo "configure: error: --with-system-libvpx requested but it is not v0.9.7 or later" 1>&2; exit 1; }
-+ { echo "configure: error: --with-system-libvpx requested but it is not v1.0.0 or later" 1>&2; exit 1; }
- fi
- rm -f conftest*
- fi
-@@ -25794,4 +25794,3 @@ if cmp -s config/autoconf.mk config/auto
- else
- rm -f config/autoconf.mk.orig 2> /dev/null
- fi
--
diff --git a/mozilla-724615.patch b/mozilla-724615.patch
new file mode 100644
index 0000000..d39e174
--- /dev/null
+++ b/mozilla-724615.patch
@@ -0,0 +1,24 @@
+# HG changeset patch
+# Parent 6292e55419d1730a2e88a56fd30b2440ce0b393a
+# User Raúl Porcel <armin76@gentoo.org>
+Bug XXXXXX - Fix TARGET_CPU usage on ARM
+
+
+diff --git a/xpcom/glue/objs.mk b/xpcom/glue/objs.mk
+--- a/mozilla/xpcom/glue/objs.mk
++++ b/mozilla/xpcom/glue/objs.mk
+@@ -71,13 +71,13 @@ XPCOM_GLUENS_SRC_LCPPSRCS = \
+ SSE.cpp \
+ unused.cpp \
+ nsProxyRelease.cpp \
+ nsTextFormatter.cpp \
+ GenericFactory.cpp \
+ FileUtils.cpp \
+ $(NULL)
+
+-ifeq (arm,$(TARGET_CPU))
++ifneq (,$(filter arm%,$(TARGET_CPU)))
+ XPCOM_GLUENS_SRC_LCPPSRCS += arm.cpp
+ endif
+
+ XPCOM_GLUENS_SRC_CPPSRCS = $(addprefix $(topsrcdir)/xpcom/glue/,$(XPCOM_GLUENS_SRC_LCPPSRCS))
diff --git a/mozilla-733867-x.patch b/mozilla-733867-x.patch
index 9b6fcb8..92116dc 100644
--- a/mozilla-733867-x.patch
+++ b/mozilla-733867-x.patch
@@ -1,6 +1,6 @@
-diff -up thunderbird-11.0/comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp.733867 thunderbird-11.0/comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp
---- thunderbird-11.0/comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp.733867 2012-03-13 03:37:12.000000000 +0100
-+++ thunderbird-11.0/comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp 2012-03-16 07:20:29.299342799 +0100
+diff -up comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp.733867 comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp
+--- comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp.733867 2012-04-21 00:32:39.000000000 +0200
++++ comm-release/mailnews/base/search/src/nsMsgSearchAdapter.cpp 2012-04-25 10:51:32.343536178 +0200
@@ -688,7 +688,7 @@ nsresult nsMsgSearchAdapter::EncodeImapV
PL_strcat(encoding, "{");
lengthStr.AppendInt((PRInt32) strlen(value));
@@ -10,10 +10,10 @@ diff -up thunderbird-11.0/comm-release/mailnews/base/search/src/nsMsgSearchAdapt
PL_strcat(encoding, value);
return NS_OK;
}
-diff -up thunderbird-11.0/comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp.733867 thunderbird-11.0/comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp
---- thunderbird-11.0/comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp.733867 2012-03-13 03:37:13.000000000 +0100
-+++ thunderbird-11.0/comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp 2012-03-16 07:20:29.300342735 +0100
-@@ -753,7 +753,7 @@ nsFolderCompactState::OnDataAvailable(ns
+diff -up comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp.733867 comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp
+--- comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp.733867 2012-04-21 00:32:39.000000000 +0200
++++ comm-release/mailnews/base/src/nsMsgFolderCompactor.cpp 2012-04-25 10:51:33.208535909 +0200
+@@ -758,7 +758,7 @@ nsFolderCompactState::OnDataAvailable(ns
}
}
}
@@ -22,7 +22,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/base/src/nsMsgFolderCompactor.cp
// if status offset isn't in the first block, this code won't work. There's no good reason
// for the status offset not to be at the beginning of the message anyway.
-@@ -1203,7 +1203,7 @@ nsOfflineStoreCompactState::OnDataAvaila
+@@ -1216,7 +1216,7 @@ nsOfflineStoreCompactState::OnDataAvaila
// check if there's an envelope header; if not, write one.
if (strncmp(m_dataBuffer, "From ", 5))
{
@@ -31,19 +31,19 @@ diff -up thunderbird-11.0/comm-release/mailnews/base/src/nsMsgFolderCompactor.cp
m_offlineMsgSize += bytesWritten;
}
}
-diff -up thunderbird-11.0/comm-release/mailnews/compose/src/nsSmtpProtocol.cpp.733867 thunderbird-11.0/comm-release/mailnews/compose/src/nsSmtpProtocol.cpp
---- thunderbird-11.0/comm-release/mailnews/compose/src/nsSmtpProtocol.cpp.733867 2012-03-13 03:37:13.000000000 +0100
-+++ thunderbird-11.0/comm-release/mailnews/compose/src/nsSmtpProtocol.cpp 2012-03-16 07:23:01.225877457 +0100
+diff -up comm-release/mailnews/compose/src/nsSmtpProtocol.cpp.733867 comm-release/mailnews/compose/src/nsSmtpProtocol.cpp
+--- comm-release/mailnews/compose/src/nsSmtpProtocol.cpp.733867 2012-04-21 00:32:39.000000000 +0200
++++ comm-release/mailnews/compose/src/nsSmtpProtocol.cpp 2012-04-25 10:51:33.365535861 +0200
@@ -1722,7 +1722,7 @@ PRInt32 nsSmtpProtocol::SendQuit()
{
- m_sendDone = PR_TRUE;
+ m_sendDone = true;
nsCOMPtr<nsIURI> url = do_QueryInterface(m_runningURL);
- SendData(url, "QUIT"CRLF); // send a quit command to close the connection with the server.
+ SendData(url, "QUIT" CRLF); // send a quit command to close the connection with the server.
m_nextState = SMTP_RESPONSE;
m_nextStateAfterResponse = SMTP_DONE;
return(0);
-@@ -1969,7 +1969,7 @@ nsresult nsSmtpProtocol::LoadUrl(nsIURI
+@@ -1969,7 +1969,7 @@ nsresult nsSmtpProtocol::LoadUrl(nsIURI
{
nsCOMPtr<nsIURI> url = do_QueryInterface(m_runningURL);
// send a quit command to close the connection with the server.
@@ -57,10 +57,10 @@ diff -up thunderbird-11.0/comm-release/mailnews/compose/src/nsSmtpProtocol.cpp.7
return rv;
}
-
-diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapMailFolder.cpp.733867 thunderbird-11.0/comm-release/mailnews/imap/src/nsImapMailFolder.cpp
---- thunderbird-11.0/comm-release/mailnews/imap/src/nsImapMailFolder.cpp.733867 2012-03-13 03:37:13.000000000 +0100
-+++ thunderbird-11.0/comm-release/mailnews/imap/src/nsImapMailFolder.cpp 2012-03-16 07:20:29.309342162 +0100
-@@ -8298,7 +8298,7 @@ nsImapMailFolder::CopyFileToOfflineStore
+diff -up comm-release/mailnews/imap/src/nsImapMailFolder.cpp.733867 comm-release/mailnews/imap/src/nsImapMailFolder.cpp
+--- comm-release/mailnews/imap/src/nsImapMailFolder.cpp.733867 2012-04-21 00:32:39.000000000 +0200
++++ comm-release/mailnews/imap/src/nsImapMailFolder.cpp 2012-04-25 10:51:33.367535861 +0200
+@@ -8309,7 +8309,7 @@ nsImapMailFolder::CopyFileToOfflineStore
bool needMoreData = false;
char * newLine = nsnull;
PRUint32 numBytesInLine = 0;
@@ -69,10 +69,10 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapMailFolder.cpp.73
offlineStore->Write(envelope, strlen(envelope), &bytesWritten);
fileSize += bytesWritten;
do
-diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.733867 thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp
---- thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.733867 2012-03-13 03:37:13.000000000 +0100
-+++ thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp 2012-03-16 07:20:29.314341844 +0100
-@@ -1410,7 +1410,7 @@ void nsImapProtocol::HandleIdleResponses
+diff -up comm-release/mailnews/imap/src/nsImapProtocol.cpp.733867 comm-release/mailnews/imap/src/nsImapProtocol.cpp
+--- comm-release/mailnews/imap/src/nsImapProtocol.cpp.733867 2012-04-21 00:32:39.000000000 +0200
++++ comm-release/mailnews/imap/src/nsImapProtocol.cpp 2012-04-25 10:51:33.370535858 +0200
+@@ -1409,7 +1409,7 @@ void nsImapProtocol::HandleIdleResponses
{
// PRInt32 oldRecent = GetServerStateParser().NumberOfRecentMessages();
nsCAutoString commandBuffer(GetServerCommandTag());
@@ -81,7 +81,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
do
{
-@@ -3290,7 +3290,7 @@ void nsImapProtocol::FetchMsgAttribute(c
+@@ -3287,7 +3287,7 @@ void nsImapProtocol::FetchMsgAttribute(c
commandString.Append(messageIds);
commandString.Append(" (");
commandString.Append(attribute);
@@ -114,10 +114,10 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
command.Append(correctedPassword);
- command.Append("\""CRLF);
+ command.Append("\"" CRLF);
- rv = SendData(command.get(), PR_TRUE /* suppress logging */);
+ rv = SendData(command.get(), true /* suppress logging */);
NS_ENSURE_SUCCESS(rv, rv);
ParseIMAPandCheckForNewMail();
-@@ -7446,7 +7446,7 @@ void nsImapProtocol::CreateMailbox(const
+@@ -7447,7 +7447,7 @@ void nsImapProtocol::CreateMailbox(const
nsCString command(GetServerCommandTag());
command += " create \"";
command += escapedName;
@@ -126,7 +126,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
nsresult rv = SendData(command.get());
if(NS_SUCCEEDED(rv))
-@@ -7549,7 +7549,7 @@ void nsImapProtocol::Lsub(const char *ma
+@@ -7550,7 +7550,7 @@ void nsImapProtocol::Lsub(const char *ma
nsCString command (GetServerCommandTag());
command += " lsub \"\" \"";
command += escapedPattern;
@@ -135,7 +135,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
PR_Free(boxnameWithOnlineDirectory);
-@@ -7578,7 +7578,7 @@ void nsImapProtocol::List(const char *ma
+@@ -7579,7 +7579,7 @@ void nsImapProtocol::List(const char *ma
command += useXLIST ?
" xlist \"\" \"" : " list \"\" \"";
command += escapedPattern;
@@ -144,7 +144,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
PR_Free(boxnameWithOnlineDirectory);
-@@ -7599,7 +7599,7 @@ void nsImapProtocol::Subscribe(const cha
+@@ -7600,7 +7600,7 @@ void nsImapProtocol::Subscribe(const cha
nsCString command (GetServerCommandTag());
command += " subscribe \"";
command += escapedName;
@@ -153,7 +153,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
nsresult rv = SendData(command.get());
if (NS_SUCCEEDED(rv))
-@@ -7617,7 +7617,7 @@ void nsImapProtocol::Unsubscribe(const c
+@@ -7618,7 +7618,7 @@ void nsImapProtocol::Unsubscribe(const c
nsCString command (GetServerCommandTag());
command += " unsubscribe \"";
command += escapedName;
@@ -162,7 +162,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
nsresult rv = SendData(command.get());
if (NS_SUCCEEDED(rv))
-@@ -7631,7 +7631,7 @@ void nsImapProtocol::Idle()
+@@ -7632,7 +7632,7 @@ void nsImapProtocol::Idle()
if (m_urlInProgress)
return;
nsCAutoString command (GetServerCommandTag());
@@ -171,7 +171,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
nsresult rv = SendData(command.get());
if (NS_SUCCEEDED(rv))
{
-@@ -7658,7 +7658,7 @@ void nsImapProtocol::EndIdle(bool waitFo
+@@ -7659,7 +7659,7 @@ void nsImapProtocol::EndIdle(bool waitFo
nsCOMPtr <nsIAsyncInputStream> asyncInputStream = do_QueryInterface(m_inputStream);
if (asyncInputStream)
asyncInputStream->AsyncWait(nsnull, 0, 0, nsnull);
@@ -180,7 +180,7 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
// set a short timeout if we don't want to wait for a response
if (m_transport && !waitForResponse)
m_transport->SetTimeout(nsISocketTransport::TIMEOUT_READ_WRITE, 5);
-@@ -7727,8 +7727,8 @@ void nsImapProtocol::Copy(const char * m
+@@ -7728,8 +7728,8 @@ void nsImapProtocol::Copy(const char * m
PRUint32 msgsHandled = 0;
const char *formatString;
formatString = (idsAreUid)
@@ -191,9 +191,9 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapProtocol.cpp.7338
do
{
-diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp.733867 thunderbird-11.0/comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp
---- thunderbird-11.0/comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp.733867 2012-03-13 03:37:13.000000000 +0100
-+++ thunderbird-11.0/comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp 2012-03-16 07:20:29.316341717 +0100
+diff -up comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp.733867 comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp
+--- comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp.733867 2012-04-21 00:32:39.000000000 +0200
++++ comm-release/mailnews/imap/src/nsImapServerResponseParser.cpp 2012-04-25 10:51:33.374535858 +0200
@@ -185,7 +185,7 @@ void nsImapServerResponseParser::ParseIM
NS_ASSERTION(aCurrentCommand && *aCurrentCommand != '\r' &&
@@ -201,11 +201,11 @@ diff -up thunderbird-11.0/comm-release/mailnews/imap/src/nsImapServerResponsePar
- bool sendingIdleDone = !strcmp(aCurrentCommand, "DONE"CRLF);
+ bool sendingIdleDone = !strcmp(aCurrentCommand, "DONE" CRLF);
if (sendingIdleDone)
- fWaitingForMoreClientInput = PR_FALSE;
+ fWaitingForMoreClientInput = false;
-diff -up thunderbird-11.0/comm-release/mailnews/local/src/nsPop3Protocol.cpp.733867 thunderbird-11.0/comm-release/mailnews/local/src/nsPop3Protocol.cpp
---- thunderbird-11.0/comm-release/mailnews/local/src/nsPop3Protocol.cpp.733867 2012-03-13 03:37:13.000000000 +0100
-+++ thunderbird-11.0/comm-release/mailnews/local/src/nsPop3Protocol.cpp 2012-03-16 07:23:38.980300990 +0100
+diff -up comm-release/mailnews/local/src/nsPop3Protocol.cpp.733867 comm-release/mailnews/local/src/nsPop3Protocol.cpp
+--- comm-release/mailnews/local/src/nsPop3Protocol.cpp.733867 2012-04-21 00:32:40.000000000 +0200
++++ comm-release/mailnews/local/src/nsPop3Protocol.cpp 2012-04-25 10:51:33.375535858 +0200
@@ -2483,7 +2483,7 @@ PRInt32 nsPop3Protocol::SendList()
return(MK_OUT_OF_MEMORY);
m_pop3ConData->next_state_after_response = POP3_GET_LIST;
@@ -215,9 +215,9 @@ diff -up thunderbird-11.0/comm-release/mailnews/local/src/nsPop3Protocol.cpp.733
}
-diff -up thunderbird-11.0/comm-release/mailnews/mime/src/mimedrft.cpp.733867 thunderbird-11.0/comm-release/mailnews/mime/src/mimedrft.cpp
---- thunderbird-11.0/comm-release/mailnews/mime/src/mimedrft.cpp.733867 2012-03-13 03:37:13.000000000 +0100
-+++ thunderbird-11.0/comm-release/mailnews/mime/src/mimedrft.cpp 2012-03-16 07:20:29.320341461 +0100
+diff -up comm-release/mailnews/mime/src/mimedrft.cpp.733867 comm-release/mailnews/mime/src/mimedrft.cpp
+--- comm-release/mailnews/mime/src/mimedrft.cpp.733867 2012-04-21 00:32:40.000000000 +0200
++++ comm-release/mailnews/mime/src/mimedrft.cpp 2012-04-25 10:51:33.376535858 +0200
@@ -1473,7 +1473,7 @@ mime_parse_stream_complete (nsMIMESessio
*newbody = 0;
PL_strcatn(newbody, newbodylen, "<PRE>");
@@ -227,9 +227,9 @@ diff -up thunderbird-11.0/comm-release/mailnews/mime/src/mimedrft.cpp.733867 thu
PR_Free(body);
body = newbody;
}
-diff -up thunderbird-11.0/comm-release/mailnews/mime/src/mimemult.cpp.733867 thunderbird-11.0/comm-release/mailnews/mime/src/mimemult.cpp
---- thunderbird-11.0/comm-release/mailnews/mime/src/mimemult.cpp.733867 2012-03-13 03:37:13.000000000 +0100
-+++ thunderbird-11.0/comm-release/mailnews/mime/src/mimemult.cpp 2012-03-16 07:20:29.321341397 +0100
+diff -up comm-release/mailnews/mime/src/mimemult.cpp.733867 comm-release/mailnews/mime/src/mimemult.cpp
+--- comm-release/mailnews/mime/src/mimemult.cpp.733867 2012-04-21 00:32:40.000000000 +0200
++++ comm-release/mailnews/mime/src/mimemult.cpp 2012-04-25 10:52:45.835512632 +0200
@@ -280,7 +280,7 @@ MimeMultipart_parse_line (const char *li
MimeWriteAString(obj, NS_LITERAL_CSTRING(MSG_LINEBREAK));
MimeWriteAString(obj, NS_LITERAL_CSTRING("Content-Disposition: attachment; filename=\""));
@@ -260,6 +260,6 @@ diff -up thunderbird-11.0/comm-release/mailnews/mime/src/mimemult.cpp.733867 thu
- MimeWriteAString(obj, NS_LITERAL_CSTRING(MSG_LINEBREAK"You deleted an attachment from this message. The original MIME headers for the attachment were:"MSG_LINEBREAK));
+ MimeWriteAString(obj, NS_LITERAL_CSTRING("\"" MSG_LINEBREAK));
+ MimeWriteAString(obj, NS_LITERAL_CSTRING(MSG_LINEBREAK "You deleted an attachment from this message. The original MIME headers for the attachment were:" MSG_LINEBREAK));
- MimeHeaders_write_raw_headers(mult->hdrs, obj->options, PR_FALSE);
+ MimeHeaders_write_raw_headers(mult->hdrs, obj->options, false);
}
PRInt32 old_nchildren = container->nchildren;
diff --git a/mozilla-file.patch b/mozilla-file.patch
new file mode 100644
index 0000000..14b0182
--- /dev/null
+++ b/mozilla-file.patch
@@ -0,0 +1,26 @@
+diff -up mozilla-beta/ipc/chromium/src/base/file_util_linux.cc.file mozilla-beta/ipc/chromium/src/base/file_util_linux.cc
+--- mozilla-beta/ipc/chromium/src/base/file_util_linux.cc.file 2012-01-24 09:00:00.000000000 +0100
++++ mozilla-beta/ipc/chromium/src/base/file_util_linux.cc 2012-01-25 15:30:43.707796295 +0100
+@@ -5,6 +5,9 @@
+ #include "base/file_util.h"
+
+ #include <fcntl.h>
++#if defined(ANDROID) || defined(OS_POSIX)
++#include <unistd.h>
++#endif
+
+ #include <string>
+ #include <vector>
+diff -up mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc.file mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc
+--- mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc.file 2012-01-24 09:00:00.000000000 +0100
++++ mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc 2012-01-25 15:13:11.947771212 +0100
+@@ -6,6 +6,9 @@
+
+ #include <errno.h>
+ #include <fcntl.h>
++#if defined(ANDROID) || defined(OS_POSIX)
++#include <unistd.h>
++#endif
+
+ #include "eintr_wrapper.h"
+ #include "base/logging.h"
diff --git a/thunderbird-enigmail.spec b/thunderbird-enigmail.spec
index ca69720..fdc0d70 100644
--- a/thunderbird-enigmail.spec
+++ b/thunderbird-enigmail.spec
@@ -1,7 +1,7 @@
%define debug_build 0
# Use system Librairies ?
-%if 0%{?fedora} <= 15
+%if 0%{?fedora} <= 17
%define system_sqlite 0
%else
%define system_sqlite 1
@@ -28,20 +28,14 @@
%define cairo_version 1.10.0
%define freetype_version 2.1.9
%define lcms_version 1.19
-%define sqlite_version 3.7.7.1
+%define sqlite_version 3.7.10
%define libnotify_version 0.4
%global libvpx_version 1.0.0
%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
-%if 0%{?fedora} <= 15
-%define system_sqlite 0
-%else
-%define system_sqlite 1
-%endif
-
-%global thunver 11.0
-%global thunmax 12.0
+%global thunver 12.0
+%global thunmax 13.0
# The tarball is pretty inconsistent with directory structure.
# Sometimes there is a top level directory. That goes here.
@@ -59,11 +53,11 @@
Summary: Authentication and encryption extension for Mozilla Thunderbird
Name: thunderbird-enigmail
-Version: 1.4
+Version: 1.4.1
%if 0%{?prever:1}
Release: 0.1.%{prever}%{?dist}
%else
-Release: 2%{?dist}.1
+Release: 1%{?dist}
%endif
URL: http://enigmail.mozdev.org/
License: MPLv1.1 or GPLv2+
@@ -92,13 +86,15 @@ Patch7: crashreporter-remove-static.patch
Patch8: xulrunner-10.0-secondary-ipc.patch
# Build patches
-Patch100: xulrunner-10.0-gcc47.patch
-Patch101: mozilla-722127.patch
Patch102: mozilla-733867-x.patch
-
+Patch103: mozilla-file.patch
+Patch104: xulrunner-10.0-gcc47.patch
# Linux specific
Patch200: thunderbird-8.0-enable-addons.patch
+# ARM Specific
+Patch210: mozilla-724615.patch
+
# Enigmail patch
@@ -186,14 +182,13 @@ cd %{tarballdir}
cd mozilla
%patch7 -p2 -b .static
%patch8 -p3 -b .secondary-ipc
-%if 0%{?fedora} >= 17
-%patch100 -p1 -b .gcc47
-%endif
-%patch101 -p2 -b .722127
+%patch103 -p1 -b .mozilla-file
+%patch104 -p1 -b .gcc47
cd ..
-%patch102 -p2 -b .733867
+%patch102 -p1 -b .733867
%patch200 -p1 -b .addons
+%patch210 -p1 -b .724615
%if %{official_branding}
# Required by Mozilla Corporation
@@ -263,7 +258,7 @@ pushd mailnews/extensions/enigmail
# All tarballs (as well as CVS) will *always* report as 1.4a1pre (or whatever
# the next major version would be). This is because I create builds from trunk
# and simply label the result as 1.3.x.
-# sed -i -e '/em:version/s/1.4a1pre/%{version}/' package/install.rdf
+sed -i -e '/em:version/s/1.5pre/%{version}/' package/install.rdf
grep '<em:version>%{version}</em:version>' package/install.rdf || exit 1
# Apply Enigmail patch here
popd
@@ -330,7 +325,6 @@ rm -rf $RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT%{enigmail_extname}
unzip -q mozilla/dist/bin/enigmail-*-linux-*.xpi -d $RPM_BUILD_ROOT%{enigmail_extname}
-chmod +x $RPM_BUILD_ROOT%{enigmail_extname}/wrappers/*.sh
%clean
@@ -345,6 +339,9 @@ rm -rf $RPM_BUILD_ROOT
#===============================================================================
%changelog
+* Sat Apr 28 2012 Remi Collet <remi@fedoraproject.org> 1.4.1-1
+- Enigmail 1.4.1 for Thunderbird 12.0
+
* Fri Mar 16 2012 Remi Collet <remi@fedoraproject.org> 1.4-2.1
- latest patch from rawhide
diff --git a/thunderbird-mozconfig b/thunderbird-mozconfig
index 1206528..5dfc417 100644
--- a/thunderbird-mozconfig
+++ b/thunderbird-mozconfig
@@ -21,7 +21,8 @@ ac_add_options --disable-xprint
ac_add_options --disable-strip
ac_add_options --disable-install-strip
ac_add_options --enable-pango
-ac_add_options --enable-system-cairo
+# temporary disable system cairo, because compilation fails
+#ac_add_options --enable-system-cairo
ac_add_options --enable-svg
ac_add_options --enable-canvas
ac_add_options --enable-system-hunspell
diff --git a/xulrunner-10.0-gcc47.patch b/xulrunner-10.0-gcc47.patch
index 7efbfba..91a948a 100644
--- a/xulrunner-10.0-gcc47.patch
+++ b/xulrunner-10.0-gcc47.patch
@@ -23,41 +23,3 @@ diff -up mozilla-beta/toolkit/crashreporter/client/Makefile.in.gcc47 mozilla-bet
ifeq ($(OS_ARCH),WINNT)
CPPSRCS += crashreporter_win.cpp
LIBS += \
-diff -up mozilla-beta/ipc/chromium/src/base/file_util_linux.cc.file mozilla-beta/ipc/chromium/src/base/file_util_linux.cc
---- mozilla-beta/ipc/chromium/src/base/file_util_linux.cc.file 2012-01-24 09:00:00.000000000 +0100
-+++ mozilla-beta/ipc/chromium/src/base/file_util_linux.cc 2012-01-25 15:30:43.707796295 +0100
-@@ -5,6 +5,9 @@
- #include "base/file_util.h"
-
- #include <fcntl.h>
-+#if defined(ANDROID) || defined(OS_POSIX)
-+#include <unistd.h>
-+#endif
-
- #include <string>
- #include <vector>
-diff -up mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc.file mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc
---- mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc.file 2012-01-24 09:00:00.000000000 +0100
-+++ mozilla-beta/ipc/chromium/src/base/message_pump_libevent.cc 2012-01-25 15:13:11.947771212 +0100
-@@ -6,6 +6,9 @@
-
- #include <errno.h>
- #include <fcntl.h>
-+#if defined(ANDROID) || defined(OS_POSIX)
-+#include <unistd.h>
-+#endif
-
- #include "eintr_wrapper.h"
- #include "base/logging.h"
-diff -up mozilla-beta/ipc/chromium/src/base/file_util.cc.old mozilla-beta/ipc/chromium/src/base/file_util.cc
---- mozilla-beta/ipc/chromium/src/base/file_util.cc.old 2012-01-25 13:48:11.000000000 +0100
-+++ mozilla-beta/ipc/chromium/src/base/file_util.cc 2012-01-25 13:52:25.096659244 +0100
-@@ -8,7 +8,7 @@
- #include <io.h>
- #endif
- #include <stdio.h>
--#if defined(ANDROID)
-+#if defined(ANDROID) || defined(OS_POSIX)
- #include <unistd.h>
- #endif
-