summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-03-15 18:37:32 +0100
committerRemi Collet <fedora@famillecollet.com>2012-03-15 18:37:32 +0100
commit0778000b7d7b68457078800dea5e8a5f14cabcbc (patch)
tree66a8543a64701cdf36fc65e9c7d5295cf0c1b560
parent6ba1936d42634a83e9a5e2b8894b707191fb1087 (diff)
Thunderbird 11.0
-rw-r--r--mozilla-722127.patch74
-rw-r--r--thunderbird-enigmail.spec74
-rw-r--r--thunderbird-mozconfig3
-rw-r--r--xulrunner-9.0-secondary-build-fix.patch11
4 files changed, 134 insertions, 28 deletions
diff --git a/mozilla-722127.patch b/mozilla-722127.patch
new file mode 100644
index 0000000..f86fcae
--- /dev/null
+++ b/mozilla-722127.patch
@@ -0,0 +1,74 @@
+diff -up xulrunner-11.0/mozilla-beta/configure.in.vpx1.0.0 xulrunner-11.0/mozilla-beta/configure.in
+--- xulrunner-11.0/mozilla-beta/configure.in.vpx1.0.0 2012-03-09 01:39:31.000000000 +0100
++++ xulrunner-11.0/mozilla-beta/configure.in 2012-03-09 15:03:51.246031329 +0100
+@@ -5710,20 +5710,20 @@ if test -n "$MOZ_WEBM"; then
+ [MOZ_NATIVE_LIBVPX_DEC_TEST=1],
+ ([--with-system-libvpx requested but symbol vpx_codec_dec_init_ver not found]))
+ if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
+- AC_MSG_CHECKING([for libvpx version >= v0.9.7])
+- dnl We need at least v0.9.7 to fix several crash bugs (for which we
+- dnl had local patches prior to v0.9.7).
++ AC_MSG_CHECKING([for libvpx version >= v1.0.0])
++ dnl We need at least v1.0.0 to fix several crash bugs (for which we
++ dnl had local patches prior to v1.0.0).
+ dnl
+ dnl This is a terrible test for the library version, but we don't
+ dnl have a good one. There is no version number in a public header,
+ dnl and testing the headers still doesn't guarantee we link against
+ dnl the right version. While we could call vpx_codec_version() at
+ dnl run-time, that would break cross-compiling. There are no
+- dnl additional exported symbols between the v0.9.7 release and the
+- dnl v0.9.6 one to check for.
++ dnl additional exported decoder symbols between the v1.0.0 release
++ dnl and the v0.9.7 one to check for.
+ AC_TRY_COMPILE([
+ #include <vpx/vpx_decoder.h>
+- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
++ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
+ #error "test failed."
+ #endif
+ ],
+@@ -5734,7 +5734,7 @@ if test -n "$MOZ_WEBM"; then
+ MOZ_LIBVPX_INCLUDES="-I${LIBVPX_DIR}/include"
+ MOZ_LIBVPX_LIBS="-L${LIBVPX_DIR}/lib -lvpx"],
+ [AC_MSG_RESULT([no])
+- AC_MSG_ERROR([--with-system-libvpx requested but it is not v0.9.7 or later])])
++ AC_MSG_ERROR([--with-system-libvpx requested but it is not v1.0.0 or later])])
+ fi
+ CFLAGS=$_SAVE_CFLAGS
+ LDFLAGS=$_SAVE_LDFLAGS
+diff -up xulrunner-11.0/mozilla-beta/configure.vpx1.0.0 xulrunner-11.0/mozilla-beta/configure
+--- xulrunner-11.0/mozilla-beta/configure.vpx1.0.0 2012-03-09 01:58:50.000000000 +0100
++++ xulrunner-11.0/mozilla-beta/configure 2012-03-09 15:15:42.537585632 +0100
+@@ -17761,14 +17761,14 @@ else
+ fi
+
+ if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
+- echo $ac_n "checking for libvpx version >= v0.9.7""... $ac_c" 1>&6
+-echo "configure:17766: checking for libvpx version >= v0.9.7" >&5
++ echo $ac_n "checking for libvpx version >= v1.0.0""... $ac_c" 1>&6
++echo "configure:17766: checking for libvpx version >= v1.0.0" >&5
+ cat > conftest.$ac_ext <<EOF
+ #line 17768 "configure"
+ #include "confdefs.h"
+
+ #include <vpx/vpx_decoder.h>
+- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
++ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
+ #error "test failed."
+ #endif
+
+@@ -17791,7 +17791,7 @@ else
+ cat conftest.$ac_ext >&5
+ rm -rf conftest*
+ echo "$ac_t""no" 1>&6
+- { echo "configure: error: --with-system-libvpx requested but it is not v0.9.7 or later" 1>&2; exit 1; }
++ { echo "configure: error: --with-system-libvpx requested but it is not v1.0.0 or later" 1>&2; exit 1; }
+ fi
+ rm -f conftest*
+ fi
+@@ -25794,4 +25794,3 @@ if cmp -s config/autoconf.mk config/auto
+ else
+ rm -f config/autoconf.mk.orig 2> /dev/null
+ fi
+-
diff --git a/thunderbird-enigmail.spec b/thunderbird-enigmail.spec
index 5438219..678d219 100644
--- a/thunderbird-enigmail.spec
+++ b/thunderbird-enigmail.spec
@@ -1,11 +1,37 @@
-%define nspr_version 4.8.9
-%define nss_version 3.13.1
+%define debug_build 0
+
+# Use system Librairies ?
+%if 0%{?fedora} <= 15
+%define system_sqlite 0
+%else
+%define system_sqlite 1
+%endif
+%if 0%{?fedora} < 17
+%define system_nspr 0
+%define system_nss 0
+%else
+%define system_nspr 1
+%define system_nss 1
+%endif
+%if 0%{?fedora} < 15
+%define system_cairo 0
+%define system_vpx 0
+%else
+%define system_cairo 1
+%define system_vpx 1
+%endif
+
+%define build_langpacks 1
+
+%define nspr_version 4.9
+%define nss_version 3.13.3
%define cairo_version 1.10.0
%define freetype_version 2.1.9
%define lcms_version 1.19
%define sqlite_version 3.7.7.1
%define libnotify_version 0.4
-%define build_langpacks 1
+%global libvpx_version 1.0.0
+
%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
%if 0%{?fedora} <= 15
@@ -14,8 +40,8 @@
%define system_sqlite 1
%endif
-%global thunver 10.0.2
-%global thunmax 11.0
+%global thunver 11.0
+%global thunmax 12.0
# The tarball is pretty inconsistent with directory structure.
# Sometimes there is a top level directory. That goes here.
@@ -37,7 +63,7 @@ Version: 1.4
%if 0%{?prever:1}
Release: 0.1.%{prever}%{?dist}
%else
-Release: 1%{?dist}
+Release: 2%{?dist}
%endif
URL: http://enigmail.mozdev.org/
License: MPLv1.1 or GPLv2+
@@ -64,11 +90,10 @@ Source100: http://www.mozilla-enigmail.org/download/source/enigmail-%{versi
Patch0: thunderbird-install-dir.patch
Patch7: crashreporter-remove-static.patch
Patch8: xulrunner-10.0-secondary-ipc.patch
-# # cherry-picked from 13afcd4c097c
-Patch13: xulrunner-9.0-secondary-build-fix.patch
# Build patches
Patch100: xulrunner-10.0-gcc47.patch
+Patch101: mozilla-722127.patch
# Linux specific
Patch200: thunderbird-8.0-enable-addons.patch
@@ -85,13 +110,13 @@ Patch200: thunderbird-8.0-enable-addons.patch
%endif
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-%if 0%{?fedora} >= 15
+%if %{system_nspr}
BuildRequires: nspr-devel >= %{nspr_version}
%endif
-%if 0%{?fedora} >= 15
+%if %{system_nss}
BuildRequires: nss-devel >= %{nss_version}
%endif
-%if 0%{?fedora} >= 15
+%if %{system_cairo}
# Library requirements (cairo-tee >= 1.10)
BuildRequires: cairo-devel >= %{cairo_version}
%endif
@@ -157,10 +182,10 @@ cd %{tarballdir}
cd mozilla
%patch7 -p2 -b .static
%patch8 -p3 -b .secondary-ipc
-%patch13 -p2 -b .secondary-build
%if 0%{?fedora} >= 17
%patch100 -p1 -b .gcc47
%endif
+%patch101 -p2 -b .722127
cd ..
%patch200 -p1 -b .addons
@@ -176,15 +201,18 @@ cd ..
%{__rm} -f .mozconfig
cat %{SOURCE10} \
-%if 0%{?fedora} < 15
+%if ! %{system_nss}
| grep -v system-nss \
%endif
-%if 0%{?fedora} < 15
+%if ! %{system_nspr}
| grep -v system-nspr \
%endif
-%if 0%{?fedora} < 15 && 0%{?rhel} <= 6
+%if ! %{system_cairo}
| grep -v enable-system-cairo \
%endif
+%if ! %{system_vpx}
+ | grep -v with-system-libvpx \
+%endif
| tee .mozconfig
%if 0%{?fedora} < 14 && 0%{?rhel} <= 6
@@ -206,6 +234,18 @@ echo "ac_add_options --enable-system-sqlite" >> .mozconfig
echo "ac_add_options --disable-system-sqlite" >> .mozconfig
%endif
+%if %{?debug_build}
+echo "ac_add_options --enable-debug" >> .mozconfig
+echo "ac_add_options --disable-optimize" >> .mozconfig
+%else
+echo "ac_add_options --disable-debug" >> .mozconfig
+echo "ac_add_options --enable-optimize" >> .mozconfig
+%endif
+
+%ifarch %{arm}
+echo "ac_add_options --disable-elf-hack" >> .mozconfig
+%endif
+
# ===== Enigmail work =====
%if 0%{?CVS}
mkdir mailnews/extensions/enigmail
@@ -260,6 +300,7 @@ MOZ_SMP_FLAGS=-j1
RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
[ "$RPM_BUILD_NCPUS" -ge 4 ] && MOZ_SMP_FLAGS=-j4
+[ "$RPM_BUILD_NCPUS" -ge 8 ] && MOZ_SMP_FLAGS=-j8
%endif
@@ -299,6 +340,9 @@ rm -rf $RPM_BUILD_ROOT
#===============================================================================
%changelog
+* Thu Mar 15 2012 Remi Collet <remi@fedoraproject.org> 1.4-2
+- Enigmail 1.4 for Thunderbird 11.0
+
* Sat Mar 03 2012 Remi Collet <remi@fedoraproject.org> 1.4-1
- Enigmail 1.4 for Thunderbird 10.0.2
- using upstream fixlang.pl instead of our fixlang.php
diff --git a/thunderbird-mozconfig b/thunderbird-mozconfig
index 552f532..1206528 100644
--- a/thunderbird-mozconfig
+++ b/thunderbird-mozconfig
@@ -11,11 +11,10 @@ ac_add_options --with-system-nspr
ac_add_options --with-system-nss
ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
+ac_add_options --with-system-libvpx
ac_add_options --with-pthreads
ac_add_options --disable-tests
-ac_add_options --disable-debug
ac_add_options --disable-installer
-ac_add_options --enable-optimize
ac_add_options --enable-xinerama
ac_add_options --enable-default-toolkit=cairo-gtk2
ac_add_options --disable-xprint
diff --git a/xulrunner-9.0-secondary-build-fix.patch b/xulrunner-9.0-secondary-build-fix.patch
deleted file mode 100644
index fc1c1db..0000000
--- a/xulrunner-9.0-secondary-build-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -up xulrunner-9.0.1/mozilla-release/js/src/jscompartment.cpp.orig xulrunner-9.0.1/mozilla-release/js/src/jscompartment.cpp
---- xulrunner-9.0.1/mozilla-release/js/src/jscompartment.cpp.orig 2012-01-04 11:06:39.000000000 +0100
-+++ xulrunner-9.0.1/mozilla-release/js/src/jscompartment.cpp 2012-01-04 11:06:43.000000000 +0100
-@@ -50,7 +50,6 @@
- #include "jswatchpoint.h"
- #include "jswrapper.h"
- #include "assembler/wtf/Platform.h"
--#include "assembler/jit/ExecutableAllocator.h"
- #include "yarr/BumpPointerAllocator.h"
- #include "methodjit/MethodJIT.h"
- #include "methodjit/PolyIC.h"