summaryrefslogtreecommitdiffstats
path: root/sunbird-1.0-libical.patch
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2010-06-26 07:46:49 +0200
committerRemi Collet <fedora@famillecollet.com>2010-06-26 07:46:49 +0200
commit6f77138fd8f6b6e3c0cdfbe72acc964da48cc04c (patch)
tree73082d5c987c51c21733c7649e8b50a0b81bb6b9 /sunbird-1.0-libical.patch
import sunbird (for thunderbird-lightning)
Diffstat (limited to 'sunbird-1.0-libical.patch')
-rw-r--r--sunbird-1.0-libical.patch59
1 files changed, 59 insertions, 0 deletions
diff --git a/sunbird-1.0-libical.patch b/sunbird-1.0-libical.patch
new file mode 100644
index 0000000..ba71f01
--- /dev/null
+++ b/sunbird-1.0-libical.patch
@@ -0,0 +1,59 @@
+Link against system libical instead of bundled.
+https://bugzilla.redhat.com/show_bug.cgi?id=459923
+
+Lubomir Rintel <lkundrak@v3.sk>
+
+--- calendar/base/build/Makefile.in.libical 2007-12-27 11:01:41.000000000 +0100
++++ calendar/base/build/Makefile.in 2008-09-23 16:02:42.000000000 +0200
+@@ -63,7 +63,6 @@
+ js \
+ xpconnect \
+ string \
+- ical \
+ calbase
+
+ CPPSRCS = calBaseModule.cpp \
+@@ -74,7 +73,6 @@
+
+ SHARED_LIBRARY_LIBS = \
+ $(DEPTH)/calendar/base/src/$(LIB_PREFIX)calbase_s.$(LIB_SUFFIX) \
+- $(DEPTH)/calendar/libical/src/libical/$(LIB_PREFIX)mozical.$(LIB_SUFFIX) \
+ $(NULL)
+
+ ifdef MOZILLA_INTERNAL_API
+@@ -94,4 +92,7 @@
+ $(NULL)
+ endif
+
++# External libical
++EXTRA_DSO_LDOPTS += -lical
++
+ include $(topsrcdir)/config/rules.mk
+--- calendar/Makefile.in.libical 2008-09-23 17:13:34.000000000 +0200
++++ calendar/Makefile.in 2008-09-23 17:07:30.000000000 +0200
+@@ -42,7 +42,7 @@
+ include $(DEPTH)/config/autoconf.mk
+
+ MODULE = calendar
+-DIRS = libical resources base providers import-export locales
++DIRS = resources base providers import-export locales
+
+ ifdef ENABLE_TESTS
+ DIRS += test
+--- calendar/lightning/Makefile.in.libical 2008-07-24 03:07:05.000000000 +0200
++++ calendar/lightning/Makefile.in 2008-09-23 16:02:42.000000000 +0200
+@@ -71,7 +71,7 @@
+ endif
+ endif
+
+-DIRS = ../libical \
++DIRS = \
+ ../locales \
+ ../base \
+ ../providers \
+--- /dev/null 2008-09-23 20:44:22.879046487 +0200
++++ calendar/base/src/ical.h 2008-09-24 11:28:09.000000000 +0200
+@@ -0,0 +1,3 @@
++#pragma GCC visibility push(default)
++#include <libical/ical.h>
++#pragma GCC visibility pop