summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2010-09-11 10:15:56 +0200
committerRemi Collet <fedora@famillecollet.com>2010-09-11 10:15:56 +0200
commit095510e4c546b828af250799e8a0cb5150068f0a (patch)
tree01f72c9fcad3f892ae582b34ace58c26094c6a55
parenta736fcbcaac87578a7bffc6a5186dc69d22fd1cc (diff)
sunbird-1.0-0.28
-rw-r--r--mozilla-missing-cflags.patch9
-rw-r--r--sunbird.spec18
-rwxr-xr-xtestfixlang.sh2
3 files changed, 21 insertions, 8 deletions
diff --git a/mozilla-missing-cflags.patch b/mozilla-missing-cflags.patch
new file mode 100644
index 0000000..fcef959
--- /dev/null
+++ b/mozilla-missing-cflags.patch
@@ -0,0 +1,9 @@
+diff -up comm-1.9.2/mozilla/toolkit/system/gnome/Makefile.in.mozcflags comm-1.9.2/mozilla/toolkit/system/gnome/Makefile.in
+--- comm-1.9.2/mozilla/toolkit/system/gnome/Makefile.in.mozcflags 2010-07-26 12:52:38.000000000 +0200
++++ comm-1.9.2/mozilla/toolkit/system/gnome/Makefile.in 2010-07-26 12:39:34.000000000 +0200
+@@ -93,4 +93,5 @@ CXXFLAGS += \
+ $(MOZ_GNOMEVFS_CFLAGS) \
+ $(GLIB_CFLAGS) \
+ $(MOZ_LIBNOTIFY_CFLAGS) \
++ $(MOZ_GTK2_CFLAGS) \
+ $(NULL)
diff --git a/sunbird.spec b/sunbird.spec
index 8fd2017..328df78 100644
--- a/sunbird.spec
+++ b/sunbird.spec
@@ -15,7 +15,7 @@
%define version_internal 1.0b2
%define progdir %{_libdir}/%{name}-%{version_internal}pre
%define thunderbird_internal 3.1
-%define thunderbird_version 3.1.2
+%define thunderbird_version 3.1.3
%define libnotify_version 0.4
%define thundir %{_libdir}/thunderbird-%{thunderbird_internal}
@@ -51,6 +51,7 @@ Patch1: xulrunner-1.9.2.1-build.patch
# Ours
Patch10: sunbird-1.0-libical.patch
Patch11: sunbird-1.0-uilocale.patch
+Patch12: mozilla-missing-cflags.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -63,7 +64,7 @@ BuildRequires: freetype-devel >= 2.1.9
BuildRequires: libXt-devel
BuildRequires: libXrender-devel
BuildRequires: desktop-file-utils
-%if 0%{?fedora} >= 11
+%if 0%{?fedora} >= 15
BuildRequires: nspr-devel >= %{nspr_version}
BuildRequires: nss-devel >= %{nss_version}
%endif
@@ -72,6 +73,8 @@ BuildRequires: libpng-devel, libjpeg-devel, gtk2-devel
BuildRequires: zlib-devel, gzip, zip, unzip
BuildRequires: GConf2-devel
BuildRequires: gnome-vfs2-devel
+BuildRequires: libgnome-devel
+
BuildRequires: libical-devel
BuildRequires: zip
BuildRequires: autoconf213
@@ -84,7 +87,7 @@ Requires: nspr >= %{nspr_version}
BuildRequires: cairo-devel >= %{cairo_version}
Requires: nss >= %{nss_version}
%endif
-%if 0%{?fedora} >= 13
+%if 0%{?fedora} >= 15
BuildRequires: sqlite-devel >= %{sqlite_version}
%endif
%if %{fedora} >= 10
@@ -135,6 +138,9 @@ calendaring tasks.
%patch1 -p1 -b .protected
%patch10 -p0 -b .libical
%patch11 -p0 -b .uilocale
+%if %{fedora} >= 14
+%patch12 -p1 -b .mozcflags
+%endif
find . -name '*.cpp' -o -name '*.h' |xargs chmod -x
@@ -166,8 +172,6 @@ ac_add_options --with-pthreads
ac_add_options --with-system-jpeg
%if %{fedora} >= 15
ac_add_options --with-system-nspr
-%endif
-%if %{fedora} >= 11
ac_add_options --with-system-nss
%endif
ac_add_options --with-system-zlib
@@ -179,7 +183,7 @@ ac_add_options --disable-libnotify
%if %{fedora} >= 11
ac_add_options --enable-system-lcms
%endif
-%if %{fedora} >= 13
+%if %{fedora} >= 15
ac_add_options --enable-system-sqlite
%endif
%ifarch ppc ppc64
@@ -323,7 +327,7 @@ fi
%changelog
* Fri Aug 06 2010 Remi Collet <rpms@famillecollet.com> 1.0-0.28
-- Rebuild against Thunderbird 3.1.2
+- Rebuild against Thunderbird 3.1.3
- add fixlang.php
* Wed Jul 21 2010 Remi Collet <rpms@famillecollet.com> 1.0-0.27
diff --git a/testfixlang.sh b/testfixlang.sh
index 54aa36d..a42e3c6 100755
--- a/testfixlang.sh
+++ b/testfixlang.sh
@@ -3,7 +3,7 @@
set -x
if [ ! -d /tmp/comm-1.9.2 ]; then
- tar xjf thunderbird-3.1.2.source.tar.bz2 -C /tmp && echo Sources extracted
+ tar xjf thunderbird-3.1.3.source.tar.bz2 -C /tmp && echo Sources extracted
fi
DIR=/tmp/testfixlang