summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--firefox.spec16
-rw-r--r--mozilla-938730.patch27
2 files changed, 40 insertions, 3 deletions
diff --git a/firefox.spec b/firefox.spec
index 4f59aee..672a865 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -1,5 +1,5 @@
# Use system nss/nspr?
-%if 0%{?fedora} < 21
+%if 0%{?fedora} < 18 && 0%{?rhel} < 6
%define system_nss 0
%else
%define system_nss 1
@@ -31,7 +31,7 @@
%global xulrunner_version 26.0
%global xulrunner_version_max 26.1
-%global xulrunner_release 1
+%global xulrunner_release 2
%global alpha_version 0
%global beta_version 0
%global rc_version 0
@@ -72,7 +72,7 @@
Summary: Mozilla Firefox Web browser
Name: firefox
Version: 26.0
-Release: 1%{?pre_tag}%{?dist}
+Release: 2%{?pre_tag}%{?dist}
URL: http://www.mozilla.org/projects/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
@@ -96,6 +96,7 @@ Patch15: firefox-15.0-enable-addons.patch
Patch16: firefox-duckduckgo.patch
# Upstream patches
+Patch20: mozilla-938730.patch
%if %{official_branding}
# Required by Mozilla Corporation
@@ -151,6 +152,7 @@ cd %{tarballdir}
%patch16 -p1 -b .duckduckgo
# Upstream patches
+%patch20 -p1 -b .938730
%if %{official_branding}
# Required by Mozilla Corporation
@@ -518,6 +520,14 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#---------------------------------------------------------------------
%changelog
+* Tue Dec 24 2013 Remi Collet <RPMS@FamilleCollet.com> - 26.0-2
+- sync patch with rawhide
+- rebuild against RHEL-6.5
+
+* Tue Dec 17 2013 Martin Stransky <stransky@redhat.com> - 26.0-4
+- Added fix for rhbz#1007603 - NSS and cert9 (sql): firefox crash
+ on exit with https-everywhere installed (edit)
+
* Tue Dec 10 2013 Remi Collet <RPMS@FamilleCollet.com> - 26.0-1
- sync with rawhide, update to 26.0 Build 2
diff --git a/mozilla-938730.patch b/mozilla-938730.patch
new file mode 100644
index 0000000..3b84553
--- /dev/null
+++ b/mozilla-938730.patch
@@ -0,0 +1,27 @@
+diff -up mozilla-release/storage/src/Makefile.in.938730 mozilla-release/storage/src/Makefile.in
+--- mozilla-release/storage/src/Makefile.in.938730 2013-12-09 15:15:44.708527295 +0100
++++ mozilla-release/storage/src/Makefile.in 2013-12-09 15:17:16.119682503 +0100
+@@ -6,14 +6,23 @@
+ # Don't use the jemalloc allocator on Android, because we can't guarantee
+ # that Gecko will configure sqlite before it is first used (bug 730495).
+ #
++# Don't use the jemalloc allocator when using system NSS. Linked in libraries
++# (such as NSS) might trigger an initialization of sqlite and allocation
++# of memory using the default allocator, prior to the storage service
++# registering its allocator, causing memory management failures (bug 938730).
++#
+ # Note: On Windows our sqlite build assumes we use jemalloc. If you disable
+ # MOZ_STORAGE_MEMORY on Windows, you will also need to change the "ifdef
+ # MOZ_MEMORY" options in db/sqlite3/src/Makefile.in.
++
++ifndef _USE_SYSTEM_NSS
+ ifdef MOZ_MEMORY
+ ifneq ($(OS_TARGET), Android)
+ DEFINES += -DMOZ_STORAGE_MEMORY
+ endif
+ endif
++endif
++
+
+ # For nsDependentJSString
+ LOCAL_INCLUDES = \