summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-06-24 15:08:28 +0200
committerRemi Collet <fedora@famillecollet.com>2013-06-24 15:08:28 +0200
commite1a9f0b298534c2b7b7335c9459515b5ea2ff264 (patch)
tree069406514a93b204f0e21c690e57262f64c641f2
parentf6c58693e58b540585725bb6ca65a47b245a09c4 (diff)
Xulrunner / Firefox 22.0
-rw-r--r--firefox-mozconfig1
-rw-r--r--firefox-mozconfig-debuginfo5
-rw-r--r--firefox-packager-build.patch12
-rw-r--r--firefox.sh.in4
-rw-r--r--firefox.spec43
5 files changed, 22 insertions, 43 deletions
diff --git a/firefox-mozconfig b/firefox-mozconfig
index d7757e1..88764b1 100644
--- a/firefox-mozconfig
+++ b/firefox-mozconfig
@@ -19,7 +19,6 @@ ac_add_options --enable-canvas
ac_add_options --enable-startup-notification
ac_add_options --enable-libxul
ac_add_options --with-system-libxul
-ac_add_options --disable-crashreporter
ac_add_options --enable-safe-browsing
ac_add_options --enable-libnotify
ac_add_options --disable-necko-wifi
diff --git a/firefox-mozconfig-debuginfo b/firefox-mozconfig-debuginfo
deleted file mode 100644
index 4dd2427..0000000
--- a/firefox-mozconfig-debuginfo
+++ /dev/null
@@ -1,5 +0,0 @@
-# For mozilla's debuginfo:
-export CFLAGS="$CFLAGS -gdwarf-2"
-export CXXFLAGS="$CXXFLAGS -gdwarf-2"
-export MOZ_DEBUG_SYMBOLS=1
-ac_add_options --enable-crashreporter
diff --git a/firefox-packager-build.patch b/firefox-packager-build.patch
deleted file mode 100644
index f35d566..0000000
--- a/firefox-packager-build.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up firefox-21.0/mozilla-release/toolkit/mozapps/installer/packager.py.old firefox-21.0/mozilla-release/toolkit/mozapps/installer/packager.py
---- firefox-21.0/mozilla-release/toolkit/mozapps/installer/packager.py.old 2013-05-15 08:27:23.000000000 +0200
-+++ firefox-21.0/mozilla-release/toolkit/mozapps/installer/packager.py 2013-05-15 08:27:54.828483740 +0200
-@@ -344,7 +344,7 @@ def main():
- # Fill startup cache
- if isinstance(formatter, OmniJarFormatter) and launcher.can_launch():
- if buildconfig.substs['LIBXUL_SDK']:
-- gre_path = buildconfig.substs['LIBXUL_DIST']
-+ gre_path = buildconfig.substs['LIBXUL_DIST'] + '/bin'
- else:
- gre_path = None
- for base in sorted([[p for p in [mozpack.path.join('bin', b), b]
diff --git a/firefox.sh.in b/firefox.sh.in
index 863f334..db9f6f3 100644
--- a/firefox.sh.in
+++ b/firefox.sh.in
@@ -135,11 +135,11 @@ GNOME_DISABLE_CRASH_DIALOG=1
export GNOME_DISABLE_CRASH_DIALOG
##
-## Use $MOZ_TMPDIR if set. Otherwise use /var/tmp instead of /tmp
+## Use $TMPDIR if set. Otherwise use /var/tmp instead of /tmp
## because of 1GB /tmp limit in Fedora 18 and later.
## See: https://bugzilla.redhat.com/show_bug.cgi?id=867073
##
-TMPDIR="${MOZ_TMPDIR:-/var/tmp}"
+TMPDIR="${TMPDIR:-/var/tmp}"
export TMPDIR
# OK, here's where all the real work gets done
diff --git a/firefox.spec b/firefox.spec
index e79b059..3ca098d 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -23,19 +23,19 @@
%endif
# Build as a debug package?
-%define debug_build 0
+%define debug_build 1
%define homepage http://start.fedoraproject.org/
%define default_bookmarks_file %{_datadir}/bookmarks/default-bookmarks.html
%define firefox_app_id \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
-%global xulrunner_version 21.0
-%global xulrunner_version_max 21.1
+%global xulrunner_version 22.0
+%global xulrunner_version_max 22.1
%global xulrunner_release 1
%global alpha_version 0
%global beta_version 0
%global rc_version 0
-%global datelang 20130514
+%global datelang 20130621
%global mozappdir %{_libdir}/%{name}
%global langpackdir %{mozappdir}/langpacks
@@ -43,7 +43,7 @@
%define official_branding 1
%define build_langpacks 1
-%define include_debuginfo 0
+%define include_debuginfo 1
%if %{alpha_version} > 0
%global pre_version a%{alpha_version}
@@ -70,8 +70,8 @@
Summary: Mozilla Firefox Web browser
Name: firefox
-Version: 21.0
-Release: 4%{?pre_tag}%{?dist}
+Version: 22.0
+Release: 1%{?pre_tag}%{?dist}
URL: http://www.mozilla.org/projects/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
@@ -82,14 +82,12 @@ Source1: firefox-langpacks-%{version}%{?pre_version}-%{datelang}.tar.xz
Source10: firefox-mozconfig
Source11: firefox-mozconfig-branded
Source12: firefox-redhat-default-prefs.js
-Source13: firefox-mozconfig-debuginfo
Source20: firefox.desktop
Source21: firefox.sh.in
Source23: firefox.1
#Build patches
Patch0: firefox-install-dir.patch
-Patch1: firefox-packager-build.patch
# Fedora patches
Patch14: firefox-5.0-asciidel.patch
@@ -142,7 +140,6 @@ cd %{tarballdir}
# there is a compare of config and js/config directories and .orig suffix is
# ignored during this compare.
%patch0 -p1
-%patch1 -p2 -b .build
# For branding specific patches.
@@ -174,9 +171,6 @@ cd %{tarballdir}
%if %{official_branding}
%{__cat} %{SOURCE11} >> .mozconfig
%endif
-%if %{include_debuginfo}
-%{__cat} %{SOURCE13} >> .mozconfig
-%endif
%if %{?system_nss}
echo "ac_add_options --with-system-nspr" >> .mozconfig
@@ -279,12 +273,6 @@ MOZ_SMP_FLAGS=-j1
export LDFLAGS="-Wl,-rpath,%{mozappdir}"
make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
-# create debuginfo for crash-stats.mozilla.com
-%if %{include_debuginfo}
-#cd %{moz_objdir}
-make buildsymbols
-%endif
-
#---------------------------------------------------------------------
%install
@@ -507,15 +495,24 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{mozappdir}/webapprt/omni.ja
%{mozappdir}/webapprt/webapprt.ini
%if %{include_debuginfo}
-#%{mozappdir}/crashreporter
-%{mozappdir}/crashreporter-override.ini
-#%{mozappdir}/Throbber-small.gif
-#%{mozappdir}/plugin-container
+%{mozappdir}/browser/crashreporter-override.ini
%endif
#---------------------------------------------------------------------
%changelog
+* Mon Jun 24 2013 Remi Collet <RPMS@FamilleCollet.com> - 22.0-1
+- Update to 22.0, sync with rawhide
+
+* Fri Jun 21 2013 Martin Stransky <stransky@redhat.com> - 22.0-1
+- Updated to latest upstream (22.0)
+
+* Thu Jun 13 2013 Jan Horak <jhorak@redhat.com> - 21.0-5
+- Enable Mozilla crash report tool
+
+* Thu May 23 2013 Jan Horak <jhorak@redhat.com> - 21.0-4
+- Do not override user defined TMPDIR variable
+
* Sun May 19 2013 Remi Collet <RPMS@FamilleCollet.com> - 21.0-4
- rebuild