summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2011-01-13 18:51:45 +0100
committerRemi Collet <fedora@famillecollet.com>2011-01-13 18:51:45 +0100
commit7aed93ad2afb086239f6c7a875a3e66320ad1608 (patch)
tree182f55e3c58f538d264659c3d1d36bc51c4d2c03
parent74fcd5ec0c12b0b8efce9a9b7d74d41490b07f01 (diff)
clean bis
-rw-r--r--firefox-dev.spec4
-rw-r--r--mozilla-ps-pdf-simplify-operators.patch42
2 files changed, 2 insertions, 44 deletions
diff --git a/firefox-dev.spec b/firefox-dev.spec
index ac54ebc..dd8a034 100644
--- a/firefox-dev.spec
+++ b/firefox-dev.spec
@@ -56,7 +56,7 @@ Source100: find-external-requires
#Patch0: xulrunner-version.patch => firefox / firefox4-version.patch
#Patch1: mozilla-build.patch
Patch1: firefox4-build.patch
-Patch3: firefox4-jemalloc.patch
+#Patch3: firefox4-jemalloc.patch
#Patch9: mozilla-build-sbrk.patch
Patch9: firefox4-build-sbrk.patch
Patch11: mozilla-malloc.patch
@@ -204,7 +204,7 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{internal_version}/' %{P:%%PATCH0} \
# Build Patches
%patch1 -p2 -b .build
-%patch3 -p1 -b .jemalloc
+#patch3 -p1 -b .jemalloc
%patch9 -p2 -b .sbrk
%patch11 -p2 -b .malloc
#patch12 -p1 -b .macos
diff --git a/mozilla-ps-pdf-simplify-operators.patch b/mozilla-ps-pdf-simplify-operators.patch
deleted file mode 100644
index cab1341..0000000
--- a/mozilla-ps-pdf-simplify-operators.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-https://bugzilla.mozilla.org/show_bug.cgi?id=435313
-
-Index: mozilla/gfx/thebes/public/gfxPDFSurface.h
-===================================================================
-RCS file: /cvsroot/mozilla/gfx/thebes/public/gfxPDFSurface.h,v
-retrieving revision 1.13
-diff -d -u -p -r1.13 gfxPDFSurface.h
---- mozilla/gfx/thebes/public/gfxPDFSurface.h 19 Mar 2008 20:51:42 -0000 1.13
-+++ mozilla/gfx/thebes/public/gfxPDFSurface.h 23 May 2008 00:50:31 -0000
-@@ -63,7 +63,11 @@ public:
- // this is in points!
- const gfxSize& GetSize() const { return mSize; }
-
-- virtual PRInt32 GetDefaultContextFlags() const { return gfxContext::FLAG_DISABLE_SNAPPING; }
-+ virtual PRInt32 GetDefaultContextFlags() const
-+ {
-+ return gfxContext::FLAG_SIMPLIFY_OPERATORS |
-+ gfxContext::FLAG_DISABLE_SNAPPING;
-+ }
-
- private:
- nsCOMPtr<nsIOutputStream> mStream;
-Index: mozilla/gfx/thebes/public/gfxPSSurface.h
-===================================================================
-RCS file: /cvsroot/mozilla/gfx/thebes/public/gfxPSSurface.h,v
-retrieving revision 1.13
-diff -d -u -p -r1.13 gfxPSSurface.h
---- mozilla/gfx/thebes/public/gfxPSSurface.h 19 Mar 2008 20:51:42 -0000 1.13
-+++ mozilla/gfx/thebes/public/gfxPSSurface.h 23 May 2008 00:50:31 -0000
-@@ -63,7 +63,11 @@ public:
- // this is in points!
- const gfxSize& GetSize() const { return mSize; }
-
-- virtual PRInt32 GetDefaultContextFlags() const { return gfxContext::FLAG_DISABLE_SNAPPING; }
-+ virtual PRInt32 GetDefaultContextFlags() const
-+ {
-+ return gfxContext::FLAG_SIMPLIFY_OPERATORS |
-+ gfxContext::FLAG_DISABLE_SNAPPING;
-+ }
-
- private:
- nsCOMPtr<nsIOutputStream> mStream;