summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2010-06-23 23:13:27 +0200
committerRemi Collet <fedora@famillecollet.com>2010-06-23 23:13:27 +0200
commit688197d7c210f4eefd25d26dab7c4addf1437a33 (patch)
treee71c12655af0fb2187399e99ada7edf119dfd8b4
parente3872cdaf1715e0245a77b64101e053f936d5306 (diff)
update Firefox to 3.6.4 (finale)
-rw-r--r--mozilla-192-pkgconfig.patch73
-rw-r--r--mozilla-build-sbrk.patch24
-rw-r--r--mozilla-plugin.patch10
-rw-r--r--nspr-build.patch35
-rw-r--r--xulrunner-1.9.2.1-build.patch12
5 files changed, 154 insertions, 0 deletions
diff --git a/mozilla-192-pkgconfig.patch b/mozilla-192-pkgconfig.patch
new file mode 100644
index 0000000..1f234a7
--- /dev/null
+++ b/mozilla-192-pkgconfig.patch
@@ -0,0 +1,73 @@
+diff -up mozilla-1.9.2/config/autoconf.mk.in.pk mozilla-1.9.2/config/autoconf.mk.in
+--- mozilla-1.9.2/config/autoconf.mk.in.pk 2009-11-09 01:33:58.000000000 +0100
++++ mozilla-1.9.2/config/autoconf.mk.in 2009-11-12 12:49:28.000000000 +0100
+@@ -58,14 +58,14 @@ MOZ_PKG_SPECIAL = @MOZ_PKG_SPECIAL@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ bindir = @bindir@
+-includedir = @includedir@/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
++includedir = @includedir@/$(MOZ_APP_NAME)-sdk-$(MOZ_APP_VERSION)
+ libdir = @libdir@
+ datadir = @datadir@
+ mandir = @mandir@
+-idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
++idldir = $(datadir)/idl/$(MOZ_APP_NAME)-sdk-$(MOZ_APP_VERSION)
+
+ installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+-sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
++sdkdir = $(libdir)/$(MOZ_APP_NAME)-sdk-$(MOZ_APP_VERSION)
+
+ DIST = $(DEPTH)/dist
+ LIBXUL_SDK = @LIBXUL_SDK@
+diff -up mozilla-1.9.2/xulrunner/installer/libxul-embedding.pc.in.pk mozilla-1.9.2/xulrunner/installer/libxul-embedding.pc.in
+--- mozilla-1.9.2/xulrunner/installer/libxul-embedding.pc.in.pk 2009-11-09 01:34:25.000000000 +0100
++++ mozilla-1.9.2/xulrunner/installer/libxul-embedding.pc.in 2009-11-12 13:09:18.000000000 +0100
+@@ -6,5 +6,6 @@ idldir=%idldir%
+ Name: libxul-embedding
+ Description: Static library for version-independent embedding of the Mozilla runtime
+ Version: %MOZILLA_VERSION%
++Requires: %NSPR_NAME% >= %NSPR_VERSION%
+ Libs: -L${sdkdir}/lib -lxpcomglue
+ Cflags: -DXPCOM_GLUE -I${includedir} %WCHAR_CFLAGS%
+diff -up mozilla-1.9.2/xulrunner/installer/libxul.pc.in.pk mozilla-1.9.2/xulrunner/installer/libxul.pc.in
+--- mozilla-1.9.2/xulrunner/installer/libxul.pc.in.pk 2009-11-09 01:34:25.000000000 +0100
++++ mozilla-1.9.2/xulrunner/installer/libxul.pc.in 2009-11-12 13:10:03.000000000 +0100
+@@ -2,6 +2,7 @@ prefix=%prefix%
+ sdkdir=%sdkdir%
+ includedir=%includedir%
+ idldir=%idldir%
++libdir=%libdir%
+
+ Name: libxul
+ Description: The Mozilla Runtime and Embedding Engine
+diff -up mozilla-1.9.2/xulrunner/installer/Makefile.in.pk mozilla-1.9.2/xulrunner/installer/Makefile.in
+--- mozilla-1.9.2/xulrunner/installer/Makefile.in.pk 2009-11-12 12:49:28.000000000 +0100
++++ mozilla-1.9.2/xulrunner/installer/Makefile.in 2009-11-12 12:49:28.000000000 +0100
+@@ -123,6 +123,7 @@ endif
+ -e "s|%includedir%|$(includedir)|" \
+ -e "s|%idldir%|$(idldir)|" \
+ -e "s|%sdkdir%|$(sdkdir)|" \
++ -e "s|%libdir%|$(installdir)|" \
+ -e "s|%MOZ_APP_NAME%|$(MOZ_APP_NAME)|" \
+ -e "s|%MOZILLA_VERSION%|$(MOZ_APP_VERSION)|" \
+ -e "s|%WCHAR_CFLAGS%|$(WCHAR_CFLAGS)|" \
+diff -up mozilla-1.9.2/xulrunner/installer/mozilla-gtkmozembed-embedding.pc.in.pk mozilla-1.9.2/xulrunner/installer/mozilla-gtkmozembed-embedding.pc.in
+--- mozilla-1.9.2/xulrunner/installer/mozilla-gtkmozembed-embedding.pc.in.pk 2009-11-09 01:34:25.000000000 +0100
++++ mozilla-1.9.2/xulrunner/installer/mozilla-gtkmozembed-embedding.pc.in 2009-11-12 12:49:28.000000000 +0100
+@@ -1,5 +1,6 @@
+ prefix=%prefix%
+ sdkdir=%sdkdir%
++libdir=%libdir%
+ includedir=%includedir%
+
+ Name: mozilla-gtkembedmoz
+diff -up mozilla-1.9.2/xulrunner/installer/mozilla-gtkmozembed.pc.in.pk mozilla-1.9.2/xulrunner/installer/mozilla-gtkmozembed.pc.in
+--- mozilla-1.9.2/xulrunner/installer/mozilla-gtkmozembed.pc.in.pk 2009-11-09 01:34:25.000000000 +0100
++++ mozilla-1.9.2/xulrunner/installer/mozilla-gtkmozembed.pc.in 2009-11-12 12:49:28.000000000 +0100
+@@ -1,5 +1,6 @@
+ prefix=%prefix%
+ sdkdir=%sdkdir%
++libdir=%libdir%
+ includedir=%includedir%
+
+ Name: mozilla-gtkembedmoz
diff --git a/mozilla-build-sbrk.patch b/mozilla-build-sbrk.patch
new file mode 100644
index 0000000..e7e8773
--- /dev/null
+++ b/mozilla-build-sbrk.patch
@@ -0,0 +1,24 @@
+diff -up xulrunner-1.9.2.1/mozilla-1.9.2/js/src/shell/js.cpp.sbrk xulrunner-1.9.2.1/mozilla-1.9.2/js/src/shell/js.cpp
+--- xulrunner-1.9.2.1/mozilla-1.9.2/js/src/shell/js.cpp.sbrk 2010-01-06 04:35:17.000000000 +0100
++++ xulrunner-1.9.2.1/mozilla-1.9.2/js/src/shell/js.cpp 2010-01-13 21:49:33.000000000 +0100
+@@ -1119,7 +1119,7 @@ GC(JSContext *cx, uintN argc, jsval *vp)
+ char buf[256];
+ JS_snprintf(buf, sizeof(buf), "before %lu, after %lu, break %08lx\n",
+ (unsigned long)preBytes, (unsigned long)rt->gcBytes,
+-#ifdef HAVE_SBRK
++#if 0
+ (unsigned long)sbrk(0)
+ #else
+ 0
+diff -up xulrunner-1.9.2.1/mozilla-1.9.2/js/src/xpconnect/shell/xpcshell.cpp.sbrk xulrunner-1.9.2.1/mozilla-1.9.2/js/src/xpconnect/shell/xpcshell.cpp
+--- xulrunner-1.9.2.1/mozilla-1.9.2/js/src/xpconnect/shell/xpcshell.cpp.sbrk 2010-01-06 04:35:19.000000000 +0100
++++ xulrunner-1.9.2.1/mozilla-1.9.2/js/src/xpconnect/shell/xpcshell.cpp 2010-01-13 22:32:46.000000000 +0100
+@@ -543,7 +543,7 @@ GC(JSContext *cx, JSObject *obj, uintN a
+ JS_GC(cx);
+ fprintf(gOutFile, "before %lu, after %lu, break %08lx\n",
+ (unsigned long)preBytes, (unsigned long)rt->gcBytes,
+-#if defined(XP_UNIX) && !defined(__SYMBIAN32__)
++#if 0 //defined(XP_UNIX) && !defined(__SYMBIAN32__)
+ (unsigned long)sbrk(0)
+ #else
+ 0
diff --git a/mozilla-plugin.patch b/mozilla-plugin.patch
new file mode 100644
index 0000000..75eac7e
--- /dev/null
+++ b/mozilla-plugin.patch
@@ -0,0 +1,10 @@
+diff -up mozilla-1.9.2/xulrunner/installer/mozilla-plugin.pc.in.old mozilla-1.9.2/xulrunner/installer/mozilla-plugin.pc.in
+--- mozilla-1.9.2/xulrunner/installer/mozilla-plugin.pc.in.old 2009-11-25 05:13:11.000000000 +0100
++++ mozilla-1.9.2/xulrunner/installer/mozilla-plugin.pc.in 2009-12-03 10:14:41.000000000 +0100
+@@ -5,5 +5,5 @@ includedir=%includedir%
+ Name: Mozilla Plug-In API
+ Description: Mozilla Plug-In API
+ Version: %MOZILLA_VERSION%
+-Cflags: -I${includedir}/stable -DXP_UNIX %ojidef%
++Cflags: -I${includedir} -DXP_UNIX %ojidef%
+
diff --git a/nspr-build.patch b/nspr-build.patch
new file mode 100644
index 0000000..fe7cc1b
--- /dev/null
+++ b/nspr-build.patch
@@ -0,0 +1,35 @@
+diff --git a/ipc/chromium/src/base/basictypes.h b/ipc/chromium/src/base/basictypes.h
+--- a/ipc/chromium/src/base/basictypes.h
++++ b/ipc/chromium/src/base/basictypes.h
+@@ -14,29 +14,29 @@
+ #error You_must_include_basictypes.h_before_prtypes.h!
+ #endif
+
+ #ifndef NO_NSPR_10_SUPPORT
+ #define NO_NSPR_10_SUPPORT
+ #define NO_NSPR_10_SUPPORT_SAVE
+ #endif
+
+-#include "nspr/prtypes.h"
++#include "prtypes.h"
+
+ #ifdef NO_NSPR_10_SUPPORT_SAVE
+ #undef NO_NSPR_10_SUPPORT_SAVE
+ #undef NO_NSPR_10_SUPPORT
+ #endif
+
+ #ifdef _WIN32
+ #undef _WIN32
+ #define _WIN32_SAVE
+ #endif
+
+-#include "nspr/obsolete/protypes.h"
++#include "obsolete/protypes.h"
+
+ #define _INT32
+ #define _UINT32
+
+ #ifdef _WIN32_SAVE
+ #undef _WIN32_SAVE
+ #define _WIN32
+ #endif
diff --git a/xulrunner-1.9.2.1-build.patch b/xulrunner-1.9.2.1-build.patch
new file mode 100644
index 0000000..12f966b
--- /dev/null
+++ b/xulrunner-1.9.2.1-build.patch
@@ -0,0 +1,12 @@
+diff -up xulrunner-1.9.2.1/mozilla-1.9.2/layout/generic/nsFrame.h.old xulrunner-1.9.2.1/mozilla-1.9.2/layout/generic/nsFrame.h
+--- xulrunner-1.9.2.1/mozilla-1.9.2/layout/generic/nsFrame.h.old 2009-11-11 15:34:51.000000000 +0100
++++ xulrunner-1.9.2.1/mozilla-1.9.2/layout/generic/nsFrame.h 2009-11-11 15:33:09.000000000 +0100
+@@ -157,7 +157,7 @@ private:
+ // Left undefined; nsFrame objects are never allocated from the heap.
+ void* operator new(size_t sz) CPP_THROW_NEW;
+
+-protected:
++public:
+ // Overridden to prevent the global delete from being called, since
+ // the memory came out of an arena instead of the heap.
+ //