summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2010-12-12 11:55:25 +0100
committerRemi Collet <fedora@famillecollet.com>2010-12-12 11:55:25 +0100
commit625edb59e04f800e31688b7e5bc69c8b8018748b (patch)
tree1082f3ef30e960f7cffd131ee29f600ae3015ccd
parentfc466de7fc81171ca0109979395afda5bee5fd65 (diff)
firefox 3.6.13
-rwxr-xr-xffxpi4
-rw-r--r--firefox.spec15
-rw-r--r--mozilla-crashreporter-static.patch11
3 files changed, 24 insertions, 6 deletions
diff --git a/ffxpi b/ffxpi
index 0de2600..8fea6e0 100755
--- a/ffxpi
+++ b/ffxpi
@@ -11,9 +11,9 @@ getxpi() {
then URL=http://releases.mozilla.org/pub/mozilla.org/firefox/releases/$1/linux-i686/xpi
else URL=ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/$1-candidates/$2/linux-i686/xpi/
fi
- # 74 extensions (25+25+24)
+ # 75 extensions (25+26+24)
for i in af ar as be bg bn-BD bn-IN ca cs cy da de el en-GB eo es-AR es-CL es-ES es-MX et eu fa fi fr fy-NL \
- ga-IE gl gu-IN he hi-IN hr hu id is it ja ka kk kn ko ku lt lv mk ml mn mr nb-NO nl nn-NO \
+ ga-IE gd gl gu-IN he hi-IN hr hu id is it ja ka kk kn ko ku lt lv mk ml mn mr nb-NO nl nn-NO \
oc or pa-IN pl pt-BR pt-PT rm ro ru si sk sl sq sr sv-SE ta-LK ta te th tr uk vi zh-CN zh-TW
do echo -en "$i\t"
[ -f $i.xpi ] && echo "already downloaded"
diff --git a/firefox.spec b/firefox.spec
index a2555c7..9efab42 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -29,7 +29,7 @@
Summary: Mozilla Firefox Web browser
Name: firefox
-Version: 3.6.12
+Version: 3.6.13
Release: 1%{?dist}
URL: http://www.mozilla.org/projects/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
@@ -43,7 +43,7 @@ Group: Applications/Internet
%endif
Source0: %{tarball}
%if %{build_langpacks}
-Source2: firefox-langpacks-%{version}%{?relcan}-20101028.tar.bz2
+Source2: firefox-langpacks-%{version}%{?relcan}-20101212.tar.bz2
%endif
Source12: firefox-redhat-default-prefs.js
# firefox3.destop without translation to allow change name
@@ -60,7 +60,6 @@ Patch1: mozilla-build.patch
Patch3: mozilla-jemalloc.patch
Patch4: mozilla-about-firefox-version.patch
Patch7: xulrunner-1.9.2.1-build.patch
-Patch8: mozilla-plugin.patch
Patch9: mozilla-build-sbrk.patch
Patch10: mozilla-build-s390.patch
Patch11: mozilla-gdk-pixbuf.patch
@@ -73,6 +72,7 @@ Patch31: firefox-default.patch
# Fedora specific patches
Patch20: mozilla-192-pkgconfig.patch
Patch21: mozilla-libjpeg-turbo.patch
+Patch22: mozilla-crashreporter-static.patch
# Remi specific patches
@@ -150,6 +150,7 @@ BuildRequires: libXrender-devel
BuildRequires: startup-notification-devel
BuildRequires: alsa-lib-devel
BuildRequires: autoconf213
+BuildRequires: libcurl-devel
%if %{fedora} >= 7
Requires: system-bookmarks
@@ -191,7 +192,6 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{internal_version}/' %{P:%%PATCH0} \
%patch3 -p1 -b .jemalloc
%patch4 -p1 -b .about-firefox-version
%patch7 -p2 -b .del
-%patch8 -p1 -b .plugin
%patch9 -p2 -b .sbrk
%ifarch s390
%patch10 -p1 -b .s390
@@ -204,6 +204,7 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{internal_version}/' %{P:%%PATCH0} \
%if %{fedora} >= 14
%patch21 -p2 -b .jpeg-turbo
%endif
+%patch22 -p1 -b .static
%patch30 -p1 -b .checkupdates
%patch31 -p2 -b .default
@@ -554,6 +555,12 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#---------------------------------------------------------------------
%changelog
+* Sun Dec 12 2010 Remi Collet <rpms@famillecollet.com> - 3.6.13-1
+- update to Firefox 3.6.13
+
+* Thu Dec 9 2010 Jan Horak <jhorak@redhat.com> - 3.6.13-1
+- Update to 3.6.13
+
* Thu Oct 28 2010 Remi Collet <rpms@famillecollet.com> - 3.6.12-1
- update to Firefox 3.6.12
diff --git a/mozilla-crashreporter-static.patch b/mozilla-crashreporter-static.patch
new file mode 100644
index 0000000..610b66e
--- /dev/null
+++ b/mozilla-crashreporter-static.patch
@@ -0,0 +1,11 @@
+diff -up mozilla-1.9.2/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in.static mozilla-1.9.2/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in
+--- mozilla-1.9.2/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in.static 2010-09-14 20:53:09.000000000 +0200
++++ mozilla-1.9.2/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in 2010-10-13 14:21:14.000000000 +0200
+@@ -64,6 +64,6 @@ FORCE_USE_PIC = 1
+
+ #XXX: bug 554854 causes us to be unable to run binaries on the build slaves
+ # due to them having an older libstdc++
+-HOST_LDFLAGS += -static
++#HOST_LDFLAGS += -static
+
+ include $(topsrcdir)/config/rules.mk