summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-10-29 19:24:17 +0100
committerRemi Collet <fedora@famillecollet.com>2013-10-29 19:24:17 +0100
commit4431bfb10b6f822e676a9b79c98f2c2648f194e6 (patch)
treeecdcd40b3bb39bf4c5e37c347c796249c06a3ff0
parent609436a7b4b1ef03fbb02dfa102d691cf6a273eb (diff)
Xulrunner / Firefox 25.0
-rw-r--r--firefox.sh.in6
-rw-r--r--firefox.spec48
2 files changed, 22 insertions, 32 deletions
diff --git a/firefox.sh.in b/firefox.sh.in
index db9f6f3..7964d3a 100644
--- a/firefox.sh.in
+++ b/firefox.sh.in
@@ -187,7 +187,7 @@ if [ $MOZILLA_DOWN -ne 0 ]; then
CURRENT_LOCALE=$LC_ALL
CURRENT_LOCALE=${CURRENT_LOCALE:-$LC_MESSAGES}
CURRENT_LOCALE=${CURRENT_LOCALE:-$LANG}
-
+
# Try with a local variant first, then without a local variant
SHORTMOZLOCALE=`echo $CURRENT_LOCALE | sed "s|_\([^.]*\).*||g"`
MOZLOCALE=`echo $CURRENT_LOCALE | sed "s|_\([^.]*\).*|-\1|g"`
@@ -213,6 +213,10 @@ if [ $MOZILLA_DOWN -ne 0 ]; then
create_langpack_link $MOZLOCALE || create_langpack_link $SHORTMOZLOCALE || true
fi
+# BEAST fix (rhbz#1005611)
+NSS_SSL_CBC_RANDOM_IV=${NSS_SSL_CBC_RANDOM_IV-1}
+export NSS_SSL_CBC_RANDOM_IV
+
# Prepare command line arguments
script_args=""
pass_arg_count=0
diff --git a/firefox.spec b/firefox.spec
index 58dd2d9..38eab60 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -29,13 +29,13 @@
%define default_bookmarks_file %{_datadir}/bookmarks/default-bookmarks.html
%define firefox_app_id \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
-%global xulrunner_version 24.0
-%global xulrunner_version_max 24.1
+%global xulrunner_version 25.0
+%global xulrunner_version_max 25.1
%global xulrunner_release 1
%global alpha_version 0
%global beta_version 0
%global rc_version 0
-%global datelang 20130913
+%global datelang 20131024
%global mozappdir %{_libdir}/%{name}
%global langpackdir %{mozappdir}/langpacks
@@ -71,7 +71,7 @@
Summary: Mozilla Firefox Web browser
Name: firefox
-Version: 24.0
+Version: 25.0
Release: 1%{?pre_tag}%{?dist}
URL: http://www.mozilla.org/projects/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
@@ -515,6 +515,18 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#---------------------------------------------------------------------
%changelog
+* Tue Oct 29 2013 Remi Collet <RPMS@FamilleCollet.com> - 25.0-1
+- sync with rawhide, update to 25.0
+
+* Thu Oct 24 2013 Martin Stransky <stransky@redhat.com> - 25.0-2
+- Fixed xulrunner dependency
+
+* Thu Oct 24 2013 Martin Stransky <stransky@redhat.com> - 25.0-1
+- Update to 25.0 Build 2
+
+* Thu Oct 17 2013 Martin Stransky <stransky@redhat.com> - 24.0-2
+- Fixed rhbz#1005611 - BEAST workaround not enabled in Firefox
+
* Mon Sep 16 2013 Remi Collet <RPMS@FamilleCollet.com> - 24.0-1
- sync with rawhide, update to 24.0
@@ -540,7 +552,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
* Wed Aug 7 2013 Remi Collet <RPMS@FamilleCollet.com> - 23.0-1
- sync with rawhide, update to 23.0
-* Mon Aug 5 2013 Martin Stransky <stransky@redhat.com> - 23.0-1
+* Mon Aug 5 2013 Martin Stransky <stransky@redhat.com> - 23.0-1
- Updated to latest upstream (23.0 Build 2)
* Thu Jul 25 2013 Martin Stransky <stransky@redhat.com> - 22.0-3
@@ -959,29 +971,3 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
* Tue Jan 4 2011 Martin Stransky <stransky@redhat.com> - 4.0-0.8b8
- Fixed rhbz#664877 - Cannot read application.ini
-
-* Tue Dec 21 2010 Martin Stransky <stransky@redhat.com> - 4.0-0.7b8
-- Update to Beta 8
-- Fixed rhbz#437608 - When prelink is installed,
- rpm builds are garbage
-
-* Wed Dec 8 2010 Christopher Aillon <caillon@redhat.com> - 4.0-0.6b7
-- Use official branding since this is an official beta
-- Fix Tab Candy/Panorama (#658573)
-
-* Thu Nov 11 2010 Jan Horak <jhorak@redhat.com> - 4.0b7-1
-- Update to 4.0b7
-- Added x-scheme-handler to firefox.desktop
-
-* Wed Sep 29 2010 jkeating - 4.0-0.4b6
-- Rebuilt for gcc bug 634757
-
-* Tue Sep 21 2010 Martin Stransky <stransky@redhat.com> - 4.0-0.3.b6
-- Update to 4.0 Beta 6
-
-* Tue Sep 7 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 4.0-0.2.b4
-- get package building and mostly functional
-
-* Mon Aug 30 2010 Martin Stransky <stransky@redhat.com> - 4.0-0.1.b4
-- Update to 4.0 Beta 4
-