summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2010-05-13 16:22:15 +0200
committerRemi Collet <fedora@famillecollet.com>2010-05-13 16:22:15 +0200
commit38a23ef90eab3e798260999d546e4b62beb30838 (patch)
treed41bbac5c7057320301a11156fd8c1fc95a34acb
parent139f64c6307428ff5ccc8a6e3fd5fa607f2f95ef (diff)
Firefox 3.6.4build3
-rw-r--r--Makefile14
-rw-r--r--firefox-remi.patch30
-rw-r--r--firefox.spec43
-rw-r--r--firefox36.sh.in98
-rw-r--r--mozilla-191-pkgconfig.patch142
-rw-r--r--mozilla-jemalloc-526152.patch19
-rw-r--r--mozilla-jemalloc.patch4
7 files changed, 171 insertions, 179 deletions
diff --git a/Makefile b/Makefile
index 1e65467..0e9fe75 100644
--- a/Makefile
+++ b/Makefile
@@ -2,3 +2,17 @@ SRCDIR := $(shell pwd)
NAME := $(shell basename $(SRCDIR))
include ../common/Makefile
+
+checkcvs:
+ for file in fire* moz* fin*; \
+ do \
+ if [ -f /home/extras/CVS/firefox/devel/$$file ]; then \
+ echo "--------- $$file (firefox)"; \
+ diff -u /home/extras/CVS/firefox/devel/$$file $$file; \
+ elif [ -f /home/extras/CVS/xulrunner/devel/$$file ]; then \
+ echo "--------- $$file (xulrunner)"; \
+ diff -u /home/extras/CVS/xulrunner/devel/$$file $$file; \
+ else \
+ echo "--------- $$file NOTFOUND"; \
+ fi; \
+ done
diff --git a/firefox-remi.patch b/firefox-remi.patch
new file mode 100644
index 0000000..038058e
--- /dev/null
+++ b/firefox-remi.patch
@@ -0,0 +1,30 @@
+--- mozilla-1.9.2/layout/generic/nsFrame.h.orig 2009-11-06 19:29:14.000000000 +0100
++++ mozilla-1.9.2/layout/generic/nsFrame.h 2009-11-06 19:30:54.000000000 +0100
+@@ -153,23 +153,14 @@
+ friend nsIFrame* NS_NewEmptyFrame(nsIPresShell* aShell,
+ nsStyleContext* aContext);
+
++
++ // Set this public as in 1.9.1 !
++ void operator delete(void* aPtr, size_t sz);
++
+ private:
+ // Left undefined; nsFrame objects are never allocated from the heap.
+ void* operator new(size_t sz) CPP_THROW_NEW;
+
+-protected:
+- // Overridden to prevent the global delete from being called, since
+- // the memory came out of an arena instead of the heap.
+- //
+- // Ideally this would be private and undefined, like the normal
+- // operator new. Unfortunately, the C++ standard requires an
+- // overridden operator delete to be accessible to any subclass that
+- // defines a virtual destructor, so we can only make it protected;
+- // worse, some C++ compilers will synthesize calls to this function
+- // from the "deleting destructors" that they emit in case of
+- // delete-expressions, so it can't even be undefined.
+- void operator delete(void* aPtr, size_t sz);
+-
+ public:
+
+ // nsQueryFrame
diff --git a/firefox.spec b/firefox.spec
index cb0bc10..5e1c141 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -13,8 +13,7 @@
%define mozappdir %{_libdir}/firefox-%{internal_version}
-#define tarballdir mozilla-1.9.2
-%define tarballdir firefox-lorentz
+%define tarballdir mozilla-1.9.2
%define official_branding 1
%define build_langpacks 1
@@ -24,13 +23,13 @@
%define nightly .cvs%{cvsdate}
%endif
-%define relcan plugin1
+#define relcan plugin1
%define firefox firefox
Summary: Mozilla Firefox Web browser
Name: firefox
-Version: 3.6.3
-Release: 2.plugin1%{?dist}
+Version: 3.6.4
+Release: 0.1.build3%{?dist}
URL: http://www.mozilla.org/projects/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
@@ -43,7 +42,7 @@ Group: Applications/Internet
%endif
Source0: %{tarball}
%if %{build_langpacks}
-Source2: firefox-langpacks-%{version}%{?relcan}-20100410.tar.bz2
+Source2: firefox-langpacks-%{version}%{?relcan}-20100513.tar.bz2
%endif
Source12: firefox-redhat-default-prefs.js
# firefox3.destop without translation to allow change name
@@ -62,13 +61,13 @@ Patch4: mozilla-about-firefox-version.patch
Patch5: mozilla-jemalloc-526152.patch
# Fedora specific patches
-Patch10: mozilla-191-pkgconfig.patch
# Upstream patches
Patch100: mozilla-ps-pdf-simplify-operators.patch
-# Remi
-Patch200: xulrunner-remi.patch
+# Remi specific patches
+Patch200: firefox-remi.patch
+
%if %{official_branding}
# Required by Mozilla Corporation
@@ -170,8 +169,6 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{internal_version}/' %{P:%%PATCH0} \
%patch4 -p1 -b .about-firefox-version
%patch5 -p1 -b .jemalloc-526152
-#%patch10 -p1 -b .pk
-
%patch100 -p1 -b .ps-pdf-simplify-operators
%patch200 -p1 -b .remi
@@ -189,9 +186,7 @@ ac_add_options --libdir="\$LIBDIR"
ac_add_options --enable-system-sqlite
%endif
%if %{fedora} >= 11
-%if "%{relcan}" != "plugin1"
-ac_add_options --with-system-nspr
-%endif
+## Not working since plugin version.... ac_add_options --with-system-nspr
ac_add_options --with-system-nss
ac_add_options --enable-system-hunspell
ac_add_options --enable-system-cairo
@@ -356,11 +351,11 @@ ln -s %{default_bookmarks_file} $RPM_BUILD_ROOT/%{mozappdir}/defaults/profile/bo
echo > ../%{name}.lang
%if %{build_langpacks}
# Install langpacks
-%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/extensions
+%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
%{__tar} xjf %{SOURCE2}
for langpack in `ls firefox-langpacks/*.xpi`; do
language=`basename $langpack .xpi`
- extensiondir=$RPM_BUILD_ROOT/%{mozappdir}/extensions/langpack-$language@firefox.mozilla.org
+ extensiondir=$RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-$language@firefox.mozilla.org
%{__mkdir_p} $extensiondir
unzip $langpack -d $extensiondir
find $extensiondir -type f | xargs chmod 644
@@ -408,6 +403,10 @@ touch $RPM_BUILD_ROOT/%{mozappdir}/components/xpti.dat
# jemalloc shows up sometimes, but it's not needed here, it's in XR
#%{__rm} -f $RPM_BUILD_ROOT/%{mozappdir}/libjemalloc.so
+# Remi : this appears on Fedora <= 10
+%{__rm} -f $RPM_BUILD_ROOT/%{mozappdir}/*.chk
+
+
#---------------------------------------------------------------------
%clean
@@ -444,6 +443,7 @@ update-desktop-database &> /dev/null || :
if [ $1 -eq 0 ]; then
%{__rm} -rf %{mozappdir}/components
%{__rm} -rf %{mozappdir}/extensions
+ %{__rm} -rf %{mozappdir}/langpacks
%{__rm} -rf %{mozappdir}/plugins
fi
@@ -475,6 +475,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{mozappdir}/dictionaries
%dir %{mozappdir}/extensions
%{mozappdir}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
+%dir %{mozappdir}/langpacks
%{mozappdir}/icons
%{mozappdir}/searchplugins
%{mozappdir}/firefox
@@ -483,9 +484,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{mozappdir}/plugins
%{mozappdir}/res
%{mozappdir}/*.so
-%if "%{relcan}" == "plugin1"
-%{mozappdir}/mozilla-runtime
-%endif
+%{mozappdir}/plugin-container
%{mozappdir}/mozilla-xremote-client
%{mozappdir}/platform.ini
%{mozappdir}/run-mozilla.sh
@@ -493,9 +492,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{mozappdir}/.autoreg
# XXX See if these are needed still
%{mozappdir}/update*
-%if %{fedora} <= 10
-%{mozappdir}/*.chk
-%endif
%exclude %{mozappdir}/removed-files
%exclude %{_includedir}/firefox-%{internal_version}
%exclude %{_libdir}/firefox-devel-%{internal_version}
@@ -510,6 +506,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#---------------------------------------------------------------------
%changelog
+* Thu May 13 2010 Remi Collet <rpms@famillecollet.com> - 3.6.4-0.1.build3
+- update to Firefox 3.6.4 Beta (build3)
+
* Sat Apr 10 2010 Remi Collet <rpms@famillecollet.com> - 3.6.3-2.plugin1
- update to Firefox "lorentz" 3.6.3plugin1
diff --git a/firefox36.sh.in b/firefox36.sh.in
index ecbdad6..4822393 100644
--- a/firefox36.sh.in
+++ b/firefox36.sh.in
@@ -23,7 +23,7 @@
##
## Usage:
##
-## $ mozilla
+## $ firefox
##
## This script is meant to run a mozilla program from the mozilla
## rpm installation.
@@ -38,7 +38,7 @@ cmdname=`basename $0`
##
MOZ_ARCH=$(uname -m)
case $MOZ_ARCH in
- x86_64 | ia64 | s390 )
+ x86_64 | s390x | sparc64)
MOZ_LIB_DIR="/usr/lib64"
SECONDARY_LIB_DIR="/usr/lib"
;;
@@ -59,14 +59,16 @@ if [ ! -x $MOZ_LIB_DIR/firefox-FIREFOX_VERSION/firefox ]; then
MOZ_LIB_DIR="$SECONDARY_LIB_DIR"
fi
MOZ_DIST_BIN="$MOZ_LIB_DIR/firefox-FIREFOX_VERSION"
-MOZ_EXTENSIONS_DIR="$MOZ_DIST_BIN/extensions"
+## not used for remi ## MOZ_XUL_DIR="$MOZ_LIB_DIR/XULRUNNER_DIRECTORY"
+MOZ_LANGPACKS_DIR="$MOZ_DIST_BIN/langpacks"
+MOZ_EXTENSIONS_PROFILE_DIR="$HOME/.mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}"
MOZ_PROGRAM="$MOZ_DIST_BIN/firefox"
MOZ_LAUCHER="$MOZ_DIST_BIN/run-mozilla.sh"
##
## Set MOZ_GRE_CONF
##
-## This build use bundled Xulrunner
+## Not used for remi ## This build use bundled Xulrunner
##
## Set MOZILLA_FIVE_HOME
@@ -98,6 +100,11 @@ fi
export MOZ_PLUGIN_PATH
##
+## Set MOZ_APP_LAUNCHER for gnome-session
+##
+export MOZ_APP_LAUNCHER="/usr/bin/firefox"
+
+##
## If plugins are wrapped, check them
##
if [ -x "/usr/bin/mozilla-plugin-config" ]
@@ -132,15 +139,86 @@ export GNOME_DISABLE_CRASH_DIALOG
# OK, here's where all the real work gets done
+
+##
+## To disable the use of Firefox localization, set MOZ_DISABLE_LANGPACKS=1
+## in your environment before launching Firefox.
+##
+#
+# MOZ_DISABLE_LANGPACKS=1
+# export MOZ_DISABLE_LANGPACKS
+#
+
+##
+## Automatically installed langpacks are tracked by .fedora-langpack-install
+## config file.
+##
+FEDORA_LANGPACK_CONFIG="$MOZ_EXTENSIONS_PROFILE_DIR/.fedora-langpack-install"
+
# check system locale
MOZARGS=
-# Try without a local variant first, then with a local variant
-# So that pt-BR doesn't try to use pt for example
-SHORTMOZLOCALE=`echo $LC_MESSAGES | sed "s|_\([^.]*\).*||g"`
-[ -f $MOZ_EXTENSIONS_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org/chrome/$SHORTMOZLOCALE.jar ] && MOZARGS="-UILocale $SHORTMOZLOCALE"
-MOZLOCALE=`echo $LC_MESSAGES | sed "s|_\([^.]*\).*|-\1|g"`
-[ -f $MOZ_EXTENSIONS_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org/chrome/$MOZLOCALE.jar ] && MOZARGS="-UILocale $MOZLOCALE"
+# MOZ_DISABLE_LANGPACKS disables language packs completelly
+MOZILLA_DOWN=0
+if ! [ $MOZ_DISABLE_LANGPACKS ] || [ $MOZ_DISABLE_LANGPACKS -eq 0 ]; then
+ if [ -x $MOZ_XUL_DIR/mozilla-xremote-client ]; then
+ # Is firefox running?
+ $MOZ_XUL_DIR/mozilla-xremote-client -a firefox 'ping()' > /dev/null 2>&1
+ MOZILLA_DOWN=$?
+ fi
+fi
+
+# Modify language pack configuration only when firefox is not running
+# and language packs are not disabled
+if [ $MOZILLA_DOWN -ne 0 ]; then
+
+ # Clear already installed langpacks
+ mkdir -p $MOZ_EXTENSIONS_PROFILE_DIR
+ if [ -f $FEDORA_LANGPACK_CONFIG ]; then
+ rm `cat $FEDORA_LANGPACK_CONFIG` > /dev/null 2>&1
+ rm $FEDORA_LANGPACK_CONFIG > /dev/null 2>&1
+ fi
+
+ # Get locale from system
+ CURRENT_LOCALE=$LC_ALL
+ CURRENT_LOCALE=${CURRENT_LOCALE:-$LC_MESSAGES}
+ CURRENT_LOCALE=${CURRENT_LOCALE:-$LANG}
+
+ # Try without a local variant first, then with a local variant
+ # So that pt-BR doesn't try to use pt for example
+ SHORTMOZLOCALE=`echo $CURRENT_LOCALE | sed "s|_\([^.]*\).*||g"`
+ MOZLOCALE=`echo $CURRENT_LOCALE | sed "s|_\([^.]*\).*|-\1|g"`
+
+ # Try to link global langpacks to an extension directory
+ if [ -f $MOZ_LANGPACKS_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org/chrome/$SHORTMOZLOCALE.jar ]; then
+ if [ -d $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org ]; then
+ rmdir "$MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org" > /dev/null 2>&1
+ fi
+ if ! [ -e $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org ]; then
+ ln -s $MOZ_LANGPACKS_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org \
+ $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org
+ echo "$MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org" > $FEDORA_LANGPACK_CONFIG
+ fi
+ elif [ -f $MOZ_LANGPACKS_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org/chrome/$MOZLOCALE.jar ]; then
+ if [ -d $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org ]; then
+ rmdir "$MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org" > /dev/null 2>&1
+ fi
+ if ! [ -e $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org ]; then
+ ln -s $MOZ_LANGPACKS_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org \
+ $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org
+ echo "$MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org" > $FEDORA_LANGPACK_CONFIG
+ fi
+ fi
+
+ # And set it up for mozilla
+ if [ -f $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org/chrome/$SHORTMOZLOCALE.jar ]; then
+ MOZARGS="-UILocale $SHORTMOZLOCALE"
+ else
+ if [ -f $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org/chrome/$MOZLOCALE.jar ]; then
+ MOZARGS="-UILocale $MOZLOCALE"
+ fi
+ fi
+fi
# Prepare command line arguments
script_args=""
diff --git a/mozilla-191-pkgconfig.patch b/mozilla-191-pkgconfig.patch
deleted file mode 100644
index d894533..0000000
--- a/mozilla-191-pkgconfig.patch
+++ /dev/null
@@ -1,142 +0,0 @@
-diff -r f1af606531f5 config/autoconf.mk.in
---- a/config/autoconf.mk.in Sat Nov 22 20:22:22 2008 +0100
-+++ b/config/autoconf.mk.in Mon Dec 01 22:30:12 2008 -0500
-@@ -57,14 +57,14 @@
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- bindir = @bindir@
--includedir = @includedir@/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-+includedir = @includedir@/$(MOZ_APP_NAME)-sdk-$(MOZ_APP_VERSION)
- libdir = @libdir@
- datadir = @datadir@
- mandir = @mandir@
--idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
-+idldir = $(datadir)/idl/$(MOZ_APP_NAME)-sdk-$(MOZ_APP_VERSION)
-
- installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
--sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
-+sdkdir = $(libdir)/$(MOZ_APP_NAME)-sdk-$(MOZ_APP_VERSION)
-
- DIST = $(DEPTH)/dist
- LIBXUL_SDK = @LIBXUL_SDK@
-diff -r f1af606531f5 xulrunner/installer/Makefile.in
---- a/xulrunner/installer/Makefile.in Sat Nov 22 20:22:22 2008 +0100
-+++ b/xulrunner/installer/Makefile.in Mon Dec 01 22:30:12 2008 -0500
-@@ -116,6 +118,7 @@
- -e "s|%includedir%|$(includedir)|" \
- -e "s|%idldir%|$(idldir)|" \
- -e "s|%sdkdir%|$(sdkdir)|" \
-+ -e "s|%libdir%|$(installdir)|" \
- -e "s|%MOZ_APP_NAME%|$(MOZ_APP_NAME)|" \
- -e "s|%MOZILLA_VERSION%|$(MOZ_APP_VERSION)|" \
- -e "s|%WCHAR_CFLAGS%|$(WCHAR_CFLAGS)|" \
-diff -r f1af606531f5 xulrunner/installer/libxul-embedding-unstable.pc.in
---- a/xulrunner/installer/libxul-embedding-unstable.pc.in Sat Nov 22 20:22:22 2008 +0100
-+++ b/xulrunner/installer/libxul-embedding-unstable.pc.in Mon Dec 01 22:30:12 2008 -0500
-@@ -1,11 +1,12 @@
- prefix=%prefix%
- sdkdir=%sdkdir%
- includedir=%includedir%
--idldir=%idldir%
-+idldir=%idldir%/unstable
- includetype=unstable
-
- Name: libxul-embedding-unstable
- Description: Static library for version-independent embedding of the Mozilla runtime (unstable API)
- Version: %MOZILLA_VERSION%
-+Requires: %NSPR_NAME% >= %NSPR_VERSION%
- Libs: -L${sdkdir}/lib -lxpcomglue
- Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} %WCHAR_CFLAGS%
-diff -r f1af606531f5 xulrunner/installer/libxul-embedding.pc.in
---- a/xulrunner/installer/libxul-embedding.pc.in Sat Nov 22 20:22:22 2008 +0100
-+++ b/xulrunner/installer/libxul-embedding.pc.in Mon Dec 01 22:30:12 2008 -0500
-@@ -1,7 +1,7 @@
- prefix=%prefix%
- sdkdir=%sdkdir%
- includedir=%includedir%
--idldir=%idldir%
-+idldir=%idldir%/stable
- includetype=stable
-
- # Note: the default pkg-config cflags will only list include directories
-@@ -11,5 +11,6 @@
- Name: libxul-embedding
- Description: Static library for version-independent embedding of the Mozilla runtime
- Version: %MOZILLA_VERSION%
--Libs: -L${sdkdir}/lib -lxpcomglue
-+Requires: %NSPR_NAME% >= %NSPR_VERSION%
-+Libs: -L${sdkdir}/sdk/lib -lxpcomglue
- Cflags: -DXPCOM_GLUE -I${includedir}/${includetype} %WCHAR_CFLAGS%
-diff -r f1af606531f5 xulrunner/installer/libxul-unstable.pc.in
---- a/xulrunner/installer/libxul-unstable.pc.in Sat Nov 22 20:22:22 2008 +0100
-+++ b/xulrunner/installer/libxul-unstable.pc.in Mon Dec 01 22:30:12 2008 -0500
-@@ -1,7 +1,8 @@
- prefix=%prefix%
- sdkdir=%sdkdir%
-+libdir=%libdir%
- includedir=%includedir%
--idldir=%idldir%
-+idldir=%idldir%/unstable
- includetype=unstable
-
- Name: libxul
-diff -r f1af606531f5 xulrunner/installer/libxul.pc.in
---- a/xulrunner/installer/libxul.pc.in Sat Nov 22 20:22:22 2008 +0100
-+++ b/xulrunner/installer/libxul.pc.in Mon Dec 01 22:30:12 2008 -0500
-@@ -1,7 +1,8 @@
- prefix=%prefix%
- sdkdir=%sdkdir%
-+libdir=%libdir%
- includedir=%includedir%
--idldir=%idldir%
-+idldir=%idldir%/stable
- includetype=stable
-
- # Note: the default pkg-config includes will only list include directories
-@@ -12,5 +13,5 @@
- Description: The Mozilla Runtime and Embedding Engine
- Version: %MOZILLA_VERSION%
- Requires: %NSPR_NAME% >= %NSPR_VERSION%
--Libs: -L${sdkdir}/lib -lxpcomglue_s -lxul -lxpcom
-+Libs: -L${sdkdir}/sdk/lib -lxpcomglue_s -lxul -lxpcom
- Cflags: -I${includedir}/${includetype} %WCHAR_CFLAGS%
-diff -r f1af606531f5 xulrunner/installer/mozilla-gtkmozembed-embedding.pc.in
---- a/xulrunner/installer/mozilla-gtkmozembed-embedding.pc.in Sat Nov 22 20:22:22 2008 +0100
-+++ b/xulrunner/installer/mozilla-gtkmozembed-embedding.pc.in Mon Dec 01 22:30:12 2008 -0500
-@@ -1,5 +1,6 @@
- prefix=%prefix%
- sdkdir=%sdkdir%
-+libdir=%libdir%
- includedir=%includedir%
-
- Name: mozilla-gtkembedmoz
-diff -r f1af606531f5 xulrunner/installer/mozilla-gtkmozembed.pc.in
---- a/xulrunner/installer/mozilla-gtkmozembed.pc.in Sat Nov 22 20:22:22 2008 +0100
-+++ b/xulrunner/installer/mozilla-gtkmozembed.pc.in Mon Dec 01 22:30:12 2008 -0500
-@@ -1,5 +1,6 @@
- prefix=%prefix%
- sdkdir=%sdkdir%
-+libdir=%libdir%
- includedir=%includedir%
-
- Name: mozilla-gtkembedmoz
-diff -r f1af606531f5 xulrunner/installer/mozilla-js.pc.in
---- a/xulrunner/installer/mozilla-js.pc.in Sat Nov 22 20:22:22 2008 +0100
-+++ b/xulrunner/installer/mozilla-js.pc.in Mon Dec 01 22:30:12 2008 -0500
-@@ -6,5 +6,5 @@
- Description: The Mozilla JavaScript Library
- Version: %MOZILLA_VERSION%
- Requires: %NSPR_NAME% >= %NSPR_VERSION%
--Libs: -L${sdkdir}/lib -lmozjs
--Cflags: -I${includedir}/stable -DXP_UNIX -DJS_THREADSAFE
-+Libs: -L${sdkdir}/sdk/lib -lmozjs
-+Cflags: -I${includedir}/stable -I${includedir}/js -DXP_UNIX -DJS_THREADSAFE
-diff -r f1af606531f5 xulrunner/installer/mozilla-plugin.pc.in
---- a/xulrunner/installer/mozilla-plugin.pc.in Sat Nov 22 20:22:22 2008 +0100
-+++ b/xulrunner/installer/mozilla-plugin.pc.in Mon Dec 01 22:30:12 2008 -0500
-@@ -6,4 +6,4 @@
- Description: Mozilla Plug-In API
- Version: %MOZILLA_VERSION%
- Requires: %NSPR_NAME% >= %NSPR_VERSION%
--Cflags: -I${includedir}/stable -DXP_UNIX %ojidef%
-+Cflags: -I${includedir}/stable -DXP_UNIX %ojidef% -I${includedir}/java -I${includedir}/plugin
diff --git a/mozilla-jemalloc-526152.patch b/mozilla-jemalloc-526152.patch
index 6ffce7a..5f60485 100644
--- a/mozilla-jemalloc-526152.patch
+++ b/mozilla-jemalloc-526152.patch
@@ -1,6 +1,14 @@
---- mozilla-1.9.2/memory/jemalloc/jemalloc.c.orig 2009-12-17 21:56:35.000000000 +0100
-+++ mozilla-1.9.2/memory/jemalloc/jemalloc.c 2009-12-17 21:57:32.000000000 +0100
-@@ -5822,14 +5822,14 @@
+From: David Mandelin <dmandelin@mozilla.com>
+
+diff --git a/memory/jemalloc/jemalloc.c b/memory/jemalloc/jemalloc.c
+--- a/memory/jemalloc/jemalloc.c
++++ b/memory/jemalloc/jemalloc.c
+@@ -5792,24 +5792,24 @@ __attribute__((noinline))
+ #else
+ inline
+ #endif
+ void *
+ memalign(size_t alignment, size_t size)
{
void *ret;
@@ -17,3 +25,8 @@
ret = ipalloc(alignment, size);
RETURN:
+ #ifdef MALLOC_XMALLOC
+ if (opt_xmalloc && ret == NULL) {
+ _malloc_message(_getprogname(),
+ ": (malloc) Error in memalign(): out of memory\n", "", "");
+ abort();
diff --git a/mozilla-jemalloc.patch b/mozilla-jemalloc.patch
index 2ef0b97..aabd690 100644
--- a/mozilla-jemalloc.patch
+++ b/mozilla-jemalloc.patch
@@ -1,6 +1,6 @@
diff -r f1af606531f5 memory/jemalloc/jemalloc.h
---- mozilla/memory/jemalloc/jemalloc.h Sat Nov 22 20:22:22 2008 +0100
-+++ mozilla/memory/jemalloc/jemalloc.h Mon Dec 01 16:53:06 2008 -0500
+--- a/memory/jemalloc/jemalloc.h Sat Nov 22 20:22:22 2008 +0100
++++ b/memory/jemalloc/jemalloc.h Mon Dec 01 16:53:06 2008 -0500
@@ -45,14 +45,14 @@
} jemalloc_stats_t;