summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2010-11-06 13:01:57 +0100
committerRemi Collet <fedora@famillecollet.com>2010-11-06 13:01:57 +0100
commit1d81a7236ec40ce5367e824cd7c74a7e0f8d1fff (patch)
treeec2abc18f1b3d5422d26bba55a6d9558b157b159
parent1e280f45ccf3289598a4a288227eac1e555242b7 (diff)
firefox 4.0b7 build1
-rw-r--r--firefox-dev.spec59
-rw-r--r--firefox4-disable-checkupdates.patch11
-rw-r--r--firefox4-libjpeg-turbo.patch31
-rw-r--r--firefox4.sh.in9
-rw-r--r--mozilla-notify.patch13
-rw-r--r--wmclass.patch29
6 files changed, 102 insertions, 50 deletions
diff --git a/firefox-dev.spec b/firefox-dev.spec
index 9684cd6..526ecbb 100644
--- a/firefox-dev.spec
+++ b/firefox-dev.spec
@@ -23,14 +23,14 @@
%define nightly .cvs%{cvsdate}
%endif
-%global relcan b6
+%global relcan b7
%global firefox firefox
-%global mycomment Beta 6
+%global mycomment Beta 7 Build 1 candidate
Summary: Mozilla Firefox Web browser
Name: firefox4
Version: 4.0
-Release: 0.10.beta6%{?dist}
+Release: 0.11.beta7.build1%{?dist}
URL: http://www.mozilla.org/projects/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
@@ -43,7 +43,7 @@ Group: Applications/Internet
%endif
Source0: %{tarball}
%if %{build_langpacks}
-Source2: firefox-langpacks-%{version}%{?relcan}-20100916.tar.bz2
+Source2: firefox-langpacks-%{version}%{?relcan}-20101106.tar.bz2
%endif
Source12: firefox-redhat-default-prefs.js
# firefox3.destop without translation to allow change name
@@ -59,7 +59,7 @@ Source200: firefox-bookmarks.html
#Patch1: mozilla-build.patch
Patch1: firefox4-build.patch
Patch3: firefox4-jemalloc.patch
-Patch4: mozilla-about-firefox-version.patch
+# Patch4: mozilla-about-firefox-version.patch
Patch7: xulrunner-1.9.2.1-build.patch
Patch8: mozilla-plugin.patch
#Patch9: mozilla-build-sbrk.patch
@@ -72,13 +72,15 @@ Patch12: firefox4-build-macos.patch
Patch20: mozilla-193-pkgconfig.patch
#Patch21: mozilla-libjpeg-turbo.patch
Patch21: firefox4-libjpeg-turbo.patch
+Patch22: mozilla-notify.patch
+Patch23: wmclass.patch
# build patches from firefox
Patch0: firefox4-version.patch
#Patch1: firefox4-jemalloc.patch = xulrunner / firefox4-jemalloc.patch
#Patch2: firefox4-build-throw.patch = xulrunner / mozilla-malloc.patch
-Patch30: firefox-disable-checkupdates.patch
+Patch30: firefox4-disable-checkupdates.patch
Patch31: firefox4-default.patch
@@ -122,6 +124,8 @@ BuildRequires: wireless-tools-devel
# BR from Xulrunner
%if %{fedora} >= 15
BuildRequires: sqlite-devel >= %{sqlite_version}
+%endif
+%if %{fedora} >= 12
BuildRequires: nspr-devel >= %{nspr_version}
BuildRequires: nss-devel >= %{nss_version}
%endif
@@ -162,6 +166,13 @@ BuildRequires: yasm
%if %{fedora} >= 7
Requires: system-bookmarks
%endif
+%if 0%{?fedora} >= 12
+Requires: nss >= %{nss_version}
+Requires: nspr >= %{nspr_version}
+%endif
+%if %{fedora} >= 9
+BuildRequires: lcms-devel >= %{lcms_version}
+%endif
Obsoletes: mozilla <= 37:1.7.13
Obsoletes: firefox36
Provides: webclient
@@ -189,7 +200,7 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{internal_version}/' %{P:%%PATCH0} \
# Build Patches
%patch1 -p2 -b .build
%patch3 -p1 -b .jemalloc
-%patch4 -p1 -b .about-firefox-version
+#patch4 -p1 -b .about-firefox-version
%patch7 -p2 -b .del
#patch8 -p1 -b .plugin
%patch9 -p2 -b .sbrk
@@ -200,9 +211,14 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{internal_version}/' %{P:%%PATCH0} \
%patch12 -p1 -b .macos
%patch20 -p2 -b .pk
+%if %{fedora} >= 14
+%patch21 -p1 -b .jpeg-turbo
+%endif
%if %{fedora} >= 15
-%patch21 -p2 -b .jpeg-turbo
+# when libnotify >= 0.7.0
+%patch22 -p2 -b .notify
%endif
+%patch23 -p1 -b .wmclass
%patch30 -p1 -b .checkupdates
%patch31 -p2 -b .default
@@ -211,18 +227,18 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{internal_version}/' %{P:%%PATCH0} \
cat <<EOF_MOZCONFIG | tee .mozconfig
. \$topsrcdir/browser/config/mozconfig
-mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/objdir-%{name}/
+mk_add_options MOZ_OBJDIR=@TOPSRCDIR@
# --with-system-png is disabled because Mozilla requires APNG support in libpng
#ac_add_options --with-system-png
ac_add_options --prefix="\$PREFIX"
ac_add_options --libdir="\$LIBDIR"
%if %{fedora} >= 15
-ac_add_options --with-system-nspr
-ac_add_options --with-system-nss
ac_add_options --enable-system-sqlite
%endif
-%if %{fedora} >= 13
+%if %{fedora} >= 12
+ac_add_options --with-system-nspr
+ac_add_options --with-system-nss
%endif
%if %{fedora} >= 11
ac_add_options --enable-system-hunspell
@@ -309,9 +325,7 @@ make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
%{__rm} -rf $RPM_BUILD_ROOT
cd %{tarballdir}
-pushd objdir-%{name}
DESTDIR=$RPM_BUILD_ROOT make install
-popd
%{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
@@ -439,6 +453,12 @@ touch $RPM_BUILD_ROOT/%{mozappdir}/components/xpti.dat
%{__rm} -f $RPM_BUILD_ROOT/%{mozappdir}/*.chk
%{__rm} -f $RPM_BUILD_ROOT/%{mozappdir}/dependentlibs.list
+# Don't need this
+%{__rm} -f $RPM_BUILD_ROOT/%{mozappdir}/removed-files
+%{__rm} -rf $RPM_BUILD_ROOT/%{_includedir}/firefox-sdk-%{internal_version}
+%{__rm} -rf $RPM_BUILD_ROOT/%{_libdir}/firefox-sdk-%{internal_version}
+%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/idl/firefox-sdk-%{internal_version}
+
#---------------------------------------------------------------------
@@ -448,8 +468,8 @@ touch $RPM_BUILD_ROOT/%{mozappdir}/components/xpti.dat
#---------------------------------------------------------------------
%pre
-echo -e "\nWARNING : This %{name} RPM is not an official Fedora build and it"
-echo -e "overrides the official one. Don't file bugs on Fedora Project.\n"
+echo -e "\nWARNING : This %{name} %{version} %{mycomment} RPM is not an official"
+echo -e "Fedora build and it overrides the official one. Don't file bugs on Fedora Project.\n"
echo -e "Use dedicated forums http://forums.famillecollet.com/\n"
%if %{?fedora}%{!?fedora:99} <= 11
@@ -531,10 +551,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%{mozappdir}/run-mozilla.sh
%{mozappdir}/application.ini
#%{mozappdir}/.autoreg
-%exclude %{mozappdir}/removed-files
-%exclude %{_includedir}/firefox-sdk-%{internal_version}
-%exclude %{_libdir}/firefox-sdk-%{internal_version}
-%exclude %{_datadir}/idl/firefox-sdk-%{internal_version}
%{_datadir}/icons/hicolor/16x16/apps/%{name}.png
%{_datadir}/icons/hicolor/22x22/apps/%{name}.png
%{_datadir}/icons/hicolor/24x24/apps/%{name}.png
@@ -545,6 +561,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#---------------------------------------------------------------------
%changelog
+* Sat Nov 06 2010 Remi Collet <rpms@famillecollet.com> - 4.0-0.11.beta7.build1
+- update to 4.0b7 build1 candidate
+
* Thu Sep 16 2010 Remi Collet <rpms@famillecollet.com> - 4.0-0.10.beta6
- update to 4.0b6
diff --git a/firefox4-disable-checkupdates.patch b/firefox4-disable-checkupdates.patch
new file mode 100644
index 0000000..72b3200
--- /dev/null
+++ b/firefox4-disable-checkupdates.patch
@@ -0,0 +1,11 @@
+--- mozilla-central/browser/base/content/utilityOverlay.js.checkupdates 2010-11-04 21:05:17.000000000 +0100
++++ mozilla-central/browser/base/content/utilityOverlay.js 2010-11-06 10:49:40.172670752 +0100
+@@ -525,7 +525,7 @@
+
+ // Disable the UI if the update enabled pref has been locked by the
+ // administrator or if we cannot update for some other reason
+- var canCheckForUpdates = updates.canCheckForUpdates;
++ var canCheckForUpdates = updates.canCheckForUpdates && updates.canApplyUpdates;
+ checkForUpdates.setAttribute("disabled", !canCheckForUpdates);
+ if (!canCheckForUpdates)
+ return;
diff --git a/firefox4-libjpeg-turbo.patch b/firefox4-libjpeg-turbo.patch
index 9abd0e9..3aadec4 100644
--- a/firefox4-libjpeg-turbo.patch
+++ b/firefox4-libjpeg-turbo.patch
@@ -1,28 +1,7 @@
-diff -up xulrunner-1.9.3.0/mozilla-central/modules/libpr0n/decoders/jpeg/nsJPEGDecoder.cpp.jpeg-turbo xulrunner-1.9.3.0/mozilla-central/modules/libpr0n/decoders/jpeg/nsJPEGDecoder.cpp
---- xulrunner-1.9.3.0/mozilla-central/modules/libpr0n/decoders/jpeg/nsJPEGDecoder.cpp.jpeg-turbo 2010-08-06 03:09:15.000000000 +0200
-+++ xulrunner-1.9.3.0/mozilla-central/modules/libpr0n/decoders/jpeg/nsJPEGDecoder.cpp 2010-08-16 11:19:17.000000000 +0200
-@@ -58,19 +58,6 @@
-
- extern "C" {
- #include "iccjpeg.h"
--
--/* Colorspace conversion (copied from jpegint.h) */
--struct jpeg_color_deconverter {
-- JMETHOD(void, start_pass, (j_decompress_ptr cinfo));
-- JMETHOD(void, color_convert, (j_decompress_ptr cinfo,
-- JSAMPIMAGE input_buf, JDIMENSION input_row,
-- JSAMPARRAY output_buf, int num_rows));
--};
--
--METHODDEF(void)
--ycc_rgb_convert_argb (j_decompress_ptr cinfo,
-- JSAMPIMAGE input_buf, JDIMENSION input_row,
-- JSAMPARRAY output_buf, int num_rows);
- }
-
- NS_IMPL_ISUPPORTS1(nsJPEGDecoder, imgIDecoder)
-@@ -443,14 +430,6 @@ nsresult nsJPEGDecoder::Write(const char
- return NS_OK; /* I/O suspension */
+--- mozilla-central/modules/libpr0n/decoders/nsJPEGDecoder.cpp.jpeg-turbo 2010-11-04 21:06:43.000000000 +0100
++++ mozilla-central/modules/libpr0n/decoders/nsJPEGDecoder.cpp 2010-11-06 10:46:04.081880464 +0100
+@@ -411,14 +411,6 @@
+ return; /* I/O suspension */
}
- /* Force to use our YCbCr to Packed RGB converter when possible */
@@ -36,7 +15,7 @@ diff -up xulrunner-1.9.3.0/mozilla-central/modules/libpr0n/decoders/jpeg/nsJPEGD
/* If this is a progressive JPEG ... */
mState = mInfo.buffered_image ? JPEG_DECOMPRESS_PROGRESSIVE : JPEG_DECOMPRESS_SEQUENTIAL;
}
-@@ -616,15 +595,6 @@ nsJPEGDecoder::OutputScanlines(PRBool* s
+@@ -563,15 +555,6 @@
PRUint32 *imageRow = ((PRUint32*)mImageData) +
(mInfo.output_scanline * mInfo.output_width);
diff --git a/firefox4.sh.in b/firefox4.sh.in
index bb28a52..5a72c6b 100644
--- a/firefox4.sh.in
+++ b/firefox4.sh.in
@@ -189,9 +189,10 @@ if [ $MOZILLA_DOWN -ne 0 ]; then
# So that pt-BR doesn't try to use pt for example
SHORTMOZLOCALE=`echo $CURRENT_LOCALE | sed "s|_\([^.]*\).*||g"`
MOZLOCALE=`echo $CURRENT_LOCALE | sed "s|_\([^.]*\).*|-\1|g"`
+ MANIFEST="chrome.manifest"
# Try to link global langpacks to an extension directory
- if [ -d $MOZ_LANGPACKS_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org/chrome/$SHORTMOZLOCALE ]; then
+ if [ -f $MOZ_LANGPACKS_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org/$MANIFEST ]; then
if [ -d $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org ]; then
rmdir "$MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org" > /dev/null 2>&1
fi
@@ -200,7 +201,7 @@ if [ $MOZILLA_DOWN -ne 0 ]; then
$MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org
echo "$MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org" > $FEDORA_LANGPACK_CONFIG
fi
- elif [ -d $MOZ_LANGPACKS_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org/chrome/$MOZLOCALE ]; then
+ elif [ -f $MOZ_LANGPACKS_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org/$MANIFEST ]; then
if [ -d $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org ]; then
rmdir "$MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org" > /dev/null 2>&1
fi
@@ -212,10 +213,10 @@ if [ $MOZILLA_DOWN -ne 0 ]; then
fi
# And set it up for mozilla
- if [ -d $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org/chrome/$SHORTMOZLOCALE ]; then
+ if [ -f $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org/$MANIFEST ]; then
MOZARGS="-UILocale $SHORTMOZLOCALE"
else
- if [ -d $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org/chrome/$MOZLOCALE ]; then
+ if [ -f $MOZ_EXTENSIONS_PROFILE_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org/$MANIFEST ]; then
MOZARGS="-UILocale $MOZLOCALE"
fi
fi
diff --git a/mozilla-notify.patch b/mozilla-notify.patch
new file mode 100644
index 0000000..54a1c59
--- /dev/null
+++ b/mozilla-notify.patch
@@ -0,0 +1,13 @@
+diff -up xulrunner-2.0/mozilla-central/toolkit/system/gnome/nsAlertsIconListener.cpp.notify xulrunner-2.0/mozilla-central/toolkit/system/gnome/nsAlertsIconListener.cpp
+--- xulrunner-2.0/mozilla-central/toolkit/system/gnome/nsAlertsIconListener.cpp.notify 2010-11-02 17:02:18.266180000 -0400
++++ xulrunner-2.0/mozilla-central/toolkit/system/gnome/nsAlertsIconListener.cpp 2010-11-02 17:02:37.699180028 -0400
+@@ -218,7 +218,7 @@ nsAlertsIconListener::ShowAlert(GdkPixbu
+ {
+ mNotification = notify_notification_new(mAlertTitle.get(),
+ mAlertText.get(),
+- NULL, NULL);
++ NULL);
+ if (!mNotification)
+ return NS_ERROR_OUT_OF_MEMORY;
+
+
diff --git a/wmclass.patch b/wmclass.patch
new file mode 100644
index 0000000..5fe76ac
--- /dev/null
+++ b/wmclass.patch
@@ -0,0 +1,29 @@
+#
+# Online Desktop expects WMCLASS to match the .desktop file
+# Since renaming the .desktop file is bad, work around this here
+#
+
+diff -up ./widget/src/gtk2/nsWindow.cpp.wmclass ./widget/src/gtk2/nsWindow.cpp
+--- ./widget/src/gtk2/nsWindow.cpp.wmclass 2010-10-25 11:33:21.649433261 -0700
++++ ./widget/src/gtk2/nsWindow.cpp 2010-10-25 11:36:19.864431870 -0700
+@@ -3738,6 +3738,10 @@ nsWindow::Create(nsIWidget *aPare
+ GetBrandName(brandName);
+ NS_ConvertUTF16toUTF8 cBrand(brandName);
+
++ if (brandName.EqualsLiteral("Minefield")) {
++ cBrand.Assign("Firefox");
++ }
++
+ if (mWindowType == eWindowType_dialog) {
+ mShell = gtk_window_new(GTK_WINDOW_TOPLEVEL);
+ SetDefaultIcon();
+@@ -4109,6 +4113,9 @@ nsWindow::SetWindowClass(const nsAString
+ #ifdef MOZ_X11
+ nsXPIDLString brandName;
+ GetBrandName(brandName);
++ if (brandName.EqualsLiteral("Minefield")) {
++ brandName.AssignLiteral("Firefox");
++ }
+
+ XClassHint *class_hint = XAllocClassHint();
+ if (!class_hint)