summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-04-29 09:09:32 +0200
committerRemi Collet <fedora@famillecollet.com>2012-04-29 09:09:32 +0200
commit147aea85de341322d0f95e6772a0e172b700cc8d (patch)
treeb055b4194e08daefa8a53d7b35c14f0d49f21f47
parent3bd3e0aa8af58fbef853a26b3256adb106be1edf (diff)
Firefox 12.0
-rw-r--r--firefox-mozconfig1
-rw-r--r--firefox.spec30
-rw-r--r--mozilla-722127.patch74
3 files changed, 19 insertions, 86 deletions
diff --git a/firefox-mozconfig b/firefox-mozconfig
index 4dc2638..773a903 100644
--- a/firefox-mozconfig
+++ b/firefox-mozconfig
@@ -13,7 +13,6 @@ ac_add_options --enable-xinerama
ac_add_options --enable-default-toolkit=cairo-gtk2
ac_add_options --disable-xprint
ac_add_options --disable-strip
-ac_add_options --enable-system-cairo
ac_add_options --enable-pango
ac_add_options --enable-svg
ac_add_options --enable-canvas
diff --git a/firefox.spec b/firefox.spec
index 1634cbd..f51706d 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -1,14 +1,14 @@
# Use system nspr/nss?
%if 0%{?fedora} < 15
%define system_nss 0
-%define system_cairo 0
%define system_vpx 0
%else
%define system_nss 1
-%define system_cairo 1
%define system_vpx 1
%endif
+%define system_cairo 0
+
# Separated plugins are supported on x86(64) only
%ifarch %{ix86} x86_64
%define separated_plugins 1
@@ -25,13 +25,13 @@
%global shortname firefox
#global mycomment Beta 4
-%global firefox_dir_ver 11
-%global xulrunner_version 11.0
+%global firefox_dir_ver 12
+%global xulrunner_version 12.0
%global xulrunner_release 1
%global alpha_version 0
%global beta_version 0
%global rc_version 0
-%global datelang 20120317
+%global datelang 20120429
%global mozappdir %{_libdir}/%{shortname}
%global langpackdir %{mozappdir}/langpacks
@@ -62,7 +62,7 @@
Summary: Mozilla Firefox Web browser
Name: %{shortname}
-Version: 11.0
+Version: 12.0
Release: 1%{?dist}
URL: http://www.mozilla.org/projects/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
@@ -87,7 +87,6 @@ Patch14: firefox-5.0-asciidel.patch
Patch15: firefox-8.0-enable-addons.patch
# Upstream patches
-Patch100: mozilla-722127.patch
%if %{official_branding}
# Required by Mozilla Corporation
@@ -143,7 +142,6 @@ cd %{tarballdir}
%patch15 -p2 -b .addons
# Upstream patches
-%patch100 -p2 -b .722127
%if %{official_branding}
# Required by Mozilla Corporation
@@ -155,9 +153,6 @@ cd %{tarballdir}
%{__rm} -f .mozconfig
%{__cat} %{SOURCE10} \
-%if ! %{system_cairo}
- | grep -v enable-system-cairo \
-%endif
%ifarch %{ix86} x86_64
| grep -v disable-necko-wifi \
%endif
@@ -186,6 +181,12 @@ echo "ac_add_options --without-system-nspr" >> .mozconfig
echo "ac_add_options --without-system-nss" >> .mozconfig
%endif
+%if %{?system_cairo}
+echo "ac_add_options --enable-system-cairo" >> .mozconfig
+%else
+echo "ac_add_options --disable-system-cairo" >> .mozconfig
+%endif
+
# Set up SDK path
echo "ac_add_options --with-libxul-sdk=\
`pkg-config --variable=sdkdir libxul`" >> .mozconfig
@@ -305,6 +306,7 @@ ln -s `pkg-config --variable=libdir libxul` $RPM_BUILD_ROOT/%{mozappdir}/xulrunn
%{__install} -p -D -m 644 %{SOURCE23} $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
%{__rm} -f $RPM_BUILD_ROOT/%{mozappdir}/firefox-config
+%{__rm} -f $RPM_BUILD_ROOT/%{mozappdir}/update-settings.ini
for s in 16 22 24 32 48 256; do
%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/${s}x${s}/apps
@@ -433,6 +435,12 @@ fi
#---------------------------------------------------------------------
%changelog
+* Sun Apr 29 2012 Remi Collet <RPMS@FamilleCollet.com> - 12.0-1
+- Sync with rawhide, update to 12.0
+
+* Tue Apr 24 2012 Martin Stransky <stransky@redhat.com> - 12.0-1
+- Update to 12.0
+
* Sat Mar 17 2012 Remi Collet <RPMS@FamilleCollet.com> - 11.0-1
- Update to 11.0, sync with rawhide
diff --git a/mozilla-722127.patch b/mozilla-722127.patch
deleted file mode 100644
index f86fcae..0000000
--- a/mozilla-722127.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-diff -up xulrunner-11.0/mozilla-beta/configure.in.vpx1.0.0 xulrunner-11.0/mozilla-beta/configure.in
---- xulrunner-11.0/mozilla-beta/configure.in.vpx1.0.0 2012-03-09 01:39:31.000000000 +0100
-+++ xulrunner-11.0/mozilla-beta/configure.in 2012-03-09 15:03:51.246031329 +0100
-@@ -5710,20 +5710,20 @@ if test -n "$MOZ_WEBM"; then
- [MOZ_NATIVE_LIBVPX_DEC_TEST=1],
- ([--with-system-libvpx requested but symbol vpx_codec_dec_init_ver not found]))
- if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
-- AC_MSG_CHECKING([for libvpx version >= v0.9.7])
-- dnl We need at least v0.9.7 to fix several crash bugs (for which we
-- dnl had local patches prior to v0.9.7).
-+ AC_MSG_CHECKING([for libvpx version >= v1.0.0])
-+ dnl We need at least v1.0.0 to fix several crash bugs (for which we
-+ dnl had local patches prior to v1.0.0).
- dnl
- dnl This is a terrible test for the library version, but we don't
- dnl have a good one. There is no version number in a public header,
- dnl and testing the headers still doesn't guarantee we link against
- dnl the right version. While we could call vpx_codec_version() at
- dnl run-time, that would break cross-compiling. There are no
-- dnl additional exported symbols between the v0.9.7 release and the
-- dnl v0.9.6 one to check for.
-+ dnl additional exported decoder symbols between the v1.0.0 release
-+ dnl and the v0.9.7 one to check for.
- AC_TRY_COMPILE([
- #include <vpx/vpx_decoder.h>
-- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
-+ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
- #error "test failed."
- #endif
- ],
-@@ -5734,7 +5734,7 @@ if test -n "$MOZ_WEBM"; then
- MOZ_LIBVPX_INCLUDES="-I${LIBVPX_DIR}/include"
- MOZ_LIBVPX_LIBS="-L${LIBVPX_DIR}/lib -lvpx"],
- [AC_MSG_RESULT([no])
-- AC_MSG_ERROR([--with-system-libvpx requested but it is not v0.9.7 or later])])
-+ AC_MSG_ERROR([--with-system-libvpx requested but it is not v1.0.0 or later])])
- fi
- CFLAGS=$_SAVE_CFLAGS
- LDFLAGS=$_SAVE_LDFLAGS
-diff -up xulrunner-11.0/mozilla-beta/configure.vpx1.0.0 xulrunner-11.0/mozilla-beta/configure
---- xulrunner-11.0/mozilla-beta/configure.vpx1.0.0 2012-03-09 01:58:50.000000000 +0100
-+++ xulrunner-11.0/mozilla-beta/configure 2012-03-09 15:15:42.537585632 +0100
-@@ -17761,14 +17761,14 @@ else
- fi
-
- if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
-- echo $ac_n "checking for libvpx version >= v0.9.7""... $ac_c" 1>&6
--echo "configure:17766: checking for libvpx version >= v0.9.7" >&5
-+ echo $ac_n "checking for libvpx version >= v1.0.0""... $ac_c" 1>&6
-+echo "configure:17766: checking for libvpx version >= v1.0.0" >&5
- cat > conftest.$ac_ext <<EOF
- #line 17768 "configure"
- #include "confdefs.h"
-
- #include <vpx/vpx_decoder.h>
-- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
-+ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
- #error "test failed."
- #endif
-
-@@ -17791,7 +17791,7 @@ else
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- echo "$ac_t""no" 1>&6
-- { echo "configure: error: --with-system-libvpx requested but it is not v0.9.7 or later" 1>&2; exit 1; }
-+ { echo "configure: error: --with-system-libvpx requested but it is not v1.0.0 or later" 1>&2; exit 1; }
- fi
- rm -f conftest*
- fi
-@@ -25794,4 +25794,3 @@ if cmp -s config/autoconf.mk config/auto
- else
- rm -f config/autoconf.mk.orig 2> /dev/null
- fi
--