summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2011-04-30 12:01:57 +0200
committerRemi Collet <fedora@famillecollet.com>2011-04-30 12:01:57 +0200
commit30c14c362eacfb402f41627423fd2756718fcfcc (patch)
tree67d5aed90757becf547bbc90680d1fffd9c8a1a8
parentaffdf9534c414bda69a95cd81280953937293baa (diff)
mock: add patch for https://bugzilla.redhat.com/700983HEADmaster
-rw-r--r--mock.patch11
-rw-r--r--mock.spec8
2 files changed, 18 insertions, 1 deletions
diff --git a/mock.patch b/mock.patch
index e6fe85d..09cbfd3 100644
--- a/mock.patch
+++ b/mock.patch
@@ -50,3 +50,14 @@ diff -up mock-1.1.9/py/mock/util.py.orig mock-1.1.9/py/mock/util.py
+ directory = os.path.realpath(directory)
+
+ return os.path.commonprefix([path, directory]) == directory
+--- mock-1.1.9/py/mock/plugins/ccache.py.orig 2011-04-30 11:23:04.167083378 +0200
++++ mock-1.1.9/py/mock/plugins/ccache.py 2011-04-30 11:26:58.778589188 +0200
+@@ -50,6 +50,8 @@
+ def _ccachePreInitHook(self):
+ getLog().info("enabled ccache")
+ mock.util.mkdirIfAbsent(self.rootObj.makeChrootPath('/tmp/ccache'))
++ self.rootObj.uidManager.dropPrivsTemp()
+ mock.util.mkdirIfAbsent(self.ccachePath)
++ self.rootObj.uidManager.restorePrivs()
+ os.environ['CCACHE_DIR'] = "/tmp/ccache"
+ os.environ['CCACHE_UMASK'] = "002"
diff --git a/mock.spec b/mock.spec
index 6212831..2b0d8f1 100644
--- a/mock.spec
+++ b/mock.spec
@@ -11,7 +11,7 @@
Summary: Builds packages inside chroots
Name: mock
Version: %{release_version}
-Release: 1%{?dist}
+Release: 1%{?dist}.2
License: GPLv2+
Group: Development/Tools
Source: https://fedorahosted.org/mock/attachment/wiki/MockTarballs/%{name}-%{version}.tar.gz
@@ -122,6 +122,12 @@ fi
%attr(02775, root, mock) %dir /var/cache/mock
%changelog
+* Sat Apr 30 2011 Remi Collet <rpms@famillecollet.com> 1.1.9-1.2
+- Fix previous patch and dump release
+
+* Sat Apr 30 2011 Remi Collet <rpms@famillecollet.com> 1.1.9-1.1
+- Fix #700983 ccache dir owned by root
+
* Thu Apr 21 2011 Remi Collet <rpms@famillecollet.com> 1.1.9-1
- Fix #688222 cleanup_on_success from config not honored