summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--0001-fix-multiple-definition-of-crc32c-GCC-10.patch39
-rw-r--r--memcached.spec11
2 files changed, 49 insertions, 1 deletions
diff --git a/0001-fix-multiple-definition-of-crc32c-GCC-10.patch b/0001-fix-multiple-definition-of-crc32c-GCC-10.patch
new file mode 100644
index 0000000..10d0fc7
--- /dev/null
+++ b/0001-fix-multiple-definition-of-crc32c-GCC-10.patch
@@ -0,0 +1,39 @@
+From 8e6b12f96886412d47894f56193b3b92bd4a850e Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 9 Mar 2020 13:04:06 +0100
+Subject: [PATCH] fix multiple definition of 'crc32c' (GCC 10)
+
+---
+ crc32c.c | 2 ++
+ crc32c.h | 2 +-
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/crc32c.c b/crc32c.c
+index a4296a7..a3c526e 100644
+--- a/crc32c.c
++++ b/crc32c.c
+@@ -46,6 +46,8 @@
+ #endif
+ #include "crc32c.h"
+
++crc_func crc32c;
++
+ /* CRC-32C (iSCSI) polynomial in reversed bit order. */
+ #define POLY 0x82f63b78
+
+diff --git a/crc32c.h b/crc32c.h
+index 8b030de..c09cb42 100644
+--- a/crc32c.h
++++ b/crc32c.h
+@@ -2,7 +2,7 @@
+ #define CRC32C_H
+
+ typedef uint32_t (*crc_func)(uint32_t crc, const void *buf, size_t len);
+-crc_func crc32c;
++extern crc_func crc32c;
+
+ void crc32c_init(void);
+
+--
+2.24.1
+
diff --git a/memcached.spec b/memcached.spec
index f242a95..3dd37ab 100644
--- a/memcached.spec
+++ b/memcached.spec
@@ -39,7 +39,7 @@
%global with_tests 0%{?_with_tests:1}
Name: memcached
-Version: 1.5.22
+Version: 1.6.0
Release: 1%{?dist}
Epoch: 0
Summary: High Performance, Distributed Memory Object Cache
@@ -57,6 +57,7 @@ Source4: memcached.sysv
Source3: memcached.service
Patch1: memcached-unit.patch
+Patch2: 0001-fix-multiple-definition-of-crc32c-GCC-10.patch
BuildRequires: gcc
BuildRequires: pkgconfig(libevent) >= 2
@@ -132,12 +133,15 @@ access to the memcached binary include files.
# and SELinux policy sources into memcached-selinux-X.X
%setup -q -b 2
%patch1 -p1 -b .unit
+%patch2 -p1 -b .gcc10
%build
%configure \
%if %{with_extstore}
--enable-extstore \
+%else
+ --disable-extstore \
%endif
%if %{with_sasl}
--enable-sasl \
@@ -343,6 +347,11 @@ fi
%changelog
+* Mon Mar 9 2020 Remi Collet <remi@remirepo.net> - 1.6.0-1
+- update to 1.6.0 (2020-3-8)
+- add patch for GCC 10 from
+ https://github.com/memcached/memcached/pull/622
+
* Mon Feb 3 2020 Remi Collet <remi@remirepo.net> - 1.5.22-1
- update to 1.5.22