summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-01-10 16:24:50 +0100
committerRemi Collet <remi@php.net>2024-01-10 16:24:50 +0100
commit5afbd9f782391fa9337965d77557846c0fb354dc (patch)
tree50937398e4f327f4fa8d9db286b87d802f35bbcf
parentb9bf276446aa0986d8de19cad74b2aec7f292a84 (diff)
fix build for proxy
-rw-r--r--memcached.spec13
1 files changed, 12 insertions, 1 deletions
diff --git a/memcached.spec b/memcached.spec
index 46cf87f..ff3106f 100644
--- a/memcached.spec
+++ b/memcached.spec
@@ -15,7 +15,7 @@
%bcond_without sasl
%bcond_without sasl_pwdb
%bcond_with seccomp
-# Experimental and not ready
+# Experimental
%bcond_with proxy
%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
%bcond_without tls
@@ -60,6 +60,8 @@ Source3: memcached.conf
Source4: memcached.service
Patch1: memcached-unit.patch
+# honors system CFLAGS for bundled libraries (lua, mcmc)
+Patch2: memcached-build.patch
BuildRequires: gcc
BuildRequires: pkgconfig(libevent) >= 2
@@ -93,6 +95,11 @@ Requires(pre): shadow-utils
Requires: (%{name}-selinux if selinux-policy-targeted)
%endif
+%if %{with proxy}
+Provides: bundled(lua) = 5.4.3
+Provides: bundled(mcmc)
+%endif
+
%if %{with selinux}
%package selinux
@@ -129,6 +136,10 @@ access to the memcached binary include files.
# and SELinux policy sources into memcached-selinux-X.X
%setup -q -b 2
%patch -P1 -p1 -b .unit
+%if %{with proxy}
+%patch -P2 -p0 -b .fixbuild
+sed -e 's:@CFLAGS@:%{build_cflags}:' -i vendor/Makefile
+%endif
%build