summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-28 16:32:37 +0100
committerRemi Collet <remi@remirepo.net>2018-02-28 16:32:37 +0100
commit58ac5452a0393fc46db3f29e90728f8c186913a2 (patch)
tree37a281c4d77dbf36888310c3a28f52b7726f35f3
parent149d606d592d3ae5b8b93f5b53e5624456eb8c0a (diff)
v1.5.5
-rw-r--r--memcached-format_errors.patch32
-rw-r--r--memcached.spec13
2 files changed, 44 insertions, 1 deletions
diff --git a/memcached-format_errors.patch b/memcached-format_errors.patch
new file mode 100644
index 0000000..53a9c65
--- /dev/null
+++ b/memcached-format_errors.patch
@@ -0,0 +1,32 @@
+commit aa5cc9ad74c871970c2d93c114e1d2c125b63e81
+Author: Miroslav Lichvar <mlichvar@redhat.com>
+Date: Tue Jan 30 13:28:08 2018 +0100
+
+ fix gcc warnings
+
+diff --git a/items.c b/items.c
+index 400048b..519764f 100644
+--- a/items.c
++++ b/items.c
+@@ -925,7 +925,7 @@ void item_stats_sizes(ADD_STAT add_stats, void *c) {
+ int i;
+ for (i = 0; i < stats_sizes_buckets; i++) {
+ if (stats_sizes_hist[i] != 0) {
+- char key[8];
++ char key[12];
+ snprintf(key, sizeof(key), "%d", i * 32);
+ APPEND_STAT(key, "%u", stats_sizes_hist[i]);
+ }
+diff --git a/memcached.c b/memcached.c
+index a8a724c..dba7941 100644
+--- a/memcached.c
++++ b/memcached.c
+@@ -3338,7 +3338,7 @@ static void process_stats_conns(ADD_STAT add_stats, void *c) {
+ int i;
+ char key_str[STAT_KEY_LEN];
+ char val_str[STAT_VAL_LEN];
+- char conn_name[MAXPATHLEN + sizeof("unix:")];
++ char conn_name[MAXPATHLEN + sizeof("unix:") + sizeof("65535")];
+ int klen = 0, vlen = 0;
+
+ assert(add_stats);
diff --git a/memcached.spec b/memcached.spec
index 7877458..1172b75 100644
--- a/memcached.spec
+++ b/memcached.spec
@@ -29,7 +29,7 @@
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
Name: memcached
-Version: 1.5.4
+Version: 1.5.5
Release: 1%{?dist}
Epoch: 0
Summary: High Performance, Distributed Memory Object Cache
@@ -46,9 +46,12 @@ Source2: memcached.sysv
Source3: memcached.service
Patch1: memcached-unit.patch
+Patch2: memcached-format_errors.patch
BuildRequires: pkgconfig(libevent) >= 2
+%if %{with_systemd}
BuildRequires: systemd
+%endif
%if 0%{?fedora} > 22
BuildRequires: perl-generators
%endif
@@ -92,6 +95,7 @@ access to the memcached binary include files.
%prep
%setup -q
%patch1 -p1 -b .unit
+%patch2 -p1 -b .format_errors
%build
@@ -247,6 +251,13 @@ fi
%changelog
+* Tue Feb 13 2018 Remi Collet <remi@remirepo.net> - 0:1.5.5-1
+- Update to 1.5.5
+
+* Tue Jan 30 2018 Miroslav Lichvar <mlichvar@redhat.com> - 0:1.5.4-2
+- fix building with new gcc
+- use macro for systemd scriptlet dependencies
+
* Tue Dec 26 2017 Remi Collet <remi@remirepo.net> - 0:1.5.4-1
- Update to 1.5.4
- enable extstore feature on 64-bit