summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-07-27 10:53:18 +0200
committerRemi Collet <remi@remirepo.net>2021-07-27 10:53:18 +0200
commit36a859c29648ebf5f064a40ad59693b72745bf5b (patch)
tree0322f5ad58c491de55b660f2f366c7f719500de1
parent23309081a6e6e16776abc0b46baac7a9ebe120f5 (diff)
update to 1.6.10 (2021-07-25)
-rw-r--r--memcached.spec37
-rw-r--r--memcached.sysv94
2 files changed, 8 insertions, 123 deletions
diff --git a/memcached.spec b/memcached.spec
index 39519fb..16542d7 100644
--- a/memcached.spec
+++ b/memcached.spec
@@ -25,18 +25,19 @@
%else
%bcond_with selinux
%endif
+# disable testing as it is unreliable on build systems
+%bcond_with tests
+
%global selinuxtype targeted
%global selinuxmoduletype contrib
%global selinuxmodulename memcached
%global selinuxmodulever 1.0.2
%global selinuxmoduledir %{selinuxmodulename}-selinux-%{selinuxmodulever}
-# disable testing as it is unreliable on build systems
-%bcond_with tests
Name: memcached
-Version: 1.6.9
-Release: 2%{?dist}
+Version: 1.6.10
+Release: 1%{?dist}
Epoch: 0
Summary: High Performance, Distributed Memory Object Cache
@@ -47,8 +48,6 @@ Source1: memcached.sysconfig
# SELinux policy sources: https://pagure.io/memcached-selinux/tree/master
Source2: https://releases.pagure.org/memcached-selinux/memcached-selinux-1.0.2.tar.gz
-# custom init script
-Source4: memcached.sysv
# custom unit file
Source3: memcached.service
@@ -239,38 +238,15 @@ exit 0
%post
-%if 0%{?systemd_post:1}
%systemd_post %{name}.service
-%else
-if [ $1 = 1 ]; then
- # Initial installation
- /sbin/chkconfig --add %{name}
-fi
-%endif
%preun
-%if 0%{?systemd_preun:1}
%systemd_preun %{name}.service
-%else
-if [ "$1" = 0 ] ; then
- # Package removal, not upgrade
- /sbin/service %{name} stop > /dev/null 2>&1
- /sbin/chkconfig --del %{name}
-fi
-exit 0
-%endif
%postun
-%if 0%{?systemd_postun_with_restart:1}
%systemd_postun_with_restart %{name}.service
-%else
-if [ "$1" -ge 1 ]; then
- /sbin/service %{name} condrestart > /dev/null 2>&1
-fi
-exit 0
-%endif
%files
@@ -300,6 +276,9 @@ exit 0
%changelog
+* Tue Jul 27 2021 Remi Collet <remi@remirepo.net> - 1.6.10-1
+- update to 1.6.10 (2021-07-25)
+
* Mon Dec 21 2020 Remi Collet <remi@remirepo.net> - 1.6.9-2
- build with --enable-sasl-pwdb
diff --git a/memcached.sysv b/memcached.sysv
deleted file mode 100644
index 19e5a12..0000000
--- a/memcached.sysv
+++ /dev/null
@@ -1,94 +0,0 @@
-#! /bin/sh
-#
-# chkconfig: - 55 45
-# description: The memcached daemon is a network memory cache service.
-# processname: memcached
-# config: /etc/sysconfig/memcached
-# pidfile: /var/run/memcached/memcached.pid
-
-# Standard LSB functions
-#. /lib/lsb/init-functions
-
-# Source function library.
-. /etc/init.d/functions
-
-PORT=11211
-USER=memcached
-MAXCONN=1024
-CACHESIZE=64
-OPTIONS=""
-
-if [ -f /etc/sysconfig/memcached ];then
- . /etc/sysconfig/memcached
-fi
-
-# Check that networking is up.
-. /etc/sysconfig/network
-
-if [ "$NETWORKING" = "no" ]
-then
- exit 0
-fi
-
-RETVAL=0
-prog="memcached"
-pidfile=${PIDFILE-/var/run/memcached/memcached.pid}
-lockfile=${LOCKFILE-/var/lock/subsys/memcached}
-
-start () {
- echo -n $"Starting $prog: "
- # Ensure that $pidfile directory has proper permissions and exists
- piddir=`dirname $pidfile`
- if [ ! -d $piddir ]; then
- mkdir $piddir
- fi
- if [ "`stat -c %U $piddir`" != "$USER" ]; then
- chown $USER $piddir
- fi
-
- daemon --pidfile ${pidfile} memcached -d -p $PORT -u $USER -m $CACHESIZE -c $MAXCONN -P ${pidfile} $OPTIONS
- RETVAL=$?
- echo
- [ $RETVAL -eq 0 ] && touch ${lockfile}
-}
-stop () {
- echo -n $"Stopping $prog: "
- killproc -p ${pidfile} /usr/bin/memcached
- RETVAL=$?
- echo
- if [ $RETVAL -eq 0 ] ; then
- rm -f ${lockfile} ${pidfile}
- fi
-}
-
-restart () {
- stop
- start
-}
-
-
-# See how we were called.
-case "$1" in
- start)
- start
- ;;
- stop)
- stop
- ;;
- status)
- status -p ${pidfile} memcached
- RETVAL=$?
- ;;
- restart|reload|force-reload)
- restart
- ;;
- condrestart|try-restart)
- [ -f ${lockfile} ] && restart || :
- ;;
- *)
- echo $"Usage: $0 {start|stop|status|restart|reload|force-reload|condrestart|try-restart}"
- RETVAL=2
- ;;
-esac
-
-exit $RETVAL