summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-18 17:45:11 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-18 17:45:11 +0200
commit2beb744cde6630c1ed96e9a87735bee112dde085 (patch)
tree62ad82f2039138fb238dfe43562427c95f1619cc
parent636e624a210c45811e3ab913de6ce69df4a119cc (diff)
v1.4.29
-rw-r--r--memcached-unit.patch11
-rw-r--r--memcached.spec37
-rw-r--r--memcached.sysconfig5
3 files changed, 49 insertions, 4 deletions
diff --git a/memcached-unit.patch b/memcached-unit.patch
new file mode 100644
index 0000000..4d745f2
--- /dev/null
+++ b/memcached-unit.patch
@@ -0,0 +1,11 @@
+diff -up memcached-1.4.28/scripts/memcached.service.unit memcached-1.4.28/scripts/memcached.service
+--- memcached-1.4.28/scripts/memcached.service.unit 2016-07-02 03:14:25.000000000 +0200
++++ memcached-1.4.28/scripts/memcached.service 2016-07-12 13:54:54.275782170 +0200
+@@ -9,6 +9,7 @@
+
+ [Unit]
+ Description=memcached daemon
++Before=httpd.service
+ After=network.target
+
+ [Service]
diff --git a/memcached.spec b/memcached.spec
index c4dfc3c..b4c4749 100644
--- a/memcached.spec
+++ b/memcached.spec
@@ -23,7 +23,7 @@
%{!?runselftest: %global runselftest 1}
Name: memcached
-Version: 1.4.28
+Version: 1.4.29
Release: 1%{?dist}
Epoch: 0
Summary: High Performance, Distributed Memory Object Cache
@@ -32,11 +32,14 @@ Group: System Environment/Daemons
License: BSD
URL: http://www.memcached.org/
Source0: http://www.memcached.org/files/%{name}-%{version}.tar.gz
+Source1: memcached.sysconfig
-# custom unit file
-Source1: memcached.service
# custom init script
Source2: memcached.sysv
+# custom unit file
+Source3: memcached.service
+
+Patch1: memcached-unit.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%if "%{?vendor}" == "Remi Collet"
@@ -88,6 +91,7 @@ access to the memcached binary include files.
%prep
%setup -q
+%patch1 -p1 -b .unit
%build
@@ -105,6 +109,10 @@ make %{?_smp_mflags}
%check
%if %runselftest
+%if 0%{?rhel} == 5
+rm t/chunked-items.t
+%endif
+
make test
%endif
@@ -122,7 +130,12 @@ install -Dp -m0644 scripts/memcached-tool.1 \
%if %{with_systemd}
# Unit file
-install -Dp -m0644 %{SOURCE1} %{buildroot}%{_unitdir}/memcached.service
+%if 0%{?fedora} < 25
+install -Dp -m0644 %{SOURCE3} %{buildroot}%{_unitdir}/memcached.service
+%else
+install -Dp -m0644 scripts/memcached.service \
+ %{buildroot}%{_unitdir}/memcached.service
+%endif
%else
# Init script
install -Dp -m0755 %{SOURCE2} %{buildroot}%{_initrddir}/memcached
@@ -133,6 +146,7 @@ mkdir -p %{buildroot}/%{_localstatedir}/run/memcached
# Default configs
+%if 0%{?fedora} < 25
mkdir -p %{buildroot}/%{_sysconfdir}/sysconfig
cat <<EOF >%{buildroot}/%{_sysconfdir}/sysconfig/%{name}
PORT="11211"
@@ -144,6 +158,9 @@ EOF
# Constant timestamp on the config file.
touch -r %{SOURCE1} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
+%else
+install -Dp -m0644 %{SOURCE1} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
+%endif
%clean
@@ -235,6 +252,18 @@ fi
%changelog
+* Mon Jul 18 2016 Remi Collet <remi@remirepo.net> - 0:1.4.29-1
+- Update to 1.4.29
+
+* Thu Jul 14 2016 Miroslav Lichvar <mlichvar@redhat.com> - 0:1.4.29-1
+- update to 1.4.29
+
+* Tue Jul 12 2016 Miroslav Lichvar <mlichvar@redhat.com> - 0:1.4.28-1
+- update to 1.4.28
+- listen only on loopback interface by default (#1182542)
+- use upstream unit file (#1350939)
+- remove obsolete macros and scriptlet
+
* Sun Jul 3 2016 Remi Collet <rpms@famillecollet.com> - 0:1.4.28-1
- Update to 1.4.28
diff --git a/memcached.sysconfig b/memcached.sysconfig
new file mode 100644
index 0000000..d065678
--- /dev/null
+++ b/memcached.sysconfig
@@ -0,0 +1,5 @@
+PORT="11211"
+USER="memcached"
+MAXCONN="1024"
+CACHESIZE="64"
+OPTIONS="-l 127.0.0.1,::1"