summaryrefslogtreecommitdiffstats
path: root/vips.spec
diff options
context:
space:
mode:
Diffstat (limited to 'vips.spec')
-rw-r--r--vips.spec150
1 files changed, 61 insertions, 89 deletions
diff --git a/vips.spec b/vips.spec
index 1c2f08b..e7de439 100644
--- a/vips.spec
+++ b/vips.spec
@@ -7,27 +7,31 @@
#
# Please preserve changelog entries
#
-%global vips_version_base 8.7
-%global vips_version %{vips_version_base}.4
+%global vips_version_base 8.8
+%global vips_version %{vips_version_base}.0
%global vips_soname_major 42
-#global vips_prever rc3
-%global vips_tarver %{vips_version}%{?vips_prever:-%{vips_prever}}
+%global vips_prever rc1
+%global vips_tarver %{vips_version}%{?vips_prever:-%{vips_prever}a}
-%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
-%global with_python2 0
+%if 0%{?fedora} || 0%{?rhel} >= 8
+%global with_doc 1
%else
-%global with_python2 1
+%global with_doc 0
%endif
%if 0%{?fedora} || 0%{?rhel} >= 8
-%global with_python3 1
-%global with_doc 1
+%global with_libimagequant 1
%else
-%global with_python3 0
-%global with_doc 0
+%global with_libimagequant 0
%endif
+%global with_libheif 0
+
+%if %{with_libheif}
+Name: vips-full
+%else
Name: vips
+%endif
Version: %{vips_version}%{?vips_prever:~%{vips_prever}}
Release: 1%{?dist}
Summary: C/C++ library for processing large images
@@ -56,19 +60,31 @@ BuildRequires: pkgconfig(pangoft2)
BuildRequires: pkgconfig(zlib)
BuildRequires: pkgconfig(libpng)
BuildRequires: pkgconfig(libtiff-4)
-BuildRequires: pkgconfig(libwebp)
+# Ensure we use libwebp7 on EL
+BuildRequires: pkgconfig(libwebp) > 1
BuildRequires: pkgconfig(libexif)
BuildRequires: pkgconfig(openslide)
BuildRequires: pkgconfig(libgsf-1)
BuildRequires: pkgconfig(librsvg-2.0)
BuildRequires: pkgconfig(poppler-glib)
BuildRequires: pkgconfig(libjpeg)
-
+%if %{with_libheif}
+BuildRequires: pkgconfig(libheif)
+%endif
+%if %{with_libimagequant}
+#BuildRequires: pkgconfig(imagequant) TODO only in 2.12+
+BuildRequires: libimagequant-devel
+%endif
BuildRequires: giflib-devel
BuildRequires: gcc-c++
BuildRequires: pkgconfig gettext
+%if %{with_libheif}
+Conflicts: vips < %{version}-%{release}
+Provides: vips = %{version}-%{release}
+%endif
+
%description
VIPS is an image processing library. It is good for very large images
@@ -82,7 +98,10 @@ against VIPS.
%package devel
Summary: Development files for %{name}
Requires: libjpeg-devel%{?_isa} libtiff-devel%{?_isa} zlib-devel%{?_isa}
-Requires: vips%{?_isa} = %{version}-%{release}
+Requires: %{name}%{?_isa} = %{version}-%{release}
+%if %{with_libheif}
+Conflicts: vips-devel < %{version}-%{release}
+%endif
%description devel
The %{name}-devel package contains the header files and
@@ -92,55 +111,23 @@ contains a C++ API and development documentation.
%package tools
Summary: Command-line tools for %{name}
-Requires: vips%{?_isa} = %{version}-%{release}
+Requires: %{name}%{?_isa} = %{version}-%{release}
+%if %{with_libheif}
+Conflicts: vips-tools < %{version}-%{release}
+%endif
%description tools
The %{name}-tools package contains command-line tools for working with VIPS.
-%if %{with_python2}
-%package -n python2-vips
-Summary: Python 2 support for %{name}
-BuildRequires: python2-devel
-Requires: vips%{?_isa} = %{version}-%{release}
-Requires: pygobject3-base >= 3.12.0
-Provides: python2-vipsCC = %{version}-%{release}
-Provides: python2-vipsCC%{?_isa} = %{version}-%{release}
-Obsoletes: vips-python < 8.7.2
-Provides: vips-python = %{version}-%{release}
-Provides: vips-python%{?_isa} = %{version}-%{release}
-
-%{?python_provide:%python_provide python2-vips}
-%{?python_provide:%python_provide python2-vipsCC}
-
-%description -n python2-vips
-The %{name}-python package contains Python 2 support for VIPS.
-%endif
-
-
-%if %{with_python3}
-%package -n python3-vips
-Summary: Python 3 support for %{name}
-BuildRequires: python3-devel
-Requires: vips%{?_isa} = %{version}-%{release}
-Requires: python3-gobject >= 3.12.0
-Obsoletes: vips-python3 < 8.7.2
-Provides: vips-python3 = %{version}-%{release}
-Provides: vips-python3%{?_isa} = %{version}-%{release}
-%{?python_provide:%python_provide python3-vips}
-
-# No provide for python3-vipsCC, since we only have the gi overrides
-
-%description -n python3-vips
-The %{name}-python3 package contains Python 3 support for VIPS.
-%endif
-
-
%if %{with_doc}
%package doc
Summary: Documentation for %{name}
BuildRequires: swig gtk-doc
Conflicts: %{name} < %{version}-%{release}, %{name} > %{version}-%{release}
+%if %{with_libheif}
+Conflicts: vips-doc < %{version}-%{release}
+%endif
%description doc
The %{name}-doc package contains extensive documentation about VIPS in both
@@ -168,41 +155,32 @@ sed -i 's|sys_lib_dlsearch_path_spec="|sys_lib_dlsearch_path_spec="/%{_lib} %{_l
export CFLAGS="%{optflags} -ftree-vectorize"
export CXXFLAGS="%{optflags} -ftree-vectorize"
%configure \
+%if %{with_libheif}
+ --with-heif \
+%else
+ --without-heif \
+%endif
%if %{with_doc}
- --disable-static \
--enable-gtk-doc \
%endif
- --enable-cpp7 \
- --enable-pyvips8 \
-%if %{with_python2}
- --enable-pyvips7 \
- PYTHON=%{_bindir}/python2
-%else
- PYTHON=%{_bindir}/python3
-%endif
+ --disable-static
make %{?_smp_mflags}
%install
-make install DESTDIR=$RPM_BUILD_ROOT
-find $RPM_BUILD_ROOT \( -name '*.la' -o -name '*.a' \) -exec rm -f {} ';'
+make install DESTDIR=%{buildroot}
+find %{buildroot} \( -name '*.la' -o -name '*.a' \) -exec rm -f {} ';'
# delete doc (we will get it later with %%doc)
-rm -rf ${RPM_BUILD_ROOT}%{_datadir}/doc/vips
+rm -rf %{buildroot}%{_datadir}/doc/vips
+
+%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
+sed -e 's:/usr/bin/python:%{_bindir}/python3:' -i %{buildroot}/%{_bindir}/vipsprofile
+%endif
# locale stuff
%find_lang vips%{vips_version_base}
-%if %{with_python2} && %{with_python3}
-# Upstream supports the GI override module on Python 3, but doesn't install
-# it into the Python 3 path
-mkdir -p ${RPM_BUILD_ROOT}%{python3_sitearch}
-cp -a ${RPM_BUILD_ROOT}%{python2_sitearch}/gi \
- ${RPM_BUILD_ROOT}%{python3_sitearch}
-find ${RPM_BUILD_ROOT}%{python3_sitearch} \
- \( -name '*.pyc' -o -name '*.pyo' \) -delete
-%endif
-
%if 0%{?fedora} < 28 && 0%{?rhel} < 8
%post -p /sbin/ldconfig
@@ -230,20 +208,6 @@ find ${RPM_BUILD_ROOT}%{python3_sitearch} \
%{_mandir}/man1/*
-%if %{with_python2}
-%files -n python2-vips
-%{python2_sitearch}/gi/overrides/*
-%{python2_sitearch}/vipsCC/
-%endif
-
-
-%if %{with_python3}
-%files -n python3-vips
-%{python3_sitearch}/gi/overrides/*.py
-%{python3_sitearch}/gi/overrides/__pycache__/*
-%endif
-
-
%if %{with_doc}
%files doc
%doc doc/html
@@ -252,6 +216,14 @@ find ${RPM_BUILD_ROOT}%{python3_sitearch} \
%changelog
+* Mon May 6 2019 Remi Collet <remi@remirepo.net> - 8.8.0~rc1-1
+- update to 8.8.0-rc1
+- drop libvipsCC
+- drop python support
+
+* Mon Mar 18 2019 Remi Collet <remi@remirepo.net> - 8.7.4-2
+- rebuild using libwebp7
+
* Fri Jan 18 2019 Remi Collet <remi@remirepo.net> - 8.7.4-1
- update to 8.7.4