summaryrefslogtreecommitdiffstats
path: root/vips.spec
diff options
context:
space:
mode:
Diffstat (limited to 'vips.spec')
-rw-r--r--vips.spec172
1 files changed, 123 insertions, 49 deletions
diff --git a/vips.spec b/vips.spec
index a6a5cf4..ea3c0c4 100644
--- a/vips.spec
+++ b/vips.spec
@@ -7,24 +7,36 @@
#
# Please preserve changelog entries
#
-%global vips_version_base 8.14
+%global vips_version_base 8.16
%global vips_version %{vips_version_base}.1
%global vips_soname_major 42
-#global vips_prever rc1
+#global vips_prever rc2
%global vips_tagver %{vips_version}%{?vips_prever:-%{vips_prever}}
-%if 0%{?fedora} || 0%{?rhel} >= 8
+# 2-3 builds needed to get the full stack (im6 only for EL8, EL9)
+# --without heif --without im7 --with im6
+# --without heif --without im7 --with gm
+# --with heif --with im7
+%bcond_with im6
+%bcond_without im7
+%bcond_with gm
+
%bcond_without doc
+%bcond_without cplusplus
+%bcond_without matio
+%bcond_without libimagequant
+%bcond_without libcgif
+
+%if 0%{?fedora} || 0%{?rhel} >= 9
+%bcond_without imath
%else
-%bcond_with doc
+%bcond_with imath
%endif
-%if 0%{?fedora} || 0%{?rhel} >= 8
-%bcond_without libimagequant
-%bcond_without libcgif
+%if 0%{?fedora} || 0%{?rhel} >= 9
+%bcond_without highway
%else
-%bcond_with libimagequant
-%bcond_with libcgif
+%bcond_with highway
%endif
%if 0%{?fedora} >= 34 || 0%{?rhel} >= 9
@@ -45,14 +57,6 @@
%bcond_with niftic
%endif
-# 3 builds needed to get the full stack
-# --without heif --without im7 --with im6
-# --without heif --without im7 --with gm
-# --with heif --with im7
-%bcond_with im6
-%bcond_without im7
-%bcond_with gm
-
%bcond_without tests
%if 0%{?fedora} >= 34 || 0%{?rhel} >= 9
@@ -61,8 +65,8 @@
%bcond_with jxl
%endif
-# from mock config, when rpmfusion enabled
-%if 0%{?_with_rpmfusion:1}
+# from fedora/epel repository, or from rpmfusion when enabled (from mock config)
+%if 0%{?fedora} >= 36 || 0%{?rhel} >= 9 || 0%{?_with_rpmfusion:1}
%bcond_without heif
%else
%bcond_with heif
@@ -73,9 +77,9 @@ Version: %{vips_version}%{?vips_prever:~%{vips_prever}}
Release: 1%{?dist}
Summary: C/C++ library for processing large images
-License: LGPLv2+
-URL: https://libvips.github.io/libvips/
-Source0: https://github.com/libvips/libvips/releases/download/v%{vips_tagver}/vips-%{vips_version}.tar.xz
+License: LGPL-2.1-or-later
+URL: https://www.libvips.org/
+Source0: https://github.com/libvips/libvips/releases/download/v%{vips_tagver}/vips-%{vips_tagver}.tar.xz
BuildRequires: gcc
BuildRequires: gcc-c++
@@ -86,14 +90,17 @@ BuildRequires: pkgconfig(glib-2.0)
BuildRequires: pkgconfig(expat)
BuildRequires: pkgconfig(fftw3)
BuildRequires: pkgconfig(gobject-introspection-1.0)
-BuildRequires: pkgconfig(orc-0.4)
+%if %{with highway}
+BuildRequires: pkgconfig(libhwy) >= 1.0.5
+%else
+BuildRequires: pkgconfig(orc-0.4) >= 0.4.11
+%endif
BuildRequires: pkgconfig(lcms2)
-BuildRequires: pkgconfig(OpenEXR)
-%if 0%{?fedora} >= 35
+BuildRequires: pkgconfig(OpenEXR) >= 1.2.2
+%if %{with imath}
BuildRequires: pkgconfig(Imath)
%endif
-# https://bugzilla.redhat.com/2034536 - missing in EPEL-9
-%if 0%{?rhel} < 9
+%if %{with matio}
BuildRequires: pkgconfig(matio)
%endif
BuildRequires: pkgconfig(cfitsio)
@@ -104,7 +111,7 @@ BuildRequires: pkgconfig(libtiff-4)
# upstream requires 0.6
BuildRequires: pkgconfig(libwebp) > 1
BuildRequires: pkgconfig(libexif)
-BuildRequires: pkgconfig(libgsf-1)
+BuildRequires: pkgconfig(libarchive) >= 3
BuildRequires: pkgconfig(librsvg-2.0) >= 2.40.3
BuildRequires: pkgconfig(libjpeg)
%if %{with libspng}
@@ -133,8 +140,11 @@ BuildRequires: bc
# Not available as system library
Provides: bundled(libnsgif)
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 9
+Recommends: %{name}-heif
+%else
Suggests: %{name}-heif
+%endif
%if 0%{?fedora} >= 38 || 0%{?rhel} >= 10
Recommends: %{name}-magick-im7
%else
@@ -144,10 +154,6 @@ Recommends: %{name}-magick-im6
%endif
Recommends: %{name}-openslide
Recommends: %{name}-poppler
-%else
-Requires: %{name}-openslide
-Requires: %{name}-poppler
-%endif
%description
@@ -173,7 +179,6 @@ Additional image formats are supported in additional optional packages:
%package devel
Summary: Development files for %{name}
-Requires: libjpeg-devel%{?_isa} libtiff-devel%{?_isa} zlib-devel%{?_isa}
Requires: %{name}%{?_isa} = %{version}-%{release}
Obsoletes: vips-full-devel < 8.11
@@ -207,30 +212,29 @@ HTML and PDF formats.
%if %{with jxl}
%package jxl
-Summary: JPEG-XL support for %{name}
+Summary: JPEG XL support for %{name}
BuildRequires: pkgconfig(libjxl) >= 0.6
Requires: %{name}%{?_isa} = %{version}-%{release}
Supplements: %{name}
%description jxl
-The %{name}-jxl package contains the Jxl module for VIPS.
+The %{name}-jxl package contains the jxl module for VIPS, providing JPEG XL.
%endif
%if %{with heif}
%package heif
Summary: Heif support for %{name}
-%if 0%{?rhel} == 7
-# ensure we use our on EL-7
BuildRequires: pkgconfig(libheif) >= 1.4.0
-Requires: libheif%{?_isa} >= 1.4.0
-%else
-BuildRequires: pkgconfig(libheif) >= 1.3
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 9
+# x265 HEVC encoder from RPMFusion
+Recommends: libheif-freeworld%{?_isa}
%endif
Requires: %{name}%{?_isa} = %{version}-%{release}
Obsoletes: vips-full < 8.11
%description heif
-The %{name}-heif package contains the Heif module for VIPS.
+The %{name}-heif package contains the heif module for VIPS, providing AVIF
+support.
%endif
%package openslide
@@ -254,7 +258,7 @@ The %{name}-poppler package contains the Poppler module for VIPS.
Summary: Magick support for %{name} using ImageMagick6
BuildRequires: ImageMagick6-devel
Requires: %{name}%{?_isa} = %{version}-%{release}
-%if 0%{?fedora} >= 34
+%if 0%{?fedora} >= 34 && 0%{?fedora} < 38
Obsoletes: %{name}-magick < %{version}-%{release}
%endif
Provides: %{name}-magick = %{version}-%{release}
@@ -272,6 +276,9 @@ using ImageMagick version 6.
Summary: Magick support for %{name} using ImageMagick7
BuildRequires: ImageMagick7-devel
Requires: %{name}%{?_isa} = %{version}-%{release}
+%if 0%{?fedora} >= 38 || 0%{?rhel} >= 10
+Obsoletes: %{name}-magick < %{version}-%{release}
+%endif
Provides: %{name}-magick = %{version}-%{release}
Provides: %{name}-magick%{?_isa} = %{version}-%{release}
Conflicts: %{name}-magick-im6
@@ -312,6 +319,7 @@ exit 1
%setup -q -n vips-%{vips_version}
+
%build
# Upstream recommends enabling auto-vectorization of inner loops:
# https://github.com/libvips/libvips/pull/212#issuecomment-68177930
@@ -354,9 +362,19 @@ export CXXFLAGS="%{optflags} -ftree-vectorize"
-Ddoxygen=true \
-Dgtk_doc=true \
%endif
+%if %{with cplusplus}
+ -Dcplusplus=true \
+%else
+ -Dcplusplus=false \
+%endif
%if %{with gm}
-Dmagick-package=GraphicsMagick \
%endif
+%if %{with highway}
+ -Dhighway=enabled \
+%else
+ -Dhighway=disabled \
+%endif
-Dpdfium=disabled \
%{nil}
@@ -375,12 +393,6 @@ export CXXFLAGS="%{optflags} -ftree-vectorize"
%endif
-%if 0%{?fedora} < 28 && 0%{?rhel} < 8
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
-%endif
-
-
%files -f vips%{vips_version_base}.lang
%doc ChangeLog README.md
%license LICENSE
@@ -404,7 +416,9 @@ export CXXFLAGS="%{optflags} -ftree-vectorize"
%if %{with doc}
%files doc
%{_datadir}/gtk-doc
+%if %{with cplusplus}
%{_docdir}/vips-doc/html
+%endif
%license LICENSE
%endif
@@ -442,6 +456,66 @@ export CXXFLAGS="%{optflags} -ftree-vectorize"
%changelog
+* Thu Mar 13 2025 Remi Collet <remi@remirepo.net> - 8.16.1-1
+- update to 8.16.1
+
+* Mon Oct 28 2024 Remi Collet <remi@remirepo.net> - 8.16.0-1
+- update to 8.16.0
+
+* Mon Oct 21 2024 Remi Collet <remi@remirepo.net> - 8.16.0~rc2-1
+- update to 8.16.0-rc2
+
+* Fri Oct 11 2024 Remi Collet <remi@remirepo.net> - 8.16.0~rc1-1
+- update to 8.16.0-rc1
+- open https://github.com/libvips/libvips/issues/4192
+ Build failure with libheif 1.7.0 (EL-8)
+
+* Mon Oct 7 2024 Remi Collet <remi@remirepo.net> - 8.15.5~rc1-1
+- update to 8.15.5-rc1
+- re-add libvips-cpp
+
+* Thu Oct 3 2024 Remi Collet <remi@remirepo.net> - 8.15.4-1
+- update to 8.15.4
+- remove libvips-cpp (C++ library) which have no stable ABI
+
+* Mon Aug 12 2024 Remi Collet <remi@remirepo.net> - 8.15.3-1
+- update to 8.15.3
+
+* Wed Mar 13 2024 Remi Collet <remi@remirepo.net> - 8.15.2-1
+- update to 8.15.2
+
+* Mon Jan 8 2024 Remi Collet <remi@remirepo.net> - 8.15.1-2
+- add weak dependency on libheif-freeworld from RPMFusion (Fedora and EL-9)
+
+* Tue Dec 19 2023 Remi Collet <remi@remirepo.net> - 8.15.1-1
+- update to 8.15.1
+
+* Mon Nov 13 2023 Remi Collet <remi@remirepo.net> - 8.15.0-1
+- update to 8.15.0
+
+* Mon Nov 6 2023 Remi Collet <remi@remirepo.net> - 8.15.0~rc2-1
+- update to 8.15.0rc2
+- drop patch merged upstream
+
+* Thu Oct 19 2023 Remi Collet <remi@remirepo.net> - 8.15.0~rc1-1
+- update to 8.15.0rc1
+- use libhwy instead of liborc on Fedora and EL-9
+- use libarchive instead of libgsf
+- open https://github.com/libvips/libvips/pull/3722
+ Revert "raise librsvg minver to 2.48
+
+* Tue Sep 19 2023 Remi Collet <remi@remirepo.net> - 8.14.5-1
+- update to 8.14.5
+
+* Thu Aug 17 2023 Remi Collet <remi@remirepo.net> - 8.14.4-1
+- update to 8.14.4
+
+* Fri Jul 21 2023 Remi Collet <remi@remirepo.net> - 8.14.3-1
+- update to 8.14.3
+
+* Tue Mar 21 2023 Remi Collet <remi@remirepo.net> - 8.14.2-1
+- update to 8.14.2
+
* Mon Jan 9 2023 Remi Collet <remi@remirepo.net> - 8.14.1-1
- update to 8.14.1