summaryrefslogtreecommitdiffstats
path: root/vips.spec
diff options
context:
space:
mode:
Diffstat (limited to 'vips.spec')
-rw-r--r--vips.spec108
1 files changed, 86 insertions, 22 deletions
diff --git a/vips.spec b/vips.spec
index b0723fb..258fc80 100644
--- a/vips.spec
+++ b/vips.spec
@@ -7,11 +7,11 @@
#
# Please preserve changelog entries
#
-%global vips_version_base 8.14
-%global vips_version %{vips_version_base}.0
+%global vips_version_base 8.15
+%global vips_version %{vips_version_base}.2
%global vips_soname_major 42
-#global vips_prever rc1
-%global vips_tagver %{vips_version}%{?vips_prever:-%{vips_prever}}
+#global vips_prever rc2
+%global vips_tagver %{vips_version}%{?vips_prever:-%{vips_prever}}a
%if 0%{?fedora} || 0%{?rhel} >= 8
%bcond_without doc
@@ -19,6 +19,12 @@
%bcond_with doc
%endif
+%if 0%{?fedora} || 0%{?rhel} >= 9
+%bcond_without highway
+%else
+%bcond_with highway
+%endif
+
%if 0%{?fedora} || 0%{?rhel} >= 8
%bcond_without libimagequant
%bcond_without libcgif
@@ -46,6 +52,7 @@
%endif
# 3 builds needed to get the full stack
+# NOTICE: for EL-7, epel-rpm-macros needed (clean root_cache before build with el7xr config)
# --without heif --without im7 --with im6
# --without heif --without im7 --with gm
# --with heif --with im7
@@ -53,16 +60,16 @@
%bcond_without im7
%bcond_with gm
-%bcond_with tests
+%bcond_without tests
-%if 0%{?fedora} >= 33 || 0%{?rhel} >= 9
+%if 0%{?fedora} >= 34 || 0%{?rhel} >= 9
%bcond_without jxl
%else
%bcond_with jxl
%endif
-# from mock config, when rpmfusion enabled
-%if 0%{?_with_rpmfusion:1}
+# from fedora/epel repository, or from rpmfusion when enabled (from mock config)
+%if 0%{?fedora} >= 36 || 0%{?rhel} >= 9 || 0%{?_with_rpmfusion:1}
%bcond_without heif
%else
%bcond_with heif
@@ -79,16 +86,20 @@ Source0: https://github.com/libvips/libvips/releases/download/v%{vips_tag
BuildRequires: gcc
BuildRequires: gcc-c++
-BuildRequires: meson >= 0.56
+BuildRequires: meson >= 0.55
BuildRequires: pkgconfig
BuildRequires: gettext
BuildRequires: pkgconfig(glib-2.0)
BuildRequires: pkgconfig(expat)
BuildRequires: pkgconfig(fftw3)
BuildRequires: pkgconfig(gobject-introspection-1.0)
-BuildRequires: pkgconfig(orc-0.4)
+%if %{with highway}
+BuildRequires: pkgconfig(libhwy) >= 1.0.5
+%else
+BuildRequires: pkgconfig(orc-0.4) >= 0.4.11
+%endif
BuildRequires: pkgconfig(lcms2)
-BuildRequires: pkgconfig(OpenEXR)
+BuildRequires: pkgconfig(OpenEXR) >= 1.2.2
%if 0%{?fedora} >= 35
BuildRequires: pkgconfig(Imath)
%endif
@@ -104,7 +115,7 @@ BuildRequires: pkgconfig(libtiff-4)
# upstream requires 0.6
BuildRequires: pkgconfig(libwebp) > 1
BuildRequires: pkgconfig(libexif)
-BuildRequires: pkgconfig(libgsf-1)
+BuildRequires: pkgconfig(libarchive) >= 3
BuildRequires: pkgconfig(librsvg-2.0) >= 2.40.3
BuildRequires: pkgconfig(libjpeg)
%if %{with libspng}
@@ -133,11 +144,19 @@ BuildRequires: bc
# Not available as system library
Provides: bundled(libnsgif)
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 9
+Recommends: %{name}-heif
+%else
Suggests: %{name}-heif
+%endif
+%if 0%{?fedora} >= 38 || 0%{?rhel} >= 10
+Recommends: %{name}-magick-im7
+%else
# im6 is temporarily recommended for smooth upgrade from 8.10
# user can remove / replace with alternative
Recommends: %{name}-magick-im6
+%endif
Recommends: %{name}-openslide
Recommends: %{name}-poppler
%else
@@ -204,7 +223,7 @@ HTML and PDF formats.
%if %{with jxl}
%package jxl
Summary: JPEG-XL support for %{name}
-BuildRequires: pkgconfig(libjxl) >= 0.5
+BuildRequires: pkgconfig(libjxl) >= 0.6
Requires: %{name}%{?_isa} = %{version}-%{release}
Supplements: %{name}
@@ -215,12 +234,14 @@ The %{name}-jxl package contains the Jxl module for VIPS.
%if %{with heif}
%package heif
Summary: Heif support for %{name}
+BuildRequires: pkgconfig(libheif) >= 1.4.0
%if 0%{?rhel} == 7
# ensure we use our on EL-7
-BuildRequires: pkgconfig(libheif) >= 1.4.0
Requires: libheif%{?_isa} >= 1.4.0
-%else
-BuildRequires: pkgconfig(libheif) >= 1.3
+%endif
+%if 0%{?fedora} >= 37 || 0%{?rhel} >= 9
+# x265 HEVC encoder from RPMFusion
+Recommends: libheif-freeworld%{?_isa}
%endif
Requires: %{name}%{?_isa} = %{version}-%{release}
Obsoletes: vips-full < 8.11
@@ -250,7 +271,7 @@ The %{name}-poppler package contains the Poppler module for VIPS.
Summary: Magick support for %{name} using ImageMagick6
BuildRequires: ImageMagick6-devel
Requires: %{name}%{?_isa} = %{version}-%{release}
-%if 0%{?fedora} >= 34
+%if 0%{?fedora} >= 34 && 0%{?fedora} < 38
Obsoletes: %{name}-magick < %{version}-%{release}
%endif
Provides: %{name}-magick = %{version}-%{release}
@@ -268,6 +289,9 @@ using ImageMagick version 6.
Summary: Magick support for %{name} using ImageMagick7
BuildRequires: ImageMagick7-devel
Requires: %{name}%{?_isa} = %{version}-%{release}
+%if 0%{?fedora} >= 38 || 0%{?rhel} >= 10
+Obsoletes: %{name}-magick < %{version}-%{release}
+%endif
Provides: %{name}-magick = %{version}-%{release}
Provides: %{name}-magick%{?_isa} = %{version}-%{release}
Conflicts: %{name}-magick-im6
@@ -308,6 +332,7 @@ exit 1
%setup -q -n vips-%{vips_version}
+
%build
# Upstream recommends enabling auto-vectorization of inner loops:
# https://github.com/libvips/libvips/pull/212#issuecomment-68177930
@@ -353,6 +378,11 @@ export CXXFLAGS="%{optflags} -ftree-vectorize"
%if %{with gm}
-Dmagick-package=GraphicsMagick \
%endif
+%if %{with highway}
+ -Dhighway=enabled \
+%else
+ -Dhighway=disabled \
+%endif
-Dpdfium=disabled \
%{nil}
@@ -361,10 +391,6 @@ export CXXFLAGS="%{optflags} -ftree-vectorize"
%install
%meson_install
-%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
-sed -e 's:/usr/bin/python:%{_bindir}/python3:' -i %{buildroot}/%{_bindir}/vipsprofile
-%endif
-
# locale stuff
%find_lang vips%{vips_version_base}
@@ -442,6 +468,44 @@ sed -e 's:/usr/bin/python:%{_bindir}/python3:' -i %{buildroot}/%{_bindir}/vipspr
%changelog
+* Wed Mar 13 2024 Remi Collet <remi@remirepo.net> - 8.15.2-1
+- update to 8.15.2
+
+* Mon Jan 8 2024 Remi Collet <remi@remirepo.net> - 8.15.1-2
+- add weak dependency on libheif-freeworld from RPMFusion (Fedora and EL-9)
+
+* Tue Dec 19 2023 Remi Collet <remi@remirepo.net> - 8.15.1-1
+- update to 8.15.1
+
+* Mon Nov 13 2023 Remi Collet <remi@remirepo.net> - 8.15.0-1
+- update to 8.15.0
+
+* Mon Nov 6 2023 Remi Collet <remi@remirepo.net> - 8.15.0~rc2-1
+- update to 8.15.0rc2
+- drop patch merged upstream
+
+* Thu Oct 19 2023 Remi Collet <remi@remirepo.net> - 8.15.0~rc1-1
+- update to 8.15.0rc1
+- use libhwy instead of liborc on Fedora and EL-9
+- use libarchive instead of libgsf
+- open https://github.com/libvips/libvips/pull/3722
+ Revert "raise librsvg minver to 2.48
+
+* Tue Sep 19 2023 Remi Collet <remi@remirepo.net> - 8.14.5-1
+- update to 8.14.5
+
+* Thu Aug 17 2023 Remi Collet <remi@remirepo.net> - 8.14.4-1
+- update to 8.14.4
+
+* Fri Jul 21 2023 Remi Collet <remi@remirepo.net> - 8.14.3-1
+- update to 8.14.3
+
+* Tue Mar 21 2023 Remi Collet <remi@remirepo.net> - 8.14.2-1
+- update to 8.14.2
+
+* Mon Jan 9 2023 Remi Collet <remi@remirepo.net> - 8.14.1-1
+- update to 8.14.1
+
* Mon Jan 2 2023 Remi Collet <remi@remirepo.net> - 8.14.0-1
- update to 8.14.0
- open https://github.com/libvips/libvips/issues/3254 ABI/API compat