summaryrefslogtreecommitdiffstats
path: root/vips.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-15 12:30:04 +0200
committerRemi Collet <remi@remirepo.net>2021-06-15 12:30:04 +0200
commit4c881c4a712c6c3ab0fbd89436a2872db02b0dbd (patch)
tree42cf9aa797285083a33bebdba16b814429e3e496 /vips.spec
parent0654a74c50ca863b464accacc9b0fdafacabf9e5 (diff)
test build using openjpeg2 2.3
open https://github.com/libvips/libvips/pull/2305 allow libopenjp2 2.3
Diffstat (limited to 'vips.spec')
-rw-r--r--vips.spec37
1 files changed, 34 insertions, 3 deletions
diff --git a/vips.spec b/vips.spec
index 4f28910..9d942e3 100644
--- a/vips.spec
+++ b/vips.spec
@@ -25,16 +25,27 @@
%bcond_with libimagequant
%endif
+%if 0%{?rhel} == 7
+# disabled by default
+# as vips pulls poppler (libopenjpeg) and IM (libopenjp2)
+# so vips segfaults in various place
+%bcond_with openjpeg2
+%else
+%bcond_without openjpeg2
+%endif
+
%if 0%{?fedora}
%bcond_without libspng
+%bcond_without niftic
%else
%bcond_with libspng
+%bcond_with niftic
%endif
# 3 builds needed to get the full stack
-# --with heif
# --without im6 --with im7
# --without im6 --with gm
+# --with heif
%bcond_without im6
%bcond_with im7
@@ -48,7 +59,7 @@
%endif
Name: vips
-Release: 1%{?dist}
+Release: 1%{?dist}.1
Version: %{vips_version}%{?vips_prever:~%{vips_prever}}
Summary: C/C++ library for processing large images
@@ -79,6 +90,12 @@ BuildRequires: pkgconfig(libjpeg)
%if %{with libspng}
BuildRequires: pkgconfig(spng) >= 0.6
%endif
+%if %{with niftic}
+BuildRequires: nifticlib-devel
+%endif
+%if %{with openjpeg2}
+BuildRequires: pkgconfig(libopenjp2) >= 2.3
+%endif
%if %{with libimagequant}
#BuildRequires: pkgconfig(imagequant) TODO only in 2.12+
BuildRequires: libimagequant-devel
@@ -233,6 +250,11 @@ sed -i "s/\\(VIPS_VERSION_STRING=\\)\$VIPS_VERSION-\`date\`/\\1\"\$VIPS_VERSION-
configure
unset FAKE_BUILD_DATE
+%if %{with openjpeg2}
+# allow openjpeg2 version 2.3
+sed -i '/libopenjp2/s/2.4/2.3/' -i configure
+%endif
+
# Avoid setting RPATH to /usr/lib64 on 64-bit builds
# The DIE_RPATH_DIE trick breaks the build wrt gobject-introspection
sed -i 's|sys_lib_dlsearch_path_spec="|sys_lib_dlsearch_path_spec="/%{_lib} %{_libdir} |' configure
@@ -254,6 +276,11 @@ export CXXFLAGS="%{optflags} -ftree-vectorize"
%else
--without-imagequant \
%endif
+%if %{with openjpeg2}
+ --with-libopenjp2 \
+%else
+ --without-libopenjp2 \
+%endif
%if %{with libspng}
--with-libspng \
%else
@@ -291,7 +318,7 @@ sed -e 's:/usr/bin/python:%{_bindir}/python3:' -i %{buildroot}/%{_bindir}/vipspr
%files -f vips%{vips_version_base}.lang
-%doc AUTHORS NEWS THANKS ChangeLog
+%doc AUTHORS NEWS THANKS README.md ChangeLog
%license COPYING
%{_libdir}/*.so.%{vips_soname_major}*
%{_libdir}/girepository-1.0
@@ -346,6 +373,10 @@ sed -e 's:/usr/bin/python:%{_bindir}/python3:' -i %{buildroot}/%{_bindir}/vipspr
%changelog
+* Tue Jun 15 2021 Remi Collet <remi@remirepo.net> - 8.11.0-1.1
+- test build using openjpeg2 2.3
+- open https://github.com/libvips/libvips/pull/2305 allow libopenjp2 2.3
+
* Thu Jun 10 2021 Remi Collet <remi@remirepo.net> - 8.11.0-1
- update to 8.11.0