summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-03 16:06:29 +0200
committerRemi Collet <remi@remirepo.net>2021-09-03 16:06:29 +0200
commit104bdaedcfdeb056e6c7531de4feb0c4a2930d59 (patch)
tree9b5d482c21209a33fe566c6f65d20c7d57d9f312
parent3c175c2dce368a8999e98aeda0ae2ca8bb604907 (diff)
add Jxl support
build with ImageMagick7 by default
-rw-r--r--vips.spec59
1 files changed, 52 insertions, 7 deletions
diff --git a/vips.spec b/vips.spec
index 212e7eb..c099f84 100644
--- a/vips.spec
+++ b/vips.spec
@@ -44,14 +44,20 @@
%endif
# 3 builds needed to get the full stack
-# --without heif --without im6 --with im7
-# --without heif --without im6 --with gm
-# --with heif --with im6
+# --without heif --without im7 --with im6
+# --without heif --without im7 --with gm
+# --with heif --with im7
-%bcond_without im6
-%bcond_with im7
+%bcond_with im6
+%bcond_without im7
%bcond_with gm
+%if 0%{?fedora} >= 33
+%bcond_without jxl
+%else
+%bcond_with jxl
+%endif
+
# from mock config, when rpmfusion enabled
%if 0%{?_with_rpmfusion:1}
%bcond_without heif
@@ -60,7 +66,7 @@
%endif
Name: vips
-Release: 1%{?dist}
+Release: 2%{?dist}
Version: %{vips_version}%{?vips_prever:~%{vips_prever}}
Summary: C/C++ library for processing large images
@@ -132,6 +138,9 @@ This package should be installed if you want to use a program compiled
against VIPS.
Additional image formats are supported in additional optional packages:
+%if %{with jxl}
+* %{name}-jxl
+%endif
* %{name}-heif
* %{name}-openslide
* %{name}-poppler
@@ -175,6 +184,17 @@ The %{name}-doc package contains extensive documentation about VIPS in both
HTML and PDF formats.
%endif
+%if %{with jxl}
+%package jxl
+Summary: Jxl support for %{name}
+BuildRequires: pkgconfig(libjxl) >= 0.3.7
+Requires: %{name}%{?_isa} = %{version}-%{release}
+Supplements: %{name}
+
+%description jxl
+The %{name}-jxl package contains the Jxl module for VIPS.
+%endif
+
%if %{with heif}
%package heif
Summary: Heif support for %{name}
@@ -212,7 +232,7 @@ BuildRequires: ImageMagick-devel
BuildRequires: ImageMagick6-devel
%endif
Requires: %{name}%{?_isa} = %{version}-%{release}
-%if 0%{?fedora} >= 35
+%if 0%{?fedora} >= 34
Obsoletes: %{name}-magick < %{version}-%{release}
%endif
Provides: %{name}-magick = %{version}-%{release}
@@ -257,6 +277,17 @@ using GraphicsMagick.
%prep
+%if %{with gm}
+%if %{with im7}
+: Cannot enable GraphicsMagick and ImageMagick7
+exit 1
+%endif
+%if %{with im6}
+: Cannot enable GraphicsMagick and ImageMagick6
+exit 1
+%endif
+%endif
+
%setup -q -n vips-%{vips_version}
# make the version string consistent for multiarch
@@ -296,6 +327,11 @@ export CXXFLAGS="%{optflags} -ftree-vectorize"
%else
--without-libspng \
%endif
+%if %{with jxl}
+ --with-libjxl=module \
+%else
+ --without-libjxl \
+%endif
%if %{with doc}
--enable-gtk-doc \
%endif
@@ -366,6 +402,11 @@ mv cplusplus/html cplusplus_html
%files poppler
%{_libdir}/vips-modules-%{vips_version_base}/vips-poppler.so
+%if %{with jxl}
+%files jxl
+%{_libdir}/vips-modules-%{vips_version_base}/vips-jxl.so
+%endif
+
%if %{with heif}
%files heif
%{_libdir}/vips-modules-%{vips_version_base}/vips-heif.so
@@ -388,6 +429,10 @@ mv cplusplus/html cplusplus_html
%changelog
+* Fri Sep 3 2021 Remi Collet <remi@remirepo.net> - 8.11.3-2
+- add Jxl support
+- build with ImageMagick7 by default
+
* Wed Aug 25 2021 Remi Collet <remi@remirepo.net> - 8.11.3-1
- update to 8.11.3