summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--uuid-1.6.2-php54.patch12
-rw-r--r--uuid.spec15
3 files changed, 28 insertions, 3 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1e65467
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../common/Makefile
+
diff --git a/uuid-1.6.2-php54.patch b/uuid-1.6.2-php54.patch
new file mode 100644
index 0000000..e0281a8
--- /dev/null
+++ b/uuid-1.6.2-php54.patch
@@ -0,0 +1,12 @@
+diff -up uuid-1.6.2/php/uuid.c.php54 uuid-1.6.2/php/uuid.c
+--- uuid-1.6.2/php/uuid.c.php54 2011-12-27 17:23:00.948400710 +0100
++++ uuid-1.6.2/php/uuid.c 2011-12-27 17:23:16.668401029 +0100
+@@ -496,7 +496,7 @@ PHP_FUNCTION(uuid_version)
+ }
+
+ /* module function table */
+-static function_entry uuid_functions[] = {
++static zend_function_entry uuid_functions[] = {
+ PHP_FE(uuid_create, NULL)
+ PHP_FE(uuid_destroy, NULL)
+ PHP_FE(uuid_clone, NULL)
diff --git a/uuid.spec b/uuid.spec
index ce9fd03..c44ddbd 100644
--- a/uuid.spec
+++ b/uuid.spec
@@ -11,6 +11,7 @@ URL: http://www.ossp.org/pkg/lib/uuid/
Source0: ftp://ftp.ossp.org/pkg/lib/uuid/uuid-%{version}.tar.gz
Patch0: uuid-1.6.1-ossp.patch
Patch1: uuid-1.6.1-mkdir.patch
+Patch2: uuid-1.6.2-php54.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libtool
@@ -110,6 +111,7 @@ DCE development headers and libraries for OSSP uuid.
%setup -q
%patch0 -p1
%patch1 -p1
+%patch2 -p1 -b .php54
%build
# Build the library.
@@ -184,9 +186,13 @@ pushd perl
LD_LIBRARY_PATH=../.libs make test
popd
-pushd php
-LD_LIBRARY_PATH=../.libs make test
-popd
+#pushd php
+# no test run...
+# LD_LIBRARY_PATH=../.libs make test
+#popd
+# Simple extension load test
+LD_LIBRARY_PATH=.libs php -n -d extension_dir=php/modules -d extension=uuid.so -m | grep uuid
+
%clean
rm -rf $RPM_BUILD_ROOT
@@ -258,6 +264,9 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/libossp-uuid_dce.so
%changelog
+* Tue Dec 27 2011 Remi Collet <remi@fedoraproject.org> - 1.6.2-6
+- build against php 5.4
+
* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.6.2-6
- Perl mass rebuild