summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2011-12-27 17:21:21 +0100
committerRemi Collet <fedora@famillecollet.com>2011-12-27 17:21:21 +0100
commitf27cfe11cf754603cc0c4fb52c2f83693919923f (patch)
tree34b4aab17e4e980559a8e67262afe6171a478515
uuid: import from f16
-rw-r--r--uuid-1.6.1-mkdir.patch11
-rw-r--r--uuid-1.6.1-ossp.patch207
-rw-r--r--uuid.spec356
3 files changed, 574 insertions, 0 deletions
diff --git a/uuid-1.6.1-mkdir.patch b/uuid-1.6.1-mkdir.patch
new file mode 100644
index 0000000..89e230c
--- /dev/null
+++ b/uuid-1.6.1-mkdir.patch
@@ -0,0 +1,11 @@
+diff -up uuid-1.6.2/pgsql/Makefile.mkdir uuid-1.6.2/pgsql/Makefile
+--- uuid-1.6.2/pgsql/Makefile.mkdir 2011-03-03 15:12:12.000000000 +0000
++++ uuid-1.6.2/pgsql/Makefile 2011-03-03 16:15:45.000000000 +0000
+@@ -16,6 +16,7 @@ PG_CONFIG ?= pg_config
+ PGXS := $(shell $(PG_CONFIG) --pgxs)
+ POSTGRES := $(shell $(PG_CONFIG) --bindir)/postgres
+ top_builddir := $(dir $(PGXS))../..
++mkinstalldirs = ../shtool mkdir -p
+ include $(top_builddir)/src/Makefile.global
+
+ NAME = ossp-uuid
diff --git a/uuid-1.6.1-ossp.patch b/uuid-1.6.1-ossp.patch
new file mode 100644
index 0000000..c0c7d57
--- /dev/null
+++ b/uuid-1.6.1-ossp.patch
@@ -0,0 +1,207 @@
+diff -up uuid-1.6.1/uuid-config.in.BAD uuid-1.6.1/uuid-config.in
+--- uuid-1.6.1/uuid-config.in.BAD 2008-03-06 11:56:13.000000000 -0500
++++ uuid-1.6.1/uuid-config.in 2008-03-06 11:56:25.000000000 -0500
+@@ -121,7 +121,7 @@ do
+ output_extra="$output_extra $uuid_ldflags"
+ ;;
+ --libs)
+- output="$output -luuid"
++ output="$output -lossp-uuid"
+ output_extra="$output_extra $uuid_libs"
+ ;;
+ * )
+diff -up uuid-1.6.1/Makefile.in.BAD uuid-1.6.1/Makefile.in
+--- uuid-1.6.1/Makefile.in.BAD 2008-03-06 11:10:13.000000000 -0500
++++ uuid-1.6.1/Makefile.in 2008-03-06 11:11:39.000000000 -0500
+@@ -62,13 +62,13 @@ PERL = @PERL@
+ PHP = @PHP@
+ PG_CONFIG = @PG_CONFIG@
+
+-LIB_NAME = libuuid.la
++LIB_NAME = libossp-uuid.la
+ LIB_OBJS = uuid.lo uuid_md5.lo uuid_sha1.lo uuid_prng.lo uuid_mac.lo uuid_time.lo uuid_ui64.lo uuid_ui128.lo uuid_str.lo
+
+-DCE_NAME = libuuid_dce.la
++DCE_NAME = libossp-uuid_dce.la
+ DCE_OBJS = uuid_dce.lo $(LIB_OBJS)
+
+-CXX_NAME = libuuid++.la
++CXX_NAME = libossp-uuid++.la
+ CXX_OBJS = uuid++.lo $(LIB_OBJS)
+
+ PRG_NAME = uuid
+@@ -79,10 +79,10 @@ MAN_NAME = uuid.3 uuid++.3 uuid.1
+ PERL_NAME = $(S)/perl/blib/lib/OSSP/uuid.pm
+ PERL_OBJS = $(S)/perl/uuid.pm
+
+-PHP_NAME = $(S)/php/modules/uuid.so
++PHP_NAME = $(S)/php/modules/ossp-uuid.so
+ PHP_OBJS = $(S)/php/uuid.c
+
+-PGSQL_NAME = $(S)/pgsql/libuuid.so
++PGSQL_NAME = $(S)/pgsql/libossp-uuid.so
+ PGSQL_OBJS = $(S)/pgsql/uuid.c
+
+ TARGETS = $(LIB_NAME) @DCE_NAME@ @CXX_NAME@ $(PRG_NAME) @PERL_NAME@ @PHP_NAME@ @PGSQL_NAME@
+@@ -231,7 +231,7 @@ install:
+ $(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(mandir)/man1
+ $(SHTOOL) install -c -m 755 uuid-config $(DESTDIR)$(bindir)/
+ $(SHTOOL) install -c -m 644 $(S)/uuid-config.1 $(DESTDIR)$(mandir)/man1/
+- $(SHTOOL) install -c -m 644 $(S)/uuid.pc $(DESTDIR)$(libdir)/pkgconfig/
++ $(SHTOOL) install -c -m 644 $(S)/uuid.pc $(DESTDIR)$(libdir)/pkgconfig/ossp-uuid.pc
+ $(SHTOOL) install -c -m 644 uuid.h $(DESTDIR)$(includedir)/
+ -@if [ ".$(WITH_DCE)" = .yes ]; then \
+ echo "$(SHTOOL) install -c -m 644 $(S)/uuid_dce.h $(DESTDIR)$(includedir)/"; \
+@@ -241,7 +241,7 @@ install:
+ echo "$(SHTOOL) install -c -m 644 $(S)/uuid++.hh $(DESTDIR)$(includedir)/"; \
+ $(SHTOOL) install -c -m 644 $(S)/uuid++.hh $(DESTDIR)$(includedir)/; \
+ fi
+- $(SHTOOL) install -c -m 644 $(S)/uuid.3 $(DESTDIR)$(mandir)/man3/
++ $(SHTOOL) install -c -m 644 $(S)/uuid.3 $(DESTDIR)$(mandir)/man3/ossp-uuid.3
+ -@if [ ".$(WITH_CXX)" = .yes ]; then \
+ echo "$(SHTOOL) install -c -m 644 $(S)/uuid++.3 $(DESTDIR)$(mandir)/man3/"; \
+ $(SHTOOL) install -c -m 644 $(S)/uuid++.3 $(DESTDIR)$(mandir)/man3/; \
+@@ -276,7 +276,7 @@ uninstall:
+ -@if [ ".$(WITH_CXX)" = .yes ]; then \
+ $(LIBTOOL) --mode=uninstall $(RM) $(DESTDIR)$(libdir)/$(CXX_NAME); \
+ fi
+- -$(RM) $(DESTDIR)$(mandir)/man3/uuid.3
++ -$(RM) $(DESTDIR)$(mandir)/man3/ossp-uuid.3
+ -@if [ ".$(WITH_CXX)" = .yes ]; then \
+ echo "$(RM) $(DESTDIR)$(mandir)/man3/uuid++.3"; \
+ $(RM) $(DESTDIR)$(mandir)/man3/uuid++.3; \
+@@ -290,7 +290,7 @@ uninstall:
+ echo "$(RM) $(DESTDIR)$(includedir)/uuid++.hh"; \
+ $(RM) $(DESTDIR)$(includedir)/uuid++.hh; \
+ fi
+- -$(RM) $(DESTDIR)$(libdir)/pkgconfig/uuid.pc
++ -$(RM) $(DESTDIR)$(libdir)/pkgconfig/ossp-uuid.pc
+ -$(RM) $(DESTDIR)$(mandir)/man1/uuid-config.1
+ -$(RM) $(DESTDIR)$(bindir)/uuid-config
+ -$(RMDIR) $(DESTDIR)$(mandir)/man1 >/dev/null 2>&1 || $(TRUE)
+diff -up uuid-1.6.1/pgsql/Makefile.BAD uuid-1.6.1/pgsql/Makefile
+--- uuid-1.6.1/pgsql/Makefile.BAD 2008-03-06 11:53:26.000000000 -0500
++++ uuid-1.6.1/pgsql/Makefile 2008-03-06 11:54:14.000000000 -0500
+@@ -18,13 +18,13 @@ POSTGRES := $(shell $(PG_CONFIG
+ top_builddir := $(dir $(PGXS))../..
+ include $(top_builddir)/src/Makefile.global
+
+-NAME = uuid
++NAME = ossp-uuid
+ OBJS = uuid.o
+ SO_MAJOR_VERSION = 1
+ SO_MINOR_VERSION = 0
+
+ override CPPFLAGS := -I.. $(CPPFLAGS)
+-SHLIB_LINK := -L../.libs -luuid
++SHLIB_LINK := -L../.libs -lossp-uuid
+ SHLIB_LINK += $(shell test $(shell uname -s) = FreeBSD && echo "-Wl,-Bsymbolic")
+ SHLIB_LINK += $(shell test $(shell uname -s) = Darwin && echo "-bundle_loader $(POSTGRES)")
+ rpath :=
+@@ -35,16 +35,16 @@ enable_shared = yes
+ include $(top_builddir)/src/Makefile.shlib
+
+ uuid.sql: uuid.sql.in
+- sed -e 's;MODULE_PATHNAME;$(DESTDIR)$(pkglibdir)/uuid$(DLSUFFIX);g' <uuid.sql.in >uuid.sql
++ sed -e 's;MODULE_PATHNAME;$(DESTDIR)$(pkglibdir)/ossp-uuid$(DLSUFFIX);g' <uuid.sql.in >uuid.sql
+
+ install: all
+ $(mkinstalldirs) $(DESTDIR)$(pkglibdir)
+ $(mkinstalldirs) $(DESTDIR)$(datadir)
+- $(INSTALL_SHLIB) $(shlib) $(DESTDIR)$(pkglibdir)/uuid$(DLSUFFIX)
++ $(INSTALL_SHLIB) $(shlib) $(DESTDIR)$(pkglibdir)/ossp-uuid$(DLSUFFIX)
+ $(INSTALL_DATA) uuid.sql $(DESTDIR)$(datadir)/uuid.sql
+
+ uninstall:
+- -rm -f $(DESTDIR)$(pkglibdir)/uuid$(DLSUFFIX)
++ -rm -f $(DESTDIR)$(pkglibdir)/ossp-uuid$(DLSUFFIX)
+ -rm -f $(DESTDIR)$(datadir)/uuid.sql
+
+ clean distclean: clean-lib
+diff -up uuid-1.6.1/uuid.pc.in.BAD uuid-1.6.1/uuid.pc.in
+--- uuid-1.6.1/uuid.pc.in.BAD 2008-03-06 11:57:29.000000000 -0500
++++ uuid-1.6.1/uuid.pc.in 2008-03-06 11:57:36.000000000 -0500
+@@ -37,6 +37,6 @@ Description: Universally Unique Identifi
+ Version: @UUID_VERSION_RAW@
+ URL: http://www.ossp.org/pkg/lib/uuid/
+ Cflags: -I${includedir}
+-Libs: -L${libdir} -luuid
++Libs: -L${libdir} -lossp-uuid
+ Libs.private: @LIBS@
+
+diff -up uuid-1.6.1/perl/Makefile.PL.BAD uuid-1.6.1/perl/Makefile.PL
+--- uuid-1.6.1/perl/Makefile.PL.BAD 2008-03-06 11:12:05.000000000 -0500
++++ uuid-1.6.1/perl/Makefile.PL 2008-03-06 11:49:25.000000000 -0500
+@@ -33,9 +33,9 @@ use Config;
+ use ExtUtils::MakeMaker;
+
+ # determine source directory
+-my ($srcdir) = map { my $d = $_; $d =~ s/\/libuuid\.la$//; $d }
+- grep { -f $_ } ("../libuuid.la", glob("../*/libuuid.la"))
+- or die "no source directory found (where libuuid.la is located)";
++my ($srcdir) = map { my $d = $_; $d =~ s/\/libossp-uuid\.la$//; $d }
++ grep { -f $_ } ("../libossp-uuid.la", glob("../*/libossp-uuid.la"))
++ or die "no source directory found (where libossp-uuid.la is located)";
+
+ # determine extra build options
+ my $compat = 0;
+@@ -47,7 +47,7 @@ WriteMakefile(
+ VERSION_FROM => 'uuid.pm',
+ ABSTRACT_FROM => 'uuid.pod',
+ PREREQ_PM => {},
+- LIBS => [ "-L$srcdir/.libs -L$srcdir -luuid" ],
++ LIBS => [ "-L$srcdir/.libs -L$srcdir -lossp-uuid" ],
+ DEFINE => '',
+ INC => "-I. -I$srcdir",
+ PM => { 'uuid.pm' => '$(INST_LIBDIR)/uuid.pm',
+diff -up uuid-1.6.1/Makefile.PL.BAD uuid-1.6.1/Makefile.PL
+--- uuid-1.6.1/Makefile.PL.BAD 2008-03-06 11:09:49.000000000 -0500
++++ uuid-1.6.1/Makefile.PL 2008-03-06 11:10:01.000000000 -0500
+@@ -44,7 +44,7 @@ ARGS = $ARGS
+ all pure_all:
+ \@if [ ! -d build ]; then mkdir build; fi
+ \@if [ ! -f build/Makefile ]; then (cd build && ../configure --disable-shared); fi
+- \@if [ ! -f build/libuuid.la ]; then (cd build && \$(MAKE) \$(MFLAGS) libuuid.la); fi
++ \@if [ ! -f build/libossp-uuid.la ]; then (cd build && \$(MAKE) \$(MFLAGS) libossp-uuid.la); fi
+ \@if [ ! -f perl/Makefile ]; then (cd perl && \$(PERL) Makefile.PL \$(ARGS)); fi
+ \@cd perl && \$(MAKE) \$(MFLAGS) \$\@
+
+diff -up uuid-1.6.1/php/config.m4.BAD uuid-1.6.1/php/config.m4
+--- uuid-1.6.1/php/config.m4.BAD 2008-03-06 11:54:55.000000000 -0500
++++ uuid-1.6.1/php/config.m4 2008-03-06 11:55:07.000000000 -0500
+@@ -34,7 +34,7 @@ if test "$PHP_UUID" != "no"; then
+ PHP_NEW_EXTENSION(uuid, uuid.c, $ext_shared)
+ AC_DEFINE(HAVE_UUID, 1, [Have OSSP uuid library])
+ PHP_ADD_LIBPATH([..], )
+- PHP_ADD_LIBRARY([uuid],, UUID_SHARED_LIBADD)
++ PHP_ADD_LIBRARY([ossp-uuid],, UUID_SHARED_LIBADD)
+ PHP_ADD_INCLUDE([..])
+ PHP_SUBST(UUID_SHARED_LIBADD)
+
+diff -up uuid-1.6.1/php/Makefile.local.BAD uuid-1.6.1/php/Makefile.local
+--- uuid-1.6.1/php/Makefile.local.BAD 2008-03-06 11:54:39.000000000 -0500
++++ uuid-1.6.1/php/Makefile.local 2008-03-06 11:54:49.000000000 -0500
+@@ -48,7 +48,7 @@ install: build
+ @version=`$(PHP)-config --version | sed -e 's;^\([0-9]\).*$$;\1;'`; extdir="$(EXTDIR)"; \
+ echo "installing PHP$$version API into $$extdir"; \
+ ./build/shtool mkdir -f -p -m 755 $(DESTDIR)$$extdir; \
+- ./build/shtool install -c -m 755 modules/uuid.so $(DESTDIR)$$extdir/uuid.so; \
++ ./build/shtool install -c -m 755 modules/uuid.so $(DESTDIR)$$extdir/ossp-uuid.so; \
+ ./build/shtool install -c -m 644 uuid.php$$version $(DESTDIR)$$extdir/uuid.php
+
+ clean:
+diff -up uuid-1.6.1/php/uuid.ts.BAD uuid-1.6.1/php/uuid.ts
+--- uuid-1.6.1/php/uuid.ts.BAD 2008-03-06 11:55:38.000000000 -0500
++++ uuid-1.6.1/php/uuid.ts 2008-03-06 11:56:03.000000000 -0500
+@@ -34,9 +34,9 @@
+
+ $php_version = $argv[1];
+
+-print "++ loading DSO uuid.so (low-level API)\n";
++print "++ loading DSO ossp-uuid.so (low-level API)\n";
+ if (!extension_loaded('uuid')) {
+- dl('modules/uuid.so');
++ dl('modules/ossp-uuid.so');
+ }
+
+ print "++ loading PHP uuid.php${php_version} (high-level API)\n";
diff --git a/uuid.spec b/uuid.spec
new file mode 100644
index 0000000..ce9fd03
--- /dev/null
+++ b/uuid.spec
@@ -0,0 +1,356 @@
+%define php_extdir %(php-config --extension-dir 2>/dev/null || echo %{_libdir}/php4)
+%global php_apiver %((echo 0; php -i 2>/dev/null | sed -n 's/^PHP API => //p') | tail -1)
+
+Name: uuid
+Version: 1.6.2
+Release: 6%{?dist}
+Summary: Universally Unique Identifier library
+License: MIT
+Group: System Environment/Libraries
+URL: http://www.ossp.org/pkg/lib/uuid/
+Source0: ftp://ftp.ossp.org/pkg/lib/uuid/uuid-%{version}.tar.gz
+Patch0: uuid-1.6.1-ossp.patch
+Patch1: uuid-1.6.1-mkdir.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: libtool
+
+%description
+OSSP uuid is a ISO-C:1999 application programming interface (API)
+and corresponding command line interface (CLI) for the generation
+of DCE 1.1, ISO/IEC 11578:1996 and RFC 4122 compliant Universally
+Unique Identifier (UUID). It supports DCE 1.1 variant UUIDs of version
+1 (time and node based), version 3 (name based, MD5), version 4
+(random number based) and version 5 (name based, SHA-1). Additional
+API bindings are provided for the languages ISO-C++:1998, Perl:5 and
+PHP:4/5. Optional backward compatibility exists for the ISO-C DCE-1.1
+and Perl Data::UUID APIs.
+
+%package devel
+Summary: Development support for Universally Unique Identifier library
+Group: Development/Libraries
+Requires: pkgconfig
+Requires: %{name} = %{version}-%{release}
+
+%description devel
+Development headers and libraries for OSSP uuid.
+
+%package c++
+Summary: C++ support for Universally Unique Identifier library
+Group: System Environment/Libraries
+Requires: %{name} = %{version}-%{release}
+
+%description c++
+C++ libraries for OSSP uuid.
+
+%package c++-devel
+Summary: C++ development support for Universally Unique Identifier library
+Group: Development/Libraries
+Requires: %{name}-c++ = %{version}-%{release}
+Requires: %{name}-devel = %{version}-%{release}
+
+%description c++-devel
+C++ development headers and libraries for OSSP uuid.
+
+%package perl
+Summary: Perl support for Universally Unique Identifier library
+Group: Development/Libraries
+BuildRequires: perl(ExtUtils::MakeMaker)
+BuildRequires: perl(Test::More)
+Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
+Requires: %{name} = %{version}-%{release}
+
+%description perl
+Perl OSSP uuid modules, which includes a Data::UUID replacement.
+
+%package php
+Summary: PHP support for Universally Unique Identifier library
+Group: Development/Libraries
+BuildRequires: php-devel
+Requires: %{name} = %{version}-%{release}
+%if 0%{?php_zend_api:1}
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+%else
+Requires: php-api = %{php_apiver}
+%endif
+
+%description php
+PHP OSSP uuid module.
+
+%package pgsql
+Summary: PostgreSQL support for Universally Unique Identifier library
+Group: Development/Libraries
+BuildRequires: postgresql-devel
+Requires: postgresql%{_isa}
+Requires: %{_datadir}/pgsql
+Requires: %{name} = %{version}-%{release}
+
+%description pgsql
+PostgreSQL OSSP uuid module.
+
+%package dce
+Summary: DCE support for Universally Unique Identifier library
+Group: Development/Libraries
+Requires: %{name} = %{version}-%{release}
+
+%description dce
+DCE OSSP uuid library.
+
+%package dce-devel
+Summary: DCE development support for Universally Unique Identifier library
+Group: Development/Libraries
+Requires: %{name}-dce = %{version}-%{release}
+Requires: %{name}-devel = %{version}-%{release}
+
+%description dce-devel
+DCE development headers and libraries for OSSP uuid.
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+
+%build
+# Build the library.
+export LIB_NAME=libossp-uuid.la
+export DCE_NAME=libossp-uuid_dce.la
+export CXX_NAME=libossp-uuid++.la
+export PHP_NAME=$(pwd)/php/modules/ossp-uuid.so
+export PGSQL_NAME=$(pwd)/pgsql/libossp-uuid.so
+%configure \
+ --disable-static \
+ --without-perl \
+ --without-php \
+ --with-dce \
+ --with-cxx \
+ --with-pgsql
+
+make LIBTOOL=/usr/bin/libtool %{?_smp_mflags}
+
+# Build the Perl module.
+pushd perl
+%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS" COMPAT=1
+%{__perl} -pi -e 's/^\tLD_RUN_PATH=[^\s]+\s*/\t/' Makefile
+make %{?_smp_mflags}
+popd
+
+# Build the PHP module.
+pushd php
+export PHP_RPATH=no
+phpize
+CFLAGS="$RPM_OPT_FLAGS -I.. -L.. -L../.libs"
+%configure --enable-uuid
+make %{?_smp_mflags}
+popd
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+make install DESTDIR=$RPM_BUILD_ROOT
+rm -f $RPM_BUILD_ROOT%{_libdir}/*.la $RPM_BUILD_ROOT%{_libdir}/*.a
+chmod 755 $RPM_BUILD_ROOT%{_libdir}/*.so.*.*.*
+
+# Install the Perl modules.
+pushd perl
+make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
+
+find $RPM_BUILD_ROOT -type f -name '*.bs' -size 0 -exec rm -f {} \;
+find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
+find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
+
+%{_fixperms} $RPM_BUILD_ROOT/*
+popd
+
+# Install the PHP module.
+pushd php
+make install INSTALL_ROOT=$RPM_BUILD_ROOT
+rm -f $RPM_BUILD_ROOT%{php_extdir}/*.a
+popd
+
+# Put the php config bit into place
+%{__mkdir_p} %{buildroot}%{_sysconfdir}/php.d
+%{__cat} << __EOF__ > %{buildroot}%{_sysconfdir}/php.d/%{name}.ini
+; Enable %{name} extension module
+extension=%{name}.so
+__EOF__
+
+
+
+%check
+make check
+
+pushd perl
+LD_LIBRARY_PATH=../.libs make test
+popd
+
+pushd php
+LD_LIBRARY_PATH=../.libs make test
+popd
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post -p /sbin/ldconfig
+
+%post c++ -p /sbin/ldconfig
+
+%post dce -p /sbin/ldconfig
+
+%postun -p /sbin/ldconfig
+
+%postun c++ -p /sbin/ldconfig
+
+%postun dce -p /sbin/ldconfig
+
+%files
+%defattr(-,root,root,-)
+%doc AUTHORS ChangeLog HISTORY NEWS PORTING README SEEALSO THANKS TODO USERS
+%{_bindir}/uuid
+%{_libdir}/libossp-uuid.so.*
+%{_mandir}/man1/*
+%exclude %{_mandir}/man1/uuid-config.*
+
+%files devel
+%defattr(-,root,root,-)
+%{_bindir}/uuid-config
+%{_includedir}/uuid.h
+%{_libdir}/libossp-uuid.so
+%{_libdir}/pkgconfig/ossp-uuid.pc
+%{_mandir}/man3/ossp-uuid.3*
+%{_mandir}/man1/uuid-config.*
+
+%files c++
+%defattr(-,root,root,-)
+%{_libdir}/libossp-uuid++.so.*
+
+%files c++-devel
+%defattr(-,root,root,-)
+%{_includedir}/uuid++.hh
+%{_libdir}/libossp-uuid++.so
+%{_mandir}/man3/uuid++.3*
+
+%files perl
+%defattr(-,root,root,-)
+%{perl_vendorarch}/auto/*
+%{perl_vendorarch}/Data*
+%{perl_vendorarch}/OSSP*
+%{_mandir}/man3/Data::UUID.3*
+%{_mandir}/man3/OSSP::uuid.3*
+
+%files php
+%defattr(-,root,root,-)
+%config(noreplace) %{_sysconfdir}/php.d/%{name}.ini
+%{php_extdir}/%{name}.so
+
+%files pgsql
+%defattr(-,root,root,-)
+%{_libdir}/pgsql/*
+%{_datadir}/pgsql/*
+
+%files dce
+%defattr(-,root,root,-)
+%{_libdir}/libossp-uuid_dce.so.*
+
+%files dce-devel
+%defattr(-,root,root,-)
+%{_includedir}/uuid_dce.h
+%{_libdir}/libossp-uuid_dce.so
+
+%changelog
+* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.6.2-6
+- Perl mass rebuild
+
+* Sat May 14 2011 Iain Arnell <iarnell@gmail.com> 1.6.2-5
+- fix php_zend_api check
+
+* Thu Mar 03 2011 Karsten Hopp <karsten@redhat.com> 1.6.2-4
+- fix build
+
+* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.2-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Wed Jun 02 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.6.2-2
+- Mass rebuild with perl-5.12.0
+
+* Wed Apr 21 2010 Michal Hlavinka <mhlavink@redhat.com> - 1.6.2-1
+- updated to 1.6.2
+- uuid-config man page moved to sub-package containing uuid-config (#562838)
+
+* Mon Feb 1 2010 Stepan Kasal <skasal@redhat.com> - 1.6.1-10
+- silence rpmlint by using $(pwd) instead of shell variable RPM_SOURCE_DIR
+
+* Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 1.6.1-9
+- rebuild against perl 5.10.1
+
+* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.1-8
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
+
+* Mon Jul 13 2009 Remi Collet <Fedora@FamilleCollet.com> - 1.6.1-7
+- rebuild for new PHP 5.3.0 ABI (20090626)
+- add PHP ABI check
+- use php_extdir
+- add php configuration file (/etc/php.d/uuid.ini)
+
+* Thu May 7 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 1.6.1-6
+- Using plain old "Requires: pkgconfig" instead -- see my post to
+ fedora-devel-list made today.
+
+* Mon May 4 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 1.6.1-5
+- Replace expensive %%{_libdir}/pkgconfig dependency in uuid-devel
+ with pkgconfig%%{_isa} for Fedora >= 11 (#484849).
+
+* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.1-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
+
+* Thu Mar 06 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.1-3
+- Rebuild for new perl
+
+* Thu Mar 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.1-2
+- forgot to cvs add patch
+
+* Thu Mar 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.1-1
+- 1.6.1
+
+* Thu Mar 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.0-4
+- rebuild for new perl
+
+* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.6.0-3
+- Autorebuild for GCC 4.3
+
+* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.6.0-2
+- Rebuild for selinux ppc32 issue.
+
+* Tue Jul 24 2007 Steven Pritchard <steve@kspei.com> 1.6.0-1
+- Update to 1.6.0.
+- BR Test::More.
+
+* Tue Apr 17 2007 Steven Pritchard <steve@kspei.com> 1.5.1-3
+- Fix find option order.
+- Use fixperms macro instead of our own chmod incantation.
+- BR ExtUtils::MakeMaker.
+
+* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 1.5.1-2
+ - rebuilt for unwind info generation, broken in gcc-4.1.1-21
+
+* Mon Aug 28 2006 Steven Pritchard <steve@kspei.com> 1.5.1-1
+- Update to 1.5.1.
+
+* Sat Jul 29 2006 Steven Pritchard <steve@kspei.com> 1.5.0-1
+- Update to 1.5.0.
+- Rename libuuid* to libossp-uuid*, uuid.3 to ossp-uuid.3, and uuid.pc
+ to ossp-uuid.pc to avoid conflicts with e2fsprogs-devel (#198520).
+- Clean out the pgsql directory. (Some cruft shipped with this release.)
+
+* Wed May 24 2006 Steven Pritchard <steve@kspei.com> 1.4.2-4
+- Remove static php module.
+
+* Tue May 23 2006 Steven Pritchard <steve@kspei.com> 1.4.2-3
+- Force use of system libtool.
+- Make libs executable.
+
+* Tue May 23 2006 Steven Pritchard <steve@kspei.com> 1.4.2-2
+- License is MIT(-ish).
+
+* Fri May 19 2006 Steven Pritchard <steve@kspei.com> 1.4.2-1
+- Initial packaging attempt.