summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-06-21 17:00:11 +0200
committerRemi Collet <remi@php.net>2023-06-21 17:00:11 +0200
commit35dda533579c08f066d03b26f5b7643b3a5e63c0 (patch)
tree7aeefa1900b19a8064cb852a0f02f90ba37027d0
parent8000b76513d1aba35cc21e8a030bf60c2c7fad7b (diff)
update to 0.8.5
-rw-r--r--sexp-files-by-license.txt12
-rw-r--r--sexp.spec17
2 files changed, 18 insertions, 11 deletions
diff --git a/sexp-files-by-license.txt b/sexp-files-by-license.txt
index 7b13202..ed476a2 100644
--- a/sexp-files-by-license.txt
+++ b/sexp-files-by-license.txt
@@ -1,13 +1,17 @@
-BSD 2-Clause License
+MIT License
------------
CMakeLists.txt
+CMakeLists.txt.sover
+LICENSE.md
codecov.yml
default.nix
+flake.nix
cmake/sexp-samples-folder.h.in
cmake/version.cmake
src/ext-key-format.cpp
src/sexp-char-defs.cpp
+src/sexp-depth-manager.cpp
src/sexp-error.cpp
src/sexp-input.cpp
src/sexp-main.cpp
@@ -18,8 +22,10 @@ src/sexp-simple-string.cpp
.github/workflows/build-and-test-msys.yml
.github/workflows/build-and-test-rh.yml
.github/workflows/build-and-test.yml
+.github/workflows/codeql.yml
.github/workflows/coverage.yml
.github/workflows/coverity.yml
+.github/workflows/lint.yml
.github/workflows/nix.yml
include/sexp/ext-key-format.h
include/sexp/sexp-error.h
@@ -33,7 +39,3 @@ tests/src/g10-compat-tests.cpp
tests/src/g23-compat-tests.cpp
tests/src/g23-exception-tests.cpp
tests/src/primitives-tests.cpp
-
-MIT License
-------------
-LICENSE.md
diff --git a/sexp.spec b/sexp.spec
index 7ef0590..efb7519 100644
--- a/sexp.spec
+++ b/sexp.spec
@@ -15,17 +15,17 @@
Name: sexp
Summary: S-expressions parser and generator tools
-Version: 0.8.4
+Version: 0.8.5
Release: 1%{?dist}
-# See exp-files-by-license.txt and upstream LICENSE* files
-# see https://github.com/rnpgp/sexp/issues/33
-License: MIT and BSD-2-Clause
+License: MIT
URL: https://github.com/rnpgp/%{name}
Source0: %{url}/archive/refs/tags/v%{version}.tar.gz
# Use --with licensecheck to generate
Source3: %{name}-files-by-license.txt
+Patch0: %{name}-sover.patch
+
BuildRequires: cmake >= 3.14
BuildRequires: gcc
BuildRequires: gcc-c++
@@ -67,6 +67,7 @@ for %{libname}.
%prep
%setup -q
+%patch -P0 -p1 -b .sover
%if %{with licensecheck}
LST=$(mktemp)
@@ -83,6 +84,7 @@ rm $LST
%build
%cmake . \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
-DDOWNLOAD_GTEST:BOOL=OFF
%cmake_build
@@ -103,15 +105,18 @@ rm $LST
%files -n %{libname}
%license LICENSE*
-# see https://github.com/rnpgp/sexp/issues/32
-%{_libdir}/%{libname}.a
+%{_libdir}/%{libname}.so.%{soname}*
%files -n %{libname}-devel
%{_includedir}/%{name}
+%{_libdir}/%{libname}.so
%{_libdir}/pkgconfig/%{name}.pc
%changelog
+* Wed Jun 21 2023 Remi Collet <remi@remirepo.net> - 0.8.5-1
+- update to 0.8.5
+
* Thu May 4 2023 Remi Collet <remi@remirepo.net> - 0.8.4-1
- initial package
- open https://github.com/rnpgp/sexp/issues/32 build as shared