summaryrefslogtreecommitdiffstats
path: root/rnp.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rnp.spec')
-rw-r--r--rnp.spec30
1 files changed, 27 insertions, 3 deletions
diff --git a/rnp.spec b/rnp.spec
index 3e23080..06c0e12 100644
--- a/rnp.spec
+++ b/rnp.spec
@@ -8,6 +8,7 @@
#
%bcond_without tests
+%bcond_with licensecheck
%if 0%{?rhel} == 8
# use openssl by default as botan2 is too old
@@ -24,14 +25,16 @@ Name: rnp
Summary: OpenPGP (RFC4880) tools
Version: 0.16.2
Release: 3%{?dist}
-# From LICENSE.md
-License: BSD-2-Clause AND BSD-3-Clause AND Apache-2.0
+# See rnp-files-by-license.txt
+License: BSD-2-Clause AND BSD-3-Clause AND Apache-2.0 AND MIT
URL: https://github.com/rnpgp/rnp
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
Source1: %{url}/releases/download/v%{version}/v%{version}.tar.gz.asc
# See https://www.rnpgp.org/openpgp_keys/
Source2: %{name}-keyring.gpg
+# Use --with licensecheck to generate
+Source3: %{name}-files-by-license.txt
BuildRequires: cmake >= 3.14
BuildRequires: gcc
@@ -50,6 +53,10 @@ BuildRequires: cmake(GTest)
%endif
BuildRequires: python3
BuildRequires: gnupg2
+BuildRequires: rubygem-asciidoctor
+%if %{with licensecheck}
+BuildRequires: licensecheck
+%endif
Requires: %{libname}%{?_isa} = %{version}-%{release}
@@ -78,6 +85,18 @@ for %{libname}.
%setup -q
%{?gpgverify:%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'}
+%if %{with licensecheck}
+LST=$(mktemp)
+
+licensecheck -r . | sed -e 's:^./::' >$LST
+grep -v UNKNOWN $LST | sed -e 's/.*: //' | sort -u | while read lic
+do
+ echo -e "\n$lic\n------------"
+ grep ": $lic\$" $LST | sed -e "s/: $lic//"
+done | tee %{SOURCE3}
+rm $LST
+%endif
+
%build
%cmake . \
@@ -105,6 +124,7 @@ for %{libname}.
%files
%{_bindir}/rnp
%{_bindir}/rnpkeys
+%{_mandir}/man1/rnp*
%files -n %{libname}
%license LICENSE*
@@ -116,10 +136,14 @@ for %{libname}.
%{_libdir}/%{libname}.so
%{_libdir}/pkgconfig/%{libname}.pc
%{_libdir}/cmake/rnp
+%{_mandir}/man3/librnp*
%changelog
-* Fri Oct 28 2022 Remi Collet <remi@remirepo.net> - 0.16.2-3
+* Wed Nov 2 2022 Remi Collet <remi@remirepo.net> - 0.16.2-3
+- add files by license list in package sources
+- open https://github.com/rnpgp/rnp/issues/1932 missing MIT
+- add man pages
- check archive signature
* Fri Oct 28 2022 Remi Collet <remi@remirepo.net> - 0.16.2-2