summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--pdflib-lite-7.0.5-format-security.patch11
-rw-r--r--pdflib-lite.spec8
2 files changed, 18 insertions, 1 deletions
diff --git a/pdflib-lite-7.0.5-format-security.patch b/pdflib-lite-7.0.5-format-security.patch
new file mode 100644
index 0000000..4c3e6ae
--- /dev/null
+++ b/pdflib-lite-7.0.5-format-security.patch
@@ -0,0 +1,11 @@
+--- bind/pdflib/perl/pdflib_pl.c
++++ bind/pdflib/perl/pdflib_pl.c
+@@ -375,7 +375,7 @@ SWIGEXPORT(void,boot_pdflib_pl)(CV *cv,
+ #include "pdflib.h"
+
+ /* Exception handling */
+-#define SWIG_exception(msg) croak(msg)
++#define SWIG_exception(msg) croak("%s", msg)
+ #define try PDF_TRY(p)
+ #define catch PDF_CATCH(p) { \
+ char errmsg[1024];\
diff --git a/pdflib-lite.spec b/pdflib-lite.spec
index d94a8e0..89b83d0 100644
--- a/pdflib-lite.spec
+++ b/pdflib-lite.spec
@@ -5,13 +5,14 @@ Summary: Portable C library for dynamically generating PDF files
Name: pdflib-lite
# Remenber to check the URL after changing this...
Version: 7.0.5
-Release: 6%{?dist}
+Release: 7%{?dist}
License: Distributable
URL: http://www.pdflib.com/
Source: http://www.pdflib.com/binaries/PDFlib/705/PDFlib-Lite-%{version}.tar.gz
Patch0: pdflib-lite-7.0.4-gcc43.patch
+Patch1: pdflib-lite-7.0.5-format-security.patch
BuildRequires: gcc
BuildRequires: gcc-c++
@@ -77,6 +78,7 @@ that will use the PDFlib library.
%prep
%setup -q -n PDFlib-Lite-%{version}
%patch0 -p0 -b .gcc43
+%patch1 -b .format-security
sed -i -e 's,^PYTHONLIBDIR.*,PYTHONLIBDIR = %{python_sitearch},' \
-e 's,^PERLLIBDIR.*,PERLLIBDIR = %{perl_vendorarch},' \
@@ -185,6 +187,10 @@ cp bind/pdflib/php/examples.php5/*.php \
%changelog
+* Wed Aug 22 2018 Remi Collet <remi@remirepo.net> - 7.0.5-7
+- Add patch to work around false positive in format-security check
+ (From rpmfusion, by Paul Howarth )
+
* Mon Feb 26 2018 Remi Collet <remi@remirepo.net> - 7.0.5-6
- F28 cleanup